Você está na página 1de 2

27/04/2019 pfSense – Wikipédia, a enciclopédia livre

pfSense
Origem: Wikipédia, a enciclopédia livre.
O pfSense é open source, licenciado sob BSD license, baseado no sistema
operacional FreeBSD e adaptado para assumir o papel de um firewall e/ou pfSense
roteador de redes.[1] Ele possui recursos que muitas vezes, só encontrada em
Versão do sistema operativo FreeBSD
firewalls comerciais caros,[2] já que podemos realizar com o pfSense a imensa
maioria das atividades que esperamos de sistemas com este título.[1]

O projeto pfSense foi concebido em meados de setembro de 2004 por Chris


Buechler e Scott Ullrich. Chris foi um colaborador assíduo de códigos por
muito tempo do projeto m0n0wall. O m0n0wall tem basicamente as mesmas
pretensões técnicas do pfSense, mas desde o seu surgimento até o fim de seu
desenvolvimento, seu foco foi em appliances.[3]

A desvantagem do m0n0wall foi de ser um sistema contido em si e voltado


para dispositivos que pudessem rodá-lo diretamente da memória principal.
Produção Electric Sheep
Não é possível instalá-lo em um sistema de arquivos comum em um disco Fencing, LLC (Até
rígido, por exemplo. Daí muitas funções desejáveis para sistemas mais 2.3.x, após 2.3.3_1
está sob o comando
complexos (VPN, suporte a modems 3G, autenticação de usuários, proxy, de Rubicon
IDS, etc.) não podem ser razoavelmente implementadas nele. Communications,
LLC (Netgate)
Diante de tal cenário, Chris Buechler e Scott Ullrich resolveram criar um Modelo Open source
projeto baseado em todas as funcionalidades existentes no m0n0wall, porém
Versão 2.4.4_1 Lançada no
com melhorias na interface web de configuração e uma aproximação com as estável dia 29 de outubro
versões mais recentes do FreeBSD (sistema base). O sistema conquistou de 2018
usuários por ser extremamente organizado e agregar uma série de Arquitetura(s) Intel x86(Até 2.3.x),
funcionalidades com fácil acesso, permitindo à um leigo que tenha AMD64
conhecimentos básicos de redes, instalar e gerenciar um sistema pfSense.[4] Núcleo Kernel Monolítico
Licença ESF (6-clause BSD-
alike License)
Mudança de sistema operacional /
Página oficial www.pfsense.org (h
arquitetura na Versão 2.4.x ttp://www.pfsense.or
g/)
Atualização do sistema operacional básico para FreeBSD 11.1- Cronologia
RELEASE-p1
Adicionado suporte para sistemas baseados em ARM da Netgate, como M0n0wall
o SG-1000
Suporte de 32 bits foi obsoleto e removido - Não há imagens
disponíveis para sistemas de arquitetura Intel de 32 bits (x86 / i386)
O NanoBSD foi reprovado e removido - Não há imagens disponíveis para o NanoBSD.
Para sistemas de 64 bits que executam o NanoBSD, consulte Atualizando NanoBSD 2.3 para 2.4 de 64 bits para
obter informações sobre como atualizar no local do NanoBSD para uma instalação completa

https://pt.wikipedia.org/wiki/PfSense 1/2
27/04/2019 pfSense – Wikipédia, a enciclopédia livre

O x86 de 32 bits e o NanoBSD foram obsoletos e não são suportados em 2.4. O hardware capaz de executar imagens de 64
bits deve ser reinstalado com uma versão de 64 bits. As instalações do NanoBSD em hardware de 64 bits devem ser
reinstaladas como uma instalação completa.

O hardware x86 de 32 bits pode continuar a executar o software pfSense versão 2.3.x, que receberá atualizações de
segurança pelo menos um ano após o 2.4.0-RELEASE. Para usar o ZFS, é necessária uma reinstalação do sistema
operacional. Não é possível atualizar no local do UFS para o ZFS neste momento. As interfaces sem fio devem ser criadas
na guia Sem fio em Interfaces> Atribuições antes que elas estejam disponíveis para atribuição Os firewalls que utilizam
6RD para conectividade WAN IPv6 podem exigir novos testes para garantir que o fluxo de tráfego e o monitoramento
funcionem corretamente, veja # 7272 Alguns dispositivos de hardware podem não inicializar imagens de instalação 2.4.0,
por exemplo, devido a mudanças de compatibilidade UEFI. Estes são principalmente problemas de BIOS e não problemas
com as imagens do instalador. Atualizar no local a partir de 2.3.x normalmente permite que o hardware afetado execute a
versão 2.4. Para atualizar Firewalls no local que estão executando o software pfSense versão 2.2.x ou anterior, primeiro
atualize o firewall para o pfSense 2.3.4 e, em seguida, execute uma atualização para o pfSense 2.4.0 depois.
Alternativamente, reinstale 2.4.0 diretamente e restaure a Configuração.

Notas e Referências
1. Venezia, Paul. «You should be running a pfSense firewall» (http://www.infoworld.com/article/2861574/network-securit
y/you-should-be-running-pfsense-firewall.html). infoworld.com (em inglês). Consultado em 1 de agosto de 2015
2. «DIY pfSense firewall system beats others for features, reliability, and security» (http://www.techrepublic.com/blog/linu
x-and-open-source/diy-pfsense-firewall-system-beats-others-for-features-reliability-and-security/). techrepublic.com
(em inglês). Consultado em 1 de agosto de 2015
3. «10 motivos para considerar o pfSense como o gateway da sua rede» (https://www.escolalinux.com.br/blog/10-motivo
s-para-considerar-o-pfsense-como-o-gateway-da-sua-rede). escolalinux.com.br. Consultado em 15 de julho de 2016
4. Corrêa, Mauro Paes (2015) [2015]. pfSense®: O Guia Ideal para Iniciantes 1a ed. [S.l.]: Mauro Paes Corrêa.
136 páginas. ISBN 978-85-920407-0-3

Ligações externas
Página oficial (http://www.pfsense.org)

Obtida de "https://pt.wikipedia.org/w/index.php?title=PfSense&oldid=53709102"

Esta página foi editada pela última vez às 00h53min de 29 de novembro de 2018.

Este texto é disponibilizado nos termos da licença Atribuição-CompartilhaIgual 3.0 Não Adaptada (CC BY-SA 3.0) da
Creative Commons; pode estar sujeito a condições adicionais. Para mais detalhes, consulte as condições de utilização.

https://pt.wikipedia.org/wiki/PfSense 2/2