Você está na página 1de 19

Centro Universitrio Ritter dos Reis

Faculdade de Informtica
Sistemas de Informao

Matemtica Discreta
2011/2
Professor: Paulo Werlang de Oliveira

Edio e Montagem
Vitor Miguel Xavier Peres

Porto Alegre, 2011.

1. Teoria dos Conjuntos

Um conjunto uma coleo de elementos ou objetos que tem alguma propriedade em


comum. Os elementos do conjunto so representados com letras latinas minsculas (a, b, c,
etc...) e os conjuntos so representados por letras latinas maisculas (A, B, C, etc...). Os
conjuntos podem ser descritos por Compreenso ou por Enumerao.
Na definio por Compreenso, definimos a propriedade que caracteriza os elementos
que compem o conjunto. Por exemplo, no caso dos nmeros pares, a definio por
Compreenso seria:
P = {a N | a mod 2 = 0}

O caso da representao por enumerao feita quando o conjunto envolvido finito e


contvel. Por exemplo, o conjunto dos dias da semana pode ser definido como:

S = {segunda, tera, quarta, quinta, sexta, sbado, domingo}

Para os conjuntos, esto definidas trs operaes bsicas: a Interseco, a Unio e o


Complementar. A Interseco consiste em selecionar elementos de um conjunto que
satisfazem, Simultaneamente, duas propriedades que definem os conjuntos, por exemplo:

F = conjunto de frutas;
C = ctricas = {laranja, limo, acerola, tangerina, kiwi, lima, goiaba amarela};
A = amarelas = {maracuj, laranja, banana, lima, pssego, carambola, melo};

Interseco de A e C:
A C = {laranja, lima, goiaba amarela}

Unio de A e C:

A U C = {laranja, limo, acerola, tangerina, kiwi, lima, goiaba amarela,


maracuj, banana, pssego, carambola, melo}

2. Princpio Fundamental da Contagem


Sejam A e B dois conjuntos finitos. Se n(x) o numero de elementos do conjunto x
ento vale a seguinte propriedade:

n(A U B) = n(A) + n(B) n(A B)

Exemplo: n(C) = 7; n(A) = 8; n(A C) = 3.


n(A U B) = n(A) + n(B) n(A B)
=7+83
= 12

Obs: A unio de dois conjuntos obtida juntando-se TODOS os elementos de A com TODOS
os elementos de B, sem Repetio.

A Interseco entre dois conjuntos obtida selecionando-se TODOS os elementos que


so COMUNS A e B, ou seja, selecionamos aqueles elementos que pertencem
SIMULTANEAMENTE aos dois conjuntos.

Exemplo de Princpio Fundamental de Contagem:

Uma empresa de propaganda veiculou um anuncio de um novo produto no jornal e em


uma revista. Sabendo que o total de leitores 87, e que 49 leem revista, e 13 leem jornal e
revista, determine o numero de pessoas que leem jornal.
87 = n(A) + 49 13
87 = n(A) + 36
n(A) = 87 36
n(A) = 51

3. Produto Cartesiano

Sejam A e B dois conjuntos no vazios. O produto cartesiano entre A e B um


conjunto de Pares Ordenados definido e denotado por:

A x B = {(x, y) | x A, y B}

Convm observar que se A e B so conjuntos finitos com m e n elementos,


respectivamente, ento o produto cartesiano um conjunto com exatamente m.n pares
ordenados.

Exemplo: A = {a, e, i, o, u}
B = {V, F}

A x B = {(a, V); (a, F); (e, V); (e, F); (i, V); (i, F); (o, V); (o, F); (u, V); (u, F)} observe que
B x A = {(V, a); (F, a); (V, e); (F, e); (V, i); (F, i); (V, o); (F, o); (V, u); (F, u)} tambm um
conjunto de 10 pares ordenados, porem A x B B x A.

Uma forma de representar o produto cartesiano fazendo-se uma representao


grfica.

Observe que o produto cartesiano


NO Comutativo.

3.1. Relaes

Uma relao do conjunto A no conjunto B qualquer seleo que se faa no produto


cartesiano A x B; seguindo o critrio dado:

Exemplo: A = {1, 2, 3, 4, 5, 6}
B = {V, F}
R = {(1, F); (2, V); (3, F); (4, V); (5, F); (6, V)}

Interpretao Geomtrica

Se A x B ento podemos representar a relao atravs de um Grafo, onde os vrtices


correspondem aos elementos de A e as setas correspondem aos pares que fazem parte da
relao.
Considere o exemplo:
A = {1, 2, 3, 4, 6}
R = {(x, y) A | x divide y} cujo grfico dado abaixo:

O respectivo Grafo da relao R desenhado a seguir:

n Grafos do
grfico

n de pares

n de setas

da relao

do grafo

Exerccios:
1) Represente o grfico das seguintes relaes:
a) R = {(x, y) N | 3x + 2y = 12}
b) S = {(x, y) N | x +2y 10}
c) T = {(x, y) R | x 0; y 1; x + y 5}
d) U a relao dos pares que so sada do seguinte algoritmo:
inicio
para i = 1 ate 10 faa
para j = 1 ate 10 faa
se (i j) e (2i + j < 10) ento escreve (i, j)
fim para
fim para
fim

Estudo Dirigido

Exerccio 1
Representar, no plano cartesiano, o grfico das seguintes relaes:
a) R = {(x, y) N | 4x +6y = 24}
b) S = {(x, y) R | 5x + 2y 20}

Exerccio 2
Considerando o conjunto A = {a, b, c, d, e}, represente o grafo das seguintes relaes:
a) R = {(a, b); (a, c); (b, d); (c, d); (d, e)}
b) S = {(a, c); (b, d); (e, e); (d, b); (d, a); (c, a)}

Exerccio 3
Use o principio fundamental da contagem para interpretar e resolver o seguinte problema: Um
grupo de pessoas respondeu a um questionrio com duas questes. Sabendo que 9 homens
acertaram a questo 1, 12 pessoas acertaram a questo 1, 14 pessoas so homens e 12
pessoas acertaram a questo 2. Quantas pessoas participaram do teste e qual o numero de
mulheres que acertaram a questo 2.

Exercicio 4
Faa o grfico do conjunto de pares ordenados que so sada para o seguinte algoritmo.
inicio
para i = 1 ate 10 faa
para j = 1 ate 10 faa
se (2i < j) e (3i + 2j 18) ento escreve (i j)
fim para
fim para
fim

1)

2)

3)
-

Q1

Q2

Total

Homens

14

Mulheres

10

Total

12

12

24

4)

4. Estudo das Propriedades das Relaes


4.1 Reflexiva

Seja R uma relao definida no produto cartesiano A x A, onde A um conjunto no


vazio. Dizemos que a relao R Reflexiva se para cada a A existe o par (a, a) em R. Isso
significa que todo elemento do conjunto A esta relacionado com ele mesmo. No grfico, para
que a relao seja Reflexiva temos que ter TODOS os pares da diagonal principal marcados.
Equivalentemente, no grafo TODOS os vrtices tm Loops.
Exemplo: Considere A = {1, 2, 4, 6} e R = {(x, y) A x A | x mod y = 0) R = y divide x

Mostre que essa relao Reflexiva.

Questo: como provar algebricamente essa propriedade?

x mod y = 0

x mod x = 0

(x, y)

(x, x)

x mod y = 0

( n N) | x = n. y

x mod x = 0

( n N) | x = n. x

se n = 1; x = 1. x

x divide y

4.2. Simtrica

Digamos que a relao S Simtrica se para cada par (a, b) que esta na relao, o par
(b, a) tambm esta na relao. No grfico, para que seja Simtrica temos que ter uma
distribuio Simtrica de pontos em relao a diagonal principal. Equivalentemente, no grafo
todas as setas so duplas.
Exemplo: Seja A = {1, 2, 3, 4, 5, 6} e seja R = {(x, y) A x A | (x-y) mod 2 = 0}
(x, y) R

(y, x) R

(x-y) mod 2 = 0

( k N) | (x-y) = 2k
(-1).(x-1) = (-1).2k
-x+y = 2(-k)
(y-x) = 2(-k)
(y-x) mod 2 = 0

(y, x) R

Ex2: (5, 5)

(5-5) = 2k
0 = 2k
0 = 2.0

Ex3: (7, 1)

(7-1) = 2k
6 = 2k
6 = 2.3

Simetria permite definir classes


de equivalncia!

Obs: Numa relao simtrica a ordem dos elementos no par ordenado pode ser trocado
(x, y)

(y, x)

4.3. Antissimtrica

Seja S um conjunto no vazio e U uma relao definida no produto cartesiano A x A.


Dizemos que a relao U Antissimtrica, quando valer a seguinte propriedade:
Se (a, b) S e (b, a) S

a=b

A propriedade da Antissimetria aparece como pontos distribudos SOMENTO em um


dos lados da diagonal principal. No grafo, a Antissimetria caracterizada pelo fato de que
todas as setas so unidirecionais.
Exemplo: Seja A = {1, 2, 3, 4, 5, 6} e seja U = {(x, y) AxA | x divide y}

x divide y

( m N) | y = m.x

( n N) | x = n.y

y divide x

y = m.n.y
y/y = m.n
1 = m.n

m=n=1
y = 1.x
y=x

Antissimetria permite definir relaes de Ordem.

Obs: Na relao Antissimtrica a Ordem dos elementos no par ordenado NUNCA pode ser
trocado, a menos que os elementos sejam iguais.

4.4. Transitiva

Seja A um conjunto no vazio e T uma relao definida no produto cartesiano AxA.


Dizemos que a relao T Transitiva, quando valer a seguinte propriedade:
Se (a, b) T e (b, c) T ento (a, c) T
A propriedade da Transitividade permite estabelecer uma relao entre os elementos
extremos de pares distintos, eliminando o elemento intermedirio. No grafo, a Transitividade
vista da seguinte maneira: para cada par de setas, sempre existe uma terceira ligando o objeto
inicial ao final.
Exemplo: Seja A = N e seja T = {(x, y) AxA | x y}
(x, y) T

xy

(y, z) T

yz

(x+m) + n = z
x + (m+n) = z

( m N) | x + m = y
( n N) | y + n = z

xz
(x, y) T

4.5. Relaes de Equivalncia

Dizemos que E uma relao de equivalncia se ela for Reflexiva, Simtrica e


Transitiva. (Ex: ter a mesma cor)

4.6. Relaes de Ordem

Dizemos que O uma relao de ordem se ela for Reflexiva, Antissimtrica e


Transitiva. (Ex: ter o mesmo tamanho)

Observe os seguintes Algoritmos:

Algoritmo_A
leia (N)
S=0
para i = 1 ate N faa
para j = 1 ate N faa
S := S + 3
fim para
fim para
para k = 1 ate N faa
S := S + 5
fim para
S := S + 7

Algoritmo_Z
leia (N)
S := 7
para i = 1 ate N faa
para j = 1 ate N faa
S := S + 3
fim para
S := S + 5
fim para
escreve (N)
escreve (S)
fim

escreve (N)
escreve (S)
fim
Algoritmo_P
Algoritmo_B
leia (N)
S := 0
para i = 1 ate N faa
S := S + 3
fim para
S := (S + 5) N
S := S + 7
escreve (N)
escreve (S)
fim

leia (N)
S := 3 N N + 5 N +7
escreve (N)
escreve (S)
fim

Algoritmo_M
leia (N)
escreve (N)
escreve (7+N(5+3N))
fim

Qual a relao de ordem que podemos definir para os Algoritmos?


Ordem de Complexidade

Definimos a Complexidade de um Algoritmo como sendo o numero total de operaes


realizadas para a sua completa execuo.

Qual a relao de equivalncia que podemos definir para os Algoritmos?


Relao de Equivalncia

Definimos relao de Equivalncia entre algoritmos como segue: dois algoritmos so


equivalentes sempre que, para uma mesma entrada, produziram a mesma sada.

AZBPM
Exerccio:
Considere os seguintes algoritmos:
inicio
leia (A)
inicio
leia (A)

i := 0
enquanto (i i < A)

x := 0
hx := A
enquanto xn x faa
x := nx
nx := (x x + A)/2 x

i := i + 1
fim enquanto
INF := i 1
SUP := i
enquanto INF SUP faa

fim enquanto

m = (INF + SUP)/2

escreve (nx)
fim

se (m m < A) ento INF := m seno SUP := m


fim enquanto
escreve (m)
fim

Analisar o funcionamento de cada algoritmo, decidindo se eles so equivalentes ou no caso


sejam equivalentes, ordene-os conforme a complexidade.

A=7
x := 0

A=7

nx := 7

i := 0

x := 7

00<7

nx := (7 7 + 7)/2 7 = 4

i := 1

x := 4

11<7

nx := (4 4 + 7)/2 4 = 2,875

i := 2

x := 2,875

22<7

nx := (2,875 2,875 + 7)/2 2,875 = 2,654891304

i := 3

x := 2,654891304

3 3 <7 (falso)

nx := 2,645767044
x := 2,645767044
nx := 2,645751311

A=7

INF := 2

SUP := 3

( . + )
=
2

: =

2x = x + A

(2 + 3)
= 25
2

6,25 < 7

2x - x = A
x = A
x=

5. Estudo das Funes

Sejam A e B dois conjunto no vazios. Uma funo f de A em B um subconjunto do


produto cartesiano AxB que tem a seguinte propriedade:
{( a A) (! b B) | (a, b) f AxB}
Isso significa que para cada elemento a A existe um nico elemento b B tal que b
a imagem de a pela funo f, ou seja, b = f(a). Convm observar que a funo f um conjunto
de pares ordenados do produto cartesiano que possui como primeira coordenada os elementos
do conjunto A e como segunda coordenada os elementos do conjunto B. Assim, o conceito de

funo mais restrito que o conceito de relao, pois existe um par comeando com cada um
dos elementos do conjunto A. A representao de funes feita atravs de grficos.
A classificao das funes feita de acordo com as propriedades algbricas que as
funes possuem. Dizemos que uma funo Injetiva se ela mapeia elementos diferentes do
conjunto A em imagens distintas do conjunto B, ou seja, se f(a) = f(b) ento a = b. No grfico,
isso corresponde a ter uma ideia marca por cada linha.
Por outro lado, dizemos que a funo Sobrejetiva se TODOS os elementos de B so
usados como imagem de algum elemento a A. Isso significa que nenhuma linha fica A = {1,
2, 3, 4}:

funo, mas no Injetiva (f(1) = f(1)),


e nem Sobrejetiva (1 imagem de ningum).

funo Injetiva e Sobrejetiva.

No funo (tem 2 pontos na

funo Injetiva, mas no

mesma linha).

Sobrejetiva.

funo Sobrejetiva, mas no


No funo (no existe f(2)).

Injetiva.

5.1. Teorema

Sejam A e B dois conjuntos finitos com m e n elementos respectivamente e seja f uma


funo de A em B. Ento, valem as seguintes afirmaes:

a) Se m > n ento a funo No Injetiva;


b) Se m < n ento a funo No Sobrejetiva;
c) Se m = n ento pode se afirmar, devendo-se fazer uma analise detalhada da funo
(nesse caso).

Notao: A notao usual para funes representada a seguir:

f=A
x

B
y = f(x)

Onde f o nome da funo;


A o domnio da funo (determina o tipo de dado de entrada e sua abrangncia);
B o contradomnio da funo (determina o tipo de dado de sada e sua abrangncia);
x := a varivel de entrada;
y := a varivel de sada;
f (x) a regra que define a funo (formula, algoritmos ou sentena).

Exemplo:
Considere o seguinte Algoritmo:
inicio
leia (N)
i := 0
enquanto (i i < N) faa
i := i + 1
fim enquanto
escreve (i 1)
fim

Determine:
a) o domnio da funo;
b) o contradomnio da funo;
c) a imagem da funo;
d) o grfico da funo;
e) determine uma funo equivalente, menos complexa.

5.2. Tipos de funes

5.2.1. Funo Bijetiva

Uma funo Bijetiva se ela for, simultaneamente, Injetiva e Sobrejetiva. O conceito de


Bijetividade importante para a noo de funo inversa, que ser definida a seguir:

5.2.2. Funo Inversa

Seja f uma funo definida do conjunto A no conjunto B, definida pelo seguinte grfico:
f = {(a, b) AxB | b = f(a)}

A funo inversa a funo definida e denotada por:


f

-1

= {(b, a) BxA | b = f(a)}

Do ponto de vista algbrico, a funo inversa obtida invertendo-se a ordem dos pares
ordenados. No grfico, os eixos so trocados entre si e existe uma simetria entre os grficos de
f e f em relao a diagonal principal.

Exemplo:
-1

A = {1, 2, 3, 4}

A = {a, b, c, d}

B = {a, b, c, d}

B = {1, 2, 3, 4}

f: A -> B

f : B -> A

-1

-1