Você está na página 1de 4

Matriz Definio Uma matriz uma varivel composta homognea multidimensional, formada por uma sequncia de variveis, todas

s do mesmo tipo, com o mesmo identificador (mesmo nome), e alocadas sequencialmente na memria. Uma varivel do tipo matriz precisa de um ndice para cada uma de suas dimenses. Uma matriz de duas dimenses ser chamada bi-dimensional, uma de trs dimenses tri-dimensional e assim por diante.

Declarao e inicializao de um matriz A declarao de uma matriz bidimensional em pseudocdigo pode ser da seguinte forma: matriz [tamanho_linha, tamanho_coluna] <tipo> : <nome da varivel>; Exemplo de uma matriz bidimensional, onde o tamanho da primeira dimenso (linha) 3 e o da segunda dimenso (coluna) 5: matriz [3,5] inteiro: X 1 2 3 4 5

X[1,1] Atribuio de valores a uma matriz

X[3,5]

Cada elemento de uma matriz pode armazenar um valor. Exemplo: X[2,4] 33 X[3,1] 10 Preenchendo uma matriz Para preencher uma matriz, necessrio identificar todas as suas posies, atravs de um ndice para cada dimenso da matriz. Exemplo: para i de 1 at 3 faa para j de 1 at 5 faa imprima (Digite o numero da linha,i,e coluna, j); leia (X[i,j])); fim para; fim para; Obs: para cada valor de i, a varivel j varia de 1 a 5 nas cinco colunas que cada linha possui. Mostrando os elementos de uma matriz X[1,1] 399 X[2,5] 222

Para mostrar os elementos de uma matriz necessrio identificar as suas posies, atravs de um ndice para cada dimenso da matriz. para i de 1 at 3 faa para j de 1 at 5 faa imprima (X[i,j]); fim para; fim para;

Exerccios: 1- Faa um programa que preencha uma matriz 3 x 5 com nmeros inteiros, calcule e mostre a quantidade de elementos entre 15 e 20. Incio inteiro cont; matriz [3,5] inteiro: X; cont 0 para i de 1 at 3 faa para j de 1 at 5 faa imprima(entre com um valor para a linha:, i, coluna:, j); leia (X[i,j]); se (X[i,j]) > 15 e (X[i,j]<20) ento cont cont +1; fim se; fim para; fim para; imprima(quantidade de elementos=, cont); Fim. 2- Crie um programa que preencha duas matrizes 3 x 8 com nmeros inteiros, calcule e mostre: - A soma das duas matrizes, resultando em uma terceira matriz tambm de ordem 3x8 - a diferena das duas matrizes, resultando em uma quarta matriz tambm de ordem 3x8 Incio matriz [3,8] inteiro: X1, X2, Soma, dif; inteiro: i,j; para i de 1 at 3 faa para j de 1 at 8 faa imprima (Escreva o elemento da matriz X1); leia (X1[i,j]); imprima (Escreva o elemento da matriz X2); leia (X2[i,j]); Soma[i,j] X1[i,j] + X2[i,j]; dif[i,j] X1[i,j] - X2[i,j]; fim para; fim para; imprima(Matriz soma:); para i de 1 at 3 faa para j de 1 at 8 faa imprima(soma[i,j]); fim para; fim para; imprima(Matriz diferena:); para i de 1 at 3 faa para j de 1 at 8 faa

imprima(dif[i,j]); fim para; fim para; Fim.

3- Faa um programa que preencha uma matriz M(2x2), calcule e mostre a matriz R, resultante da multiplicao dos elementos de M pelo seu maior elemento. Incio matriz [2,2] inteiro: M, R; inteiro: maior, i; imprima (Preencher elementos da matriz:); para i de 1 at 2 faa para j de 1 at 2 faa leia (M[i,j]) fim para; fim para; maior M[1,1]; imprima (Verificar maior elemento:); para i de 1 at 2 faa para j de 1 at 2 faa se M[i,j] > maior ento maior M[i,j]; fim se; fim para; fim para; para i de 1 at 2 faa para j de 1 at 2 faa R[i,j] M[i,j] * maior; fim para; fim para; para i de 1 at 2 faa para j de 1 at 2 faa imprima (R[i,j]); fim para; fim para; Fim 4- Faa um programa que preencha e mostre a mdia dos elementos da diagonal principal de uma matriz 10x10. 5- Faa um programa que preencha uma matriz 6x3, calcule e mostre: a- o maior elemento da matriz e sua respectiva posio, ou seja, linha e coluna b- o menor elemento da matriz e sua respectiva posio, ou seja, linha e coluna 6- Crie um programa que preencha uma matrix 10x20 com nmeros inteiros e some cada uma das linhas, armazenando o resultado das somas em um vetor. A seguir, o programa dever multiplicar cada elemento da matriz pela soma da linha correspondente e mostrar a matriz resultante.

7- Elabore um programa que preencha uma matriz 6x4 com nmeros inteiros, calcule e mostre quantos elementos dessa matriz so maiores que 30 e, sem seguida, monte uma segunda matriz com os elementos diferentes de 30. No lugar do nmero 30 da segunda matriz, coloque o nmero zero.

8- Faa um programa que preencha: um vetor com oito posies, contendo nomes de lojas; outro vetor com quatro posies, contendo nomes de produtos; uma matriz com os preos de todos os produtos em cada loja. O programa dever mostrar todas as relaes (nome do produto nome da loja) em que o preo no ultrapasse R$120,00. Incio vetor [1:8] character: lojas vetor [1:4] character: produtos matriz [4, 8] real: preco integer: i,j imprima (Entre com 8 nomes de lojas); para i de 1 at 8 faa leia (lojas[i]); fim para; imprima (Entre com 4 nomes de produtos); para i de 1 at 4 faa leia (produtos[i]); fim para; imprima (Entre com os preos dos produtos em cada loja); para i de 1 at 4 faa para j de 1 at 8 faa leia (preco[i,j]); fim para; fim para; para i de 1 at 4 faa para j de 1 at 8 faa se preco[i,j] <120.0 entao imprima (produtos[i], lojas[i]) fim se; fim para; fim para;

Fim