Você está na página 1de 6

Exerccios C++ Lista1

Exemplo em C++:
1- Faa um programa que receba quatro nmeros inteiros, calcule e mostre a
soma desses nmeros.

ALGORITMO Soma4
DECLARE n1, n2, n3, n4, soma INTEIRO
LEIA n1, n2, n3, n4
soma  n1 + n2 + n3 + n4
ESCREVA soma
FIM_ALGORITMO

Em C++:
#include <iostream.h>
#include <conio.h>

main()
{

int n1, n2, n3, n4, soma;

// Recebe os quatro nmeros


cin >> n1;
cin >> n2;
cin >> n3;
cin >> n4;

// Soma os nmeros digitados


soma = n1+n2+n3+n4;

// Mostra o resultado da soma. Obs.: \n faz pular uma linha antes de apresentar a soma
cout << \n << soma;

// Para o programa a espera de um ENTER


getch();

OU

#include <iostream.h>
#include <conio.h>
main()
{ int n1, n2, n3, n4, soma;
// Recebe os quatro nmeros apresentando uma msg ao usurio
cout << Informe o 1o valor: ;
cin >> n1;
cout << Informe o 2o valor: ;
cin >> n2;
cout << Informe o 3o valor: ;
cin >> n3;
cout << Informe o 4o valor: ;
cin >> n4;
// Soma os nmeros digitados
soma = n1+n2+n3+n4;
// Mostra o resultado da soma. Obs.: \n faz pular uma linha antes de apresentar a soma
cout << \nA soma e << soma;
// Para o programa a espera de um ENTER
getch();
}

-1-
Faa voc em C++ :
2- Um programa que receba trs valores, calcule e mostre a mdia aritmtica
entre eles.

ALGORITMO Media3Valores
DECLARE n1, n2, n3, media REAL
LEIA n1, n2, n3
media  (n1 + n2 + n3) / 3
ESCREVA media
FIM_ALGORITMO

Exemplo em C++:
3- Faa um programa que receba trs valores e seus respectivos pesos, calcule
e mostre a mdia ponderada entre eles.

ALGORITMO Media3Ponderada
DECLARE n1, n2, n3, p1, p2, p3, mediapond REAL
ESCREVA (Informe o 1o valor e seu peso)
LEIA n1, p1
ESCREVA (Informe o 2o valor e seu peso)
LEIA n2, p2
ESCREVA (Informe o 3 valor e seu peso)
LEIA n3, p3
mediapond  (n1 * p1 + n2 * p2 + n3 * p3) / (p1 + p2 + p3)
ESCREVA (A media ponderada e , mediapond)
FIM_ALGORITMO

Em C++:
#include <iostream.h>
#include <conio.h>

main()
{ float nota1, nota2, nota3, peso1, peso2, peso3, media;

// Recebe as tres notas e seus pesos


cout << "Informe a 1a nota e seu peso \n";
cin >> nota1 >> peso1;
cout << "\n" << "Informe a 2a nota e seu peso" << "\n";
cin >> nota2 >> peso2;
cout << "\nInforme a 3a nota e seu peso \n";
cin >> nota3 >> peso3;

// Calcula a media
media = (nota1 * peso1 + nota2 * peso2 + nota3 * peso3)/(peso1 + peso2 +
peso3);

// Mostra o resultado da media


cout << "\nA media ponderada e " << media;

// Para o programa a espera de um ENTER


getch();
}

-2-
Faa voc em C++ (4 e 5):
4- Faa um programa que receba o salrio de um operrio da construo civil,
calcule e mostre o novo salrio, sabendo-se que este sofreu um aumento de
25%.

ALGORITMO CalcNovoSalario1 ALGORITMO CalcNovoSalario1


DECLARE sal, novosal REAL DECLARE sal, aumento, novosal REAL
LEIA sal LEIA sal
novosal  sal + sal * 25/100 aumento  sal * 25/100
ESCREVA novosal novosal  sal + aumento
FIM_ALGORITMO ESCREVA novosal
FIM_ALGORITMO

5- Faa um programa que receba o salrio de um operrio e o percentual de


aumento, calcule e mostre o valor do aumento e o novo salrio.

ALGORITMO CalcAumentoESalario
DECLARE sal, percentual_de_aumento, valor_aumento, novosal REAL
ESCREVA (Informe o salario)
LEIA sal
ESCREVA (Informe o percentual de aumento)
LEIA percentual_de_aumento
valor_aumento  sal * percentual_de_aumento / 100
novosal  sal + valor_aumento
ESCREVA (O aumento foi de , valor_aumento)
ESCREVA (O novo salario e , novosal)
FIM_ALGORITMO

Exemplo em C++:
6- Faa um programa que calcule e mostre a rea de um tringulo.
rea=(base*altura)/2

ALGORITMO AreaTriangulo
DECLARE base, altura, area REAL
LEIA base, altura
area  (base * altura)/2
ESCREVA (A area do triangulo de base , base, e altura , altura, e , area)
FIM_ALGORITMO

Em C++:

#include <iostream.h>
#include <conio.h>
main()
// Declara as variveis identificadas
{ float base, altura, area;
// Recebe os dados de entrada
cout << "Informe a base e a seguir a altura \n";
cin >> base >> altura;
// Calcula a rea
area = (base * altura)/2;
// Mostra o resultado da rea
cout << "\nA area do triangulo de base " << base << e altura << altura <<
e << area;
// Para o programa a espera de um ENTER
getch();
}

-3-
Faa voc em C++ (7, 8 e 9):
7- Faa um programa que calcule e mostre a rea de um crculo. Mostre o
resultado de maneira semelhante ao exemplo anterior.
2
rea= *R

ALGORITMO AreaCirculo
DECLARE raio, area REAL
LEIA raio
area  3,1415 * pot(raio,2)
ESCREVA (A area do circulo de raio , raio, e , area)
FIM_ALGORITMO

8- Faa um programa que receba uma medida em ps, faa as converses a


seguir e mostre os resultados. Apresente os resultados informando a unidade
de medida e cada resultado em uma linha diferente.
1 p = 12 polegadas 1 jarda = 3 ps 1 milha = 1760 jardas

ALGORITMO Conversao
DECLARE pes, polegadas, jardas, milhas REAL
ESCREVA (Informe a medida em pes)
LEIA pes
polegadas  pes * 12
jardas  pes / 3
milhas  jardas / 1760
ESCREVA (\nPolegadas = , polegadas)
ESCREVA (\nJardas = , jardas)
ESCREVA (\nMilhas = , milhas)
FIM_ALGORITMO

9- Cada degrau de uma escada tem X de altura. Faa um programa que receba
essa altura e a altura que um operrio deseja alcanar subindo a escada,
calcule e mostre quantos degraus ele dever subir para atingir seu objetivo,
sem se preocupar com a altura do usurio. Todas as medidas fornecidas devem
estar em metros.

ALGORITMO Subida
DECLARE alt_degrau, alt_alcancar, qtd_degraus REAL
ESCREVA (Informe a altura do degrau)
LEIA alt_degrau
ESCREVA (Informe a altura a alcanar)
LEIA alt_alcancar
qtd_degraus  alt_alcancar / alt_degrau
ESCREVA (\nDeve subir , qtd_degraus)
FIM_ALGORITMO

-4-
Exemplo em C++:
10- Uma pessoa deseja pregar um quadro em uma parede. Faa um programa
para calcular e mostrar a que distncia a escada deve estar da parede. A pessoa
deve fornecer o tamanho da escada e a altura em que deseja pregar o quadro.

Medida
A Altura em que deseja pregar o quadro.
da escada B Tamanho da escada.
A C Distncia em que dever ficar a escada.
B
2 2 2 2 2 2
B =A +C  C =B - A

C Distncia que a escada est da parede

ALGORITMO Calculo_da_Distncia
DECLARE altura, escada, distancia REAL
LEIA escada
LEIA altura
Distancia  pot(escada,2) pot(altura,2)
Distancia  rad(distancia)
ESCREVA distancia
FIM_ALGORITMO

Em C++:

#include <iostream.h>
#include <conio.h>
#include <math.h> Para uso de pow e sqrt
main()

// Declara as variveis identificadas


{ float altura, escada, distancia;

// Recebe os dados de entrada


cout << "Informe o tamanho da escada \n";
cin >> escada;
cout << "Informe a altura desejada para o quadro \n";
cin >> altura;

// Calcula a distancia que escada deve ficar da parede (calcula C na figura)


distancia = pow(escada,2) pow(altura,2);
distancia = sqrt(distancia);

// Mostra o resultado (distncia da escada parede)


cout << "\nA escada deve ficar numa distancia de " << distancia << da
parede;

// Para o programa a espera de um ENTER


getch();
}

-5-
Faa voc:
11- Faa um programa que receba a medida (em graus / dado numrico) do
ngulo formado por uma escada apoiada no cho e encostada na parede e a
altura da parede onde est a ponta da escada, calcule e mostre a medida desta
escada.

Sabemos que: Medida


da escada
B = A / seno(radiano) A
Onde: B
radiano = a * 3,14 / 180 Altura da
parede a(
C

ALGORITMO Medida_da_Escada
DECLARE angulo, alt_parede, medida_escada, angulo_radianos REAL
ESCREVA(Informe o ngulo e a altura da parede na ponta da escada)
LEIA ngulo, alt_parede
angulo_radianos  angulo * 3,14 / 180
medida_escada  alt_parede / seno(angulo_radianos)
ESCREVA (A escada mede , medida_escada)
FIM_ALGORITMO

-6-