Você está na página 1de 7

Comparao Cisco NX-OS / IOS BGP (Bsico)

Objetivo

Esta nota tcnica descreve as principais diferenas no suporte ao protocolo Border Gateway entre o software Cisco NX-OS e o software Cisco IOS. As configuraes de
exemplo so includas para o Cisco NX-OS e o software Cisco IOS para alguns recursos comuns para demonstrar as semelhanas e diferenas. Consulte a documentao
do NX-OS no Cisco.com para obter uma lista completa dos recursos suportados.

Viso geral do BGP

BGPv4 um protocolo de roteamento externo padro definido no RFC 4271 , comumente usado para trocar informaes de acessibilidade de rede entre sistemas
autnomos. Este documento cobre os recursos necessrios para a conectividade bsica.

Importantes diferenas de software Cisco NX-OS e Cisco IOS

No Cisco NX-OS:

Os comandos de configurao e verificao BGP CLI no esto disponveis at que voc ative o recurso BGP com o comando bgp do recurso .

O protocolo BGP requer uma licena de Servios empresariais.

Os nmeros do sistema autnomo podem ser configurados como valores de 16 ou 32 bits.

As famlias de endereos precisam ser ativadas explicitamente (IE: IPv4 unicast, IPv6 unicast, etc ...). Todas as famlias de endereos esto desabilitadas por padro.

Por padro, o eBGP suporta 8 Equal Cost Paths e iBGP suporta 1. O Cisco NX-OS suporta at 16 Caminhos de custo iguais para eBGP e iBGP.

O Resumo automtico da Rota e a Sincronizao so desativados por padro.

O BGP consiste em uma configurao hierrquica baseada em vizinhos e famlias de endereos.

Se um ID de roteador no for configurado manualmente, o endereo IP de loopback sempre ser preferido. Se o loopback 0 no existir, o Cisco NX-OS seleciona o
endereo IP para a primeira interface de loopback na configurao. Se no existirem interfaces de loopback, o Cisco NX-OS seleciona o endereo IP para a primeira
interface fsica na configurao.

O registro de vizinho no est habilitado por padro na instncia do BGP. O registro de vizinho pode ser ativado com o comando log-neighbor-changes .

Quando a autenticao vizinha configurada, a chave BGP 3DES criptografada na configurao. O software Cisco IOS requer o comando da senha do servio para
criptografar a senha na configurao.

Coisas que voc deve saber

A lista a seguir fornece alguns fatos adicionais sobre o Cisco NX-OS que devem ser teis ao projetar, configurar e manter uma rede BGP.

Uma instncia do BGP pode ser configurada por Contexto do dispositivo virtual (VDC).

Numerosas instncias de encaminhamento de rotas virtuais (VRF) podem ser associadas a uma instncia BGP.

Se o comando bgp do recurso for removido, todas as informaes de configurao BGP relevantes tambm sero removidas.

As declaraes de rede devem ser configuradas sob seu respectivo modo de configurao de endereo-famlia ao anunci-las atravs do BGP.

O comando shutdown sob a instncia BGP pode ser usado para desativar o BGP enquanto mantm a configurao.

O comando show running-config bgp exibe a configurao BGP atual.

Uma instncia BGP pode ser reiniciada com o comando reiniciar bgp <instncia #> .

Graceful Restart ( RFC 3623 ) est habilitado por padro.

Comparao de configurao

As seguintes semelhanas e diferenas de cdigo de configurao de exemplo entre as CLI do Cisco NX-OS e o IOS de Cisco. Existem trs diferenas significativas: o
Cisco NX-OS permite que o BGP seja habilitado e desativado globalmente. Utiliza uma configurao hierrquica que facilita a leitura. O Cisco NX-OS no habilita famlias
de endereos por padro. Cada famlia de endereos precisa ser habilitada explicitamente. Os exemplos a seguir demonstram isso usando a famlia de endereos IPv4
unicast.

Cisco IOS CLI Cisco NX-OS CLI


Enabling the BGP Feature
Cisco IOS Software does not have the functionality to enable or disable BGP. ROUTE

Configuring a BGP Instance and Router ID


router bgp 10 router bgp 10

bgp router-id 192.168.1.1 router-id 192.168.1.1

Configuring a BGP Neighbor (Internal)


router bgp 10
router bgp 10
neighbor 192.168.2.1 remote-as 10
neighbor 192.168.2.1 remote-as 10
update-source loopback0
neighbor 192.168.2.1 update-source Loopback0
address-family ipv4 unicast

Configuring a BGP Neighbor (External)


router bgp 10
router bgp 10
neighbor 192.168.10.2 remote-as 11
neighbor 192.168.10.2 remote-as 11
address-family ipv4 unicast

Advertising a Network in an Address Family (IPv4)


router bgp 10

router bgp 10 address-family ipv4 unicast

network 159.142.1.0 mask 255.255.255.0 network 159.142.1.0/24

network 159.142.254.0 mask 255.255.255.0 network 159.142.254.0/24

neighbor 192.168.10.2 remote-as 11 neighbor 192.168.10.2 remote-as 11

address-family ipv4 unicast

Configuring Neighbor Authentication (MD5)


router bgp 10
router bgp 10
neighbor 192.168.10.2 remote-as 11
neighbor 192.168.10.2 remote-as 11
password 3 a667d47acc18ea6b
neighbor 192.168.10.2 password cisco123
address-family ipv4 unicast

Configuring an Aggregate Address (Summary-Only)


router bgp 10

router bgp 10 address-family ipv4 unicast

network 159.142.1.0 mask 255.255.255.0 network 159.142.1.0/24

network 159.142.254.0 mask 255.255.255.0 network 159.142.254.0/24

aggregate-address 159.142.0.0 255.255.0.0 summary-only aggregate-address 159.142.0.0/16 summary-only

neighbor 192.168.10.2 remote-as 11 neighbor 192.168.10.2 remote-as 11

address-family ipv4 unicast

Generating a Default Route for a Neighbor


router bgp 10
router bgp 10
neighbor 192.168.10.2 remote-as 11
neighbor 192.168.10.2 remote-as 11
address-family ipv4 unicast
neighbor 192.168.10.2 default-originate
default-originate

2
Verification Command Comparison

The following table compares some useful show commands for verifying and troubleshooting a BGP network configuration.

Cisco NX-OS BGP Cisco IOS Software BGP Command Description


show bgp convergence - Displays global convergence information
show bgp process - Displays global BGP process information
show bgp sessions - Displays information for all neighbors
show bgp statistics - Displays global BGP process statistics
- - -
show ip bgp <option> show ip bgp Displays BGP Process and BGP table entries
show ip bgp x.x.x.x show ip bgp x.x.x.x Displays a specific network in the BGP table
show ip bgp x.x.x.x vrf - Displays a network in a specified VRF BGP table
show ip bgp x.x.x.x/len show ip bgp x.x.x.x mask Displays a specific prefix in the BGP table
show ip bgp x.x.x.x/len longer-prefix show ip bgp x.x.x.x mask longer-prefix Displays a prefix in the table with longer prefixes
show ip bgp all show ip bgp all Displays the BGP table for all protocol families
show ip bgp community <word> show ip bgp community <#> Displays routes with a specific regular expression
show ip bgp community <aa:nn> - Displays routes with a specific community value
show ip bgp community internet - Displays BGP routes advertised to the Internet
show ip bgp community no-advertise show ip bgp community no-advertise Displays BGP routes not advertised to peers
show ip bgp community no-export show ip bgp community no-export Displays BGP routes not exported to next AS
show ip bgp community no-export-
- Displays BGP routes not sent to outside local AS
spoofed
show ip bgp community-list <name> show ip bgp community-list <name> Displays a specific BGP community list
show ip bgp dampening dampened-paths show ip bgp dampening dampened-paths Displays all Dampened paths
show ip bgp dampening flap-statistics show ip bgp dampening flap-statistics Displays flap statistics for BGP routes
show ip bgp dampening history-paths - Displays all history paths
show ip bgp dampening parameters show ip bgp dampening parameters Displays all of the Dampening parameters
show ip bgp extcommunity <word> - Displays routes with a specific regular expression for extended communities
show ip bgp extcommunity-list <name> - Displays a specific BGP extended community list
show ip bgp filter-list show ip bgp filter-list Displays all routes matching a specified filter list
show ip bgp flap-statistics - Displays all BGP route flap statistics
show ip bgp ipv4 multicast <option> show ip bgp ipv4 multicast <option> Displays BGP IPv4 multicast address families
show ip bgp ipv4 unicast <option> show ip bgp ipv4 unicast <option> Displays BGP IPv4 unicast address families
show ip bgp neighbors show ip bgp neighbors Displays detailed neighbor information
show ip bgp neighbors x.x.x.x show ip bgp neighbors x.x.x.x Displays detailed information for a neighbor
show ip bgp nexthop x.x.x.x - Displays all routes matching a specified next-hop
show ip bgp nexthop-database - Displays the next-hop database
show ip bgp paths show ip bgp paths Displays all BGP paths
show ip bgp peer-policy - Displays BGP peer policy by specified name
show ip bgp peer-session - Displays information about a peer session
show ip bgp peer-template show ip bgp unicast ipv4 template Displays information about a peer template
show ip bgp prefix-list show ip bgp prefix-list Displays routes matching a specified prefix-list
show ip bgp regexp show ip bgp regexp Displays routes matching a regular-expression
show ip bgp received-paths - Displays the paths stored for soft reconfiguration
show ip bgp route-map show ip bgp route-map Displays BGP routes matching a route-map
show ip bgp summary show ip bgp summary Displays a summary list of neighbors and statistics
show ip bgp vrf show ip bgp vpnv4 vrf Displays information for a specified BGP VRF

Comparao Cisco NX-OS / IOS BGP (Avanada)


Objetivo

3
Esta nota tcnica descreve as principais diferenas no suporte avanado do Protocolo de Gateway de Borda (BGP) entre o software Cisco NX-OS e o software Cisco
IOS. As configuraes de exemplo esto includas no Cisco NX-OS e no software Cisco IOS para alguns recursos comuns para demonstrar as semelhanas e
diferenas. Consulte a documentao do NX-OS no Cisco.com para obter uma lista completa dos recursos suportados.

Viso geral do BGP

BGPv4 um protocolo de roteamento externo padro definido no RFC 4271 , comumente usado para trocar informaes de acessibilidade de rede entre sistemas
autnomos. Este documento discute refletores de rotas, confederaes, modelos de pares, polticas de mapa de rota e o recurso de lista de prefixos (filtragem de rotas).

Importantes diferenas de software Cisco NX-OS e Cisco IOS

No Cisco NX-OS:

Ao configurar refletores de rota, o comando route-reflector-client atribudo por vizinho sob a famlia de endereos especficos do vizinho.

Ao configurar confederaes, a confederao configurada sob o sistema autnomo sem a palavra-chave bgp lder .

O Cisco NX-OS usa um modelo de pares em vez de um grupo de pares para reutilizar polticas comuns do BGP.

Mltiplos modelos de polticas podem ser aplicados a um nico vizinho. O software Cisco IOS permite apenas um modelo de poltica por vizinho.

O Cisco NX-OS no requer uma reinicializao manual para um vizinho quando sua poltica de roteamento modificada. O software Cisco IOS requer uma
reinicializao rgida ou suave dependendo das capacidades vizinhas trocadas.

Coisas que voc deve saber

A lista a seguir fornece alguns fatos adicionais sobre o Cisco NX-OS que devem ser teis ao projetar, configurar e manter uma configurao de rede BGP avanada.

Os modelos pares e sesses definem atributos vizinhos, como senhas de segurana, temporizadores e opes de transporte.

Os modelos de pares e os modelos de sesso possuem capacidades de configurao idnticas com uma exceo: os modelos pares podem configurar famlias de
endereos.

Os modelos de pares e sesses so herdados por um vizinho atravs do modo de configurao do vizinho BGP.

Apenas um modelo de pares e modelo de sesso pode ser herdado por um nico vizinho BGP.

Os modelos Peer podem herdar modelos de sesso.

Os modelos de sesso podem herdar outros modelos de sesso.

Os modelos de polticas definem as polticas de endereo-famlia para polticas de entrada ou de sada, incluindo originao de rota padro, listas de filtros, polticas de
mapa de rota, listas de prefixos, etc.

Mltiplos modelos de polticas podem ser atribudos por vizinho. Os modelos de poltica so executados em ordem com base no nmero de seqncia configurado.

Os modelos de polticas so herdados por um vizinho atravs do modo de configurao do vizinho e do endereo-famlia.

As polticas de mapa de rota podem configurar atributos de BGP, tais como como caminho, listas de comunidades, atributos de comunidade, amortecimento,
preferncias locais, tipo de mtrica, origem e peso.

As polticas do mapa de rota podem ser aplicadas por vizinho para polticas de roteamento de entrada e sada.

Comparao de configurao

O cdigo de exemplo a seguir mostra as semelhanas e diferenas de configurao entre o Cisco NX-OS e as CLI do software Cisco IOS. As configuraes so muito
semelhantes, com exceo da hierarquia utilizada no Cisco NX-OS.

Cisco IOS CLI Cisco NX-OS CLI


Configuring a Route-Reflector
router bgp 10 router bgp 10

no synchronization address-family ipv4 unicast

network 192.168.11.1 mask 255.255.255.255 network 192.168.11.1/32

neighbor 192.168.2.1 remote-as 10 neighbor 192.168.2.1 remote-as 10

4
neighbor 192.168.2.1 update-source Loopback0 update-source loopback0

neighbor 192.168.2.1 route-reflector-client address-family ipv4 unicast

no auto-summary route-reflector-client

Configuring Confederations
router bgp router bgp 65534

no synchronization confederation identifier 10

bgp confederation identifier 10 confederation peers 65535

bgp confederation peers 65535 address-family ipv4 unicast

network 192.168.11.1 mask 255.255.255.255 network 192.168.11.1/32

neighbor 192.168.10.2 remote-as 65535 neighbor 192.168.10.2 remote-as 65535

no auto-summary address-family ipv4 unicast

Configuring a Peer Template


router bgp 10 router bgp 10

no synchronization address-family ipv4 unicast

network 192.168.11.1 mask 255.255.255.255 network 192.168.11.1/32

neighbor IBGP-Template peer-group template peer IBGP-Template

neighbor IBGP-Template password cisco123 password 3 a667d47acc18ea6b

neighbor IBGP-Template update-source Loopback0 update-source loopback0

neighbor 192.168.2.1 remote-as 10 address-family ipv4 unicast

neighbor 192.168.2.1 peer-group IBGP-Template neighbor 192.168.2.1 remote-as 10

no auto-summary inherit peer IBGP-Template

Configuring a Policy Template


router bgp 10

template peer-policy EBGP-Policy router bgp 10

default-originate address-family ipv4 unicast

send-community network 192.168.11.1/32

exit-peer-policy template peer-policy EBGP-Policy

send-community

no synchronization default-originate

network 192.168.11.1 mask 255.255.255.255 neighbor 192.168.10.2 remote-as 20

neighbor 192.168.10.2 remote-as 20 address-family ipv4 unicast

neighbor 192.168.10.2 inherit peer-policy EBGP-Policy inherit peer-policy EBGP-Policy 10

no auto-summary

Configuring an Outbound Neighbor Route-Map Policy


route-map EBGP-Policy permit 10 route-map EBGP-Policy permit 10

set as-path prepend 10 10 10 set as-path prepend 10 10 10

router bgp 10 router bgp 10

no synchronization address-family ipv4 unicast

5
network 192.168.11.1 mask 255.255.255.255 network 192.168.11.1/32

neighbor 192.168.10.2 remote-as 20 neighbor 192.168.10.2 remote-as 20

neighbor 192.168.10.2 route-map EBGP-Policy out address-family ipv4 unicast

no auto-summary route-map EBGP-Policy out

Configuring an Outbound Prefix-List


ip prefix-list EBGP-Policy seq 5 permit 192.168.11.1/32
ip prefix-list EBGP-Policy seq 5 permit 192.168.11.1/32

router bgp 10
router bgp 10
no synchronization
neighbor 192.168.10.2 remote-as 20
neighbor 192.168.10.2 remote-as 20
address-family ipv4 unicast
neighbor 192.168.10.2 prefix-list EBGP-Policy out
prefix-list EBGP-Policy out
no auto-summary

Verification Command Comparison

The following table compares some useful show commands for verifying and troubleshooting a BGP network configuration.

Cisco NX-OS BGP Cisco IOS Software BGP Command Description


show bgp convergence - Displays global convergence information
show bgp process - Displays global BGP process information
show bgp sessions - Displays information for all neighbors
show bgp statistics - Displays global BGP process statistics
- - -
show ip bgp <option> show ip bgp Displays BGP Process and BGP table entries
show ip bgp x.x.x.x show ip bgp x.x.x.x Displays a specific network in the BGP table
show ip bgp x.x.x.x vrf - Displays a network in a specified VRF BGP table
show ip bgp x.x.x.x/len show ip bgp x.x.x.x mask Displays a specific prefix in the BGP table
show ip bgp x.x.x.x/len longer-prefix show ip bgp x.x.x.x mask longer-prefix Displays a prefix in the table with longer prefixes
show ip bgp all show ip bgp all Displays the BGP table for all protocol families
show ip bgp community <word> show ip bgp community <#> Displays routes with a specific regular expression
show ip bgp community <aa:nn> - Displays routes with a specific community value
show ip bgp community internet - Displays BGP routes advertised to the Internet
show ip bgp community no-advertise show ip bgp community no-advertise Displays BGP routes not advertised to peers
show ip bgp community no-export show ip bgp community no-export Displays BGP routes not exported to next AS
show ip bgp community no-export-
- Displays BGP routes not sent to outside local AS
spoofed
show ip bgp community-list <name> show ip bgp community-list <name> Displays a specific BGP community list
show ip bgp dampening dampened-paths show ip bgp dampening dampened-paths Displays all Dampened paths
show ip bgp dampening flap-statistics show ip bgp dampening flap-statistics Displays flap statistics for BGP routes
show ip bgp dampening history-paths - Displays all history paths
show ip bgp dampening parameters show ip bgp dampening parameters Displays all of the Dampening parameters
show ip bgp extcommunity <word> - Displays routes with a specific regular expression for extended communities
show ip bgp extcommunity-list <name> - Displays a specific BGP extended community list
show ip bgp filter-list show ip bgp filter-list Displays all routes matching a specified filter list
show ip bgp flap-statistics - Displays all BGP route flap statistics
show ip bgp ipv4 multicast <option> show ip bgp ipv4 multicast <option> Displays BGP IPv4 multicast address families
show ip bgp ipv4 unicast <option> show ip bgp ipv4 unicast <option> Displays BGP IPv4 unicast address families
show ip bgp neighbors show ip bgp neighbors Displays detailed neighbor information

6
show ip bgp neighbors x.x.x.x show ip bgp neighbors x.x.x.x Displays detailed information for a neighbor
show ip bgp nexthop x.x.x.x - Displays all routes matching a specified next-hop
show ip bgp nexthop-database - Displays the next-hop database
show ip bgp paths show ip bgp paths Displays all BGP paths
show ip bgp peer-policy - Displays BGP peer policy by specified name
show ip bgp peer-session - Displays information about a peer session
show ip bgp peer-template show ip bgp unicast ipv4 template Displays information about a peer template
show ip bgp prefix-list show ip bgp prefix-list Displays routes matching a specified prefix-list
show ip bgp regexp show ip bgp regexp Displays routes matching a regular-expression
show ip bgp received-paths - Displays the paths stored for soft reconfiguration
show ip bgp route-map show ip bgp route-map Displays BGP routes matching a route-map
show ip bgp summary show ip bgp summary Displays a summary list of neighbors and statistics
show ip bgp vrf show ip bgp vpnv4 vrf Displays information for a specified BGP VRF

Você também pode gostar