Você está na página 1de 4

Construindo Cisco BGP Community

Basicamente uma community ou community permitem o agrupamento de prefixos que compartilham um conjunto comum de princípios que
utilizam transitivo atributo BGP. Esse atributo consiste em um conjunto de quatro valores de octeto que especificam uma community. Os valores de
atributo são codificados com um sistema autônomo ou número AS nos dois primeiros octetos, com os dois octetos restantes contendo o valor. Um
prefixo pode ter mais de um atributo da community e muitas vezes faz. O diagrama abaixo descreve um cenário com um Cliente Multihomed, e um
ISP fornecendo duas conexões WAN uma Ethernet e outra conexão Serial muito mais lenta.

Lista de community do BGP


Se vamos usar as community para marcar rotas com valores, então vamos precisar de uma maneira de controlar ou aceitar essas rotas com tags com
valores na outra extremidade. É aí que a BGP Community List entra em jogo. Eles permitem que um cliente ou provedor de serviços dependendo da
direção das rotas marcadas para ser agido quando chegarem. Basicamente é como uma ACL para rotas marcadas.

Formato da community BGP


Originalmente, as community padrão eram formatadas com um único grande número que não fazia muito sentido. Felizmente com a nova versão do
IOS há um novo formato mais significativo e elegante. Este novo formato está na forma de ADN: VALOR que é muito mais fácil de se entender. No
entanto, este novo formato deve ser especificado dentro da configuração, se você quiser utilizá-lo. Eu vou cobrir isso mais tarde na configuração, em
todos os três roteadores, mas eu queria cobri-lo antes de começar.
Vamos começar por colocar as duas interfaces WAN em funcionamento no Router R1.

R1#configure terminal
R1(config)#interface f0/0
R1(config-if)#ip address 10.0.0.2 255.255.255.252
R1(config-if)#interface s0/0
R1(config-if)#ip address 10.0.1.2 255.255.255.252
R1(config-if)#end
R1#

Vamos colocar as interfaces Ethernet WAN no roteador PE SP1 do provedor de serviços em funcionamento.

SP1#configure terminal
SP1(config)#interface f0/0
SP1(config-if)#ip address 10.0.0.1 255.255.255.252
SP1(config-if)#interface f0/1
SP1(config-if)#ip address 10.65.65.1 255.255.255.252
SP1(config-if)#end
SP1#

Agora podemos fazer o mesmo com o muito mais lento Serial WAN interfaces sobre os prestadores de serviços outros PE Router SP2 juntamente com
a interface iBGP Ethernet entre SP2 e SP1.

SP2#configure terminal
SP2(config)#interface s0/0
SP2(config-if)#ip address 10.0.1.1 255.255.255.252
SP2(config-if)#interface f0/1
SP2(config-if)#ip address 10.65.65.2 255.255.255.252
SP2(config-if)#end
SP2#

Precisamos criar uma ACL simples que possamos usar em conjunto com os Mapas de Rota que basicamente cobrirão os três prefixos que vamos anunciar
do Roteador R1 para o Roteador SP1 e SP2. Este é basicamente uma rota resumida que abrange todas as interfaces de loopback que vamos anunciar
upstream para o roteador SP1 e SP2.

R1#configure terminal
R1(config)#ip access-list extended 100
R1(config-ext-nacl)#permit ip 0.0.0.0 0.0.0.0 any log
R1(config-ext-nacl)#permit ip 172.16.0.0 0.0.255.255 any log
R1(config-ext-nacl)#exit
R1#

Permite ter certeza de que permitir que o BGP novo formato [ ASN : VALOR ] no Roteador R1 juntamente com a rota padrão apontou para o Firewall
para ALL internet tráfego relacionado como descrito no diagrama acima.

R1#configure terminal
R1(config)#ip bgp-community new-format
R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.4
R1(config)#end
R1#

Agora que basicamente temos uma ACL resumida para todas as interfaces de retorno de loop, vamos seguir com a criação dos Mapas de Rota. O objetivo
do primeiro Mapa de Rota LP-300 é definir a Preferência Local do BGP nos Provedores de Serviços PE Router SP1 a 300.

R1#configure terminal
R1(config)#route-map LP-300 permit 10
R1(config-route-map)#match ip address 100
R1(config-route-map)#set local-preference 300
R1(config-route-map)#exit
R1(config)#

O objetivo do segundo Mapa de Rota LP-200 é configurar a Preferência Local do BGP a montante no Provedor de Serviços PE Router SP2 para 200.
Fazendo isso, asseguramos que o caminho preferido é sobre a conexão WAN Ethernet muito rápida Ele muito mais lento conexão WAN serial.

R1(config)#route-map LP-200 permit 10


R1(config-route-map)#match ip address 100
R1(config-route-map)#set local-preference 200
R1(config-route-map)#end
R1#

Agora que temos a ACL no lugar, juntamente com os Mapas de Rota permite saltar para a configuração BGP no Roteador R1. Lembre-se de que os
Mapas de Rotas com a ACL estendida não entram em jogo até que os configuremos com os Vizinhos.

R1#configure terminal
R1(config)#router bgp 65000
R1(config-router)#bgp router-id 10.0.0.2
R1(config-router)#network 0.0.0.0
R1(config-router)#network 172.16.0.0 mask 255.255.255.0
R1(config-router)#network 172.16.1.0 mask 255.255.255.0
R1(config-router)#network 172.16.2.0 mask 255.255.255.0
R1(config-router)#network 172.16.3.0 mask 255.255.255.0
R1(config-router)#neighbor 10.0.0.1 remote-as 500
R1(config-router)#neighbor 10.0.0.1 next-hop-self
R1(config-router)#neighbor 10.0.0.1 send-community both
R1(config-router)#neighbor 10.0.0.1 route-map LP-300 out
R1(config-router)#neighbor 10.0.1.1 remote-as 500
R1(config-router)#neighbor 10.0.1.1 next-hop-self
R1(config-router)#neighbor 10.0.1.1 send-community both
R1(config-router)#neighbor 10.0.1.1 route-map LP-200 out
R1(config-router)#end
R1#

Construindo listas de community


Pessoalmente, eu nunca entendi BGP Community (Route Tagging) que é até que eu descobri BGP Community Lista. Vamos enfrentá-lo o que é o ponto
em rotas de etiquetagem, e enviá-los upstream ou downstream se o roteador na outra extremidade não sabe o que fazer com eles ..? Depois de ter
uma lista de community no lugar que coincide com a marcação de seu envio, você pode começar a colocar as políticas de roteamento no lugar. Assim,
com o que disse vamos criar um par de BGP Community Lista no roteador do provedor de serviços SP1.

SP1#configure terminal
SP1(config)#ip bgp-community new-format
SP1(config)#ip community-list 1 permit 500:300
SP1(config)#

Agora vamos saltar para o roteador SP2 Service Provider e fazer a mesma coisa.

SP2#configure terminal
SP2(config)#ip bgp-community new-format
SP2(config)#ip community-list 1 permit 500:200
SP2(config)#

Agora que temos nossa lista de community no local, vamos passar para a configuração do mapa de rotas.

SP1(config)#route-map MATCH permit 10


SP1(config-route-map)#match community 1
SP1(config-route-map)#set local-preference 300
SP1(config-route-map)#exit
SP1(config)#

Agora vamos saltar de volta para o provedor de serviços roteador SP2 e fazer o inverso inverso.

SP2(config)#route-map MATCH permit 10


SP2(config-route-map)#match community 1
SP2(config-route-map)#set local-preference 200
SP2(config-route-map)#exit
SP2(config)#

Ok agora que temos o trabalho preliminar feito, podemos passar para configuração BGP no SP1 e SP2.

SP1(config)#router bgp 500


SP1(config-router)#bgp router-id 10.0.0.1
SP1(config-router)#redistribute connected
SP1(config-router)#neighbor 10.0.0.2 remote-as 65000
SP1(config-router)#neighbor 10.0.0.2 route-map MATCH in
SP1(config-router)#neighbor 10.65.65.2 remote-as 500
SP1(config-router)#exit
SP1#

Agora vamos passar para o Service Provider Router SP2 e obter BGP em funcionamento.

SP2(config)#router bgp 500


SP2(config-router)#bgp router-id 10.0.1.1
SP2(config-router)#redistribute connected
SP2(config-router)#neighbor 10.0.1.2 remote-as 65000
SP2(config-router)#neighbor 10.0.1.2 route-map MATCH in
SP2(config-router)#neighbor 10.65.65.1 remote-as 500
SP2(config-router)#exit
SP2#

Agora vamos dar uma olhada na tabela BGP no Router R1 do provedor de serviços.

SP1#show ip bgp | beg Network

Network Next Hop Metric LocPrf Weight Path

*> 0.0.0.0 10.0.0.2 0 300 0 65000 i

*> 10.0.0.0/30 0.0.0.0 0 32768 ?

*>i10.0.1.0/30 10.65.65.2 0 100 0 ?

* i10.65.65.0/30 10.65.65.2 0 100 0 ?

*> 0.0.0.0 0 32768 ?

*> 172.16.0.0/24 10.0.0.2 0 300 0 65000 i

*> 172.16.1.0/24 10.0.0.2 0 300 0 65000 i

*> 172.16.2.0/24 10.0.0.2 0 300 0 65000 i

*> 172.16.3.0/24 10.0.0.2 0 300 0 65000 i

*> 172.16.4.0/24 10.0.0.2 0 300 0 65000 i


Isso é exatamente o que procuram uma Local Preferência de 300

SP2#show ip bgp | begin Network

Network Next Hop Metric LocPrf Weight Path

*>i0.0.0.0 10.0.0.2 0 300 0 65000 i

* 10.0.1.2 0 200 0 65000 i

*>i10.0.0.0/30 10.65.65.1 0 100 0 ?

*> 10.0.1.0/30 0.0.0.0 0 32768 ?

*> 10.65.65.0/30 0.0.0.0 0 32768 ?

* i 10.65.65.1 0 100 0 ?

*>i172.16.0.0/24 10.0.0.2 0 300 0 65000 i

* 10.0.1.2 0 200 0 65000 i

*>i172.16.1.0/24 10.0.0.2 0 300 0 65000 i

* 10.0.1.2 0 200 0 65000 i

*>i172.16.2.0/24 10.0.0.2 0 300 0 65000 i

* 10.0.1.2 0 200 0 65000 i

*>i172.16.3.0/24 10.0.0.2 0 300 0 65000 i

* 10.0.1.2 0 200 0 65000 i

*>i172.16.4.0/24 10.0.0.2 0 300 0 65000 i

* 10.0.1.2 0 200 0 65000 i

Podemos ver a saída acima da tabela BGP no Router R2 do provedor de serviços que ele tem tanto a preferência local preferida de 300 junto com a
menos preferida preferência local de 200.
Espero que você tenha encontrado este post sobre Construindo Community útil e informativo. Certifique-se de deixar-me saber o que você pensa,
deixando sugestões, e comentários na seção de comentários abaixo. Você pode encontrar mais sobre estes e outros artigos verific para fora bornes e
arquivos recentes. Para saber mais sobre mim não se esqueça de verificar o Sobre página. E como sempre obrigado novamente para visitar o pacote .