Você está na página 1de 39

Universidade de São Paulo

Faculdade de Economia, Administração e Contabilidade de


Ribeirão Preto

Departamento de Economia

Notas de Aula de Computação para Economistas

Ribeirão Preto 2010


Índice

1 Hardware: atualidades e tendências.............................................................................3


2 Sistemas operacionais e internet..................................................................................3
3 O sistema Linux...........................................................................................................3
4 Controle de versões e sincronizadores.........................................................................3
5 Excel I: Fórmulas.........................................................................................................3

2
1 Hardware: atualidades e tendências

2 Sistemas operacionais e internet

3 O sistema Linux

4 Controle de versões e sincronizadores

5 Planilha eletrônica Excel

O programa de planilha eletrônica Excel® é uma das ferramentas mais difundidas


no mundo acadêmico e cooperativo. Apesar de haver ressalvas na utilização desse
programa para elaboração de estatísticas mais complexas e de cunho científico 1, esse
programa é amplamente aceito no ambiente corporativo. Apesar de haver limitações
estatísticas para uso acadêmico, algumas soluções já existem tais como add-ins e o
programa RExcel, além da possibilidade de programação via VBA.

1
A.T. Yalta (2008). The accuracy of statistical distributions in Microsoft Excel 2007. Computational
Statistics and Data Analysis 52, pp. 4579-4586.

3
Essa nota sobre Excel está dividida em três diferentes seções. A primeira descreve
fórmulas e funções existentes dentro dessa planilha eletrônica. A segunda parte apresenta
macros e programação VBA e finalmente a terceira demonstra o programa RExcel, o qual
se utiliza da interface gráfica do Excel e elabora as análises dentro do programa R.

Bases de Dados

As bases de dados que são utilizadas são:

1) Penn World Table - Center for International Comparisons of Production, Income


and Prices: fornece a contabilidade da renda nacional e da paridade do poder de
compra para mais de 188 países e para alguns desde 1950. As variáveis da base
são:

Real GDP per capita


Real Gross Domestic Income
Price Level of Gross(Constant Prices: Laspeyres),
Year (RGDPL adjusted for Terms
Domestic Product derived from growth rates of
of Trade changes)
c, g, i
Real GDP per capita
(Constant Prices: Laspeyres),
Population (in thousands) Price Level of Consumption Openness in Constant Prices
derived from growth rates of
domestic absorption
Real GDP per capita
Consumption Share of Real
Exchange Rate Price Level of Government (Constant Prices: Chain
GDP per capita (RGDPL)
series)
National Currency (Local Real GDP Chain perGovernment Share of Real
Price Level of Investment
Currency Unit) equivalent adult GDP per capita (RGDPL)
Purchasing Power Parity over Investment Share of Real
Openness in Current Prices Real GDP Chain per worker
GDP GDP per capita (RGDPL)
Real Gross Domestic Product Real GDP Laspeyres2 pergrowth rate of Real GDP
Ratio of GNP to GDP
per Capita, current price worker Chain per capita (RGDPCH)
Real Gross Domestic Product
Consumption Share of Real growth rate of Real GDP
per Capita Relative to theReal GDP Laspeyres2 person
Gross Domestic Product per Laspeyres2 per capita
United States (G-K method,engaged
Capita, current price (RGDPL2)
current price)
Real Gross Domestic Product
Government Share of Real Real GDP Laspeyres2 per
per Capita Relative to the
Gross Domestic Product per person counted in total 
United States (EKS method,
Capita, current price employment
current price)
Real Gross Domestic Product
Investment Share of Real
per Capita Relative to theReal GDP Laspeyres2 per
Gross Domestic Product per  
United States (weighted CPD hour worked by employees
Capita, current price
method, current price)

4
2) Human Development Index (HDI): O Índice de Desenvolvimento Humano é
coletado pela UNDP e é composto pelos dados sobre expectativa de vida,
educação e PIB per capita. Tem a finalidade de classificar os países quanto ao seu
padrão de vida. Os países são classificados como altamente desenvolvidos,
desenvolvidos, em desenvolvimento e subdesenvolvidos. Os dados são coletados
ao nível nacional.

3) Index of Democracy (ID): O Índice de democracia é elaborado pela Economist


Intelligence Unit e coletado ao nível nacional. Para seu cálculo são utilizados
indicadores de processo eleitoral, funcionamento do governo, participação
política, cultura política e liberdades civis.

5.1 Excel I: Fórmulas

Objetivo: Apresentar, descrever e praticar as funções financeiras, de data e hora,


matemáticas e trigonométricas, estatísticas, de procura e referência, de banco de dados,
de texto e lógicas.

Método: Com base nos três bancos de dados apresentados iremos juntá-los,
formataremos o banco final e analisaremos.

Base de dados utilizada: PWT, HDI e ID

Breve descrição da base:


1) PWT: A base é composta por 190 países com informações para 36 variáveis para o ano
de 2007. Dessa forma, a base possui 190 linhas por 36 colunas, uma matriz 190x36. Ou
seja:

5
2) IDH: possui 194 países e possui três variáveis, o rank do país, o valor do IDH e sua
classificação quanto ao desenvolvimento.

3) ID: possui 167 países com três variáveis, o rank, o valor do índice e o tipo de regime

6
5.1.1 Organizando os Bancos de Dados: Ferramentas de Procura e
Referências

Resumo:
 Copiar fórmulas absolutas ou relativas
 Vínculos com outras planilhas
 Função PROCV
 Função PROCV com a função CONCATENAR
 Função CORRESP
 Função COLS e LINS
 Função TRANSPOR

Copiar Fórmulas Absolutas ou Relativas

Suponha que a célula D3 é a divisão entre =B3/C3. Pode-se copiar para baixo a célula D3
e o Excel irá reconhecer a fórmula como relativa. Assim, a célula D4 será =B4/C4.
Para que as copias das fórmulas sejam absolutas deve-se utilizar o comando $ para
“travar” a linha ou a coluna, vejamos:

Assim $B$1 trava coluna e linha, B$1 trava linha e $B1 trava a coluna.

DICAS:
1) Para entrar no menu auditoria de fórmula pressione “ Crtl + ` ” – Control mais acento
agudo. Assim, poderá verificar as fórmulas.
2) Para inserir o símbolo $ em ambos coluna e linha, somente na coluna ou somente na
linha pressionar F4

7
Vínculos com outras planilhas

Pode-se vincular uma célula de determinada planilha com outra de uma planilha
diferente.
Para fazer esse vínculo digita-se = com o mouse entre na planilha desejada e clique na
célula que quer vincular. Assim, tem-se:

Pode-se também utilizar funções e vincular essas funções a outras planilhas. Assim,
quando houver alterações na planilha a qual se vinculou (em nosso caso a planilha Fonte)
automaticamente haverá alteração na planilha vinculada. Pode-se também utilizar
fórmulas relativas (A1) ou relativas ($A$1).

DICA:
1) Para trocar de uma planilha para outra no mesmo arquivo pressionar Crtl + PgUp ou
PgDn

PROCV

A função PROCV nos permite juntar os três bancos de dados. Essa função permite que
com base em uma chave seja possível pesquisar em outra planilha.
Em nosso exemplo temos três bancos de dados e todos eles possuem na sua primeira
coluna o nome do país. Essa será nossa chave. Observe que o nome do país tem que ser o
mesmo nas três planilhas.

8
Passo 1: Criar uma nova planilha com o nome Completa. Copiar e colar a base IDH que
possui a maior quantidade de países.

Passo 2: Pode-se definir um nome para cada intervalo que contem dados nas planilhas
países e Democracy. Para definir o nome siga Inserir/Nome/Definir. Vamos fazer isso
para o caso da planilha países e vamos chamá-la de “países”. Agora “países” quer dizer
=países!A2:M191 Para Democracy vamos utilizar sem dar nome e veremos a diferença.

Passo 3: Para facilitar a checagem posterior ordene de forma crescente de nome de país
todas as planilhas. Para ordenar siga Dados/Classificar.

Passo 4: Para ordenar A função PROCV


=PROCV(valor_procurado;matriz_tabela;num_índice_coluna;procurar_intervalo)

Vejamos cada um deles


Chave ou valor_procurado: É ainformaçào que está contida em todas as planilhas,
informação comum.
Fonte ou matriz_tabela: é a planilha da onde virão as informações ou seja a planilha ou
área da planilha que servirá de fonte ou insumo. A ela podemos dar um nome como dito
no passo 2.
Coluna a ser trazida ou num_índice_coluna: ë o numero da coluna a ser trazida da sua
planilha fonte. Assim, valor 1 quer dizer a primeira coluna da sua planilha fonte.

9
Exato ou procurar_intervalo: pode-se coincidir o valor exato da célula (valor 0) ou
parecido da célula (valor 1). Observe que Colômbia é diferente de Colombia (sem acento)
se a opção 1 for escolhida.

Assim tem-se:

Assim, a chave está na coluna A, países define o intervalo de informações que esta se
querendo trazer, 1 quer dizer que esta sendo trazida a primeira coluna desse intervalo e 0
é que a chave tem que ser exata. Podemos copiar essa fórmula para baixo e para o lado
lembrando que teremos que trocar qual a coluna que iremos trazer. Assim tem-se:

Observe a fórmula que está contida dentro da célula H3. Note também que não existe
coleta para Andorra e por isso aparece #N/D.

Agora repetimos o mesmo passo para a base sobre democracia. A diferença é que agora
não iremos utilizar a definição de nome e sim o intervalo das informações (=Democracy!
A2:D168) e o PROCV final para o caso do Peru será:

=PROCV($A138,Democracy!$A$2:$D$168,2,0)

10
DICA:
1) Pressione F2 e entre dentro da fórmula para alterá-la sem precisar dar dois cliques no
mouse
2) Para copiar a fórmula até o final da planilha posicione o cursor no canto direito inferior
da célula ativa onde está a fórmula. Veja que o cursor tornou-se uma cruz preta sólida. De
dois cliques no mouse e ela ira copiar até o final.
3) Para facilitar a visualização pode-se utilizar congelar painéis assim parte da planilha
ficará sempre visível. Posicione por exemplo na célula B2 e siga Janela/Congelar
painéis.

PROCV com mais de uma chave (Função CONCATENAR)

Em algumas situações temos mais de uma chave para fazer a pesquisa de


informações. Esse seria o caso, por exemplo, de termos um país com informações para
dois anos distintos 2006 e 2007. Nesse caso só a chave do nome do país não seria
suficiente. Teríamos que ter outra informação para identificarmos com precisão a
informação, como o ano.

Função CONCATENAR

Essa função junta o conteúdo de duas ou mais células. Assim, tem-se:

Para elaborar a busca das informações com mais de uma chave segue-se os passos.

Passo 1: Na planilha que serão fontes criar na 1ª coluna uma chave com a função
concatenar. A chave sempre tem que estar na primeira coluna.. Assim, cada planilha

11
fonte tem-se uma chave. Exemplo: na célula A2=CONCATENAR(B2,C2). Como
resultado possível teria Afghanistan2007.

Passo 2: Na planilha que receberá as informações será elaborada a seguinte função

=PROCV(CONCATENAR(A2,B2),Plan2!$A$2:$D$5,4,0)

Cria-se a mesma chave existente nas planilhas fontes na planilha que receberá as
informações, ou seja:

Note que a planilha dois está a esquerda e a chave foi criada na primeira coluna e a
planilha 1 está a direita com a função PROCV. Note também a diferença nos valores de
Y devido a ordem trocada do Afeganistão.

Função CORRESP

Suponha que queiramos achar na nossa base de dados completas (PWT+IDH+ID)


qual é o PIB per capita do país que ocupa a posição 100 no ranking do IDH. Observe que
nossa base está organizada por ordem crescente de país.
Para responder vamos utilizar a função CORRESP. Ela irá retornar a posição em
que se encontra o que estamos buscando. Para tanto se tem que indicar:
Valor procurado: qual valor que se quer buscado, em nosso caso é 100
Matriz procura: onde queremos buscar esse valor, em nosso caso a coluna HDI
rank.

12
Tipo correspondência: 1 - maior valor que for menor do que ou igual ao valor
procurado (padrão); 0 - primeiro valor que for exatamente igual ao valor procurado e -1
-menor valor que seja maior ou igual ao valor procurado

A fórmula para o nosso exemplo será


=CORRESP(100,C2:C195,0)
A qual gera o resultado 84, ou seja, informação 84 que corresponde a Jamaica.

Função COLS

Retorna o número de colunas de uma matriz. Para o nosso caso a seguinte função pode
ser escrita
=COLS(A2:V195)
Que retorna o valor 22, ou seja, temos 22 colunas.

Função LINS

Retorna o número de linhas de uma matriz. Para o nosso caso a seguinte função pode ser
escrita
=LINS(A2:V195)
Que retorna o valor 194, ou seja, temos 194 países em nosso banco de dados.

Esses comandos são particularmente úteis quando o banco não começa nem na linha 1 ou
na coluna A

Função TRANSPOR

Suponha que temos os 5 primeiros países em IDH e seu tipo de regime político. Assim
tem-se a seguinte tabela:

13
Ou seja, uma matriz de 6 linhas por 3 colunas (matriz 6x3). Suponha que queiramos
transpor essa matriz (matriz 3x6). O procedimento será:

Passo 1: em uma célula ativa digite a seguinte função =TRANSPOR(A1:C6), ou seja,


transpor a matriz que vai de A1 a C6 e aperte F2.

Passo 2: Começando da célula com a fórmula marque a dimensão da nova matriz (3


linhas e 6 colunas).

Passo 3: Clique dentro da barra de fórmula logo acima da planilha e pressione F2 e


depois CTRL+SHIFT+ENTER. A sua matriz estará transposta

Exercício:
Com a base na planilha de dados completa (Completa) calcule a média da população
(=media(I2:I195))entre países e o valor médio do Índice de Democracia
(=media(U2:U195)). Qual é o valor?
Resposta: Os valores serão #N/D e #N/D
Pergunta: Como fazer para obtermos essas médias?

Antes de chegarmos a resposta vamos ver as funções de Informações e Lógicas.

14
5.1.2 Trabalhando com a base de Dados: Ferramentas de Lógica

Resumo:
 Função SE
 Função E
 Função OU
 Funções aninhadas SE+OU
 Funções aninhadas SE+E
 Funções encadeadas SE

Função SE

Essa função é utilizada para testar condições determinadas pelo usuário e retorna valores
caso o teste seja verdadeiro ou falso.

Exemplo: suponha que queiramos saber os países que tiveram crescimento do PIB
positivo em 2007. Como deveríamos proceder?

Resposta: Vamos criar uma variável chamada “Crescimento PIB positivo”.

A função SE:
1) Teste_lógico: o que queremos testar, PIB>=0
2) Valor_se_verdadeiro: Valor caso verdadeiro, em nosso caso vamos considerar 1
3) Valor_se_falso: Valor caso falso, em nosso caso vamos considerar 0.

Assim a função será:


=SE(o que queremos testar, valor caso verdadeiro, valor caso falso)
=SE(R2>=0,1,0) ou =SE(R2>=0,”positivo”,”negativo”)

15
Função E

A função E é utilizada para testar diversas condições determinadas pelo usuário caso
todas as condições sejam verdadeiras retorna VERDADEIRO, caso uma delas seja falsa
retorna FALSO.

Exemplo: suponha que queiramos saber os países que tiveram crescimento do PIB
positivo e que tenham valor do índice de democracia menor que 4 (ou seja, são
autoritários). Como deveríamos proceder?

Resposta: Vamos criar uma variável chamada “Crescimento autoritário”.

A função E:
1) Lógico1: A primeira variável que queremos testar, PIB>=0
2) Lógico2: A segunda variável que queremos testar, ID<4
Obs: podemos testar até trinta condições

Assim a função será:


=E(R2>=0,U2<4)

Função OU

A função OU é utilizada para testar diversas condições determinadas pelo usuário caso
uma das condições sejam verdadeiras retorna VERDADEIRO, caso todas elas sejam falsa
retorna FALSO.

Exemplo: suponha que queiramos saber os países que tiveram crescimento do PIB
positivo ou que tenham valor do índice de democracia menor que 4 (ou seja, são
autoritários).

16
Resposta: Vamos criar uma variável chamada “Crescimento ou autoritário”.

A função OU:
1) Lógico1: A primeira variável que queremos testar, PIB>=0
2) Lógico2: A segunda variável que queremos testar, ID<4
Obs: podemos testar até trinta condições

Assim a função será:


=OU(R2>=0,U2<4)

Funções aninhadas SE+OU

Vamos agora aninhar a Função OU dentro da Função SE para aumentar nosso teste
lógico para diversas variáveis. Assim podemos testar um número maior de condições.

Exemplo: Queremos saber os países que possuem IDH menor que 5 (IDH baixo) OU
Índice de Democracia menor que 4 (autoritário) e classificá-los com vulneráveis e caso
contrário não vulneráveis.

Resposta: Vamos criar uma variável chamada “Vulneráveis 1”.

Nosso teste lógico agora é se o pais possui IDH menor que 5 (D2<5) ou se possui Índice
de democracia menor que 4 (U2<4). Assim tem-se a seguinte função:

=SE(OU(D2<5,U2<4),"vulneráveis","não vulneráveis")

Funções aninhadas SE+E

Vamos agora aninhar a Função E dentro da Função SE para também aumentar nosso teste
lógico para diversas variáveis.

17
Exemplo: Decidimos que para um país ser vulnerável deve possuir IDH menor que 5
(IDH baixo) E Índice de Democracia menor que 4 (autoritário).

Resposta: Vamos criar uma variável chamada “Vulneráveis 2”.

Nosso teste lógico agora é testar se o pais possui IDH menor que 5 (D2<5) e se também
possui Índice de Democracia menor que 4 (U2<4). Assim tem-se a seguinte função:

=SE(E(D2<5,U2<4),"vulneráveis","não vulneráveis")

Observação: Ao invés de utilizarmos nomes podemos utilizar números ou funções no


retorno da função se, como por exemplo:
=SE(E(D2<5,U2<4),1,0)
=SE(E(D2<5,U2<4),R2/100,Q2)

Funções encadeadas SE

Quando queremos testar diversas condições ou teste para mesma variável temos que
utilizar a Função SE encadeada.

Exemplo: Os países podem ser classificados quando ao seu desenvolvimento como:


Baixo – 0 a 0,499
Médio – 0,5 a 0,799
Alto – 0,8 a 0,899
Muito alto – 0,9 a 10

Relembrando a Função SE
=SE(o que queremos testar, valor caso verdadeiro, valor caso falso)

Vejamos a primeira condição para Baixo:


=SE(E(D2>0.01,D2<0.49999),"Baixo", Condição caso Falso)

18
Agora caso seja falso a primeira parte temos que acrescentar a segunda:
=SE(E(D2>0.01,D2<0.49999),"Baixo",SE(E(D2>0.5,D2<0.79999),"Medio", Condição
caso Falso)

Para a terceira:
=SE(E(D2>0.01,D2<0.49999),"Baixo",SE(E(D2>0.5,D2<0.79999),"Medio",SE(E(D2>0.
8,D2<0.89999),"Alto", Condição caso Falso)

E finalmente:
=SE(E(D2>0.01,D2<0.49999),"Baixo",SE(E(D2>0.5,D2<0.79999),"Medio",SE(E(D2>0.
8,D2<0.89999),"Alto",SE(E(D2>0.9,D2<=10),"Muito alto", "Outros"))))

Dessa forma temos a classificação para todas as categorias, para verificar isso utilize a
seguinte função SE:
=SE(AB2=E2,1,0)
Ou seja, se o IDH que criamos for igual ao IDH já criado anteriormente a função retorna
1 caso contrário retorna 0.

5.1.3 Trabalhando com a base de Dados: Ferramentas de Informações

Resumo:
 Função É.NÃO.DISP
 Função ÉERROS
 Função N

As funções de Informações são úteis para testar o tipo de conteúdo dentro de uma célula
retornando verdadeiro ou falso ou algum argumento determinado pelo usuário. São muito
úteis quando utilizadas de forma aninhada. Vejamos abaixo algumas dessas funções.

19
Função É.NÃO.DISP

Essa função verifica se o valor de determinada célula é não disponível, ou seja, #N/D e
retorna VERDADEIRO ou FALSO.

Assim, vamos criar a variável Não Disponível e verificar quantas informações não
disponíveis que temos para o Índice de Democracia. Temos:
=É.NÃO.DISP(U2)

Veja que os valores FALSO querem dizer que a célula possui valores disponíveis e que
valores VERDADEIRO diz que a célula possui valores não disponíveis. Assim, pode-se
saber quantos valores não determinados existem.

Dica: Para tornar o valor alfa numérico em numérico pode-se utilizar a função SE
(=SE(AD2=FALSO, 0, 1))

Função ÉRROS

Essa função verifica se existe algum erro na célula, sejam eles, #N/D, #VALORES!,
#REF, #DIV/0!, #NUM, #NOME?, ou #NUL0 e retorna se há erros (VERDADEIRO) ou
não há erros (FALSO).

Vamos verificar se há erros na variável criando uma variável “Erros” e utilizar a seguinte
função:
=ÉERROS(U2)

Como essa função também checa se existe #N/D, essa função retornar valores iguais a
variável Não Disponível. Verifique se é verdade.

20
Função N

Converte um valor não numérico em um valor numérico. Assim, VERDADEIRO será


convertido em 1 e FALSO será convertido em 0. Assim, pode-se calcular médias, somas
e outras estatísticas descritivas.

Vejamos a variável de Erros e aplicamos a função de N e vejamos seu resultado:


=N(AF2)

Observe que os valores FALSO na variável Erro foram transformados em 0 e os valores


VERDADEIRO foram transformados em 1.

Agora estamos preparados para montar uma nova planilha onde não irá aparecer os
valores de #N/D.

Aninhando SE, É.NÃO.DISP, PROCV e CONCATENAR.

Vamos adotar o mesmo procedimento inicial quando utilizamos o PROCV, no entanto


não utilizaremos a mesma Função PROCV.

Vamos relembrar o SE e PROCV


=SE(o que queremos testar, valor caso verdadeiro, valor caso falso)
=PROCV(valor_procurado;matriz_tabela;num_índice_coluna;procurar_intervalo)

Agora queremos dizer ao programa que quando ele encontrar valores Não disponíveis
para ele deixar esse valor em branco, ou seja, a célula sem conteúdo. Assim, para
montarmos a mesma tabela Completa mas sem os valores #N/D, utilizamos a seguinte
função:
Passo 1: O que queremos testar

21
=SE(É.NÃO.DISP(PROCV($A2,paises,1,0))=VERDADEIRO,
Passo 2: Valor caso o teste seja verdadeiro
=SE(É.NÃO.DISP(PROCV($A2,paises,1,0))=VERDADEIRO,"",
Passo 3: Valor caso o teste seja falso
=SE(É.NÃO.DISP(PROCV($A2,paises,1,0))=VERDADEIRO,"",,PROCV($A2,paises,1
,0))

Assim montamos a mesma planilha como a anterior (Completa), mas a chamaremos de


Completa 2

Outra opção é com base na planilha Completa fazer a seguinte função que iremos
elaborar para a variável “crescimento do PIB” para frente:
=SE(É.NÃO.DISP(Completa!W2), “”, Completa!W2)

Retomando o Exercício:
Com a base na planilha de dados completa (Completa) calcule a média da população
(=media(I2:I195))entre países e o valor médio do Índice de Democracia
(=media(U2:U195)). Qual é o valor?
População: 28754,7
ID: 5,541

Exercício: Vamos criar uma variável que será a união do IDH e do tipo de democracia
chamada IDH e democracia. Assim para o caso do Afeganistão o valor da variável será:
“IDH Baixo e Authoritarian Regimes”.

Resposta:

Passo 1: Como anteriormente já elaborado vamos começar da Função SE e proceder o


teste lógico

22
=SE(É.NÃO.DISP(PROCV($A2,Democracy!$A$2:$D$168,3,0))=VERDADEIRO,

Passo 2: Valor caso verdadeiro


=SE(É.NÃO.DISP(PROCV($A2,Democracy!$A$2:$D$168,3,0))=VERDADEIRO, "",

Passo 3: Valor caso falso


=SE(É.NÃO.DISP(PROCV($A2,Democracy!$A$2:$D$168,3,0))=VERDADEIRO, "",
"IDH" & " " & PROCV($A2,HDI!$A$2:$E$195,5,0) & "e" &
PROCV($A2,Democracy!$A$2:$D$168,4,0))

Dessa forma conseguimos criar a nossa variável desejada.

5.2 Formatação condicional

Essa função teve muitas modificações no Excel 2007 e tornou-se muito mais
poderosa.
Vejamos o tipo de questão que esse tipo de função responde. Suponha que
queiramos os valores do crescimento do PIB que são menores do que zero tenham a
célula preenchida com a cor vermelha e a letra branca. Como fazer?
Primeiro vamos criar na coluna AH uma copia da coluna que representa o
crescimento do PIB e chamaremos de PIB crescimento cor. Marque todos os valores
dessa coluna.
Entre agora em Formatar/formatar condicional... e aparecerá uma caixa onde
teremos dois campos.
1) Caixa contendo: Valor da célula é e A formula é Caixa contendo: entre; não
está entre; igual a; diferente de; maior do que; menor do que; maior ou igual a;
menor ou igual a.
2) Caixa contendo o limite imposto pelo usuário.

Vejamos no nosso exemplo como fazer:


Passo 1: Selecione Valor da célula é

23
Passo 2: Selecione menor do que
Passo 3: Na última caixa coloque 0
Passo 4: Indique a formatação clicando na caixa Formatar... Escolha letra branca e
preenchimento vermelho
Passo 5: Clique em adicionar – você poderá adicionar até três condições ( no
Excel 2007 as restrições são bem menores) e repita a operação de 1 a 4.

“Gráfico de Barras”

Vejamos como criar barras em uma célula a partir da função REPT. Essa função
repete um texto um número determinado de vezes escolhido pelo usuário. Vamos montar
esse gráfico para o PIBpc/1.000
Assim tem-se:
=SE(M2=””, “”, REPT(“|”, M2/1000))
Veja que temos as barras nas células indicando os países com maior PIB pc.

5.3 Manipulando a base de Dados: Funções Matemáticas

Resumo:
 Função SOMASE
 Função CONT.SE
 Função CONT.VALORES
 Função CONTAR.VAZIO
 Função SUBTOTAL
 Função SOMAPRODUTO
 Função ALEATORIO
 Função ALEATORIOENTRE
 Função ARRED
 Função MATRIZ.DETERM
 Função MATRIZ.INVERSO

24
 Função MATRIZ.MULT

Suponha agora que queiramos saber qual será a média do PIB per capta por grupo
de desenvolvimento humano e por grupo de democracia. Assim, queremos saber, por
exemplo, qual a média do PIB pc dos países classificados como Baixo desenvolvimento
humano.

Função SOMASE

Primeiramente vamos criar uma nova planilha chamada Analise1. Nela criaremos
uma tabela com três colunas (IDH, Soma PIB PC, paises). Assim teremos:
IDH PIB pc (soma) Paises
Baixo
Medio
Alto
Muito alto
Outros
Total
Total Checagem

A função SOMASE apresenta três caixas a serem preenchidas.


Caixa 1: É o intervalo para o qual faremos o teste lógico. Em nosso caso é a
coluna onde estão os países classificados por IDH (coluna E).
Caixa 2: O teste lógico a ser aplicado. Em nosso caso o primeiro será testar países
que possuem IDH Baixo (=Baixo)
Caixa 3: O intervalo onde ocorrera a soma. Em nosso caso será na coluna do PIB
per capita.(coluna M)
Assim tem-se a seguinte expressão:

=SOMASE('Completa 2'!$E$2:$E$195,"=Baixo",'Completa 2'!$M$2:$M$195)

Ou seja, o programa verifica quais as células do primeiro intervalo que são iguais
a Baixo e depois as soma a coluna M onde estão os dados de PIB pc.

25
Para obtermos a média precisamos saber quantos países estão classificados como
IDH baixo. Assim teremos que utilizar outra função CONT.SE

Funções CONT.VALORES, CONT.SE e CONTAR.VAZIO

Primeiramente vejamos a função CONT.VALORES. Na coluna de países na linha


Total checagem escreva a seguinte função:
=CONT.VALORES('Completa 2'!E2:E195)
Essa função ira contar todos os valores não nulos do nível do IDH. O valor é igual
a 194.
Repita a operação para os dados de PIB pc.
=CONT.VALORES('Completa 2'!M2:M195)
Observe que também teremos 194, pois ele soma as células que estão com função
dentro e não possuem valores.

Vamos agora contar o número de países por faixa de IDH. Assim iremos utilizar a
função CONT.SE. Esse função conta valores a partir de um teste lógico designado pelo
usuário. Assim temos a seguinte função:
=CONT.SE('Completa 2'!$E$2:$E$195,"=Alto")
Ele ira contar todas as células que possuem classificação como Alto

Com base nesses dois valores podemos utilizar a média para calcularmos o PIB pc
por classificação de IDH dos países. Assim tem-se a seguinte tabela
IDH PIB pc (soma) Paises Media errada
Baixo 31194.2308 24 1299.760
Medio 371759.9519 75 4956.799
Alto 562424.4977 45 12498.322
Muito alto 1307477.762 38 34407.310
Outros 36143.41229 12 3011.951
Total 2308999.855 194 11902.061
Total Checagem 2308999.855 194 11902.061

Qual o problema com essa tabela? Está tudo em ordem?

26
Vejamos a função CONTAR.VAZIO. Essa função conta todas as células vazias
dentro da sua planilha. Observe que a coluna do PIBpc possui uma série de células
vazias. Vamos contá-las:

=CONTAR.VAZIO('Completa 2'!M2:M195)

Chegamos a um valor de 13 células vazias.

Assim, possuímos 13 células que não possui argumento numérico, somente


função. Observe também que ao fazer a função CONT.VALORES obtivemos 194 países,
ou seja somou também as células vazias.

Função Subtotal

A função SUBTOTAL calcula diversas funções (ex.: média soma, máximo,


mínimo, variância etc) para uma certa quantidade de valores especificados pelo usuário.
Vejamos a função:
=SUBTOTAL(função que quer realizar – ver tabela abaixo, intervalo para realizar
a função )
Núm_função (incluindo valores Núm_função (ignorando valores Função
ocultos) ocultos)
1 101 MÉDIA
2 102 CONTA
3 103 CONT.VALORES
4 104 MÁX
5 105 MÍN
6 106 MULT
7 107 DESVPAD
8 108 DESVPADP
9 109 SOMA
10 110 VAR
11 111 VARP

Vamos fazer o subtotal do PIB PC para todos os nossos países. Assim teremos:
=SUBTOTAL(1,'Completa 2'!M2:M195)

27
O valor desse subtotal será: 12756,9052 o qual é diferente do que encontramos
anteriormente.
Vamos fazer o seguinte teste vamos pegar o total geral da soma dos PIBpc e
dividir por 194-13 vejamos quanto o resultado.
Resultado: 12756,9052

Dessa forma ainda não conseguimos tirar a média por grupo, pois estamos
dividindo por mais países que deveríamos.

Antes de resolvermos esse problema vamos dar uma olhada em outras funções
matemáticas.

Função SOMAPRODUTO

Suponha que queiramos somar o produto de duas ou mais variáveis, por exemplo,
somar o produto de X e Y. Suponha que essas variáveis possuam os seguintes valores:
X Y X.Y
1 10 10
2 13 26
3 16 48
4 19 76
5 22 110
6 25 150
Soma   420

Assim a soma do produto será 420.


Uma outra maneira de fazermos essa soma seria utilizar a função
SOMAPRODUTO:
=SOMARPRODUTO(A16:A21,B16:B21)
A qual gera valor igual a 420. Podemos somar o produto de diversas matrizes e
não somente de duas.

Função ALEATORIO

28
Essa função gera um número aleatório maior ou igual a 0 e menor e igual a 1
=ALEATORIO()

Função ALEATORIOENTRE
Essa função gera um número aleatório discreto entre dois valores especificados pelo
usuário, por exemplo, podemos gerar um número aleatório entre 1 e 100. Assim tem-se:
=ALEATÓRIOENTRE(1,100)

Aleatório a partir de uma distribuição


Outra maneira de criar um número aleatório é utilizar Ferramentas/Análise de
dados.../Geração de números aleatórios
Temos que identificar o número de variáveis aleatórias que serão geradas, o número de
números aleatórios para cada variável e de qual distribuição.
Vejamos:
Vamos criar uma variável com 3 números e uma distribuição uniforme entre 1 e 100.
Agora temos valores contínuos entre 1 e 100 e não mais discretos como tínhamos no
ALEATÓRIOENTRE

Função ARRED
Essa função arredonda para um número especificado de dígitos, vamos colar os 3
primeiros valores do PIBpc na planilha Análise1. Para isso faremos os seguintes passos:
1) Copiar
2) Editar/Colar especial
3) Valores.
Assim não copiamos a função, copiamos somente os valores. Observe que podemos
copiar formatos, funções, valores, transpor etc

Feito isso vamos utilizar a seguinte função:


=ARRED(G28,1)

29
Ou seja, arredondamos o PIBpc para uma casa decimal. Existem outras formas de
arredondar ( para cima, para baixo etc) que o leitor pode utilizar.

Funções MATRIZ.DETERM, MATRIZ.INVERSO, MATRIZ.MULT

Suponha que existam duas matrizes X e Y


1 0 0  3 4 5
X  0 3 0  e Y   4 5 3 
0 0 2   5 3 4 

Assim podemos calcular os determinantes, as inversas e multiplicá-las


Vejamos como calcular os determinantes, a função será
=MATRIZ.DETERM(F34:H36)

Os valores para X será 6 e para Y será -36

Vamos calcular a inversa. Em uma célula ativa escreva a seguinte função a qual deixa
ativa a matriz toda que se quer inverter:

=MATRIZ.INVERSO(F34:H36)

Nessa célula ativa ira aparecer o valor da coluna 1 linha 1. Marque as dimensões da
matriz resultante e clique em F2, logo após pressione Ctrl+Shift+Enter. Assim teremos a
inversa.

Inversas 1 0 0   -0.30556 0.027778 0.361111


-1 -1
 X = 0 0.333333 0  Y = 0.027778 0.361111 -0.30556
  0 0 0.5   0.361111 -0.30556 0.027778

30
Agora vamos multiplicar as matrizes inversas e gerar a matriz Z. Assim, em uma célula
ativa escreva a seguinte função (marca ambas as matrizes que se quer multiplicar – preste
atenção nas dimensões):

=MATRIZ.MULT(F40:H42,J40:L42)

Nessa célula ativa ira aparecer o valor da coluna 1 linha 1. Marque as dimensões da
matriz resultante e clique em F2, logo após pressione Ctrl+Shift+Enter. Assim teremos a
Z que a multiplicação das inversas.

Apesar de todo o esforço ainda não chegamos a resposta correta da questão:


Qual será a média do PIB per capta por grupo de desenvolvimento humano e por
grupo de democracia?

Vejamos uma possível solução...

5.4 Manipulando a base de Dados: Tabelas Dinâmicas

Solução força Bruta: Criando uma coluna de identificação

Vamos criar uma nova coluna chamada “PIBpc existe”que será igual a 1 quando houver
valores do PIBpc e vazia quando não houver. Após aplicaremos a função SOMASE.
Assim utilizaremos a função SE aninhada com a função OU da seguinte maneira:

=SE(OU(M2="",M2=0),"",1)

Ou seja, se o valor do PIBpc for igual a vazio ou zero a função irá retornar vazio.

31
Agora vamos utilizar a função SOMASE para encontrarmos o número correto de países
por nível de IDH da seguinte forma:

=SOMASE('Completa 2'!$E$2:$E$195,"=Baixo",'Completa 2'!$AJ$2:$AJ$195)

Assim temos a seguinte tabela:

IDH PIB pc (soma) Paises Media correta


Baixo 31194.2308 23 1356.271
Medio 371759.9519 71 5236.056
Alto 562424.4977 41 13717.671
Muito alto 1307477.762 36 36318.827
Outros 36143.41229 7 5163.345
Total 2308999.855 178 12971.909
Total Checagem 2308999.855 194 
Subtotal     12756.90527
Celulas Vazias 13 181 12756.90527

Observe que a média do subtotal é diferente da média que calculamos. Isso ocorre pela
existência de 3 países (diferença de 181-178) que possuem PIBpc igual a zero ao invés de
vazia. Dessa forma o zero entra no cálculo da média no subtotal e não entra no nosso
cálculo. Estamos sendo mais precisos. Seria importante a limpeza dessas células na base
original.

Relatório de Tabela e Gráfico Dinâmicos

Uma maneira alternativa é utilizar a função de tabela dinâmica do Excel. Essa função cria
relatórios sintéticos a partir de uma base existente.

32
Vejamos passo a passo como fazer:

1) Dados/Relatório de Tabela e Gráficos Dinâmicos....


2) Clique em Banco de Dados ou Lista do Microsoft Office Excel e em Tabela
Dinâmica - Avançar
3) Selecione a área toda da sua planilha Completa2 ($A$1:$AJ$195) - Avançar
4) Clique em Layout
5) Observe que a sua direita existe uma série de caixas contendo os nomes das
variáveis da nossa base de dados. No lado esquerdo existe uma tabela em branco a
qual temos que preencher. Clique na variável nível e arraste para a tabela na
posição linha. Clique e arraste Real GDP para o espaço dos dados.
6) Agora de dois cliques em cima da caixa Real GDP. Observe que há uma série de
funções que podemos utilizar. Iremos fazer a média.
7) Clique OK e escolha colocar o relatório em uma nova planilha e Concluir
8) Está pronto seu relatório!!!

Assim teremos a seguinte tabela ao final:


Média de Real GDP per capita (Constant Prices: Chain series)  
nivel Total
Alto 13079.63948
Baixo 1299.759617
Medio 5236.05566
Muito alto 36318.82672
Outros 5163.344613
Total geral 12756.90527

Agora podemos fazer outros cruzamentos, utilizando o mesmo procedimento anterior


tente utilizar o tipo de democracia na coluna.
Veja se chegou a essa tabela:

Média de Real GDP per capita (Constant Prices: Chain series) Clasificação democracia
nivel Authoritarian Regimes
Flawed Democrades
Full Democracy Hybrid Regimes Total geral
Alto 16256.17189 16112.89541 12661.7885 14919.78247 8242.352055 13079.63948
Baixo 389.9134254 1434.43222 894.7919074 1363.344377 1299.759617
Medio 5344.394513 5463.79881 5692.379181 3879.854033 5236.05566
Muito alto 42467.18628 65183.52355 28996.40476 34404.32735 44618.94834 36318.82672
Outros 5876.290967 1894.360562 4867.596895 5163.344613
Total geral 13136.40705 8305.024577 10470.93614 32316.69754 5617.595569 12756.90527

33
Novamente, precisamos limpar as variáveis que possuem valores iguais a zero na base
original para termos uma média mais precisa.

Gráfico no Excel

Fazer um gráfico onde o eixo horizontal está os países classificados por nível de IDH e
em um dos eixos horizontais temos o PIBpc médio e em outro temos a taxa de
investimento média.

1400000 35

1200000 30

1000000 25

800000 20
PIBpc

600000 15

400000 10

200000 5

0 0
Baixo Medio Alto Muito alto
IDH

PIBpc Investimento

Subtotal

Ë possível obter o subtotal do banco de dados por alguma variável desejada. Podemos por
exemplo achar o subtotal por nível de IDH. Para encontrar o subtotal vamos seguir os
seguintes passos:
1) criar uma nova base, Completa 3 que será uma cópia da Completa 2.

34
2) Vamos classificar de forma crescente a nossa base de dados por nível de IDH
3) Entrar em Dados/Subtotais

Observe que agora no canto superior direto temos os números 1, 2 e 3. O número 1


mostra o total geral, o 2 mostra somente os subtotais e o 3 mostra todos os dados.

Validação

Podemos definir para um determinado campo uma regra de digitação. Por exemplo,
podemos definir que o PIB per capta não pode ser negativo ou 0. Assim, utilizamos a
ferramenta de validação.Vejamos os passos
1) Na célula M2 (a do PIB per capta) utilize a opção Dados/Validação
2) Escolha na janela que se abriu Permitir: Personalizado e com a fórmula =M2>0
3) Na aba Mensagem de entrada coloque o título Valor campo e a mensagem
“Somente valores maiores do que 0”
4) Na aba Alerta de erro coloque o título Opção inválida e a mensagem de erro,
Valor incorreto. Somente valores maiores do que 0!!!
5) Copie até o final da planilha.
6) Faça o teste: clique em alguma dessas células e escreva um valor menor do que 0
e veja o que acontece!

Macro
A macro é capaz de automatizar uma determinada tarefa. Assim, se existem tarefas que
devem ser repetidas ou que possuem procedimentos repetidos, podemos gravar esses
procedimentos para utilização posterior.
Vamos supor que temos varias planilhas e que precisamos tirar o subtotal dessas
planilhas. Assim temos três procedimentos: 1) copiar, 2) Classificar por IDH e 3) inserir
subtotal.
Vejamos como fazer esse procedimento via macro. Os passos:
1) Ferramentas/Macros.../Gravar Macros
2) Nome da macro será Macrosubtotal

35
3) Agora selecione a planilha Completa 2
4) Clique com o botão direito sobre a aba da planilha e crie uma copia dessa.
5) Marque toda a extensão da planilha copiada que possua valores e classifique por
nível de IDH
6) Repita a operação de subtotal anteriormente descrita
7) Clique no botão de parar gravação da macro
8) Para testar sua macro delete a planilha feita
9) Clique em Ferramentas/Macro.../Macros.... Macrosubtotal e depois clique em
executar. Chegamos na mesma planilha anterior requereu 3 passos.

Criando um botão para a Macro

Duas maneiras para se criar um botão

1 – Botão área de trabalho:


Exibir/Barras de ferramentas/Formulários
Clique em botão e no corpo da planilha marque o tamanho que deseja o botão:
Automaticamente o Excel ira perguntar se gostaria de atribuir uma macro. Iremos atribuir
a macro Macrosubtotal. Com o botão direito podemos editar o texto e mudar a atribuição
da macro para esse botão.

Agora teste seu botão e veja se esta funcionando!!!

2- Botão na barra de ferramentas


Clique com o botão direito na barra de trabalho e em seguida em personalizar....
Selecione a aba Comandos e a Categoria Macros. Arraste o botão para a barra de
ferramentas e após atribua uma macro. Você pode alterar a imagem de exibição e mesmo
criar outras imagens.

Atingir Meta

36
O exemplo que se segue foi extraído do livro Fórmulas e Funções Excel 2007. Suponha
que uma empresa queira otimizar a sua margem de lucro.
Essa empresa irá lançar uma linha nova de produtos com expectativa de conseguir uma
margem de 30% no primeiro ano. Para esse ano as expectativas de vendas são 100.000
unidades; O desconto médio dos seus clientes será de 40%; os custos fixos serão
R$750.000 e o custo unitário será R$12,63. Assim temos:

A tabela abaixo possui o detalhamento das premissas acima.

Utilizando a ferramenta de
atingir metas
   
Preço por unidade R$ 1,00
Unidades vendidas 100.000
Desconto médio 40%
Rendimento total R$ 60.000
   
Custo por unidade R$ 12,63
Custos fixos R$ 750.000
Custos totais R$ 2.013.000
   
Lucro -R$ 1.953.000
Margem -3255,00%

Utilizando a ferramenta de atingir meta iremos definir a célula da margem como Definir
Célula; Para Valor 0,3 e alterando célula do preço por unidade. Observe que os preços
foram alterados para R$47,87.

Solucionando equações

Suponha que queiramos solucionar a seguinte equação:


(3x  8) 2 ( x  1)
1
4 x2  5

37
Vamos utilizar duas células no Excel, uma com o valor de x e outra com o lado esquerdo
da equação. Assim, teremos a seguinte fórmula:
=(((3*A20-8)^2)*(A20-1))/(4*A20^2-5)

Agora iremos utilizar a ferramenta de atingir metas e Definir Célula da equação Para o
Valor 1 e Alterando Célula de x.

Assim termos que x será igual a 0,9469.

Solver

Vejamos agora o exemplo anterior mas com duas células variando a de preço e a de
produto sendo que vamos colocar uma restrição de que não podemos produzir mais do
que 80.000 unidades de produto. Para tanto utilizaremos a ferramenta Solver.
Seguimos os seguintes passos:
a) A Célula de destino será a margem
b) Que será igual ao valor de 0,3
c) Serão preço por unidade e unidades vendidas
d) Submeter a restrição: Adicionar/ Referência de Célula menor ou igual a
restrição de 80.000
e) Solucionar

Teremos assim a solução para o nosso problema de margem alterando duas células.
Vendas 80.000 e preço R$52,39.

R Through Excel

Após a instalação correta do programa, utilize o ícone RExcel para ativar a ferramenta.
Siga os seguintes passos. Primeiro R Start depois Rcommander with Excel menus.
Vamos criar uma planilha nova e inserir uma base de dados já existente. Para isso
seguiremos os seguintes passos:

38
a) Data in packages
b) Read data set from an attached package
c) Dataset -> trees
d) Com o botão direito Get active DataFrame

Com a base ativa você pode gerar gráficos, fazer regressões e testes.

Uma outra forma é colocar os dados no R. Para ver como funciona siga os passos:
a) No comando RExcel clique em RthroughEcel Worksheet
b) Em Demo file clique em TwoColumns
c) Marque os dados e clique com o botão direito Put R DataFrame
d) Os dados estão ativos

Você pode clicar nos diversos botões para experimentar a potencialidade da ferramenta,
por exemplo Normal and t.

39