Você está na página 1de 7

Universidade Federal do Cear - UFC

Centro de Cincias CC
Resoluo do Exerccio 2 Estrutura Condicional Fundamentos de Programao
Professor: Jos Maria Monteiro
Aluno: Lucas Lima de Sousa
Matrcula: 378608
ALGORITMOS EM PORTUGOL
Questo 1
a) ALGORITMO
DECLARE A INTEIRO
DECLARE NUM1, NUM2 NUMRICO
ESCREVA Digite dois nmeros\n
LEIA NUM1, NUM2
ESCREVA "Escolha uma das opes: 1)para achar a media dos numeros.\n
ESCREVA 2) para subtrair o maior pelo menor .\n
ESCREVA 3) para achar o produto dos numeros digitados.\n
ESCREVA 4) para dividir o primeiro pelo segundo.\n"
LEIA A
ESCOLHA <A>:
CASO '1': ESCREVA A mdia =, (NUM1+NUM2)/2
CASO '2': SE (NUM2>NUM1) ENTO
INICIO
ESCREVA A diferena do maior pelo menor =, NUM2-NUM1
FIM
SENO
INICIO
ESCREVA A diferena do maior pelo menor =, NUM1-NUM2
FIM
CASO '3': ESCREVA O produto dos nmeros =, NUM1*NUM2
CASO '4': SE (NUM!=0) ENTO
INICIO
ESCREVA "A divisao do primeiro pelo segundo =",(num1/num2)
FIM
SENO
INCIO
ESCREVA Diviso por zero invalida.
FIM
OUTROCASO: ESCREVA Opo invlida.
FIM_ESCOLHA
FIM_ALGORITMO
b) ALGORITMO
DECLARE SAL NUMRICO
ESCREVA Digite o valor do salrio do funcionrio.
LEIA SAL
SE (SAL<900) ENTO
INICIO
SAL SAL*1,3

ESCREVA "Valor do novo salrio=", SAL


FIM
SENO ESCREVA "O funcionario em questao nao pode receber tal aumento."
FIM_ALGORITMO
c) ALGORITMO
DECLARE SALDO, CREDITO NUMRICO
ESCREVA "Para calcular o valor do seu credito especial, digite o valor de seu salo medio\n
LEIA SALDO
SE (SALDO>400) ENTO
INICIO
CREDITO SALDO*0,3
ESCREVA "O valor de seu saldo medio e=", SALDO, .\n
ESCREVA "O valor de seu credito e=", CREDITO, .\n
FIM
SE (SALDO<=400) E (SALDO>300) ENTO
INICIO
CREDITO SALDO*0,25
ESCREVA "O valor de seu saldo medio e=", SALDO, .\n
ESCREVA "O valor de seu credito e=", CREDITO, .\n
FIM
SE (SALDO<=300) E (SALDO>200) ENTO
INICIO
CREDITO SALDO*0,20
ESCREVA "O valor de seu saldo medio e=", SALDO, .\n
ESCREVA "O valor de seu credito e=", CREDITO, .\n
FIM
SE (SALDO<=200) ENTO
INICIO
CREDITO SALDO*0,10
ESCREVA "O valor de seu saldo medio e=", SALDO, .\n
ESCREVA "O valor de seu credito e=", CREDITO, .\n
FIM
FIM_ALGORITMO
d) ALGORITMO
DECLARE PRECO NUMERICO
ESCREVA "Digite preco\n"
LEIA PRECO
SE (preco<=50) ENTAO
INICIO
preco = preco*1.05
FIM
SE (PRECO>50) E (PRECO<=100) ENTO
PRECO= PRECO*1.10
FIM
SE PRECO>100) ENTO
INICIO
PRECO = PRECO*1.15
FIM
SE (PRECO<=80) ENTAO

INICIO
ESCREVA "Novo preco=", preco
ESCREVA "Classificao A"
FIM
SE(PRECO>80) E (PRECO<=120)
INICIO
ESCREVA "Novo preco=", preco
ESCREVA "Classificao B"
FIM
SE(PRECO>120) E (PRECO<=200) ENTAO
INICIO
ESCREVA "Novo preco=", preco
ESCREVA "Classificao C"
FIM
SE(PRECO >200) ENTAO
INICIO
ESCREVA "Novo preco=", PRECO
ESCREVA "Classificao D"
FIM
FIM_ALGORITMO
e) ALGORTIMO
DECLARE I INTEIRO
DECLARE INVESTIMENTO NUMRICO
ESCREVA "Digite 1)poupanca ou 2)fundo de renda fixa\n"
LEIA I
ESCREVA Digite o valor do investimento.\n
LEIA INVESTIMENTO
SEI(=1) ENTO
INICIO
INVESTIMENTO = INVESTIMENTO*1,10
ESCREVA Valor corrigido do investimento na poupana=, INVESTIMENTO
FIM
SE(I=2) ENTO
INICIO
INVESTIMENTO INVESTIMENTO*1,15
ESCREVA Valor corrigido do investimento no fundo de renda fixa=,
INVESTIMENTO
FIM
SENO ESCREVA INVLIDO
FIM_ALGORITMO
f) ALGORITMO
DECLARE I INTEIRO
DECLARE PESO, ALTURA NUMRICO
ESCREVA Digite 1) para homem ou 2) para mulher.\n
LEIA I
ESCREVA Digite sua altura.\n
LEIA ALTURA
SE (I=1) ENTO
INICIO

PESO (72,7*ALTURA)-58
ESCREVA Seu peso ideal em kg e=, PESO
FIM
SE(I=2) ENTO
INICIO
PESO (62,1*ALTURA)- 44,7
ESCREVA Seu peso ideal em kg e=, PESO
FIM
FIM_ALGORITMO
g) ALGORITMO
DECLARE IDADE INTEIRO
ESCREVA Escreva a idade do nadador.\n
SE(IDADE< 5) ENTO ESCREVA ERRO"
SE (IDADE>=5) E (IDADE<=7) ENTO ESCREVA "Sua categoria : Infantil."
SE(IDADE>= 8) E (IDADE<=10) ENTO ESCREVA "Sua categoria : Infanto-juvenil."
SE(IDADE>=11) E (IDADE<=15) ENTO ESCREVA "Sua categoria : Juvenil."
SE(IDADE>=16 E (IDADE<=30) ENTO ESCREVA "Sua categoria : Adulto."
SE(IDADE>30) ESCREVA "Sua categoria : Master."
FIM_ALGORITMO
h) ALGORITMO
DECLARE IDADE INTEIRO
DECLARE PESO NUMERICO
ESCREVA Escreva idade
LEIA IDADE
ESCREVA Escreva peso
LEIA PESO
SE (IDADE<20) ENTO
INICIO
SE(PESO<60) ESCREVA "Grupo de risco: 9"
SE(PESO>=60) E (PESO<=90) ESCREVA "Grupo de risco 8"
SE(PESO>90) ESCREVA "Grupo de risco: 7")
FIM
SE (IDADE>=20) E (IDADE<=50)
INICIO
SE(PESO<60) ESCREVA "Grupo de risco: 6"
SE (PESO>=60) E (PESO<=90) ESCREVA "Grupo de risco 5"
SE (PESO>90) ESCREVA("Grupo de risco: 4") FIM
SE (IDADE>50) ENTO
INICIO
SE(PESO<60) ENTO ESCREVA "Grupo de risco: 3"
SE (PESO>=60) E (PESO<=90) ENTO ESCREVA("Grupo de risco 2"
SE(PESO>90) ENTO ESCREVA "Grupo de risco: 1"
FIM
FIM_ALGORITMO
i) ALGORITMO
DECLARE A, B, C, DELTA, X1, X2 NUMERICO
{ O presente programa s funcionar para razes reais.

Para descartar a condio quanto a=0, o que levaria a uma equao do primeiro grau, o
programa s funcionar para a!=0. }
ESCREVA "Para resolver uma equacao do segundo grau qualquer na forma ax+bx+c=0,
digite os coeficientes a, b e c respectivamente\n"
LEIA A
LEIA B
LEIA C
SE(A==0) ENTO ESCREVA "Coeficiente de a invalido.\n"
SENAO
INICIO
DELTA (B*B) - (4*A*C)
SE(DELTA<0) ENTO ESCREVA"Essa equacao nao possui raizes reais.\n"
SENAO
INICIO
X1=((-1*B)+raiz_quadrada(DELTA))/(2*A)
X2=((-1*B)-raiz_quadrada(DELTA))/(2*A)
ESCREVA "As raizes de sua equacao equivalem a x1=, X1, e
x2=", X2
FIM
FIM
FIM_ALGORITMO
j) ALGORITMO
DECLARE A INTEIRO
ESCREVA "Escreva um numero\n"
LEIA A
SE (A mod 3=0) ENTO ESCREVA "O numero, A, e multiplo de 3.\n"
SENO ESCREVA "O numero, A, nao mltiplo de 3.\n"
FIM_ALGORITMO
k) ALGORITMO
DECLARE NUM INTEIRO
ESCREVA Escreva numero.\n
LEIA NUM
SE (NUM mod 5 = 0) ENTO ESCREVA O nmero, num, divisivel por cinco.
SENO ESCREVA O nmero, num, no divisvel por 5.
FIM_ALGORITMO

l) ALGORITMO
DECLARE A, B INTEIRO
ESCREVA Digite o nmero A.\n
LEIA A
ESCREVA Digite o nmero B.\n
LEIA B
SE( A mod B)=0) ENTO ESCREVA "O numero, A, e divisivel por, B
SENO ESCREVA O numero, A, nao e divisivel por", B
FIM_ALGORITMO
m) ALGORITMO
DECLARE A, B, C NUMRICO

ESCREVA "Escreva os tres lados do triangulo\n"


LEIA A
LEIA B
LEIA C
SE (A>0) E (B>0) E (C>0) ENTO
INICIO
{a soma dos lados do triangulo deve ser maior que o terceiro lado}
SE (c<(a+b)) E (B<(A+C)) E (A<(B+C)) ) ENTO ESCREVA "Os valores correspondem
ao de um triangulo existente."
SENO ESCREVA "Esse triangulo nao pode existir."
FIM
SENO ESCREVA "Esse triangulo nao pode existir.\n"
FIM_ALGORITMO
n) ALGORITMO
DECLARE A, B,C NUMRICO
ESCREVA Digite os trs lados do tringulo.\n
LEIA A
LEIA B
LEIA C
SE (A>0) E (B>0) E (C>0) ENTO
INICIO
{a soma dos lados do triangulo deve ser maior que o terceiro lado}
SE (c<(a+b)) E (B<(A+C)) E (A<(B+C)) ) ENTO
INICIO
SE (A=B) E (A=C) E (B=C) ENTO ESCREVA O tringulo
equiltero.\n
SE ((A=B) E (A!=C)) OU ((B=C ) E (A!=C)) OU
((A=C) E (A=B)) ENTO ESCREVA O tringulo isosceles.
SE (A!=B) E (A!=C) E (C!=B) ESCREVA O triangulo escaleno.
FIM
SENO ESCREVA "Esse triangulo nao pode existir."
FIM
SENO ESCREVA "Esse triangulo nao pode existir.\n"
FIM_ALGORITMO
o) ALGORITMO
DECLARE A, B, C NUMRICO
ESCREVA Digite o valor dos lados do tringulo.\n
LEIA A
LEIA B
LEIA C
SE (A>0) E (B>0) E (C>0) ENTO
INICIO
{a soma dos lados do triangulo deve ser maior que o terceiro lado}
SE (c<(a+b)) E (B<(A+C)) E (A<(B+C)) ) ENTO
INICIO

{para o tringulo ser retngulo um dois lados ao quadrado deve ser igual a soma do
quadrado dos outros dois lados.}
SE ((A*A)= (B*B+C*C)) OU ((B*B)= (A*A+C*C)) OU ((C*C)= (A*A+B*B))
ENTO ESCREVA O tringulo retngulo.\n
{para ser obtusangulo um dos lados ao quadrado deve ser maior que o quadrado de
cada um
dos outros lados somados)
SE ((A*A) > (B*B+C*C)) OU ((B*B) > (A*A+C*C)) OU ((C*C) > (A*A+B*B))
ENTO ESCREVA O tringulo obtusangulo.\n
{para ser acutangulo um dos lados ao quadrado deve ser menor que o quadrado de
cada um dos dois outros lados somados}
SE ((A*A)<(B*B+C*C)) OU ((B*B)< (A*A+C*C)) OU ((C*C)< (A*A+B*B))
ENTO ESCREVA O tringulo acutangulo.\n
FIM
SENO ESCREVA Esse triangulo no pode existir.\n
FIM
SENO ESCREVA "Esse triangulo nao pode existir.\n"
FIM_ALGORIMO
q) ALGORITMO
DECLARE X NUMERICO
ESCREVA "Escreva um numero x.\n
LEIA X
SE(X<=1) ENTO ESCREVA "f(x)=1"
SE (X>1) E (X<=2) ENTO ESCREVA f(x)=2"
SE(X>2) E (X<=3) ENTO ESCREVA "f(x)=", x*x
SE(x>3) ENTAO ESCREVA "f(x)=%f", x*x*x
FIM_ALGORITMO