Você está na página 1de 20

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 1

DE 20

Colocar sintaxe do ip route


Contedo
1.

Iniciando a Configurao ........................................................................................................................... 1


Interagindo com a CLI do Roteador .............................................................................................................. 2
1.3. Modos de configurao ....................................................................................................................... 3
1.1.1 Modo Usurio (router>) ............................................................................................................... 3
1.1.2 Modo Privilegiado (router #) ....................................................................................................... 3
1.1.3 Modo Configurao Global (router (config)#) ............................................................................ 4
1.1.4 ENTRANDO NAS INTERFACES Ethernet, Fast Ethernet e Seriais ......................................... 5
2. Configurar banners..................................................................................................................................... 6
3. Modificando o hostname............................................................................................................................ 6
4. Configurar endereos IP ............................................................................................................................ 7
5. Descries de interfaces ............................................................................................................................. 8
6. Configurando as senhas ............................................................................................................................. 9
6.1. Telnet ................................................................................................................................................... 9
6.2. Configurando senha de console........................................................................................................... 9
6.3. Senha para modo enable .................................................................................................................... 10
7. Armazenando senhas de forma criptografada .......................................................................................... 10
8. Definindo timeouts................................................................................................................................... 10
9. Salvar as configuraes............................................................................................................................ 11
10. Rotas estticas ....................................................................................................................................... 11
11. Configurando Rota default .................................................................................................................... 11
12. Configurando DHCP ............................................................................................................................ 12
13. Rota dinmica com RIP: ....................................................................................................................... 13
14. Rota dinmica com OSPF: .................................................................................................................... 14
15. Configurao de switchs ....................................................................................................................... 14

1. Iniciando a Configurao
Para iniciar esta configurao e ter acesso ao roteador necessrio usar a porta de console
disponvel no roteador. Para isso voc usar um cabo de console(rollover) o qual ser ligado na porta
serial do seu microcomputador (ou USB) e na porta de console do roteador. Porm a porta serial do
computador precisa de um conversor, o qual ter um conector DB-9 ou DB-25 na ponta.
Para fazer a configurao inicial do roteador dever ser utilizado o programa de emulao de
terminal Hyper Terminal disponvel no Windows.
A configurao do programa usa geralmente os seguintes parmetros:
Velocidade = 9600bps
Bits de dados = 8
Paridade = nenhuma
Bit de parada = 1
Sem controle de fluxo

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 2

DE 20

Estando com o Hyper Terminal devidamente configurado, ligue o roteador, ento ele executar o POST e
como no ser detectada uma configurao vlida, o IOS inicia um dilogo interativo chamado System
Configuration Dialog, no qual sera mostrado na tela do Hyper Terminal que voc est usando para acessar
a console.
Interagindo com a CLI do Roteador
A Cisco usa o acrnimo CLI para referir-se interface de linha de comando do terminal de usurio
para o IOS. O termo CLI significa que o usurio est digitando comandos em um terminal, em um
emulador de terminal ou em uma conexo remota Telnet. Para acessar a CLI, usa-se um dos mtodos,
conforme a figura abaixo:

Figura Formas de acesso CLI


Independente do mtodo de acesso utilizado, quando se configura o roteador possvel faze-lo de
vrios modos. Os modos definem como esta configurao ser feita.
Vejamos os modos existentes:
User EXEC Mode (Modo Usurio)
Privileged EXEC Mode (Modo Privilegiado)
Global Configuration Mode (Modo de Configurao Global)
Observao: A CLI (Command Line Interface) dos roteadores Cisco tem uma grande vantagem quando se
trata de digitao de comandos. Voc poder digitar as primeiras letras de um comando e j pressionar
ENTER para que ele identifique e interprete o comando. Para alguns comandos basta digitar duas letras,
mas para outros necessrio digitar mais. Isso varia pois, como existem diversos comandos cujas
primeiras letras so idnticas, ele no saber que comando dever interpretar. Veja abaixo um exemplo
dos comandos enable e disable.
Router> en
Router # disa
Router >

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 3

DE 20
Note que no caso do disable foi necessrio digitar as quatro primeiras letras, isso porque existe
um comando chamado disconnect no modo privilegiado que se voc digitar os trs primeiros gerar
conflito.
Dica: Para otimizar o trabalho tambm possvel digitar os primeiros caracteres, pressionar a tecla TAB e
ser preenchido o comando completo para que voc veja que comando foi digitado.
Estando no Modo Privilegiado possvel entrar no Modo Configurao Global onde os comandos e
as configuraes iro afetar o sistema como um todo.
1.3.

1.1.1

1.1.2

Modos de configurao

Modo Usurio (router>)


SMBOLO = >
Comandos:
Enable acesso para o modo privilegiado aceita comandos Shows
enable
acesso para o modo privilegiado
disable Turn off privileged commands
exit
Exit from the EXEC
logout
Exit from the EXEC
ping
Send echo messages
show
Show running system information
telnet
Open a telnet connection
traceroute Trace route to destination Reload reinicia

Modo Privilegiado (router #)


SMBOLO = #
show
Show running system information
configure Enter configuration mode
copy
Copy from one file to another
disable Turn off privileged commands
disconnect Disconnect an existing network connection
erase
Erase a filesystem
exit
Exit from the EXEC
logout
Exit from the EXEC
ping
Send echo messages
reload
Halt and perform a cold restart
ssh
Open a secure shell client connection
telnet
Open a telnet connection
traceroute Trace route to destination
vlan
Configure VLAN parameters

Principais comandos do MODO PRIVILEGIADO


Configure terminal - acesso para o modo configurao global (conf t)
show running-config exibe as configuraes da memria RAM (sh run)
show startup-config exibe as configuraes que esto salva na NVRAM (configuraes salvas) - (sh
start)

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
PGINA 4
DE 20
show ip interface brief - Relacionado a Configurao - Apresenta resumo da interface: endereo IP,
status do link fsico e lgico.
show ip route exibe as rotas apreendidas (cadastradas).
show interface <interface> Relacionado a Hardware - Apresenta status do link, endereo IP, clock rate,
MTU, e protocolos da camada fsica e de enlace rodando (ex: LCP, NCP no PPP).
show ip interface <interface> Relacionado a Configurao - Apresenta dados como: status da conexo
fsica e lgica, endereo IP, MTU, ACLs, NAT e diversos outros parmetros.
show protocols - Relacionado a Configurao - Apresenta status do link e endereo IP, deste.
show ip protocols - Relacionado a Protocolos de Roteamento - Apresenta todas informaes relevantes
aos protocolos de roteamento em uso: parmetros de configurao, rotas anunciadas, ltima atualizao.
show ip route
Tabela de Roteamento So as redes aprendidas (dinmica ou estaticamente), [distncia
administrativa/mtrica], o IP e a interface vinculada para realizar as rotas.
Show version exibe informao sobre verso do IOS, interfaces, config-register etc (sh ver)
Show sessions exibe as sesses de telnet abertas no momento (sh sess)
Show cdp nei exibe os routers vizinhos (sh cdp nei)
Show flash exibe o contedo existente na memria flash (sh flash)
Show memory exibe informaes sobre a memria do router (sh mem)
Show history mostra histricos dos comandos executados.
Show arp mostra a tabela ARP
Salvando Configuraes:
Copy running-config startup-config SALVA o contedo da RAM para NVRAM
Copy running-config tftp copia o contedo da RAM para um servidor de TFTP.
Copy flash tftp copia o contedo da flash para um servidor de TFTP.
Copy tftp startup-config copia o aruivo de configurao do TFTP para a NVRAM.
Copy tftp flash copia o IOS do servidor de TFTP para flash.
Wr salva as configuraes
Service password-encryption deixa todas a senha criptografadas.

1.1.3

Modo Configurao Global (router (config)#)


SMBOLO = (CONFIG)#
Hostname seta um nome ao router
Enable secret seta a principal senha do router (criptografada)
Banner motd montagem de um banner
Interface entra na interface desejada (colocar o tipo da interface E0 ou S0)
access-list
Add an access list entry
banner
Define a login banner
cdp
Global CDP configuration subcommands
clock
Configure time-of-day clock
config-register Define the configuration register

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 5

DE 20
crypto
Encryption module
do
To run exec commands in config mode
dot11
IEEE 802.11 config commands
enable
Modify enable password parameters
end
Exit from configure mode
exit
Exit from configure mode
hostname
Set system's network name
interface
Select an interface to configure
ip
Global IP configuration subcommands
ipv6
Global IPv6 configuration commands
line
Configure a terminal line
logging
Modify message logging facilities
login
Enable secure login checking
mac-address-table Configure the MAC address table
spanning-tree
Spanning Tree Subsystem
login
Enable secure login checking
mac-address-table Configure the MAC address table
router
Enable a routing process
secure
Secure image and configuration archival commands
security
Infra Security CLIs
service
Modify use of network based services
snmp-server
Modify SNMP engine parameters
spanning-tree
Spanning Tree Subsystem
1.1.4

ENTRANDO NAS INTERFACES Ethernet, Fast Ethernet e Seriais


SMBOLO = (CONFIG-IF)#
ETHERNET E FAST ETHERNET
Ip address seta ip na interface (lembra de colocar o IP e mscara)
Description coloca uma descrio para a interface. Ex: LINK DO ROUTER SP COM RJ 100
Mbps
No shutdown restart na interface (comando dado toda vez que setado um ip na interface)
SERIAIS
Ip address seta ip na interface (lembra de colocar o IP e mscara)
Encapsulation ppp seta o protocolo de encapsulamento ppp, podendo ser HDCL, Frame
Relay e ISDN.
Clockrate seta o sincronismo nos routers (lembrando que quando utilizamos modems no
necessrio)
Description coloca uma descrio para a interface. Ex: LINK DO R3 com R2
No shutdown restart na interface (comando dado toda vez que setado um ip na interface)
Bandwidth seta a velocidade. Ex: bandwidth 1000 significa uma velocidade 1 Mbps.
EXEMPLOS:
CONFIGURANDO INTERFACE FAST-ETHERNET
Router> enable
Router#configure terminal
Router(config)hostname Router_A // atribui o nome Router_A ao router
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#description DEPTO RH001
Router(config-if)#no shutdown
Router(config-if)#exit

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 6

DE 20
CONFIGURANDO INTERFACE SERIAL
Router(config)#interface serial 2/0
Router(config-if)#ip address 10.10.2.1 255.255.255.0
Router(config-if)#encapsulation ppp
Router(config-if)#clock rate 64000
Router(config-if)#description Interligacao com Filial_SP
Router(config-if)#bandwidth 1000
Router(config-if)#no shutdown
CTRL + Z
Router#copy running-config startup-config // copia configurao RAM para memria NVRAM

2. Configurar banners
Os banners so mensagens exibidas para usurios quando eles tentam se conectar ao roteador pela rede.
Atravs destas mensagens voc pode avis-los sobre manuteno, regras relacionadas ao uso, instrues
de segurana, etc.
Existem alguns tipos diferentes de banners que podem ser configurados no IOS:

exec: A mensagem do tipo exec exibida quando uma sesso exec iniciada;
incoming: Esta mensagem exibida para usurios que se conectem ao roteador atravs do
console ou linha auxiliar;
login: Este banner apresentado depois do motd e antes de aparecer o prompt e exibido em
todos os terminais conectados;
motd: O banner motd (message of the day, mensagem do dia) o banner mais comum e utilizado
em dispositivos Cisco. A mensagem definida como motd, ser exibida para todos os que tentarem
se conectar ao seu roteador no importando a forma (Telnet, console, auxiliar, etc.).

Como voc j deve ter percebido, a diferena entre os tipos de banners o momento em que eles so
exibidos. Como o motd o nico que sempre exibido, no importa o modo de conexo, geralmente ele
o mais usado.
Para configurar o banner motd:
Osiris(config)# banner <tipo do banner> <caracter delimitador da mensagem>
Depois de definir o tipo do banner, voc deve indicar qual caracter delimitar a mensagem que voc vai
digitar, ou seja, o caracter indicado no comando ir definir o fim da mensagem do banner. Por exemplo:
Osiris(config)# banner motd @ Acesso restrito somente a equipe de redes da empresa XYZ S/A
Se
nao
esta
autorizado
recomendamos
sua
desconexao
imediata.
Este sistema auditado permanentemente @
No exemplo acima, a mensagem definida Acesso restrito somente a equipe .... O @ no
considerado parte da mensagem. Vale lembar que o caracter que voc escolher no pode aparecer no
texto que voc quer definir como sendo o contedo do banner.

3. Modificando o hostname
O hostname que voc configura direto no roteador tem relevncia apenas localmente, ou seja, outros
roteadores na sua rede no podero se referir ao seu roteador pelo nome que voc definir atravs do
comando hostname. Para que seja possvel definir um nome com relevncia global (permitindo que

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
PGINA 7
DE 20
outros roteadores utilizem o nome escolhido para a comunicao com este roteador) voc deve alterar a
zona correspondente no seu servidor DNS.
Para configurar o hostname, voc deve acessar o seu roteador (se voc ainda no configurou a senha
para o telnet, voc poder apenas acess-lo atravs do console. Mais adiante neste post voc ir
aprender a definir todas as senhas necessrias para acessar o dispositivo atravs da rede) e ir para o
modo de configurao:
Router> enable
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
O comando configure terminal o levar para o modo de configurao global do IOS. Aqui voc pode
alterar todas as configuraes do sistema, por exemplo, definir os IPs das interfaces, habilitar/desabilitar
interfaces, definir rotas, configurar protocolos de roteamento dinmico (como RIPv2, OSPF, etc), definir
banners, etc.
Estando no modo de configurao, execute o seguinte comando para definir o hostname:
Router(config)# hostname NomeDesejado
Por exemplo,
Router(config)# hostname Osiris
Osiris(config)#
Note que, logo aps voc modificar o hostname, ele j passa a ser utilizado no prompt. Porm, no se
engane: se voc reiniciar o roteador agora o nome desaparecer. Para que o nome fique configurado
permanentemente no roteador, voc deve salvar as configuraes. Veremos como fazer isso mais adiante
no post.

4. Configurar endereos IP
Por motivos bvios, voc precisa configurar endereos IP em todas as interfaces que esto sendo
utilizadas pelo seu roteador.
Este processo bem simples, no leva nem 5 minutos. Para isso, voc deve saber exatamente quais
interfaces existem em seu roteador e quais delas voc deseja configurar. Para isso, utilize o comando:
Osiris# show interfaces
Alm do nome, vrias informaes relacionadas s interfaces so exibidas. Guarde bem os nomes das
interfaces que voc deseja configurar e v para o modo de configurao global:
Osiris# configure terminal
Osiris(config)#
Uma vez no modo de configurao global, voc precisa entrar no contexto da interface que voc quer
configurar. Para isso, basta utilizar o comando interface seguido do nome dela:

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
DE 20
Osiris(config)# interface FastEthernet 0/0
Osiris(config-if)#

PGINA 8

Neste modo, como voc j viu, voc poder configurar todas as opes desta interface apenas. Para
configurar opes de outras placas, voc deve entrar no contexto de configurao delas. Para configurar o
endereo IP nesta interface faa o seguinte:
Osiris(config-if)# ip address 192.168.1.1 255.255.255.0
Este comando j define tanto o endereo IP que ser utilizado nesta interface quanto a mscara de subrede.
As interfaces de roteadores Cisco por padro esto sempre desabilitadas. Depois que voc fizer a
configurao delas, voc deve ativ-las se no, mesmo que tudo tenha sido configurado corretamente,
voc no ser capaz de acessar a rede. Seguindo o padro Cisco, basta voc colocar um no na frente do
comando shutdown no contexto de configurao da interface para que ela seja ativada:
Osiris(config-if)# no shutdown
Como voc j deve ter deduzido, para desabilitar a interface voc deve executar o comando shutdown no
modo de configurao da interface especfica. O status de todas as interfaces do dispositivo pode ser
visualizado utilizando-se o comando show interfaces ou show interfaces FastEthernet 0/0 no modo
enable. A seguinte linha:
FastEthernet0/0 is administratively down, line protocol is down
Indica uma interface desabilitada. Sempre que uma interface est parada por deciso do administrador do
sistema, o status ter administratively down. Caso esta expresso no aparea, muito provvel que
algum outro problema est impedindo o correto funcionamento (um problema no cabo, por exemplo). Uma
interface ativa mostraria uma linha parecida com:
FastEthernet0/0 is up, line protocol is up

5. Descries de interfaces
Se voc configura muitos roteadores diferentes, pode acabar ficando meio difcil lembrar exatamente a
qual rede uma determinada interface est conectada, ou qual o papel de uma determinada interface. Para
isso, o IOS permite que voc adicione descries sobre cada interface presente em seu roteador.
Esta configurao tambm deve ser feita no contexto de configurao da interface em questo, utilizando
o comando description. Por exemplo:
Osiris(config-if)# description Interface que liga o roteador a rede do provedor.
Voc pode definir uma configurao de no mximo 240 caracteres. Pode utilizar espaos, porm no
bom utilizar acentuao. A descrio que voc utiliza com o comando description pode ser vista quando
voc digita o comando show interfaces no modo enable:
Osiris# show interfaces
FastEthernet0/0 is administratively down, line protocol is down
Hardware is AmdFE, address is c800.342d.0000 (bia c800.342d.0000)
Description: Interface que liga o roteador a rede do provedor
Internet address is 192.168.1.1/24

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
PGINA 9
DE 20
Como j disse, isso opcional mas pode ajudar muito voc ou quem for administrar o roteador e ainda no
o conhea.

6. Configurando as senhas
Antes de voc configurar qualquer senha no roteador, o IOS no permite qualquer tipo de conexo remota
a ele: apenas o console permite que voc se conecte a ele para que voc consiga configurar o roteador.
Ento, para permitir que voc utilize o Telnet para administrar o roteador daqui para frente, vou te mostrar
aqui como configurar as senhas para esse servio.
6.1.

Telnet

No IOS, voc deve referir-se ao Telnet como linhas VTY. A quantidade de linhas VTY varia de modelo para
modelo, no h uma quantidade fixa. Para descobrir quantas linhas o seu roteador disponibiliza para voc,
faa o seguinte. No modo de configurao global:
Osiris(config)# line vty ?
<0-4> First Line number
No dispositivo que estou usando, existem 5 linhas numeradas de 0 a 4. Para definir a senha:
Osiris(config)# line vty 0 4
Osiris(config-line)# login
Osiris(config-line)# password senha
Agora, quando voc tentar se conectar ao seu roteador atravs do Telnet basta fornecer a senha que voc
especificou no comando password, no importa qual o nmero da linha qual voc est se conectando.
Se voc quiser permitir que logins sejam feitos atravs de Telnet mesmo que uma senha no tenha sido
configurada (o que no nada recomendado), basta negar o comando login no contexto de configurao
da linha:
Osiris(config-line)# no login
E voc poder se logar no roteador sem precisar de uma senha.
Embora o Telnet seja o padro para administrao remota de roteadores e switches Cisco, ele no nada
seguro. Todo o trfego trocado entre cliente e servidor transmitido em texto claro, permitindo que algum
sniffe a conexo e consiga descobrir o seu usurio e senha. Para mitigar este problema, o mais
recomendado atualmente configurar o SSH no dispositivo e utiliz-lo ao invs de usar o Telnet. J
expliquei como funciona este processo em outro post.
6.2.

Configurando senha de console

Se voc se conectar ao roteador atravs da porta de console, o padro no ter senha para que voc
consiga configurar o switch assim que ele sai da caixa. Porm, uma boa prtica proteger esta conexo
com uma senha.
No caso do console, a linha utilizada se chama console e geralmente existe apenas 1: a porta 0. Para
configur-la, voc deve fazer o seguinte:
Osiris(config)# line console 0
Osiris(config-line)# password senha

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
PGINA 10
DE 20
Agora, sempre que voc se conectar ao console voc dever digitar a senha informada ao comando
password como descrito acima.
6.3.

Senha para modo enable

Alm de senhas para as linhas, tambm possvel definir uma senha para proteger o modo enable, que
d mais poderes ao usurio.
Para definir esta senha, acesse o modo de configurao global e utilize o comando enable secret:
Osiris(config)# enable secret senha
Isso ir criar uma senha criptografada que ser utilizada sempre que voc tentar acessar o modo enable
do roteador, no importa a forma pela qual voc se conecte ao dispositivo. Voc tambm pode criar uma
senha no-criptografada utilizando o comando enable password:
Osiris(config)# enable password senha
Se voc definir tanto a secret quanto a password, a senha secret sempre ter preferncia e ela a que
sempre ser utilizada. Embora voc tenha a opo de utilizar uma senha no-criptografada,
recomendado que voc utilize apenas a senha criptografada com o comando enable secret.

7. Armazenando senhas de forma criptografada


Por padro, a nica senha criptografada no IOS a senha definida pelo comando enable secret. Todas
as outras so exibidas em texto claro atravs do comando show running-config. Para impedir que isso
acontea, voc deve ativar o servio de criptografia de senhas. muito importante que voc ative este
servio, j que ele praticamente a sua nica proteo para as senhas armazenadas na memria do
roteador.
Habilitar o servio muito simples. No modo de configurao global, execute o seguinte comando:
Osiris(config)# service password-encryption
E pronto, agora sempre que as suas senhas forem ser exibidas, apenas o hash da criptografia aparecer
melhorando um pouco mais a segurana do sistema.

8. Definindo timeouts
Como medida de segurana, no apenas no IOS mas tambm em qualquer outro sistema que voc
acesse remotamente, interessante que voc defina timeouts para fazer com que sesses ociosas sejam
terminadas automaticamente depois de um determinado tempo. Esses timeouts so configurados para
cada linha, ou seja, o timeout do console pode ser diferente do timeout da VTY.
Como a configurao pode ser diferente para cada linha, voc deve estar no contexto de configurao da
linha para poder modificar o parmetro. Uma vez no contexto correto, basta utilizar o comando exectimeout:
Osiris(config)# line vty 0 4
Osiris(config-line)# exec-timeout <MINUTOS> <SEGUNDOS>
Por exemplo, para definir o timeout em 1:30s voc deveria executar o comando:
Osiris(config-line)# exec-timeout 1 30

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
DE 20
Para desabilitar o timeout, basta informar 0 0 para minutos e segundos.

PGINA 11

9. Salvar as configuraes
Todas as configuraes que voc acabou de fazer no so salvas automaticamente. Voc precisa instruir
o IOS a salv-las para que voc no perca tudo caso o roteador reinicie por algum motivo.
Para fazer essa cpia, voc deve utilizar o seguinte comando (no modo enable):
Osiris# copy running-config startup-config
Destination filename [startup-config]?
Ele ir te perguntar qual ser o nome do arquivo que ser criado com as configuraes. O padro, que
geralmente o aceito, startup-config. Para aceitar o padro basta pressionar a tecla enter. A seguinte
mensagem ir confirmar que a operao foi efetuada com sucesso:
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration
[OK]
OBS: pode usar o comando WR tambm

10. Rotas estticas


Router(config)#ip route 192.168.200.0 255.255.255.0 10.10.10.2 // insere uma rota esttica indicando
qual o prximo salto.
Router(config)# ip route 192.168.200.0 255.255.255.0 s2/0 // insere uma rota esttica indicando para
qual interface o router deve encaminhar.
Router(config)# no ip route 192.168.200.0 255.255.255.0 10.10.10.2 // deleta rota esttica.
Router(config)# ip route 192.168.200.0 255.255.255.0 10.10.10.2 10 // insere uma mtrica(peso) a
rota esttica, por default a mtrica 1.
OBS: sempre a menor mtrica a preferida.

11. Configurando Rota default


Para criar uma rota "default", use a sintaxe:
roteador(config)# ip default-network 192.168.76.1 ou
roteador(config)# ip route 0.0.0.0 0.0.0.0 192.168.76.1
Uma rota padro (Default Route), tambm conhecida
como gateway de ltimo recurso, a rota de rede
utilizada por um roteador quando no h nenhuma
outra rota conhecida existente para o endereo de
destino de um pacote IP. Todos os pacotes para
destinos desconhecidos pela tabela do roteador so
enviados para o endereo de rota padro. Esta rota
geralmente direciona para outro roteador, que trata o
pacote da mesma forma: Se a rota conhecida, o pacote ser direcionado para a rota conhecida. Se no,
o pacote direcionado para o default route desse roteador que geralmente direciona a outro roteador. E
assim sucessivamente.
Comando: ip route 0.0.0.0 0.0.0.0 serial0/0

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 12

DE 20

12. Configurando DHCP


A mquina pergunta na rede quem o servidor DHCP, o servio se identifica e fornece um IP para
mquina ou host solicitante. O DHCP pode ser um computador, um modem ou um roteador.
Comandos:
Router(config)#ip dhcp pool MEU_DHCP_SERVER
Router(dhcp-config)#network 192.168.0.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.0.1
Router(config)#ip dhcp excluded-address 192.168.0.1
DHCP- COMANDOS RESUMIDOS
Router(config)#ip dhcp pool DHCP_SERVER
Router(dhcp-config)#net 192.168.0.0 255.255.255.0
Router(dhcp-config)#default 192.168.0.1
Router(dhcp-config)#dns-server 192.168.0.12 (se tiver presente)
Router(dhcp-config)#exit
Router(config)#ip dhcp exc 192.168.0.1

Embora existam diversas solues de mercado para servios DHCP bem mais robustas, o servio DHCP
embutido no Cisco IOS pode ser bastante til em ambientes SOHO (Small Office Home Office), termo que
significa "pequeno escritrio ou escritrio montado em casa", e em redes de pequeno porte, que dependam
somente de um nico roteador.
O papel do DHCP na rede atribuir endereos IP automaticamente s estaes de trabalho (ou outros
dispositivos). Alm de atribuir dinamicamente endereos IP, o DHCP pode tambm configurar uma gama de
parmetros TCP/IP nestas estaes, como os endereos dos servidores DNS, endereo do default gateway da
rede, dentre outros. A configurao de um roteador Cisco para que ele funcione como um servidor DHCP
bastante simples e ilustrada a seguir.
Passo 1: Certifique-se que a porta que se conecta rede local (LAN) esteja devidamente configurada e
ativada e ative o servio DHCP no roteador:
Router(config)# interface ethernet0/0
Router(config-if)# ip address 192.168.10.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# service dhcp
Passo 2: Crie o pool onde ser especificado os endereos IP que voc deseja distribuir para os hosts em
sua rede:
Router(config)# ip dhcp pool meupooldeenderecos
Passo 3: Especifique os endereos que sero disponibilizados para os hosts:
Router(dhcp-config)# network 192.168.10.0 255.255.255.0
Passo 4: Especifique o domnio a ser configurado nos hosts:
Router(dhcp-config)#domain-name nomedodominio.com

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 13

DE 20

Passo 5: Especifique os servidores DNS (at 8 endereos podem ser configurados):


Router(dhcp-config)#dns-server 192.168.10.2 192.168.10.3
Passo 6: Especifique o endereo do default gateway da rede (at 8 endereos podem ser configurados):
Router(dhcp-config)#default-router 192.168.10.1 (endereo IP do prprio roteador, no caso)
Passo 7: Especifique o tempo de durao do lease, ou seja, quanto tempo o host pode ficar com o endereo
antes de re-checar com o DHCP:
Router(dhcp-config)#lease 7 (tempo em dias, no exemplo)
OBS: Em relao ao lease, por default, a configurao de 1 dia.
Passo 8: Exclua os endereos IP que no devem ser oferecidos aos hosts. No exemplo abaixo, os IPs
192.168.10.1 at 192.168.10.10 no sero oferecidos aos hosts pelo DHCP.
Router(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.10
Pronto! Seu roteador agora responder s solicitaes DHCP de hosts na rede, e estes hosts recebero um
endereo IP dentro do intervalo de 192.168.10.11 a 192.168.10.254.
Monitorando o servio DHCP
Os seguintes comandos possibilitam o gerenciamento do servio DHCP em um roteador Cisco:

show ip dhcp binding: Lista os IPs j fornecidos para as estaes de trabalho.


show ip dhcp conflict: Lista eventuais conflitos de endereos IP.
show ip dhcp database: Lista o DHCP database.
show ip dhcp pool: Lista todo o contedo dos pools configurados.
show ip dhcp relay information trusted-sources: Lista as informaes sobre o relay DHCP.
show ip dhcp server statistics: Mostra as estatsticas do trfego DHCP.

Em caso de problemas, as seguintes opes para debugging esto disponveis:

debug ip dhcp server events: Muito til para mostrar os emprstimos e expirations dos
endereos IP.
debug ip dhcp server linkage: Server para diagnosticar eventos em situaes onde existem relaes
entre dois ou mais servidores DHCP (esquema parent/child, tais como radix tree).
debug ip dhcp server packet: Mostra o trfego DHCP em tempo real.

13. Rota dinmica com RIP:


roteador(config)#route rip
roteador(config-router)#network 192.168.30.0
roteador(config-router)#network 192.168.40.0
roteador(config-router)#passive-interface fastethernet 0 essa interface no envia atualizaes RIP
roteador(config-router)#version 2 passa para a verso 2

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
PGINA 14
DE 20
roteador(config-router)#no auto-summary
no faz sumarizao das rotas usado qdo temos a
presena de subredes .
Sendo que a rede 192.168.30.0 e 192.168.40.0 que so as redes ligadas nas interfaces do ROUTER vo
ser agora compartilhada com os outros roteadores.
*A configurao de todos os outros protocolos de roteamento so parecidas. Por exemplo, para configurar
o IGRP (router igrp 10; network 192.168.30.0) ou o OSPF (router ospf 10; network 10.0.0.0 0.255.255.255
area 0), todos seguem mais ou menos a mesma sintaxe.
Depurando problemas no roteamento:
debug ip rip
no debug rip
no debug all

14. Rota dinmica com OSPF:


roteador(config)#router ospf 1
roteador(config-router)#network 192.168.0.0 0.0.0.255 area 0
1. Habilitar o processo OSPF no router via comando router ospf {ID do processo OSPF}
2. Associar areas OSPF s interfaces, via comando network {rede ou endereo IP} {wildcard} {area}
O ID do processo OSPF no precisa ser o mesmo em roteadores distintos, e o mais interessante,
vrios processos OSPF podem ser executados em um mesmo router. Este procedimento no
recomendado, entretanto, j que cada instncia consome grandes pores de CPU e memria. Em suma,
um bom design no utilizaria mais de um processo OSPF em um mesmo router.
O parmetro network, diferentemente do que ocorre na configurao de outros protocolos de
roteamento, serve, no OSPF, para indicar quais interfaces participaro do processo, e quais as reas
OSPF a que pertencem. Esta uma particularidade do protocolo.
O parmetro area, no comando acima o protocolo ir procurar a rede 192.168.0.0 e colocar todas as
que encontrar dentro da rea 0. Outro ponto que o valor pode ser numrico quanto em formato IP
0.0.0.0.
Verificando as configuraes:
Show ip route
Show ip ospf

15. Configurao de switchs


1- Entrar no modo privilegiado
switch>enable
switch#
2- Configurar senhas
switch(config)#enable secret ****** digite a senha
switch(config)#exit
switch(config)#line vty 0 15
switch(config)# login
switch(config)# password ****** digite a senha

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
DE 20
switch(config)#line console 0
switch(config)# login
switch(config)# password ****** digite a senha

PGINA 15

switch(config)#service password-encryption habilita a criptografia


3- Configurar um nome para o Switch.
switch(config)#hostname NOME
switch(config)#exit
4- Configurar velocidade e modo de comunicao da porta.
Switch 2950:
switch(config)#interface fastEthernet 0/1
switch(config-if)#speed auto modo automatic (100 ou 1000 Mbps)
switch(config-if)#duplex auto modo automatic (full duplex ou half duplex)
5- Configurar o endereo IP/Mscara/Gateway nos Switchs. (para acesso externo)
switch(config)#interface vlan 1
switch(config-if)#ip address X.X.X.X Y.Y.Y.Y onde X o endereo IP e Y a mscara de rede
switch(config-if)#exit
switch(config)#ip default-gateway X.X.X.X onde X o endereo IP do default-gateway
switch(config)#exit
6- Criar VLANs nos Switchs.
switch#config t
switch(config)#vlan 2
switch(config-vlan)#name SW_2347_filial
VLAN
Uma rede local virtual, normalmente denominada de VLAN, uma rede logicamente independente.
Vrias VLAN's podem co-existir em um mesmo comutador (switch), de forma a dividir uma rede local
(fsica) em mais de uma rede (virtual), criando domnios de broadcast separados. Uma VLAN tambm
torna possvel colocar em um mesmo domnio de broadcast, hosts com localizaes fsicas distintas e
ligados a switches diferentes. Um outro propsito de uma rede virtual restringir acesso a recursos de
rede sem considerar a topologia da rede, porm este mtodo questionvel.
Redes virtuais operam na camada 2 do modelo OSI. No entanto, uma VLAN geralmente
configurada para mapear diretamente uma rede ou sub-rede IP, o que d a impresso que a camada 3
est envolvida.

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
DE 20

7- Atribuir portas as VLANs. Portas 3, 4 e 5 VLAN 2


switch(config)#interface fastEthernet 0/3
switch(config-if)#switchport access vlan 2
switch(config-if)#exit
switch(config)#interface fastEthernet 0/4
switch(config-if)#switchport access vlan 2
switch(config-if)#exit
switch(config)#interface fastEthernet 0/5
switch(config-if)#switchport access vlan 2
switch(config-if)#exit
switch(config)#exit
switch#show vlan
Configurar vrias portas ao mesmo tempo use o comando RANGE
switch(config)#interface range fastEthernet 0/3-10
8- Configurar TRUNK.
Switch 2950:
switch#config t
switch(config)#interface fastEthernet 0/1
switch(config-if)#switchport mode trunk
switch(config-if)#exit
9 Criptografar as senhas console e telnet (configure terminal).
switch(config)# service password-encryption

PGINA 16

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 17

DE 20

10 - Configurando PORT SECURITY NOS SWITCHS

Todos sabemos que a configurao de port security nos switchs Cisco muito utilizada para no autorizar
mquinas estranhas rede corporativa, sem que haja prvia avaliao da equipe responsvel, isso
fundamental para que uma rede tenha os requisitos mnimos de segurana.
Comandos do Switch CTBA:
Switch(config)#interface f0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport port-security mac-address sticky -> guardar o mac-address automaticamente
Switch(config-if)#switchport port-security maximum 1 -> nmero mximo de violao
Switch(config-if)#switchport port-security violation shutdown -> se violado a inferface ficar desabilitada
Switch(config-if)#switchport port-security -> habilita o port-security
Gere trfego (com ping PC0 para PC1)
Switch# sh port-security
Switch#sh port-security interface f0/1
Port Security
: Enabled
Port Status
: Secure-up
Violation Mode
: Shutdown
Aging Time
: 0 mins
Aging Type
: Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses
:1
Total MAC Addresses
:1
Configured MAC Addresses : 0
Sticky MAC Addresses
:1
Last Source Address:Vlan : 000C.CF35.4439:1 --> mostra ultimo MAC Address
Security Violation Count : 0
Retire a ligao da FastEthernet 0/1 (ligada ao PC0)e ligue no NOTEBOOK do estagirio que pretende
acessar a rede com seu ativo de rede. A interface ficar UP, mas quando gerar trfego ela ficar DOWN.

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 18

DE 20
11 - Listas de Acesso

ACL - PADRO
#configure terminal
(config)#access-list 50 deny 192.168.31.0 0.0.0.255;
(config)#access-list 50 deny 10.21.32.254 0.0.0.0 //ou// (config)#access-list 50 deny host 10.21.32.254;
(config)#access-list 50 permit 10.21.0.0 0.0.255.255;
REMOO DE ACL
#No access-list 50
APLICANDO A UMA INTERFACE
(config)#int fastEthernet 0/0
(config-if)# ip access-group 50 in

//
//

sintaxe = int fast[#/#]

sintaxe =

ip access-group [#ACL] [in / out]

CONTROLE DE ACESSO VIA VTY (TELNET)


Pode-se filtrar usurios que tentam acessar o router via Telnet atravs de ACLs padro.

Cria a ACL padro


Aplique diretamente s portas VTY atravs do comando access-class

CRIANDO A LISTA
(config)#access-list 50 permit 172.16.10.3
APLICANDO NO ACESSO VTY (TELNET)
(config-line)#line vty 0 4
(config-line)#access-class 50 in

ACL - ESTENDIDA
Filtra por protocolo;
Filtra por nmero de porta;
Permite acesso de usurios a determinada Lan, porm negando acesso a servios especficos.

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O

PGINA 19

DE 20

CRIANDO A LISTA
Router(config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log
A linha de comando acima bloqueia o acesso do host 172.16.30.2 para o servio de telnet apenas.

APLICANDO A UMA INTERFACE


(config)#int fastEthernet 0/0
(config-if)# ip access-group 110 in

//
//

sintaxe = int fast[#/#]


sintaxe =

LISTAS NOMEADAS
CRIANDO A LISTA
Router(config)#ip access-list standard BLOCK-SALES
Router(config-std-acl)#deny 172.16.40.0 0.0.0.255
Router(config-std-acl)#permit any
Router(config-std-acl)#exit

APLICANDO A UMA INTERFACE


Router(config)#int f 0/0
Ip access-group BLOCK-SALES out

12 Roteamento Dinmico
RIP
Router(config)#router rip
Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#network 5.0.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)#passive-interface f0/0
Router(config-router)#exit

ip access-group [#ACL] [in / out]

MATERIAL DE APOIO - C O M A N D O S P A R A C O N F I G U R A O
DE 20
Router(config)#hostname R_Curitiba
R_Curitiba(config)#exit
R_Curitiba# show ip route

OSPF
R_Curitiba(config)#router ospf 1
R_Curitiba(config-router)#network 10.0.0.0 0.255.255.255 area 0
R_Curitiba(config-router)#network 1.0.0.0 0.255.255.255 area 0
R_Curitiba(config-router)#network 2.0.0.0 0.255.255.255 area 0
R_Curitiba(config-router)#network 5.0.0.0 0.255.255.255 area 0
EIGRP
R_Curitiba(config)#router eigrp 1
R_Curitiba(config-router)#network 1.0.0.0 0.255.255.255
R_Curitiba(config-router)#network 2.0.0.0 0.255.255.255
R_Curitiba(config-router)#network 5.0.0.0 0.255.255.255
R_Curitiba(config-router)#network 10.0.0.0 0.255.255.255
R_Curitiba(config-router)#passive-interface f0/0

PGINA 20