DICAS EXCEL

:

Como utilizar o relógio do computador em uma formula do Excel? De: Ricardo. Escolha uma célula em branco, digite a fórmula '=agora()' e tecle Enter. Automaticamente irão aparecer a hora e a data do computador. O legal dessa fórmula é que os valores não permanecem fixos e são atualizados assim que você realiza alguma ação dentro da planilha Se não for possível ter um texto em apenas uma linha, como se faz para mostrar em mais linhas? De: Kazuhisa Kanno. Primeiro selecione as linhas que você deseja preencher com o seu texto. Depois, no alto da tela, clique no menu Formatar > Células. Clique na aba Alinhamento e assinale a opção Mesclar Células. É só clicar em OK e pronto! Outro jeito é ir em Formatar > Células > Alinhamento e Wrap Text. Como usar a fórmula PROCV? De: Marcos. A formula PROCV serve para fazer busca de dados em tabelas. O padrão é =PROCV(número de busca;tabela;qual coluna retornar). Vamos explicar: por exemplo, você tem uma lista de funcionários da empresa e quer saber dados dele apenas inserindo o código funcional. Você faz =PROCV(Número do funcionário; marca o intervalo da tabela, e marca a coluna que contém o dado que você quer). Para que o dado retornado seja o da linha use PROCH. Se o seu Excel é em inglês, use VLookup para colunas e HLookup para linhas. Veja imagem abaixo com a fórmula em ação:

Como alterar texto para maiúsculas no Excel? De: Graça Santos. Vamos supor que a o texto que você deseja deixar em maiúsculas esteja na célula C10. Escolha uma célula vazia da planilha e digite este código: =MAIÚSCULA(C10) e pressione Enter. O conteúdo da célula C10 ficará, agora, em maiúscula. Se quiser fazer o contrário, transformar em minúsculas, basta escrever o mesmo código e substituir MAÍSCULA por MINÚSCULA. E se você quiser, ainda, que só as primeiras letras de cada palavra estejam em letra maiúscula, digite PRI.MAIÚSCULA. Como programar uma célula para aparecer com preenchimento colorido automático quando uma determinada condição ocorrer? De: Luiz Souza. Você terá que utilizar o recurso da Formatação Condicional. Imagine que na sua planilha você tem uma coluna na qual todas as células estão

As inclusões posteriores também estarão condicionadas a esta formatação.a do estoque baixo. formate a fonte em azul e negrito. e assim por diante. agora ao invés de escolher a cor vermelha. na aba Fonte. Até agora você cobriu apenas uma faixa . Na Condição 1. Você pode trabalhar com as cores da fonte e do fundo da célula e ainda com a borda. clique no botão Adicionar e determine as condições para o estoque alto. não defina nenhum formato. 500 e 200. Isso permite a criação de planilhas-resumo . escolha "o valor da célula é" (campo 1). Sua empresa convenciona que o normal é ter entre 200 e 500 peças do produto. Clique de novo em Formatação e. para reposição ou redução do estoque. basta substituir o conteúdo dessas duas células. do mesmo modo. clique no botão Formatar e estabeleça uma marca para a célula. Se mudar a política de estoques para esse produto. escolha a cor vermelha. nomeie duas células. destacar em vermelho os números abaixo de um determinado patamar e em azul os que pertencerem a uma faixa bem definida. "0" (campo 3). Para isso. Selecione a coluna com esses valores e logo na seqüência clique no menu Formatar. . Pronto. Se você usar cores em sua planilha. o arquivo ou planilha de janeiro deve ter a mesma estrutura do arquivo ou planilha de fevereiro. Clique no botão Adicionar e vamos para o estoque normal. tabelas que consolidam dados de outras tabelas. ou vários documentos de filiais resumidos num documento único. Números negativos em vermelho no Excel Faça com que os números negativos apareçam em vermelho em planilhas do Excel 97/2000/XP Antes do Excel 97. Confira o resultado. Na caixa de diálogo. Clique em OK. A partir da versão 97. entre inclui os dois extremos). "menor que" (campo 2). defina: se o valor da célula é menor que o estoque mínimo (200). é possível usar numa planilha informações armazenadas em arquivos externos. Portanto. escolha "maior do que" e no campo 3 escolha novamente "0". repita a operação no campo 1. selecione a célula e dê o comando Inserir/Nome/Definir e digite o nome. selecione a área dos dados e acione Formatar > Formatação Condicional. Na Condição 2. Na sua planilha os valores menores do que 0 estarão em vermelho e os maiores em azul. como Condição 1. No campo 2. será mais fácil perceber quando e como agir. por exemplo. esse recurso foi incorporado ao programa com o nome de Formatação Condicional. Defina. o que estiver abaixo ou acima dessa faixa requer providências. Exemplos clássicos são resultados mensais consolidados numa planilha anual. Mais uma vez. Se o valor da célula está entre 200 e 500 (nesse caso. Clique no botão Formatar e. Ou seja. Se quiser sofisticar a solução. As formatações da planilha se adaptarão automaticamente à nova política Consolide várias planilhas do Excel Aprenda a consolidar várias planilhas numa única com o Excel 97/2000/XP No Excel. os dados da filial A devem ter layout idêntico ao dos dados da filial B.preenchidas com valores e você deseja que os valores inferiores a 0 apareçam com a fonte em vermelho e os superiores em azul. Se o número de peças for maior que 500. Admita que você tem uma planilha para controlar o estoque de um produto. uma como Estoque_Max e a outra como Estoque_Min.ou seja. a fonte como vermelho e negrito. A maneira mais fácil de criar uma planilha consolidada é conceber uma estrutura única para todas as planilhas ou documentos. escolha a azul e novamente clique em OK. para toda a empresa. você precisava fazer algumas ginásticas para formatar uma célula conforme seu conteúdo. Preencha essas células com os respectivos valores. Escolha a opção Formatação Condicional. Na planilha. Por exemplo.

Admita. use um programa de banco de dados. A qualquer momento. use a fórmula: =SOMA(Janeiro:Maio!C5)+´h:\docs\[Junho. se você quiser montar um banco de dados com várias tabelas relacionadas. ganham uma caixa de verificação que lhe permite filtrar o banco de dados para ver apenas os registros de um determinado tipo. Nesse caso. deseja consolidar essas informações num documento único. todos os campos. Se você precisa manter uma lista de contatos pessoais. com uma planilha para cada mês. Uma forma simples de obter isso é construir a lógica de uma das planilhas e depois copiá-la para as demais. na célula C5. por exemplo.Vejamos um exemplo prático. em Faixas. . na célula C5 da planilha consolidada: =SOMA(Janeiro:Junho!C5) Mesmo que as seis fontes de dados não pertençam todas a um mesmo arquivo. mais uma para o total. nesse caso. Junho. Os comandos Editar > Localizar e Editar > Substituir são outros recursos para trabalhar com os registros. ao escolher a opção Rock. relatórios variados. Para facilitar. Digamos que a receita mensal esteja.. Bem. terminado o primeiro semestre. use os recursos de banco de dados do Excel. Para um cadastro simples. Para voltar a visualizar a totalidade dos registros. escolha a opção "é maior ou igual a" e ao lado escreva 10. na linha de títulos. na qual a receita mensal se encontra na planilha Plan2. desfaça o caminho: escolha Tudo. os dados que vão ser aproveitados na planilha Ano devem estar nas mesmas posições em todas as planilhas. por exemplo. Para pesquisar.. descubra quais têm dez ou mais faixas. Agora. ainda assim é possível fazer a consolidação. A forma mais simples é criar sete planilhas numa mesma pasta de trabalho: seis planilhas mensais. você pode acionar o comando Dados > Classificar e reorganizar os registros com base em até três campos. célula G7. basta usar a seguinte fórmula. o perfil das receitas e despesas da empresa. ou mesmo o cadastro de sua coleção de CDs ou DVDs.xls]Plan2´!G7 O Excel funciona como um BD. use o comando Dados > Filtrar > AutoFiltro.xls. Dos discos de rock. No primeiro campo. em Gênero. e Tudo. Ao fazer isso. você vai ver na tela apenas os registros com essa classificação. para obter a receita do semestre. que os dados de junho estão numa pasta de trabalho à parte. montar um filtro em cima de um conjunto já filtrado. Só é preciso conhecer bem o layout do documento fora do padrão. Abra a caixa de verificação do campo Faixas e escolha Personalizar. o Excel quebra um bom galho. com os campos de dados indicados na primeira linha. Você pode. Agora. tela para digitação. em todas as planilhas. ainda. Para obter a receita do semestre. Se. Você acompanha. Crie uma tabela. a tabela de CDs tem um campo Gênero.

matriz_tabela. Nesse caso. Para obter mais informações. Sintaxe PROCV(valor_procurado. em vez de PROCH. . uma correspondência aproximada será retornada. Se FALSO. o valor maior mais próximo que é menor que o valor_procurado será retornado. núm_índice_coluna É o número da coluna em matriz_tabela a partir do qual o valor correspondente deve ser retornado. O V em PROCV significa vertical. Textos em maiúsculas e minúsculas são equivalentes.COMO USAR O PROCV??? Localiza um valor na primeira coluna de uma matriz de tabela e retorna um valor na mesma linha de outra coluna na matriz da tabela. PROCV fornecerá o valor de erro #REF!. Você pode colocar os valores em ordem ascendente escolhendo o comando Classificar no menu Dados e selecionando Crescente. Um núm_índice_coluna de 1 retornará o valor na primeira coluna em matriz_tabela. o valor de erro #N/D será retornado. caso contrário. quando os valores da comparação estiverem localizados em uma coluna à esquerda dos dados que você deseja encontrar. Valor_procurado pode ser um valor ou uma referência. Os valores na primeira coluna de matriz_tabela são aqueles procurados por valor_procurado. Use uma referência a um intervalo ou nome de intervalo. Procurar_intervalo Um valor lógico que especifica se você deseja que PROCV localize uma correspondência exata ou aproximada. Se uma correspondência exata não for encontrada. Use PROCV. e assim por diante. números ou valores lógicos. Se valor_procurado for menor do que o menor valor na primeira coluna de matriz_tabela. Se VERDADEIRO ou omitida. um núm_índice_coluna de 2 retornará o valor na segunda coluna em matriz_tabela. Esses valores podem ser texto. o primeiro valor encontrado será usado. Se uma correspondência exata não for encontrada.nú… Valor_procurado O valor a ser localizado na primeira coluna da matriz (matriz: usada para criar fórmulas únicas que produzem vários resultados ou que operam em um grupo de argumentos organizados em linhas e colunas. Matriz_tabela Duas ou mais colunas de dados. PROCV poderá não fornecer o valor correto. PROCV retornará o valor de erro #VALOR!. Se houver dois ou mais valores na primeira coluna de matriz_tabela que corresponderem ao valor_procurado.) da tabela. PROCV fornecerá o valor de erro #N/D. Se núm_índice_coluna for: Menor do que 1. Um intervalo de matrizes compartilha uma fórmula comum. uma constante de matriz é um grupo de constantes usado como um argumento. Maior que o número de colunas em matriz_tabela. consulte Ordens de classificação padrão. os valores na primeira coluna de matriz_tabela não precisam ser classificados. PROCV somente localizará uma correspondência exata. Os valores na primeira coluna de matriz_tabela devem ser colocados em ordem de classificação crescente.

vai ser possível aumentar a lista sem precisar mexer nas caixas de combinação. em vez de um endereço (A2:A19). Observe: na lista foi incluída uma célula em branco. Isso define uma região chamada Produtos. Um formulário para a apresentação de orçamentos é o tipo de documento para ser utilizado muitas vezes. Aumente a altura das linhas (18 é um bom número para a altura). mas somente ao intervalo que vai de A2 (a célula em branco) até onde a coluna estiver preenchida. Assim. Dê OK. pronto para ser preenchido. Nela. Lista de produtos Vamos usar como exemplo uma planilha para orçamento de venda com as seguintes colunas: Produto. construa o formulário de orçamento. coloque o título. escolhese uma opção. A2. A primeira tarefa é definir o conteúdo dessas caixas. Assim: Plan2!A2:A19. DESLOC usa esse número para definir o intervalo. copiar e colar Cada linha da coluna Produto deve conter uma caixa de combinação com o mesmo conteúdo. Na coluna A da planilha Plan2. Mas. Produtos. terá um formulário em branco. 4. endereço etc. crie essa lista numa planilha separada. localize a linha ListFillRange. Copie a caixa de combinação. que ocupa o intervalo de células A2:A19.0. Vamos incluir nela a lista de produtos. 7. Que trabalhão. Cada caixa de combinação contém a lista de produtos. Veja no passo-a-passo a seguir como utilizá-las em suas planilhas. Na barra Caixa de Ferramentas de Controle. E como ficarão as coisas se a lista incorporar novos itens. 1. agora. Dê o comando Exibir > Barras de Ferramentas e deixe visível a barra Caixa de Ferramentas de Controle. as caixas de combinação do Excel são fáceis de usar e não exigem conhecimento avançado. Vamos usá-la junto com o recurso de nomear a coluna A de Plan2.0. clique no botão com o esquadro azul. Ajuste a caixa para que coincida com as dimensões da primeira célula da coluna Produto. no exemplo. Nessa barra. vamos incluir as caixas de combinação nas células da coluna Produto. em vez de digitar. Assim. O Excel tem uma função chamada DESLOC que pode ajudar a resolver o problema. A função CONT. Clique com o botão direito na caixa de combinação e. vamos por um atalho. 6. Batizaremos essa coluna com o nome Produtos. Desenho da caixa Volte para a planilha Plan1.Menos digitação no Excel Explore o recurso das caixas de combinação do Excel para criar listas de opções e reduzir o trabalho de digitação As caixas de combinação em planilhas do Excel constituem um recurso muito prático que poucos usuários utilizam. selecione a célula imediatamente abaixo e dê o comando colar. 5. o melhor é salvá-lo como modelo (XLT). Então. Salvar como modelo Falta. 8. Agora. clique no controle Caixa de Combinação e desenhe o objeto. 2.? Sempre que você aumentar a lista. Um novo problema A planilha já está pronta. toda vez que você abrir o modelo. na linha 1. Região automática A solução é redefinir automaticamente o intervalo da lista de produtos. A21 etc.CONT. que será a lista de produtos disponíveis. . A solução. Para organizar o trabalho.VALORES conta as células preenchidas na coluna A. Para isso. em vez de repetir o que foi feito no bloco anterior. Preço Unitário. Repita esse processo para todas as linhas. O objetivo é deixá-la como a primeira linha da lista. se você quiser. Na caixa Definir Nome. escolha a opção Propriedades. Agora. ao mesmo tempo. Ele alterna entre o modo de desenvolvimento e o modo de ação da planilha. Agora. em tese O que faz a função DESLOC? Ela define uma região da planilha de forma elástica. Portanto. adicionar fórmulas à coluna Valor e formatar os números. e embaixo: =DESLOC(Plan2! $A$2. pode adicionar o logotipo da empresa. o usuário poderá escolhê-la quando quiser cancelar a inclusão de uma linha no orçamento. vamos dizer ao Excel que Produtos não equivale a toda a coluna A. em vez de armazená-lo como um arquivo comum (XLS). Desse modo. será obrigado a atualizar o endereço dela em cada uma das caixas. Na caixa Propriedades. Essas caixas — que contêm uma lista de opções — facilitam a elaboração do documento quando há itens que se repetem em determinados campos.VALORES(Plan2!$A:$A)). nas células A20. Deixe em branco a linha seguinte e escreva a especificação de cada item. Então. 3. Além disso. no menu. escreva Produtos. As caixas de combinação vão ser usadas no campo Produto. Quantidade e Total. Além disso. digite: em cima. Conteúdo da caixa A caixa de combinação está vazia. em cada caixa. Produtos. Digite a região da lista de produtos. acione Inserir > Nome > Definir. Mas vamos pensar um pouco.

Se você quiser inserir a data do dia." na célula selecionada e. É possível. Criação da assinatura • • 1 No Microsoft Office 2000: o Fazer uma busca do arquivo SELFCERT. no formato DD / MM / AAAA e. Excel . A utilização do código VBA requer um nível de segurança baixo ou médio. Mas para isso é preciso montar um esquema bastante criativo ou programar em linguagem VBA. o E em Certificado digital para os projetos VBA.exe para exibir o assistente. mas neste caso é preciso ativar os macros a cada abertura do arquivo. o preço aparecerá na coluna correspondente. Idem. o Ferramentas Microsoft Office. quando se escolher um item.Assinatura digital. pronto. sem ser atualizada toda vez que o arquivo for aberto (ex: para indicar a data da abertura do arquivo ): • Basta clicar em "Ctrl" e ". Assim. Na janela do assistente No campo "Nome do seu certificado". em uma célula. se você quiser inserir a hora no formato HH:MM: • Basta clicar em "Ctrl" e ":" na célula. clique duas vezes em SelfCert. incluir uma coluna de preços na lista de produtos (Plan2). VISTA ou Windows7 para o Microsoft Office 2003 e o 2007 : o Botão Iniciar. que ela permaneça fixa. por exemplo. digitar um nome simples que você queira dar à . Mais expansões Você pode automatizar ainda mais a planilha de orçamento. o Clique em Microsoft Office.9. o Em Todos os programas. 2 No ambiente XP. criando a sua própria assinatura digital para autenticar a codificação dos macros gravados. É possível remediar esses inconvenientes.

3 Na barra dos menus do Visual Basic Editor: Ferramentas > Assinatura Eletrônica > clicar em Escolher > e no nome da sua assinatura e. Marcar a opção "Confiar sempre nos macros deste editor". uma caixa de diálogo proporá a ativação dos macros: • • • • Antes de ativar os macros. Ativar os macros.sua assinatura. No ambiente Microsoft Excel 2007 • • • • • Se a guia "Desenvolvedor" não estiver ativada. Agora você pode assinar nossos códigos No ambiente Microsoft Excel 2000 e 2003 • 1 Abrir o arquivo Excel com um código macro. Abrir o arquivo com o código macro para assinar Na guia "Desenvolvedor". 4 Salvar e fechar o arquivo : na abertura. os macros se ativarão. em OK. • • • 2 Ferramentas/Macro/Visual Basic Editor ou Alt+F11. Na abertura do primeiro arquivo. Ferramentas > Macros > Segurança > Guia "Nível de segurança" > assinalar o nível médio). clicar em OK. Quando a mensagem de confirmação do certificado aparecer. (Na abertura. Maior segurança Você pode aumentar a segurança para o nível elevado (Ferramentas > Macros > Segurança > marcar Elevado). como o seu pseudônimo. Salvar e fechar o arquivo. clicar no botão Microsoft Office E em Opções Excel. automaticamente. ativar os macros. Visual Basic ou (Alt+F11) . Clicar em Padrão e marcar Exibir a guia Desenvolvedor na fita. por exemplo. usando a assinatura digital. Salvar e fechar o arquivo.

clicar em Inserir . Segurança dos macros Marcar: Desativar todos os macros exceto os macros assinados digitalmente e OK Salvar Fechar o arquivo e o aplicativo.Nome . dei o nome de PRODUITOS). Voltar à sua planilha Guia Desenvolvedor.Definir (Para este exemplo. em OK. Neste exemplo. Depois de selecionar. Tutorial Função PROCH (HLOOKUP) Procedimento do PROCH (Excel 2003 e Excel 2007) Referências • Você deve selecionar as referências em sua planilha. Excel 2007: A definição do nome é feita através do menu Fórmulas. a sua referência é $A$1:$F$4.• • • • • • Na barra dos menus do Visual Basic : Ferramentas > Assinatura Eletrônica > clicar em Escolher > e no nome da sua assinatura e. Local onde os dados encontrados aparecerão • Neste exemplo: o J1=Termo a ser procurado o J3=Descrição encontrada (coluna2 da nossa planilha) .

FALSO) Simplificando. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. indica que estamos procurando uma correspondência exata. e extraímos o valor colocado na quarta linha. procuramos na primeira linha da tabela PRODUTOS.3. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. partindo do conteúdo da célula H1."Desconhecido") =PROCH($J$1.range_lookup) (tutorial PROCH) • J3 o o o o =PROCH ($J$1. procuramos na primeira linha da tabela PRODUTOS. J5 o o o o o • J7 o o . procuramos na primeira linha da tabela PRODUTOS. se nada foi encontrado.2. se nada foi encontrado.2.tabela_matriz. a coluna começando com esse conteúdo.o o J5=Quantidade encontrada (coluna 3 da nossa planilha) J7=Preço encontrado (coluna 4 da nossa planilha) Fórmulas A sintaxe de base da função PROCH é: = PROCH (valor_pesquisa. FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1.3. e extraímos o valor colocado na terceira linha.PRODUTOS.FALSO).PRODUTOS. FALSO.2. indica que estamos procurando uma correspondência exata.PRODUTOS.PRODUTOS. =SE(FORNA(PROCH($J$1. FALSO.valor_aproximado) (=HLOOKUP(lookup_value. partindo do conteúdo da célula H1.FALSO)) (Veja a função SE ou IF aqui) * • o • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1. e extraímos o valor colocado na segunda linha. FALSO." Desconhecido ".3.PRODUTOS.2. partindo do conteúdo da célula H1.FALSO) Para ser mais claro. Para evitar a mensagem #N/A. a coluna começando com esse conteúdo.PRODUTOS.4. =SE(FORNA(PROCH($J$1.no_index_lig.P ROCH($J$1.PRODUTOS.FALSO)."Desconhecido") =PROCH ($J$1. Para evitar a mensagem #N/A.PRODUTOS. PROCH ($J$1.row_index_num.PRODUTOS.table_array. a coluna começando com esse conteúdo. indica que estamos procurando uma correspondência exata.FALSO)).FALSO) Simplificando.FALSO)).3."Desconhecido".

o o o Para evitar a mensagem #N/A.PRODUTOS.FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEIERRO(PROCH($J$1.PRODUTOS. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. =SE(FORNA(PROCH($J$1.FALSO).4. colocamos o parâmetro em FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e. se nada foi encontrado.P ROCH($J$1.4."Desconhecido") Nota: Na fórmula.FALSO). Se este parâmetro for omitido.PRODUTOS. em VERDADEIRO se o valor for igual ou inferior mais próximo."Desconhecido".4. seu valor padrão é VERDADEIRO. Tutorial Função PROCV (VLOOKUP) Procedimento do PROCV(Excel 2003 & Excel 2007) . a lista de valores deve estar organizada. neste caso.

row_index_num.PR OCV($H$1.tabela_matriz.valor_aproximado) (=VLOOKUP(lookup_value.table_array.PR OCV($H$1."Desconhecido". partindo do conteúdo da célula H1. FALSO.CAMPOS.CAMPOS. indica que estamos procurando uma correspondência exata.FALSO). a coluna começando com esse conteúdo."Desconhecido".CAMPOS. Excel 2007: A definição do nome é feita através do menu Fórmulas. a sua referência é $A$2:$D$10.Nome Definir (Para este exemplo.FALSO) Para ser mais claro. procuramos na primeira linha da tabela CAMPOS. a coluna começando com esse conteúdo. e extraímos o valor colocado na segunda linha.2. Para evitar a mensagem #N/A. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.CAMPOS. se nada foi encontrado.range_lookup) • H4 o o o o o • =PROCV($H$1.FALSO) Simplificando. dei o nome de CAMPOS).3.3.2. Depois de selecionar.3.Referências • Você deve selecionar as referências em sua planilha. procuramos na primeira linha da tabela CAMPOS. indica que estamos procurando uma correspondência exata. Neste exemplo. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. Local onde os dados encontrados aparecerão • Neste exemplo: o H1= Termo a ser procurado o H4= Descrição encontrada (coluna2 da nossa planilha) o H6= Quantidade encontrada (coluna 3 da nossa planilha) o H8= Preço encontrado (coluna 4 da nossa planilha) Fórmulas A sintaxe de base da função PROCV é: =PROCV(valor_pesquisa.2. Para evitar a mensagem #N/A."Desconhecido") =PROCV($H$1.FALSO)) H6 o o o o .2.FALSO)). =SE(FORNA(PROCV($H$1. partindo do conteúdo da célula H1.CAMPOS.FALSO)).CAMPOS.no_index_lig. clicar em Inserir .CAMPOS. FALSO. =SE(FORNA(PROCV($H$1.FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1. se nada foi encontrado. e extraímos o valor colocado na terceira linha.

FALSO. Se este parâmetro for omitido.CAMPOS."Desconhecido") =PROCV($H$1. neste caso. . se nada foi encontrado."Desconhecido"."Desconhecido") H8 o o o o o Nota: Na fórmula.CAMPOS.CAMPOS. a lista de valores deve estar organizada. partindo do conteúdo da célula H1.CAMPOS.FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1. a coluna começando com esse conteúdo. seu valor padrão é VERDADEIRO.FALSO) Simplificando. Para evitar a mensagem #N/A. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.FALSO)). =SE(FORNA(PROCV($H$1. colocamos o parâmetro em FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e.3.4.o • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1. em VERDADEIRO se o valor for igual ou inferior mais próximo.4.CAMPOS. procuramos na primeira linha da tabela CAMPOS. e extraímos o valor colocado na quarta linha.FALSO). indica que estamos procurando uma correspondência exata.4.4.PR OCV($H$1.FALSO).

4. Se não houver vínculos em nenhuma das planilhas. verificar se existem planilhas ocultas e/ou protegidas. Verifique se há vínculos através do menu Editar. pode atribuir nome e valor a ela. porque às vezes os vínculos não são . 6. sem que você saiba onde eles estão. Clique no botão OK. 3. não se preocupe. Agora você poderá utilizar o nome da variável em fórmulas em qualquer planilha da pasta de trabalho para a qual foi definido o Nome. com a ajuda do Menu Editar Localizar. digite o nome desejado para variável (por exemplo ICMS). Se houver gráficos. Nesta caixa de diálogo.DEFINIR. utilizando-a em qualquer fórmula. Vá até o Menu Editar Vínculos.Crie uma variável par ser utilizada em fórmulas Se você tiver uma planilha ou pasta de trabalho que use várias vezes uma mesma constante. o MS-Excel relaciona quais são todas as pastas de trabalho que estão enviando dados para a pasta de trabalho ativa. Por exemplo: se você digitar em uma célula =A1*ICMS o Excel recuperará o valor da variável e o utilizará na fórmula. utilize no Menu Editar o comando Localizar. Localizando vínculos em um pasta de trabalho Se você abrir uma pasta de trabalho que indicar vínculos. Execute tal procedimento em todas as planilhas da pasta de trabalho. digite o valor da variável (por exemplo 0. Observe os nomes dos arquivos. 1. Verificar a existência de objetos. Verificar a existência de gráficos. Confirme a atualização deles e depois vamos procura-los. no comando Vínculos.17). Abra o menu INSERIR e escolha NOME . Para localizar a(s) célula(s) que apresentam vínculos na pasta de trabalho ativa. Verificar a existência de botões de chamada de macros. 5. 2. e procure as células que tem estes nomes. Caso o comando esteja desabilitado. clicar em cada uma das séries do gráfico e observar suas referências. Na caixa REFERE-SE A. Procurar nomes de áreas e observar suas referências Se mesmo assim a coisa ficar complicada. a pasta de trabalho ativa não possui nenhum vínculo externo. Na caixa DEFINIR NOME na caixa NOMES DA PASTA DE TRABALHO.

A expressão =ESQUERDA(B7. a função é executada. clicando sobre um ícone com a tecla SHIFT acionada.B7) . Qual o efeito prático disto? Podemos economizar espaço nas barras de ferramentas. Completando o clique.tão óbvios assim ou você não deseja fazer esta investigação toda. Vamos a um exemplo: Alguns botões das barras de ferramentas do MS-Excel (aproximadamente 40) apresentam dupla função. execute-o para instalá-lo como suplemento do Excel e pode utilizar o suplemento para verificar onde estão os links. vai verificar que. Ao clicar no botão com a tecla Shift apertada.1) retorna Jaime . representando a função contrária. há outra maneira: faça o download do suplemento findlink. o botão estará fazendo uma função contrária. Como Buscar um Nome em uma Lista Retornando Apenas o Primeiro Nome Seja o nome Jaime Monteiro Borges Júnior colocado na célula B7. o ícone se altera. Utilizando a tecla Shift para agilizar trabalhos A tecla Shift tem algumas funcionalidades muito interessantes no MS-Excel.xla (clicando no nome). uma vez que não precisamos dos dois botões com funcionalidade equivalente na barra de ferramentas. como por exemplo: Função Normal Imprimir Desfazer (Undo) Classificar ascendente Alinhar Esquerda Retirar Casas Decimais Salvar Função com a tecla Shift Visualizar Impressão Repetir (Redo) Classificar Descendente Alinhar Direita Aplicar Casas Decimais Abrir Se você tentar.PROCURAR(" ".

dependendo do idioma do Excel). como um item de menu. Imprimir seleções não contíguas Você não precisa imprimir resmas e resmas de folhas apenas para ter cópias de algumas áreas de uma planilha Excel. Colocado no mesmo diretório. exatamente o primeiro nome do nome completo que está na célula B7. Não solte a tecla CTRL! É possível marcar quantas seções não contíguas você desejar. Em vez disso. Caso contrário. ele é carregado na memória juntamente com o Excel e fica disponível no menu FERRAMENTAS.Como? A função PROCURAR busca o primeiro intervalo (espaço em branco) e retorna a sua posição (é o sexto caractere) e a função ESQUERDA retorna os 6-1=5 primeiros caracteres. Todas as pastas aí colocadas abrem automaticamente quando iniciamos o Excel. Em seguida. Alternativa Criar um suplemento xla. Na planilha. sem ter que cortar e colá-las em uma planilha separada. mantenha a tecla CTRL pressionada e vá até a próxima seção que você deseja imprimir e a selecione. colocando-a no diretório XLINICIO (ou XLSTART. clique em VISUALIZAR IMPRESSÃO na caixa de diálogo de impressão. Planilhas abrindo automaticamente ao iniciar o Excel Você pode criar uma pasta de trabalho que é aberta cada vez que o Excel é carregado. Terminada a seleção das áreas. desde que mantenha a tecla CTRL sempre pressionada. vá em Arquivo-Imprimir e aperte o botão Seleção. Se quiser ter uma visão da prévia do resultado. O Excel imprimirá cada seção em uma página separada.Esta alternativa pode descomplicar bastante a sua abertura . selecione o primeiro conjunto de células que você deseja imprimir. imprima seções não contíguas. basta apertar OK.

como na coluna B da tabela abaixo. selecionar a célula. a B5). Você pode usar o comando COLAR ESPECIAL para isto: selecione a coluna. como mostra a tabela abaixo: . por exemplo: A 100 200 300 400 500 B 100 300 600 1000 1500 1 2 3 4 5 Basta escrever na célula B1 a fórmula: =SOMA($A$1:A1) Em seguida.. Aluguel Telefone Gás Luz é colada da seguinte forma Aluguel Telefone Gás Luz Criar uma fórmula para mostrar um total acumulado progressivo Por vezes você constrói uma tabela onde precisa de uma coluna com o total acumulado a partir do valor da primeira célula calculado progressivamente. mover manualmente é lento e trabalhoso. clicar sobre a alça de arraste e arrastar a fórmula coluna abaixo até a célula final (no exemplo.Convertendo linhas em colunas ou vice-versa Você já quis transformar uma coluna de texto ou números em uma linha para poder usar as linhas como linhas de rótulos de colunas em uma tabela? às vezes. Como apenas o primeiro valor do intervalo da soma é fixado. a fórmula representará.TRANSPOR. em cada célula.. A seguir clique EDITARCOLAR ESPECIAL. o valor acumulado de A1 até a célula correspondente. copie e selecione a célula da extrema esquerda da linha que você deseja criar.

1 2 3 4 5 A B 100 =SOMA($A$1:A1) 200 =SOMA($A$1:A2) 300 =SOMA($A$1:A3) 400 =SOMA($A$1:A4) 500 =SOMA($A$1:A5) Função para retornar o tempo transcorrido entre duas datas Caso seja necessário calcular o tempo transcorrido entre duas datas.A2. Se você desejar limitar a área de exibição de uma planilha. do grupo de discussão EXCEL Br."YM") & " meses " & DATADIF(A1."Y") & " anos " & DATADIF(A1. ao qual pertenço. usar somente a primeira parte da função. usar as duas primeiras partes da função. a inicial. . Caso se deseje anos e meses. selecionando.Linha . até a linha 65536) e daí ir ao menu Formatar . pode usar dois métodos: a) Via formatação (José Luiz) Se você quiser que a sua planilha não exiba as linha abaixo da linha 115. usar a seguinte função: =DATADIF(A1.A2.Ocultar. "MD") & " dias" Caso se deseje apenas o número de anos. Acis Menezes e Marcelo Soares. basta clicar sobra a linha 116. por exemplo. na célula A1 e a final na célula A2. teclar CTRL+Shift+SetaParaBaixo (para se deslocar. Exemplo: Como limitar a área de exibição de uma planilha? Esta dica veio dos colegas José Luiz.A2. da Yahoo.

Hidden = True End Sub Para reexibir.EntireColumn. por exemplo.ScrollArea = "A1:G115" Range("A1").Para fazer o mesmo com a s colunas.Select End Sub A segunda é do Marcelo: Sub_ocultar() ' oculta linhas Range("115:65536"). .Hidden = True ' oculta colunas Range("G:IV). basta selecionar a última linha (ou coluna) em exibição e Formatar . use o mesmo procedimento (lembrar que as colunas vão até a coluna IV): selecionar a coluna H.EntireRow. substituindo TRUE por FALSE. Para reexibir. b) Via Macro Esta forma é interessante para se colocar nos eventos de abertura e fechamento da planilha. A primeira é do Acis: Sub Congela_area() Worksheet("Plan 1"). clicar CTRL+Shift+SetaParaDireita e Formatar-Coluna-Ocultar. crie uma função com a mesma sintaxe.Select Selection.Reexibir.Linha (ou Coluna) . Neste caso temos duas formas.Activate ActiveSheet.Select Selection.

Sign up to vote on this title
UsefulNot useful