Você está na página 1de 35

LAN 20x – Cisco CCNA Routing & Switching

• Módulo 15:

WANs

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Tópicos Fundamentais

• WANs diferem de LANs em diversas maneiras:


 Enlaces de WAN atingem distâncias muito maiores.
 WANs são fornecidas por um provedor de serviços.

“Você é dono de LANs, mas você aluga WANs”

• Tecnologias de acesso à Internet:


 Modens analógicos
 DSL
 Cabo
 3G/4G

• Serviços IP para acesso à Internet

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Tópicos Fundamentais

Comutação por circuito

Comutação por pacotes

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Protocolos de Camada 2 para WANs Ponto-a-Ponto

• HDLC / PPP

 Linha alugada (link ponto-a-ponto)


 Objetivo principal é entregar dados através do link
 Verificar erros (se encontra descarta o frame)
 Síncrono

• Frame-Relay

 Comutação por pacotes


 DLCI: Identificador de circuitos virtuais do Frame-Relay
 Multiplos VCs podem compartilhar o mesmo link de acesso.
 CIR garante largura mínima de banda.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

HDLC
High-Level Data Link Control

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

HDLC

• Padrão de encapsulamento para links seriais nos roteadores Cisco

4 Mbps

DCE

R1(config)# interface s0/0/0


R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)# encapsulation hdlc
R1(config-if)# clock rate 4000000
R1(config-if)# bandwidth 4000

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP
Point to Point Protocol

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP - Características

 O PPP permite a entrega de um frame de dados através de um enlace.

 Suporte a enlaces síncronos e assíncronos.

 Permite que vários protocolos de Camada 3 passem através do mesmo enlace.

 Permite autenticação PAP e CHAP.

 Possue protocolos de controle.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP - LCP (Link Control Protocol)

 O LCP implementa as funções de controle do PPP, conforme tabela abaixo:

Função Recurso LCP Descrição


Detecta se um link está com loop e
Detecção de Loop Número Mágico (Magic Number) desabilita a interface, permitindo o
roteamento para uma rota válida.
Load-balance em múltiplos links
Suporte Multilink Multilink PPP
paralelos.
Desabilita uma interface que
Monitoramento de Qualidade de Link exceder um percentual de taxa de
Detecção de erro
(Link Quality Monitoring – LQM) erro, permitindo o roteamento por
rotas melhores
Autentica os roteadores nas duas
Autenticação PAP e CHAP
extremidades do link entre si.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP - Configuração

R1(config)# interface s0/0/0


R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)# encapsulation ppp
R1(config-if)# clock rate 64000
R1(config-if)# bandwidth 64

R2(config)# interface s0/0/1


R2(config-if)# ip address 192.168.2.2 255.255.255.0
R2(config-if)# encapsulation ppp
R2(config-if)# bandwidth 64

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP - Configuração

• Multilink PPP:
R1(config)# interface Serial0 R1(config)# interface Multilink1
R1(config-if)# no ip address R1(config-if)# ip address 10.10.10.2 255.255.255.248
R1(config-if)# encapsulation ppp R1(config-if)# ppp multilink
R1(config-if)# ppp multilink R1(config-if)# ppp multilink group 1
R1(config-if)# ppp multilink group 1
R1(config)# interface Serial1
R1(config-if)# no ip address
R1(config-if)# encapsulation ppp
R1(config-if)# ppp multilink
R1(config-if)# ppp multilink group 1

• LQM (Link Quality Monitoring):


R1(config)# interface Serial1
R1(config-if)# ip address 10.10.10.2 255.255.255.248
R1(config-if)# encapsulation ppp
R1(config-if)# ppp quality percentage

 O LQM vem desabilitado por padrão. Não é compatível com o Multilink PPP.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP - Autenticação

• Há dois métodos de autenticação no PPP:

 PAP: Envia usuário e senha em texto puro.

 CHAP: Utiliza hash unidirecional com MD5 para autenticar usuário e senha.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PPP - Autenticação

• Configuração:

R1(config)# username R2 password senha


R1(config)# interface s0/0/0
R1(config-if)# ppp authentication {pap | chap}

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Frame Relay

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Visão Geral

• O Frame Relay suporta a capacidade de enviar dados a vários roteadores remotos através de um
único circuito físico de WAN.

• Redes de multiacesso

 Similares às LANs (mais de dois dispositivos podem se conectar a rede).


 Usa um endereço que identifica a qual dos roteadores remotos cada frame está endereçado.

• NBMA (nonbroadcast multiaccess)

 Não pode enviar um broadcast na camada de enlace


de dados sobre o Frame Relay.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Principais termos do Frame Relay

• VC (Virtual Circuit): Representa o caminho lógico que os frames percorrem entre DTEs.

• PVC (Permanent Virtual Circuit): Um VC pré-definido.

• DLCI (Data-Link Connection Identifier): Um endereço Frame Relay usado para identificar o VC.

• LMI (Local Management Interface): Protocolo usado entre um DCE e um DTE para administrar a
conexão.
Componentes do Frame Relay

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Circuitos Virtuais

• Um circuito virtual define um caminho lógico entre dois DTEs Frame Relay. Atuam como circuitos
ponto-a-ponto.

• Os VCs compartilham o link de acesso e a rede Frame Relay.

• Cada VC possui um CIR (committed Information Rate).

• Custo menor que com linhas privadas.

• Dois tipos de VCs são permitidos


 PVC (Permanent virtual circuit): Pré-definido pelo provedor.
 SVC (switched virtual circuit): Criados dinamicamente.

• O Frame Relay usa um endereço chamado DLCI (data-link connection identifier) para identificar
os VCs.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Endereçamento do Frame Relay

Endereçamento Local Endereçamento Glocal

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

LMI e tipos de encapsulamento

• O LMI é a definição das mensagens usadas entre o DTE (roteador) e o DCE (provedor
de serviço).

• Três opções de LMI estão disponíveis no IOS da Cisco:

Nome Descrição Parametro / Tipo de LMI


Cisco Proprietário cisco
ANSI T1.617 Anexo D ansi
ITU Q.933 Anexo A q933a

• DCE e DTE devem usar o mesmo padrão LMI.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Controlando a velocidade e os descartes na nuvem Frame Relay

• O Frame Relay possui três flags de um bit cada que ajudam a controlar a rede para evitar
congestionamento devido a descompassos na velocidade.

 Causa principal: taxa de acesso (taxa de clock) excede o CIR de um VC.

• Esses bits são:

 FECN (Forward Explicit Congestion Notification)

 BECN (Backward Explicit Congestion Notification)

 DE (Discard Eligibility)

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Topologias Frame-Relay

Star (estrela) Full-Mesh Partial-Mesh

• Configuração hub-and-spoke. • Todos os roteadores têm conexões • Apenas alguns roteadores têm
diretas (VCs) para todos os outros acesso direto ao site central.
• Sites remotos conectados a um roteadores.
site central. • Mais barato de implementar do
• Topologia mais cara. Quanto mais que um full-mesh.
• O roteador central fornece uma roteadores são adicionados mais
conexão multiponto, e usa uma cara ela se torna.
única interface para interligar
vários PVCs. • A fórmula para determinar o número
de VCs necessários: n (n-1) / 2,
• Topologia mais usada, devido ao onde n é o número de nós da rede.
custo mais baixo.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Modos de Operação

Ponto a Ponto Multiponto


• Sub-interfaces • Apenas uma sub-rede (funciona com uma LAN)
• Cada sub-interface representa um link ponto-a-ponto • Mapeamento DLCI estático

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Planejamento e Configuração

• Por default, o IOS da Cisco automaticamente percebe o tipo de LMI e descobre automaticamente o
mapeamento entre o DLCI e os endereços IPs que são next-hop (usando o ARP Inverso)

• Itens que devem ser alinhados junto ao provedor:

 Taxa de acesso (taxa de clock) usada em cada link.


 Definição de cada VC, identificando as extremidades e o CIR.
 Tipo de LMI

• Itens definidos pelo engenheiro de redes da empresa:

 Esquema de sub-rede IP.


 Definir se deve atribuir endereços IP para subinterfaces físicas, multiponto ou ponto-a-ponto.
 Definir quais interfaces precisam usar o encapsulamento IETF ao invés do default “cisco”.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Configuração

 Ponto a Ponto

1. Configurar a interface física com o encapsulamento Frame Relay.


2. Criar a sub-interface como point-to-point
3. Configurar o endereço IP sub-interface.
4. Configurar o LMI manualmente. (Opcional)
5. Associe o DLCI com a sub-interface.

router# config t
router(config)# int s0/0/0
router(config-if)# encapsulation frame-relay
router(config-if)# no shut

router(config-if)# int s0/0/0.1 point-to-point


router(config-subif)# ip address 10.2.2.2 255.255.255.252
router(config-subif)# frame-relay lmi-type ansi
router(config-subif)# frame-relay interface-dlci 100
router(config-subif)# end

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Configuração

 Multiponto

1. Configurar a interface física com o encapsulamento Frame Relay.


2. Criar a sub-interface como multipoint
3. Configurar o endereço IP sub-interface.
4. Configurar o LMI manualmente. (Opcional)
5. Configurar o mapeamento estático do DLCI para endereço IP do roteador next-hop.

router# config t
router(config)# int s0/0/0
router(config-if)# encapsulation frame-relay
router(config-if)# no shut

router(config-if)# int s0/0/0.1 multipoint


router(config-subif)# ip address 10.2.2.2 255.255.255.252
router(config-subif)# frame-relay lmi-type ansi
router(config-subif)# frame-relay map ip 199.1.1.1 51 broadcast
router(config-subif)# end

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Processo de resolução de problemas de Frame Relay

• Passo 1: Verifique se existem problemas de Camada 1 no link de acesso.

• Passo 2: Verifique se existem problemas de Camada 2 (encapsulamento e lmi).

• Passo 3: Verifique se existem problemas no PVC.

• Passo 4: Verifique se existem problemas de mapeamento estático e dinâmico (ARP Inverso).

• Passo 5: Verifique se existem problemas no encapsulamento fim-a-fim (cisco ou ietf).

• Passo 6: Verifique se existem problemas na Camada 3, incluindo sub-redes.

LAN 20x - Cisco CCNA Routing & Switching


15. WANs – Frame Relay

Comandos de verificação de Frame Relay

• Comandos específicos:

router# show frame-relay lmi


router# show frame-relay map
router# show frame-relay pvc

• Comando gerais:

router# show interfaces


router# show ip interfaces brief

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Tecnologias de Acesso à Internet

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

PSTN e Modens Analógicos

Operação Básica de Modens através da PSTN

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Linha Digital de Assinante (DSL)

• O DSL fornece capacidade de acesso de alta velocidade para residências.

• O DSL permite que sinais de voz analógicos e sinais de dados digitais sejam enviados pelo mesmo
cabo de forma simulânea no loop local (conexão entre uma residência e a central telefonica).

• O loop local deve estar conectado a um dispositivo chamado DSLAM (DSL Access Multiplexer).

• O DSL permite que uma chamada de voz esteja ativa simultaneamente a uma conexão de dados.

• De forma diferente dos modens, o componente de dados do DSL está sempre ativo. Não é
necessário sinalizar ou discar para estabelecer o circuíto de dados.

• A diferença fundamental dos serviços DSL é se o mesmo é simétrico (a velocidade do link em cada
direção é a mesma) ou assimétrico (velocidades diferentes).

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Linha Digital de Assinante (DSL)

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Internet a cabo

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Comparativo das tecnologias de acesso remoto

Modens
Descrição DSL Modens a Cabo
Analógicos
Transporte Loop local Loop local Cabo CATV

Velocidades Simétrica Sim Sim Não

Velocidades Assymétricas Sim Sim Sim

Velocidades Reais Típicas Até 100 kbps 1,5 Mbps De 3 a 6 Mbps

Permite voz e dados Não Sim Sim

Internet Ativa Não Sim Sim

Problemas de Distância (loop local) Não Sim Não

Degradação com aumento de tráfego Não Não Sim

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Acesso Móvel Celular com 3G / 4G

Tecnologia Velocidade Máxima Suportada

2G 384 Kbps

3G 1,92 Mbps

4G 100 Mbps

LAN 20x - Cisco CCNA Routing & Switching


15. WANs

Exercícios:

• Exercícios de Revisão 15.

• Laboratório LAN-20x Lab-15 - WANs.

LAN 20x - Cisco CCNA Routing & Switching