Você está na página 1de 44

FTOOL

FTOOL

APLICAÇÃO DE CONCEITOS DE MECÂNICA


DE ESTRUTURAS

PET ENGENHARIA CIVIL – UFPR

2010
Temporada de Cursos PET Engenharia Civil

FTOOL 2.11
Grupo PET Civil 2010
Alexandre Beê Amaral

Gabriel Grando Barbosa

Hugo Begueto Netto

Jairo Melara de Camargo

Marcos Antonio Costantin Filho

Maria Angélica Castelli Martinez

Paola Dutra

Paulo Afonso Nunes

Ralph Magalhães Machado Chrestenzen

Ricardo Pieralisi

Taiane Dalmagro

Thamires da Silva Matos

Vanessa Cristina Kramer

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Agradecimentos i

Agradecimentos
O grupo PET Engenharia Civil da Universidade Federal do Paraná agradece o Senhor
Luiz Fernando Martha pela permissão para a utilização do Manual on-line da versão 2.11 do
programa, para compor parte deste material didático.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Sumário iii

Sumário
Introdução ..................................................................................................................................... 1
1. Download do Programa ........................................................................................................ 3
2. Manipulação de Arquivos...................................................................................................... 5
2.1. Menu File............................................................................................................................ 5
2.2. Exportação de imagem através do Clipboard (Área de transferência) .............................. 6
3. Criação e Manipulação da Estrutura ..................................................................................... 7
3.1. Menu de Edição.................................................................................................................. 7
3.2. Criação de Barras e Nós ..................................................................................................... 7
3.3. Criação de Linhas de Cota .................................................................................................. 8
3.4. Modo Teclado..................................................................................................................... 8
3.5. Modo Seleção ..................................................................................................................... 8
3.6. Menu de Undo e Redo ....................................................................................................... 9
3.7. Menu Transform ................................................................................................................ 9
4. Controles de Visualização.................................................................................................... 11
4.1. Menu de Controle de Visualização................................................................................... 11
4.2. Controle de Coordenadas ................................................................................................ 11
4.3. Menu Display.................................................................................................................... 12
5. Configurações ...................................................................................................................... 13
5.1. Menu Options................................................................................................................... 13
5.2. Formatação de Unidades e Valores Numéricos ............................................................... 13
5.3. Sistemas de Unidades ...................................................................................................... 14
6. Atributos de Nós e Barras ................................................................................................... 17
6.1. Menu de Controle dos Atributos dos Nós e Barras.......................................................... 17
6.2. Características Comuns aos Submenus ............................................................................ 17
6.3. Submenu de Parâmetros dos Materiais ........................................................................... 18
6.4. Submenu de Propriedades das Seções Transversais........................................................ 18
6.5. Submenu de Condições de Apoio .................................................................................... 20
6.6. Submenu de Propriedades de Articulação de Barras....................................................... 21
6.7. Submenu de Restrições de Deformações de Barras ........................................................ 21
7. Atribuição de Cargas ........................................................................................................... 23

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


iv Introdução

7.1. Menu de Controle das Cargas .......................................................................................... 23


7.2. Informações Gerais .......................................................................................................... 23
7.3. Submenu de Cargas Concentradas Nodais....................................................................... 25
7.4. Submenu de Cargas Momentos em Extremidades de Barras .......................................... 25
7.5. Submenu de Cargas Distribuídas Uniformes.................................................................... 26
8. Resultados ........................................................................................................................... 29
8.1. Menu de Resultados......................................................................................................... 29
8.2. Modos de Resultados ....................................................................................................... 29
8.3. Convenção de Sinais para Esforços Internos.................................................................... 30
8.4. Escala dos Diagramas e Linhas de Influência ................................................................... 32
8.5. Resultados Pontuais ......................................................................................................... 33
9. Passo a Passo....................................................................................................................... 35
10. Exemplos de Aplicações .................................................................................................. 37
Referências Bibliográficas ........................................................................................................... 45

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Introdução 1

Introdução

O FTOOL é um programa que se destina ao ensino do comportamento estrutural de


pórticos planos, ocupando um espaço pouco explorado por programas educativos, que se
preocupam mais com o ensino das técnicas numéricas de análise, ou por versões educacionais
de programas comerciais, mais preocupados em introduzir os estudantes às suas interfaces.
Seu objetivo básico é motivar o aluno para aprender o comportamento estrutural. A
experiência de ensino nesta área tem mostrado que o processo de aprendizado dos métodos
de análise estrutural não é eficiente sem o conhecimento sobre o comportamento estrutural. É
muito difícil motivar o aluno padrão a aprender a teoria dos métodos de análise sem entender
como o modelo sendo analisado se comporta na prática. O processo de aprendizado dos
métodos de análise melhoraria bastante se o estudante pudesse aprender sobre o
comportamento estrutural simultaneamente.

Do seu objetivo básico decorre a necessidade do FTOOL ser uma ferramenta simples,
unindo em uma única interface recursos para uma eficiente criação e manipulação do modelo
(pré-processamento) aliados a uma análise da estrutura rápida e transparente e a uma
visualização de resultados rápida e efetiva (pós-processamento).

Os usuários da versão educacional do programa estão livres de qualquer compromisso


para usá-lo. Entretanto, nem o autor, nem a PUC-Rio, nem o Tecgraf/PUC-Rio, nem qualquer
outra Instituição relacionada são responsáveis pelo uso ou mau uso do programa e de seus
resultados. Os acima mencionados não têm nenhum dever legal ou responsabilidade para com
qualquer pessoa ou companhia pelos danos causados direta ou indiretamente resultantes do
uso de alguma informação ou do uso do programa aqui disponibilizado. O usuário é
responsável por toda ou qualquer conclusão feita com o uso do programa. Não existe nenhum
compromisso de bom funcionamento ou qualquer garantia.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


1.Download do Programa 3

1. Download do Programa

O programa FTOOL Versão Educacional 2.11 está disponível para download no site
<http://www.tecfraf.puc-rio.br/ftool> em versões para Windows e Linux. Também é
disponibilizado pelo site um manual para utilização do software.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


2. Manipulação de Arquivos 5

2. Manipulação de Arquivos

2.1. Menu File

A manipulação de arquivos no FTOOL se dá através do menu suspenso File.

Figura 1

O Menu File contém opções para informações sobre o programa (About (About Ftool), para
mostrar a convenção de sinais de esforços internos e definir o padrão para traçado de
diagramas (Sign Convention)) – veja detalhamento da convenção de sinais na seção sobre Pós- Pós
Processamento –,, para criar um novo modelo (New),
( para carregar na memória o modelo
gravado em um arquivo armazenado em disco (Open), para gravar o modelo corrente em um
arquivo em disco com o mesmo nome (Save) ( ) ou com um nome diferente (Save ( as), para
importar propriedades de outro arquivo do FTOOL (Import ( Properties),), para
pa exportar a
imagem da tela (Export
Export Screen)
Screen) para a área de transferência do Windows (Clipboard) ou para
arquivos com formatos específicos, para verificar o número total de barras e nós existentes no
modelo (Totals),
), para determinar o limite da janela de trabalho
t (Limits)) e, por fim, para de
saída do programa (Exit).

A importação de propriedades (Import


( Properties) do menu File incorpora ao modelo
corrente todos os parâmetros globais (sistema de unidades, parâmetros de visualização, etc.) e
todos os atributosos (tabelas de propriedades de materiais e de seções transversais, tabelas de
cargas, etc.) existentes em outro arquivo criado pelo FTOOL. Quando esta opção é selecionada,
o programa pede para o usuário indicar o arquivo para importação. Tabelas de atributos
atribut e
cargas também podem ser importadas em separado (veja seções Atributos de Nós e Barras e
Atribuição de Cargas).

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


6 Ftool 2.11

Os comandos mais utilizados do menu File foram agrupados no conjunto de botões da


régua de controle no topo da tela do FTOOL que estão mostr
mostrados abaixo:

Figura 2

2.2. Exportação de imagem através do Clipboard (Área de transferência)

Para obter os melhores resultados, siga os seguintes passos:

• Escolha a opção Export Screen/Clipboard do menu File,, ou aperte o botão , ou


ainda tecle Ctrl+C ("clicando" com o mouse
mouse antes na tela principal para deixar o foco
nela).
Isso vai copiar toda a imagem da tela principal do FTOOL para o Clipboard (Área de
transferência). Observe que toda a imagem vai ser copiada e não somente os objetos
que estiverem selecionados naquele instante.

• Abra o aplicativo que vai importar a imagem, por exemplo o MS-Word. MS


No MS-Word,
Word, para as versões NT, 2000 ou XP, selecione a opção Paste ... (Colar...) do
menu Edit (Editar)) ou tecle Ctrl+V. Pode-se usar a opção Paste Special... (Colar
Especial...),
), selecionando, em seguida, a opção Picture (Figura).). Nas plataformas
Windows 95 e 98, NÃO selecione a opção Picture (Enhanced Metafile – Figura
(Metarquivo avançado) – pois isso vai criar uma figura com tamanho demasiadamente
grande. Para Windows 95 e 98, a opção Picture (Figura)) vai gerar uma imagem
pequena que pode ser ampliada pressionando o botão do mouse sobre um dos cantos
da figura selecionada. Esta figura é gerada pequena pois foi salva com um tamanho
cinco
nco vezes maior do que a tela do FTOOL. Isto resulta em uma melhor precisão de
desenho.

• Edite a figura resultante. Nas plataformas Windows 95 e 98, pode acontecer que
círculos resultantes de rótulas ou momentos apareçam preenchidos de preto ao se
editar a figura. Não se conseguiu descobrir como evitar isso. Para corrigir, basta
selecionar o objeto
bjeto e retirar a cor de fundo ou preencher de branco (ou da cor do
fundo). Este problema não ocorre para Windows NT, 2000 ou XP. Você pode engrossar
as linhas (1/2 pt ou 3/4 pt são boas opções), trocar as cores dos elementos, etc.

• Se a impressora for preto-e-branco,


pre branco, melhores resultados serão obtidos se, antes de
exportar a imagem, a opção de imagem preto-e-branco
preto branco for selecionada. Esta é a opção
Black Foreground do menu Display.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


3. Criação e Manipulação da Estrutura 7

3. Criação e Manipulação da Estrutura

3.1. Menu de Edição

O menu de edição reúne os botões para a criação e modificação do modelo.

Figura 3

A inserção de barras, nós ou linhas de cota no FTOOL possui um comportamento que


automaticamente atrai o cursor do mouse para uma entidade existente (um nó ou uma barra).
O processo de criação pode ser auxiliado pelo uso do Snap (atração) para uma grade (Grid)
( de
pontos (veja na seção de Controles da Visualização).

3.2. Criação de Barras e Nós

A criação de uma barra ou um nó se faz de maneira direta. Para inserir uma barra
(Member),), basta selecionar o botão e "clicar" em dois pontos ontos do canvas.
Instantaneamente são criados os nós nas extremidades da barra. Se a barra inserida
interceptar uma barra existente, o nó da interseção das duas barras é automaticamente
criado. Neste caso as duas barras são automaticamente subdivididas. An
Analogamente,
alogamente, para criar
um nó, seleciona-se e "clica-se"
"clica com o mouse em um ponto do canvas. canvas Se o ponto
"clicado" estiver em uma barra existente, a barra é dividida em duas barras com a inserção do
novo nó.

A entrada de linhas via mouse para a criação de barras


barras é feita com dois "cliques" do
mouse: um para o primeiro nó da barra e o outro para o segundo nó. Usualmente a entrada de
linhas via mouse segue a regra "pressiona botão - arrasta mouse - libera botão". O modo em
dois "cliques" permite que o usuário desista
desista da inserção da barra depois do primeiro ponto,
bastando para isso "clicar" com o botão da direita do mouse ou teclar Esc.. Este tipo de entrada
de linha também permite que o usuário dê um zoom ou translade a janela de desenho depois
de ter entrado com
m o primeiro nó e antes de entrar com o segundo.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


8 Ftool 2.11

3.3. Criação de Linhas de Cota

Linhas de Cota (Dimension


Dimension Lines)
Lines) são linhas auxiliares que servem para criar anotações
de distância na imagem da estrutura. Para inserir uma linha de cota, basta selecionar o botão
correspondente no menu de edição e "clicar" em três pontos do canvas.. Os dois primeiros
pontos são os pontos de referência para cotagem de distância. O terceiro ponto serve para
definir onde a linha de cota propriamente dita vai ficar localizada. D Durante
urante a construção da
linha de cota, o programa atualiza na tela o desenho da linha de cota, até que o usuário entre
com o terceiro ponto.

O modo de criação da linha de cota em três "cliques" permite que o usuário desista da
inserção da linha antes de entrar
entrar com o ponto, bastando para isso "clicar" com o botão da
direita do mouse ou teclar Esc.
Esc. Este tipo de interação também permite que o usuário dê um
zoom ou translade a janela de desenho depois de ter entrado com o primeiro ponto ou o
segundo ponto e antess de entrar com o terceiro.

3.4. Modo Teclado

Selecionando o modo teclado (botão ), pode-se


se criar nós e barras digitando suas
coordenadas nos diálogos das figuras abaixo, onde o valor de tolerância ((Tolerance
Tolerance) é utilizado
para atração para entidades existentes (nunca utilize valor nulo para tolerância):

Figura 4

3.5. Modo Seleção

O botão coloca o FTOOL em modo de seleção. Neste modo, "clicando" com o


botão direito do mouse sobre uma barra ou um nó, pode-se
pode se visualizar seus atributos na área
do menu lateral. Usando o botão esquerdo seleciona-se
seleciona se uma entidade de um tipo (o programa
nunca permite
ite que barras e nós fiquem selecionados simultaneamente). A seleção de um
conjunto de barras ou um conjunto de nós pode ser feita "clicando" com o botão esquerdo do
mouse concomitantemente com a tecla Shift.. Um conjunto de entidades também pode ser
selecionado definindo-se
se um retângulo (Fence)
( ) de seleção. Para definir um Fence de seleção

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


3. Criação e Manipulação da Estrutura 9

deve-se
se pressionar o botão esquerdo do mouse e arrastá-lo
arrastá lo com o botão pressionado. O
retângulo de seleção fica definido pelo ponto onde o botão do mouse é liberado.

A seleção
ção de entidades tem três objetivos. O primeiro é a eliminação de entidades.
Para tanto deve-se
se usar o botão . O segundo objetivo é a transformação das entidades
selecionadas (vide Menu Transform).
Transform). O terceiro objetivo é a aplicação de atributos ou cargas,
que são sempre aplicados às barras ou nós que estiverem selecionados no instante.

3.6. Menu de Undo e Redo

A opção de Undo permite desfazer as últimas ações. A opção de Redo permite refazer
a última ação desfeita.

Figura 5

3.7. Menu Transform

Figura 6

O menu Transform fornece opções para manipular entidades já criadas. Existem


opções de mover (Move),), espelhar (Mirror),
( rotacionar (Rotate),
), aplicar um fator de escala
(Scale)) e repetir a última transformação (Repeat).
( Selecionando Leave Original,
Original a
transformação é aplicada em uma cópia das entidades selecionadas.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


4. Controles de Visualização 11

4. Controles de Visualização

4.1. Menu de Controle de Visualização

Este menu agrupa todos os controles para definição da janela de visualização do


modelo.

Figura 7

A opção para ajustar o modelo à tela enquadra a estrutura na área de desenho do


programa deixando uma margem de folga.

A escala do desenho na tela pode ser alterada de várias formas. A primeira é definindo
um retângulo de zoom (área de visualização definida por um ret retângulo).
ângulo). A entrada de dois
cantos opostos do retângulo de visualização é feita com dois "cliques" do mouse. O modo em
dois "cliques" permite que o usuário desista da redefinição da área de visualização depois do
primeiro ponto do retângulo, bastando para isso
isso "clicar" com o botão da direita do mouse ou
teclar Esc.. Se os dois "cliques" forem dados no mesmo ponto da tela, ocorrerá um zoom
centrado neste ponto.

O botão de Zoom+ aumenta o tamanho do modelo na tela, enquanto o botão de


Zoom– diminui o tamanho. Este efeito também pode ser conseguido "girando" o
potenciômetro (dial)) que controla a escala do desenho. Em ambos os casos, a escala do
desenho se dá centrada no ponto médio da área de desenho.

4.2. Controle de Coordenadas

Neste menu se encontram as informações


informações sobre a superfície de visualização. Os
campos H e V armazenam o tamanho da janela de visualização e permitem a alteração destes
valores. As mensagens X e Y mostram a posição do cursor na tela. Disponibiliza-se
Disponibiliza também a
opção do usuário definir uma grade (Grid)) de pontos na tela e outra para ativar a atração
(Snap)) do cursor para os pontos do Grid.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


12 Ftool 2.11

Figura 8

4.3. Menu Display

Neste menu o usuário pode escolher qual a cor de fundo de tela, tendo para cada cor
de fundo selecionada diferentes cores relacionadas com as barras e nós do modelo. Outra
opção é trabalhar com todos os elementos do modelo com a cor preta e fundo de tela branco.
Isto permite que a imagem do modelo possa ser impressa em uma impressora
monocromática. Pode-sese também especificar quais os atributos que devem ser mostrados na
tela durante o manuseio do programa. Deve-se
Deve se observar que certas opções aplicam-se
aplicam
somente ao pré-processamento
processamento e outras somente ao pós-processamento.
pós

Figura 9

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


5. Configurações 13

5. Configurações

5.1. Menu Options

Atualmente as únicas configurações possíveis no FTOOL são as de sistemas de


unidades e de formatação de valores numéricos. A opção Units & Number Formatting do menu
Options faz exibir um diálogo que permite estas configurações.

Figura 10

5.2. Formatação de Unidades e Valores Numéricos

Através do diálogo de interface Units & Number Formatting,, o usuário pode definir
unidades para os diversos parâmetros envolvidos em uma análise estrutural pelo FTOOL, bem
como os formatos para exibição dos valores numéricos associados a estes parâmetros. Existem
opções para especificar unidades padrão em SI (Sistema
(Sistema Internacional), em US (Sistema
Americano), ou todas as unidades em kilo-Newtons
kilo Newtons e metros. Para especificar unidades padrão
e as correspondentes formatações de valores, basta selecionar o botão correspondente no
topo diálogo. O usuário pode sempre alterar
alterar uma unidade ou formatação padrão para o que
achar mais conveniente.

Figura 11

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


14 Ftool 2.11

5.3. Sistemas de Unidades

A tabela abaixo mostra, para cada parâmetro usado, as unidades implementadas no


FTOOL e os correspondes fatores de conversão para as unidades de referência interna, que
estão indicadas em negrito. Internamente, o programa converte todas as unidades para estas
unidades de referência.

A primeira unidade de cada parâmetro é a unidade que aparece automaticamente


quando o usuário seleciona unidades SI (Sistema Internacional) ou unidades US (Sistema
Americano).

• Na conversão para unidades que utilizam tonelada força (tf), foi adotado:
1 tf = 103 kg⋅g.

Para conversão, foi adotada a aceleração da gravidade g = 9.81 m/seg2.

• Unidades Pascal:
1 Pa = 1 N/m2
1 kPa = 103 N/m2 = 1 kN/m2
1 MPa = 106 N/m2 = 103 kN/m2 = 1 N/mm2
1 GPa = 109 N/m2 = 106 kN/m2 = 1 kN/mm2

Unidades SI Unidades US
Fator da
unidade Fator da
Parâmetro
Símbolo Nome de Símbolo Nome unidade de
referência referência SI
SI
m metro 1 ft pé 0.3048
Distância e centímetr
cm 0.01 in polegada 0.0254
Comprimento o
mm milímetro 0.001
mm milímetro 0.001 in polegada 0.0254
centímetr
Deslocamento cm 0.01 ft pé 0.3048
o
m metro 1
rad radiano 1 rad radiano 1
Rotação
deg grau π/180.0 deg grau π/180.0
mm milímetro 0.001 in polegada 0.0254
Tamanho de centímetr
cm 0.01 ft pé 0.3048
seção o
m metro 1
mm2 0.000001 in2 polegada2 0.02542
Área de Seção cm2 0.0001 ft2 pé2 0.30482
m2 1
Momento de mm4 1.00E-12 in4 polegada4 0.02544

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


5. Configurações 15

Inércia cm4 1.00E-08 ft4 pé4 0.30484


m4 1
kilo-
kN 1 kip kilo-libra 4.448
Newton
Força N Newton 0.001 lb libra (força) 0.004448
tonelada
tf 9.81
(força)
kNm 1 ft-k pé⋅klb. 1.356
Nm 0.001 ft-lb pé⋅libra 0.001356
tfm 9.81 in-k poleg.⋅klb. 0.11298
kNcm 0.01 in-lb poleg.⋅libra 0.00011298
Momento Ncm 0.00001
tfcm 0.0981
kNmm 0.001
Nmm 0.000001
tfmm 0.00981
kN/m 1 k/ft klb./pé 14.593
N/m 0.001 lb/ft libra/pé 0.014593
tf/m 9.81 k/in klb./poleg. 175.1
kN/cm 100 lb/in libra/pé 0.1751
Carga
N/cm 0.1
Distribuída
tf/cm 981
kN/mm 1000
N/mm 1
tf/mm 9810
grau
Temperatura °C 1 °F grau Fahrenheit (T-32)×5/9
Celsius
mega-
MPa 1000 ksi klb./poleg.2 6895
Pascal
GPa giga-Pascal 1000000 psi libra/poleg.2 6.895
tf/mm2 9810000 k/ft2 klb./pé2 47.878
N/cm2 10 lb/ft2 libra/pé2 0.047878
Módulo de
kN/cm2 10000
Elasticidade
tf/cm2 98100
Pascal
Pa 0.001
(N/m2)
kN/m2 kilo-Pascal 1
tf/m2 9.81
kN/m3 1 pcf libra/pé3 0.1571
Peso N/m3 0.001 k/ft3 klb./pé3 157.1
Específico tf/m3 9.81 lb/in3 libra/poleg.3 271.434
kN/cm3 1000000 k/in3 klb./poleg.3 271434

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


16 Ftool 2.11

N/cm3 1000
tf/cm3 9810000
kN/mm3 1.00E+09
N/mm3 1000000
tf/mm3 9.81E+09
Dilatação
1/°C 1 1/°F 1.8
Térmica
kN/m 1 k/ft klb./pé 14.593
N/m 0.001 lb/ft libra/pé 0.014593
tf/m 9.81 k/in klb./poleg. 175.1
Rigidez kN/cm 100 lb/in libra/pé 0.1751
Translacional N/cm 0.1
de Mola tf/cm 981
kN/mm 1000
N/mm 1
tf/mm 9810
kNm/rad 1 ft-k/rad pé⋅klb./rad 1.356
ft-
Nm/rad 0.001 pé⋅libra/rad 0.001356
lb/rad
tfm/rad 9.81 in-k/rad poleg.⋅klb./rad 0.11298
in-
kNcm/rad 0.01 poleg.⋅libra/rad 0.00011298
lb/rad
Ncm/rad 0.00001 ft-k/deg pé⋅klb./grau 244.08/π
ft-
tfcm/rad 0.0981 pé⋅libra/grau 0.24408/π
lb/deg
in-
kNmm/rad 0.001 poleg.⋅klb./grau 20.3364/π
k/deg
Rigidez in- poleg.⋅libra/gra 0.0203364/
Nmm/rad 0.000001
Rotacional de lb/deg u π
Mola tfmm/rad 0.00981
kNm/deg 180.0/π
Nm/deg 0.18/π
tfm/deg 1765.8/π
kNcm/deg 1.8/π
Ncm/deg 0.0018/π
tfcm/deg 17.658/π
kNmm/de
0.18/π
g
Nmm/deg 0.00018/π
tfmm/deg 1.7658/π
Tabela 1

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


6. Atributos de Nós e Barras 17

6. Atributos de Nós e Barras

6.1. Menu de Controle dos Atributos dos Nós e Barras

Os botões deste menu permitem visualizar os diversos submenus responsáveis pela


criação e atribuição de propriedades às entidades do modelo. Estes submenus aparecem na
área lateral da tela do programa.

Figura 12

6.2. Características Comuns aos Submenus

Os submenus para manipulação dos parâmetros de materiais, propriedades de seções


transversais e valores de cargas possuem funcionamento básico igual. A lista drop-down
(próxima figura) permite que seja selecionado um conjunto de propriedades através de seu
nome. Os valores
alores desta propriedade serão automaticamente visualizadas nos campos do
submenu, permitindo sua edição.

Figura 13

Os botões da próxima figura permitem a manipulação destes conjuntos de


propriedades.

Figura 14

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


18 Ftool 2.11

Para criar um novo conjunto de propriedades, deve-se


deve se selecionar o botão e
atribuir um nome diferente das outras propriedades.

O botão aciona a importação da lista de conjunto de propriedades de outro


arquivo gerado pelo FTOOL, porém o usuário deve atentar que se no arquivo importado
existirem propriedades com o mesmo nome de propriedades do modelo corrente, elas serão
ignoradas.

A função que condensa o conjunto de propriedades elimina aquelas que não estão em
uso.

6.3. Submenu de Parâmetros dos Materiais

Para criar um novo conjunto de parâmetros de material, deve-se


deve se selecionar o botão

e atribuir um nome diferente dos outros conjuntos existentes (figura abaixo à esquerda).
Quando se cria um conjuntos de materiais, selecionando os botões Steel e Concrete cria-se
automaticamente os materiais aço (E
( = 205 GPa) e concreto (E = 25 GPa).

Figura 15

Os parâmetros de material considerados são o módulo de elasticidade, o peso


específico (não utilizado para nada no momento) e coeficiente
coeficiente de dilatação térmica.

6.4. Submenu de Propriedades das Seções Transversais

Neste submenu através do botão é criado um novo conjunto de propriedades de


seção transversal. No instante da criação deve-se
deve se escolher o tipo de seção (section type)
dentre
ntre as alternativas da lista drop-down: Genérica (Generic), Retangular (Rectangle
Rectangle), Perfil I (I-
shape), Cantoneira (Angle), ), Perfil T (T-shape),
( Perfil C (C-shape),
), Perfil Z (Z-shape),
( Barra
circular (Circle),
), Tubo anelar (Ring),
( Cantoneira dupla (Double angle),), Tubo quadrado (Box),
(
Perfil I soldado padrão NBR (NBR ( welded I-shapes) ou Perfil I eletro-soldado
soldado da Usilight™
(Usilight I-shapes).

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


6. Atributos de Nós e Barras 19

Figura 16

No caso de seção do tipo genérica, como na figura abaixo, os


parâmetros da seção transversal são a área, o momento de inércia em
relação ao centro de gravidade da seção transversal, a altura da seção
e a posição do centro de gravidade.

Figura 17

No caso de seção do tipo Perfil I soldado padrão NBR, como na


figura ao lado, escolhe-se
escolhe o tipo de perfil (Beam, Column ou Beam-
Column e altura da seção "d".
Column)

Figura 18

O FTOOL possui os dados dos perfis padrão NBR, bastando que o usuário selecione
através das setas aquele que desejar.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


20 Ftool 2.11

6.5. Submenu de Condições de Apoio

Através deste submenu, o usuário define as componentes de deslocamentos na


direção x e y e a rotação em torno do eixo z estão liberados ou não. Define-se
Define também o
ângulo do apoio, bem como se há algum deslocamento prescrito ou rotação prescrita, ou
ainda se há algum apoio
io elástico em qualquer das direções.

Figura 19

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


6. Atributos de Nós e Barras 21

6.6. Submenu de Propriedades de Articulação de Barras

Este menu permite que se atribuam rótulas a barras ou nós.

Figura 20

6.7. Submenu de Restrições de Deformações de Barras

Este menu permite que se restrinjam deformações de barras. Pode-se


Pode impedir as
deformações axiais de uma barra ou considerar uma barra como sendo infinitamente rígida.

Figura 21

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


7. Atribuição de Cargas 23

7. Atribuição de Cargas
Car

7.1. Menu de Controle das Cargas

Os botões deste menu permitem acionar os diversos submenus responsáveis pela


criação e atribuição de carregamentos às entidades do modelo. Estes submenus aparecem na
área lateral da tela do programa. Os tipos de cargas disponíveis são cargas concentradas
aplicadas a nós, momentos aplicados em extremidades de barras, cargas uniformemente ou
linearmente distribuídas aplicadas a barras e variações de temperat
temperatura
ura aplicadas a barras.

Figura 22

7.2. Informações Gerais

• Caso de carregamento único

Todas as cargas aplicadas a uma estrutura na versão atual do FTOOL atuam


concomitantemente. Isto é, cada arquivo de dados do FTOOL corresponde a um caso de
carregamento único.

• Aplicação de cargas

O sistema de atribuição das


das cargas é igual ao procedimento de aplicação de atributos
de barras (material e seção transversal). Deve-se
Deve se inicialmente criar um tipo de carga, que fica
associado a um nome fornecido e é adicionado na lista de cargas correspondente. A figura
abaixo mostra uma lista tipo drop-down de cargas distribuídas definidas pelos seus nomes. Os
valores das cargas associadas ao nome selecionado serão automaticamente visualizados nos
campos do submenu, permitindo suasu edição.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


24 Ftool 2.11

Figura 23

Os botões da próxima figura permitem a manipulação das cargas de uma lista.

Figura 24

A carga corrente é a que vai ser aplicada aos elementos selecionados. Deve-se
Deve

selecionar os elementos de interesse e aplicar a carga através do bo


botão , para o casos de

barras, ou o botão , para o caso de nós.

• Sistemas de eixos no FTOOL

No FTOOL existe um sistema de eixos globais da estrutura e um sistema de eixos locais


para cada uma das barras (membros). No sistema global, o eixo X é horizontal com c sentido da
esquerda para a direita, e o eixo Y é vertical com sentido de baixo para cima.
O sistema de eixos locais de uma barra é tal que o eixo x local coincide com o eixo da barra e
tem o sentido de criação da barra, isto é, do nó inicial para o nó ffinal.
inal. O sentido do eixo local x
pode ser visualizado no programa selecionando a opção Member Orientation do menu Display.
O eixo y local é perpendicular ao eixo x e o seu sentido é tal que o produto vetorial x × y,
usando a regra da mão direita, resulta em um vetor saindo do plano da estrutura.

• Aplicação de cargas concentradas

No FTOOL, cargas concentradas (forças e momentos) só podem ser aplicadas em nós


da estrutura. Isto é assim para simplificar a interface do programa com o usuário, não
existindo nenhum impedimento técnico para se aplicar uma carga concentrada no interior de
uma barra. Se for preciso aplicar uma carga concentrada no interior de uma barra, basta inserir
um nó na posição desejada, dividindo a barra em duas. As cargas concentradas são aplicadas
aplic
sempre com os sentidos dos eixos globais da estrutura, sendo o sinal positivo quando as forças
tiverem os sentidos dos eixos globais, e o sinal negativo quando contrário. Os momentos
aplicados serão positivos quando tiverem o sentido anti
anti-horário e negativos
gativos quando tiverem o
sentido horário.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


7. Atribuição de Cargas 25

• Sistemas de eixos para aplicação de cargas distribuídas

No FTOOL, a aplicação de uma carga distribuída em uma barra pode ser feita no
sistema de eixos globais ou no sistema de eixos locais. Os sinais dos carregamentos
carregamen serão
positivos quando coincidirem com o sentido dos eixos globais ou locais, conforme for o caso, e
negativo quando tiverem o sentido contrário. Na interface do programa, nos menus de
aplicação de cargas distribuídas uniformes ou lineares, existe uma opção para especificar o
sistema de eixos da carga distribuída (global ou local).

• Aplicação de cargas distribuídas parciais

Para aplicar cargas distribuídas que atuam parcialmente em uma barra, pode-se
pode inserir
nós no interior da barra, criando novas barras resultantes da divisão da barra original. As
cargas distribuídas são, então, aplicadas ao trecho de barra (divisão) desejada. Mas uma vez,
isso é feito dessa maneira por uma decisão de política de interface com usuário. Assim é muito
mais simples do que especificar
specificar as posições de atuação das cargas distribuídas parciais.

7.3. Submenu de Cargas Concentradas Nodais

Permite que sejam criadas e aplicadas cargas concentradas aos nós da estrutura. O
sistema de coordenadas é o global.

Figura 25

7.4. Submenu de Cargas Momentos em Extremidades de Barras

Permite que sejam criados e aplicados momentos concentrados nas seções extremas
de barras. Momentos aplicados no sentido anti-horário
anti horário são positivos e no sentido horário são
negativos, sendo "Ma"" o momento aplicado
aplicado na extremidade inicial da barra e "Mb" " o
momento aplicado na extremidade final da barra.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


26 Ftool 2.11

Figura 26

7.5. Submenu de Cargas Distribuídas Uniformes

Permite que sejam criadas e aplicadas cargas distribuídas uniformes às barras. Pode-se
Pode
adotar como sistema de referência o sistema de coordenadas global ou o sistema local da
barra.

Figura 27

7.6. Submenu de Cargas Distribuídas Lineares

Permite que sejam criadas e aplicadas cargas distribuídas lineares às barras. Pode
Pode-se
adotar como sistema de referência
referência o sistema de coordenadas global ou o sistema local da
barra.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


7. Atribuição de Cargas 27

Figura 28

7.7. Submenu de Solicitações de Variação de Temperatura

Permite que sejam criadas e aplicadas solicitações de variação de temperatura às


barras. O usuário espefica a variação de temperatura no bordo superior (na fibra do lado
positivo do eixo local y)) e no bordo inferior (na fibra do lado negativo do eixo local y) da seção
transversal.

Figura 29

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


8. Resultados 29

8. Resultados

8.1. Menu de Resultados

Figura 30

8.2. Modos de Resultados

Figura 31

Existem dois modos de resultados da análise de pórticos planos no FTOOL. A seleção


do modo desejado é feita através de uma lista drop-down no menu de resultados. O primeiro
modo é de Diagrama (Diagram
Diagram),), que considera a visualização de diagramas de esforços
internos (esforço normal, esforço cortante e momento fletor) e a visualização de configuração
deformada da estrutura.

O segundo modo é o de Linha de Influência (Influence Line). Pode-se


se visualizar linhas
de influência de esforço normal, esforço cortante e momento fletor em uma seção
selecionada. Uma linha de influência representa os valores de um esforço interno na seção
selecionada em função
ão de uma carga unitária que percorre a estrutura. No FTOOL, a carga
unitária é sempre vertical de cima para baixo, não importando a direção da barra por onde a
carga passa.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


30 Ftool 2.11

Quando o modo de Diagrama está selecionado, a opção para selecionar uma seção
para traçar linha de influência fica desativada. Por outro lado, quando o modo de Linha de
Influência está selecionado, a opção para desenhar a configuração deformada fica desativada.

Os resultados de diagramas ou linhas de influência são exibidos bastando pressionar


pre o
botão correspondente ao resultado desejado. Se o programa não estiver no modo de
resultados (se nenhum resultado estiver aparecendo), a estrutura é automaticamente
calculada quando algum botão para mostrar resultado é selecionado. No modo de Diagrama,
Diag
os resultados são traçados diretamente.

No modo de Linha de Influência, o programa solicita ao usuário que selecione uma


seção transversal de um membro para fazer o traçado. Enquanto o botão para selecionar uma
nova seção para traçado de linha de influência
influência estiver pressionado, o programa faz um novo
traçado para cada seção selecionada. Para evitar que uma nova seção para traçado de linha de
influência seja selecionada, este botão deve ser liberado. Assim, consultas a valores locais
(resultados pontuais)
is) podem ser feitas sem redefinir a linha de influência em exibição.

8.3. Convenção de Sinais para Esforços Internos

A convenção de sinais para esforços internos pode ser visualizada no programa


selecionando a opção Sign Convention do menu File. Quando isso é feito aparece um diálogo
na tela que permite visualizar a convenção de sinais e definir o padrão para traçado de
diagramas de esforços internos e linhas de influência.

Figura 32

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


8. Resultados 31

• Fibras superiores e inferiores:

A convenção de sinais para esforços internos


internos depende da definição de quais são as
fibras inferiores e superiores das seções transversais das barras. No FTOOL, nas barras
horizontais e inclinadas, as fibras inferiores são as fibras de baixo quando se olha o eixo
vertical da tela na sua orientação
orientação natural (cabeça do observador para cima). Nas barras
verticais as fibras inferiores são as da direita. A figura no topo do diálogo de convenção de
sinais indica as fibras inferiores de uma estrutura que contém barras com todas as direções
possíveis.

• Convenção de sinais::

O FTOOL adota a seguinte convenção para os sinais dos esforços e para o desenho dos
diagramas:

o Esforços normais (axiais):

Esforços normais positivos são de tração e negativos de compressão. Na linha de


mensagem também é indicado se é compressão
compressão ou tração. Valores positivos são desenhados
do lado das fibras superiores e negativos do outro lado.

Figura 33

o Esforços cortantes:

Esforços cortantes são positivos quando, entrando com as forças à esquerda de uma
seção transversal (olhando com a cabeça voltada das fibras inferiores para as superiores), a
resultante das forcas na direção vertical local for no sentido para cima. Como para esforços
axiais, valores positivos são desenhados do lado das fibras superiores e negativos do outro
lado.

Figura 34

o Momentos fletores:

Momentos fletores são positivos quando tracionam as fibras inferiores e negativos


quando tracionam as fibras superiores. O diagrama de momentos fletores pode ser desenhado
com valores positivos tanto do lado da fibra tracionada qu
quanto
anto do lado da fibra comprimida,
sendo esta configuração definida através de uma opção específica no diálogo de convenções
de sinais. O sinal negativo do momento fletor no diagrama pode ser mostrado como opção,
que pode ser acionada no menu Display (veja seção de Configurações).

Figura 35

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


32 Ftool 2.11

• Traçado de linhas de influência:


influência

As linhas de influência de esforços internos em seções selecionadas seguem a


convenção de sinais mostrada acima. O padrão para traçado das linhas de influência pode ser
definido no diálogo
ogo de convenções de sinais. Existem duas opções: valores positivos são
desenhados do lado das fibras inferiores ou o traçado da linha de influência de um
determinado esforço interno segue o padrão descrito acima para traçado de diagrama do
esforço interno correspondente.

8.4. Escala dos Diagramas e Linhas de Influência

Os diagramas de esforços e a configuração deformada têm uma escala inicial definida


na tela de forma que o valor máximo de um diagrama apareça razoavelmente na tela. Esta
escala pode ser alterada
terada utilizando o potenciômetro que fica à esquerda dos botões do menu
de resultados.

Nos diagramas de esforços a escala pode também ser ajustada pelo usuário editando o
valor mostrado na régua de controle, entre os botões de atribuição de cargas e os botões
bo de
resultados. Neste caso, a escala é definida em termos de unidade de esforço por unidade de
comprimento.

Na configuração deformada da estrutura, o fator de escala dos deslocamentos


(Deformed Factor)) pode ser ajustado do mesmo modo.

As linhas de influência têm uma escala inicial unitária. Esta escala pode ser alterada
utilizando o potenciômetro que fica à esquerda dos botões do menu de resultados. O fator de
escala também pode ser editado pelo usuário.

Figura 36

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


8. Resultados 33

8.5. Resultados Pontuais

Em modo de Diagrama (Diagram),


( ), "clicando" em um ponto sobre uma barra com o
botão esquerdo do mouse, aparece na barra de mensagem acima da área de desenho o valor
do correspondente diagrama para aquele ponto. Se for usado o botão direito do mouse,
aparecem na área lateral da tela informações adicionais sobre a barra com respeito ao
diagrama sendo visualizado. Se um passo para consulta de resultados estiver definido, na área
lateral serão exibidos os resultados do diagrama ao longo da barra consultada. Os valores para
pa
cada passo ao longo das barras também podem ser mostrados no desenho dos diagramas.
Existe uma opção específica para isso (Step
( Values)) que pode ser acionada no menu Display
(veja seção de Configurações).).

Também em modo de Diagrama, se o botão direito do do mouse for "clicado" sobre um


nó: informações sobre os resultados de análise do nó, tais como deslocamentos e reações de
apoio, são indicados na área lateral.

Em modo de Linha de Influência (Influence


( Line),
), se a opção para selecionar uma nova
seção para traçado NÃO estiver selecionada, "clicando" em um ponto sobre uma barra com o
botão esquerdo do mouse, aparece na barra de mensagem acima da área de desenho o valor
da correspondente linha de influência naquele ponto. Se for usado o botão direito do mouse
(mesmo com a opção para definir uma nova seção ativa), somente uma consulta é realizada, e
são mostrados na área lateral da tela os resultados ao longo da barra (passo a passo) com
respeito à linha de influência sendo visualizada. Valores dos resultados de linhas de influência
nos passos também podem ser visualizados com a opção Step Values do menu Display.

Figura 37

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


9. Passo a Passo 35

9. Passo a Passo

Para a resolução de problemas utilizando o FTOOL quase sempre devemos realizar os


mesmos passos. A seguir temos algumas dicas para que você possa resolver diversas situações
com facilidade.

1. Desenho da Estrutura:

a. Marcar os nós (extremos de barras, engastes, rótulas, apoios, forças, etc.);


b. Traçar os tramos;

 Dicas:
o Para minimizar erros, é importante cotar a estrutura;
o Utilizar Grid e/ou Snap para uma estrutura sem erros milimétricos.

2. Propriedades da Estrutura:

a. Definir o material;
b. Definir a seção;
c. Definir os apoios (É necessário colocar os sentidos que o apoio vai fixar - x, y ou
momento)
i. Para um apoio elástico, selecionar a opção onde tem a constante de
elasticidade "K", especificando-a abaixo;
ii. Para prever um deslocamento em certo sentido de algum apoio,
selecionar a opção "Prescribed Displacem" e indicar o deslocamento;
d. Definir as rótulas (Se existirem);
e. Definir se existe um membro totalmente rígido ou sem deformação axial.

3. Forças Externas:

Pode-se utilizar 6 tipos de forças externas:

o Força simples (aplicada em um nó);


o Momento (aplicado em um nó);
o Carga distribuída uniforme (aplicada em um tramo);
o Carga distribuída variável (aplicada em um tramo);
o Variação térmica (aplicada em um tramo);
o Carga móvel.

4. Carga Móvel:

o Clicar em Load Train;


o Clicar em Influence Line Results;
o Colocar o tamanho da carga (Length: ...);

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


36 Ftool 2.11

o Dividir o móvel em cargas concentradas ou cargas distribuídas.

5. Verificação do Resultado:

Escolher a forma de análise dos resultados, que podem ser:

a. Diagrama;
b. Linha de Influência.

Ambos os modos podem analisar os resultados baseando-se em esforços normais,


cortantes ou de momentos fletores.

Para resultados de Linha de Influência, clicar no banzo onde a carga móvel irá passar
para poder clicar no botão que gerará os gráficos.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


10. Exemplos de Aplicações 37

10. Exemplos de Aplicações

• Viga Engastada

Figura 38

• Viga Bi-Apoiada

Figura 39

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


38 Ftool 2.11

• Pórticos

Figura 40

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Referências Bibliográficas 39

• Arco

Figura 41

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


40 Ftool 2.11

• Ponte em formato de arco

Figura 42

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Referências Bibliográficas 41

• Treliças

Figura 43

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


42 Ftool 2.11

Figura 44

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Referências Bibliográficas 43

Figura 45

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


44 Ftool 2.11

• Estaca

Figura 16

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR


Referências Bibliográficas 45

Referências Bibliográficas

Martha, Luis Fernando. Manual on-line da versão 2.11. Disponível em:


<http://web.tecgraf.puc-rio.br/ftool/manual/>. Acesso em: 21/07/2010.

Programa de Educação Tutorial (PET) - Engenharia Civil UFPR