Você está na página 1de 3

Disciplina: Meteorologia Sinótica I Período: 06.

1
Tópico do Estágio Docência: Linguagem Fortran Aplicada ao Processamento e Análise de Dados Meteorológicos

Algoritmo para ler médias mensais para o estado da Paraíba e informar qual
o município com a maior média preciométrica

Algoritmo
Ler dados de precipitação de um arquivo
Fim Algoritmo

Refinamento1
defina tipo de variáveis
atribua valores iniciais necessários
Leia dados do arquivo
Armazene-os em uma variável
Comparar valores
Informar qual o maior valor e localidade de ocorrência
Fim Refinamento1

Refinamento 2
defina tipo de variáveis
atribua valores iniciais necessários
Leia cod,nome,lat,lon,prec
Verificar se valor atual é maior que o anterior
Se for fim de arquivo escrever qual localidade e maior valor
Fim Refinamento 2

Professora: Maria Regina da Silva Aragão


Aluno Estagiário Docente: Ewerton Cleudson de Sousa Melo 28/07/2006
Disciplina: Meteorologia Sinótica I Período: 06.1
Tópico do Estágio Docência: Linguagem Fortran Aplicada ao Processamento e Análise de Dados Meteorológicos

Algoritmo para ler médias mensais para o estado da Paraíba e informar qual
o município com a maior média preciométrica

Algoritmo
{Definindo os tipos de variáveis}
Inteiro cod,cod
Real lat, latg,lon,long, prec, maior
Character nome, nmaior
{abrindo arquivo}
nome_arq=‘pb.men’
abrir arquivo (unidade=50,nome=nome_arq,estado=‘antigo’)
{atribuindo valores iniciais necessários}
maior=-1
erro=0
{Lendo dados de entrada}
Faça Enquanto(erro=0)
Leia (50,10,erro) cod,nome,lat,lon,nanos,prec

Formato(1x, I7,25A, F8.2)

{Comparando a precipitação média anterior com a atual}

Se (maior<prec) então

{Trocando a precipitação média anterior menor com a atual maior}

maior=prec
nmaior=nome
Fim se
Fim faça

{Escrevendo o maior valor encontrado e a estação correpondente}

Escreva(*,10) ‘A maior média pluviométrica observada no Estado é de’,


maior ‘, no município’,nmaior,’.’
Fim Algoritmo

Professora: Maria Regina da Silva Aragão


Aluno Estagiário Docente: Ewerton Cleudson de Sousa Melo 28/07/2006
Disciplina: Meteorologia Sinótica I Período: 06.1
Tópico do Estágio Docência: Linguagem Fortran Aplicada ao Processamento e Análise de Dados Meteorológicos

Diagrama de Blocos do Programa

Diagrama de Chapin

nome_arq←´pb.men´

abrir arquivo
(unidade=50,nome=nome_arq,estado=‘antigo’)

erro← 0

maior← -1

Enquanto Erro≠0

Leia(50,10) cod, nome, lat, lon, nanos,


precmen

10
Formato(1x,25A,23X,2F8.2,6x,2I,12F8.1)

F maior<prec V

maior← prec

nome,maior

Professora: Maria Regina da Silva Aragão


Aluno Estagiário Docente: Ewerton Cleudson de Sousa Melo 28/07/2006