Você está na página 1de 14

UNIVERSIDADE DE SO PAULO USP Instituto de Biocincias Departamento de Ecologia Laboratrio de Ecologia da Paisagem e Conservao (LEPaC)

APOSTILA

GEOPROCESSAMENTO APLICADO ECOLOGIA DE PAISAGENS

Professores: Simone R. Freitas, Leandro Tambosi e Milton Czar Ribeiro

3 a 7 de Maro de 2008

Disponvel em: http://www.geocities.com/simonerfreitas

AULA TERICA
Conceitos bsicos e essenciais sobre Cartografia, Sistemas de Informaes Geogrficas, Sensoriamento Remoto e Sistema de Posicionamento Global (GPS)

A apostila Cartografia aplicada Biogeografia contm o contedo referente aula terica e est disponvel no website http://www.geocities.com/simonerfreitas/

AULAS PRTICAS

CONHECENDO OS PROGRAMAS - ArcCatalog Pode ser considerado uma verso do Windows Explorer para o ArcGis. o programa usado para organizar e administrar a base de dados e documentos. Permite recortar, copiar, colar, renomear, deletar e mover arquivos. Permite realizar uma pr-visualizao dos arquivos e da estrutura de dados associadas aos arquivos. Permite criar novos arquivos para serem usados no ArcGis e adicionar campos a esses arquivos. - ArcMap Ambiente no qual realizamos a maior parte das operaes do ArcGis (visualizao, edio, gerao de mapas para impresso,...). a1 Abrir ArcMap / Escolher a opo A new empty map. Adicionar layers: clique no boto ; aparece a janela Add Data, onde voc pode selecionar o diretrio onde esto os arquivos que sero usados; Selecione o diretrio no Look in ou aperte o boto explorar todos os diretrios do computador. que pode ser usado para

a2 Do lado esquerdo fica a Table of contents que mostra todos os arquivos carregados no ArcMap (Window > Table of Contents). Cada arquivo chamado de layer. So exibidos como se fossem camadas e podemos alterar a ordem de exibio desses arquivos. Abaixo da table of contents, existem trs abas que permitem obter informaes sobre as layers utilizadas no ArcMap (display, source e selection). Do lado direito fica a visualizao dos arquivos raster e vetorial. a3 Tipos de arquivos: vetorial (.shp) e raster (.tif) a4 Visualizar os arquivos (selecionando as layers, ); , aproximar visualizando , e deslocando a

Usar as ferramentas de zoom: zoom do projeto inteiro mais detalhes imagem

, distanciar visualizando menos detalhes

. Existe a opo do zoom cobrindo as extenses do layer (clicar sobre a ) e a opo, somente para , ou seja, que

layer com o boto direito e selecionar raster, do zoom para a resoluo do raster permite a visualizao do pixel sem perder definio.

muito grande, possvel ver o pixel, No arquivo raster, quando o zoom enquanto que no arquivo vetorial isso no acontece. Apesar disso, ambos arquivos possuem limitaes de escala porque o arquivo vetorial foi digitalizado de um mapa que originalmente tinha uma escala. Dessa forma, mesmo o arquivo vetorial tem uma escala que limita um maior detalhamento.
a5- A funo Identify usada para identificar um polgono, linha ou ponto. Para isso, clique no boto , escolha o polgono de interesse e clique com o boto esquerdo do mouse sobre o polgono. Depois do clique, aparece a tabela do referido polgono.

a6 O problema da representao e da simbologia associada escala pode ser observado no Google Earth. As informaes mudam dependendo da escala que voc est usando. Em uma escala que cobre a Amrica do Sul, o que aparece so os limites dos pases e o nome das capitais. Quando vamos aumentando o zoom, as estradas comeam a aparecer, os nomes das cidades e os limites estaduais. No zoom mximo, aparecem os nomes das ruas. Se colocarmos os nomes das ruas para a representao da Amrica do Sul, a quantidade de nomes ser to grande que ficar ilegvel. Isso deve ser levado em considerao quando fazemos mapas da rea de estudo, por exemplo. Devemos incluir apenas as informaes relevantes para a escala de representao do mapa. a7 A simbologia (como ser o visual da layer) feita nas propriedades de cada layer. Selecione o layer com o boto direito do mouse > Properties Symbology. Na aba Symbology, existem as opes: - Features (Simple symbol), na qual todos os objetos da layer tero o mesmo visual. 2 >

- Categories (Unique values), permite criar diferentes smbolos para os objetos com propriedades diferentes em um campo da tabela de atributos (ex: cores diferentes para classes de uso da terra). - Categories (Unique Values, Many fields), permite criar diferentes smbolos para os objetos com propriedade diferentes em mais de um campo da tabela de atributos (ex: fragmentos de mata grandes e isolados, fragmentos de mata pequenos e isolados, fragmentos de mata grandes e conectados,...). - Quantities (Graduated colors), permite estabelecer cortes para faixas de valores de grandeza. Em Properties > Display podemos definir uma transparncia para permitir a visualizao de layers que esto por baixo. a8 Quando abrimos o ArcMap e selecionamos um novo projeto, temos que carregar todos os arquivos novamente. Porm, o ArcMap nos permite salvar a estrutura do projeto que estamos trabalhando (as layers e seus smbolos, na ordem em que deixamos). Para isso devemos fazer o seguinte: File > Save as. Ser criado um arquivo .mxd. Esse arquivo no salva os arquivos vetoriais e matriciais, ele apenas cria um ndice que carrega todos os arquivos na tela do ArcMap. Se quisermos salvar o projeto e utilizar em outro computador, precisamos copiar, para o outro computador, todos os arquivos (shapes e raster) que estamos utilizando no projeto. O projeto do ArcMap pode apresentar caractersticas diferentes das caractersticas dos arquivos que esto carregados nele. Podemos ter arquivos vetoriais em sistema de coordenadas UTM, porm o projeto pode estar em coordenadas geogrficas. Para visualizarmos as propriedades do nosso projeto, devemos ir em: View > Data frame properties. Na janela aberta podemos verificar as diferentes propriedades do projeto (sistema do coordenadas, unidades de medidas do display...).

CONHECENDO AS FERRAMENTAS Georreferenciamento O georreferenciamento feito para associar coordenadas geogrficas aos arquivos do tipo raster (imagens de satlite, fotos areas, mapas escaneados etc.). Pode ser feito das seguintes maneiras: 1- Entrar os valores de coordenadas adquiridas em campo com GPS, utilizando o teclado a- Abrir o ArcMap b- Habilitar a barra de ferramentas de georreferenciamento View > Toolbars > Georreferencing

c- Carregar a imagem que deseja georreferenciar d- Clicar no boto add control point e- Identificar, na imagem, os locais dos pontos coletados em campo e clicar com o boto esquerdo e em seguida com o boto direito, selecionando Input X and Y. Digite os valores das coordenadas do ponto. O separador decimal deve ser ponto e no vrgula. Os valores de coordenadas geogrficas devem ser negativos para o hemisfrio Sul e Oeste, e positivos para os hemisfrios Norte e Leste. para verificar os erros de cada ponto f- Clicar no boto view link table g- Quando tiver acabado de inserir os pontos, clicar em Georreferencing > Rectify para gerar uma imagem georreferenciada. h- Definir a resoluo (tamanho do pixel ou cell size), o mtodo de reamostragem e o nome da imagem de sada. i- Adicionar a nova imagem georreferenciada e verificar as coordenadas geogrficas (clicar com o boto direito na layer > properties > source Verificar que no item extent existem os valores das coordenadas dos limites da imagem (Top, Left, Right, Bottom), porm no item Spatial Reference aparece Undefined. A imagem j possui coordenadas, mas precisamos informar o tipo de coordenada, se geogrfica (Lat-Long) ou projetada (UTM, Policonica, ...) j- possvel informar o tipo de coordenada do raster de duas maneiras: I Arc toolbox > Data Management Tools > Projections and Transformations > Define Projections II Arc Catalog > clicar com o boto direito na imagem e em Properties > Encontrar a linha Spatial Reference e clicar em Edit - selecionar o tipo de coordenada pr-definido ou importar de um arquivo que possui o mesmo sistema de coordenadas. 2- utilizar um outro raster j georreferenciado como referncia ou 3- utilizar arquivos vetoriais com coordenadas geogrficas como referncia a- Repetir os dois primeiros passos do item 1 b- Carregar o arquivo de referncia (raster ou shape j georreferenciados) e em seguida carregar a imagem a ser referenciada. c- Verificar na barra Georreferencing se a layer habilitada a layer que ser georreferenciada. d- Na Table of contents clicar com o boto direito na layer que ser georreferenciada e selecionar Zoom to Layer e clicar com o boto direito em um ponto da e- Clicar no boto add control point imagem. f- Na Table of contents clicar no nome da layer de referncia e selecionar Zoom to layer.

g- Identificar o ponto correspondente primeira imagem e clicar com o boto esquerdo. h- Repetir os passos d a g para colocar os outros pontos i- Clicar no boto view link table para verificar os erros de cada ponto j- repetir os passos g a i do item 1. Essa imagem j dever ter o sistema de coordenadas indicado, caso no tenha, repetir o passo j do item 1 EXERCCIO DE GEORREFERENCIAMENTO ARQUIVOS NA PASTA EXERCICIOS > GEORREF 1-Adicionar o arquivo USP no ArcMap e georreferenciar o mapa utilizando os valores de coordenadas da planilha coordenadas_campo. 2- Utilizar o mapa da USP georreferenciado para georreferenciar a imagem USP_google 3- Georreferenciar a imagem usp_80 4- Carregar os arquivos trilhas_usp e pontos_usp para comparar o resultado do georreferenciamento. 5- Vamos comparar o resultado do georreferenciamento com coordenadas presentes em um planilha (controle_usp). Para isso vamos carregar as coordenadas de pontos de locais da USP de uma planilha e mostr-las no ArcMap. Clicar em Tools > Add X Y Data > Selecionar o nome do arquivo que contm as coordenadas (controle_usp), selecionar qual coluna corresponde ao campo X (Longitude) e ao Y (Latitude) e indicar qual o sistema de projeo das coordenadas. 6- Para transformar essas coordenadas em um shapefile de pontos, devemos exportar o arquivo da seguinte maneira: Clicar com o boto direito no nome da layer dos pontos > Data > Export Data. Indicar o nome do arquivo de pontos que desejamos criar (ex. referncias_USP)

DEFININDO PROJEO Quando criamos arquivos vetorias, devemos definir o sistema de coordenadas. Porm, s vezes esse arquivos no contm essa informaes. Assim como acontece no raster que georreferenciamos, os arquivos vetorias podem ter as informaes sobre as coordenadas limites, porm sem a informao sobre qual o sistema de coordenadas. Podemos verificar isso clicando com o boto direito na layer > Properties > Source. Para informar o sistema de coordenadas, devemos seguir os seguintes passos a- Arc Toolbox > Data Management Tools > Projections and Transformations > Define Projections b- selecionar o sistema de coordenadas pr-definido ou importar de algum arquivo j georreferenciado.

REPROJETANDO ARQUIVOS 5

Em alguns casos temos arquivos com sistemas de coordenadas diferentes, por exemplo, um layer de linhas em UTM_SAD69, um layer de polgonos em Lat-Long e uma imagem em UTM_WGS84. Se todos os arquivos esto com suas informaes sobre as coordenadas geogrficas corretas, o prprio ArcMap faz os ajuste para que todas as informaes se sobreponham. Porm, ao realizarmos operaes de vetorizao ou operaes com diferentes layers, aconselhvel que todos os arquivos estejam em mesmo sistema de coordenadas, para evitar problemas de alinhamento. Para deixarmos todos os arquivos em mesmo sistema de coordenadas devemos fazer o seguinte: Arc Toolbox > Data Management Tools > Projections and Transformations Se desejarmos alterar a projeo de um raster devemos clicar em Raster > Project Raster. Em seguida definimos o novo sistema de coordenadas Se desejarmos alterar a projeo de um arquivo vetorial, devemos clicar em Feature > Project. Em seguida definimos o novo sistema de coordenadas do arquivo vetorial. * Tambm podemos exportar os nosso shapefiles para que eles apresentem o mesmo sistema de coordenadas do nosso projeto do ArcMap (para verificar o sistema de coordenadas do projeto: View > Data Frame Properties > Coordinate System. Para isso, na Table os Contents, clicamos com o boto direito no layer que desejamos exportar > Data > Export Data. Na janela aberta ter um item Use the same coordinate system as:, devemos selecionar the data frame para exportarmos com as coordenadas do projeto.

CLASSIFICAO MANUAL Para gerar mapas de uso e cobertura das terras, mapear estradas e identificar pontos de interesse em imagens de satlite ou fotografias areas podemos fazer uma interpretao visual e uma classificao manual. Primeiro devemos criar um shapefile no qual vamos criar nossos polgonos, linhas ou pontos. Para isso devemos fazer o seguinte: Arc Catalog > selecionar a pasta na qual queremos criar nossos shapefiles > clicar com o boto direito > New > Shapefile. Na janela que se abre vamos selecionar as propriedades do shapefile que ser criado

Com o shapefile j criado, podemos clicar com o boto direito no nome do arquivo e selecionar Properties > Fields. Assim poderemos adicionar novos campos na tabela de atributos do shapefile.

Para comear a classificao devemos voltar ao ArcMap e carregar os shapefiles que criamos. Adicionar a barra de ferramentas de edio View > Toolbars > Editor

Para comear a editar devemos clicar em Editor > Start Editing

Quando temos vrios arquivos no ArcMap, que esto em diferentes pastas do computador, temos que indicar qual pasta contm o arquivo que queremos editar. Na barra de ferramentas de edio, em Target aparece o nome do arquivo que ser editado. Explorando as ferramentas de edio de polgonos em Task: Create new feature, Auto-complete polygon, Modify feature, Cut polygon. Tambm existem algumas funes localizadas em Editor: Merge, Clip, Union (diferente do merge, pois ao invs de apenas unir, gera um novo polgono resultante da unio), Intersect, Buffer, e Move. Explorando as ferramentas de edio de linhas em Task: Create new feature, Modify feature, Merge (diferente do merge de polgonos, pois transforma em um atributo sem unir as duas linhas), Split tool, Extend/Trim features, Buffer, Copy paralel. * Quando digitalizamos hidrografia, devemos comear das nascentes em direo ao prximo rio. Na barra de ferramentas de edio devemos selecionar Editor > Snapping. Na janela que se abre devemos selecionar a opo End do shapefile que estamos digitalizando a hidrografia. Isso evitar que fique um espao entre o final da linha de um rio e a juno com o outro rio. EXERCICIO DE CLASSIFICAO (Criar os arquivos na pasta EXERCICIOS > CLASSIF) Realizar o mapeamento da imagem da USP, na regio do IB (prdios, reas verdes, ruas e pontos de interesse), utilizando os recursos mostrados acima.

CALCULANDO REA, PERMETRO E COMPRIMENTO Podemos calcular a rea e o permetro de um polgono ou o comprimento de uma linha diretamente na tabela de atributos do shapefile. Tambm podemos calcular as coordenadas X e Y do centride do polgono ou da linha. Quando calculamos o centride de um polgono, temos que ficar atentos pois polgonos com formato irregular (muito recortados ou alongados) podem ter seu centride em um local fora do fragmento. Para calcular rea, permetro e centride devemos fazer o seguinte: a- Abrir a tabela de atributos do shapefile Clicar com o direito no nome da layer > Open attribute table > Options > Add field > definir o tipo de campo criado (texto, nmero, data,...). b- Clicar com o boto direito na coluna criada > Calculate geometry > Selecionar a informao a ser calculada (rea, permetro, coordenadas), a unidade desejada (metros, hectares...) e o sistema de coordenadas que ser utilizado (o sistema de coordenadas do shapefile ou do projeto do ArcMap data frame).

Quando temos muitos shapefiles para calcular rea e permetro podemos realizar o processo de uma forma mais rpida, para isso devemos criar um Geodatabase e exportar os shapefiles para dentro do geodatabase. Quando exportamos os arquivos para o Geodatabase, automaticamente so adicionadas colunas com a rea e o permetro dos polgonos. Para isso devemos fazer o seguinte: 1 No ArcCatalog selecionar a pasta de trabalho e criar um novo Personal Geodatabase Clicar com o boto direito > New > Personal Geodatabase 2 No ArcToolbox Conversion tools > To Geodatabase > Feature class to Feature class 3- Em input features colocar o shapefile que deseja calcular a rea e o permetro. Em output location selecionar o Personal Geodatabase criado no item 2. Em output features classe colocar o nome do novo shapefile criado (ser o shapefile de entrada com o acrscimo das colunas de rea e permetro). 4- Verificar a tabela de atributos do novo shapefile.

TRABALHANDO COM A TABELA DE ATRIBUTOS Podemos utilizar as informaes contidas na tabela de atributos do shapefile para selecionar fragmentos, reagrupar classes, criar novas classes e adicionar novas informaes ao shapefile. Para selecionar baseado em informaes da tabela devemos fazer o seguinte: clicar com o direito na layer desejada > Open attribute table > Options > Select by attributes. Na janela que se abre, podemos definir os critrios da seleo desejada. Ex: selecionar fragmentos maiores que 5 hectares [AREA]>5, Selecionar todos os polgonos da classe mata [Classe]= mata, Selecionar todos os polgonos da classe mata, maiores que 5 hectares [Classe] = mata AND [AREA ]> 5). Se quisermos identificar os polgonos selecionados como pertencendo a uma classe de fragmentos pequenos, podemos criar uma nova coluna na tabela de atributos Options > Add Field. Com a nova coluna criada, clicamos com o boto direito na coluna > calculate values. Na janela que se abre, podemos digitar o nome da nova classe ou uma expresso para criar o novo nome da classe. Os valores sero calculados apenas para os itens selecionados na tabela de atributos. Se quisermos exportar apenas os polgonos selecionados, podemos clicar com o boto direito no nome da layer Data > Export Data. Na janela que se abre, em Export selecionamos Selected Features e indicamos o nome do novo shapefile. Ser criado um shapefile que conter apenas os polgonos selecionados. Podemos adicionar informaes de uma planilha tabela de atributos do shapefile. Por exemplo, podemos adicionar o nmero de habitantes dos municpios ao shape com os

limites de municpio, adicionar o nmero de espcies encontradas em cada fragmento. Para isso, a planilha e a tabela de atributos do shapefile devem conter uma coluna com a mesma informao. Clicar com o direito no nome da layer > Joins and Relates > Join Na janela que se abre devemos selecionar Join attributes from a table. Em 1. Choose the field in this layer that the join will be based on: devemos selecionar o nome da coluna da tabela de atributos que tambm estar presente na planilha. Em 2.Choose the table to join to this layer, or load the table from disk devemos selecionar a planilha que contm as informaes que queremos adicionar ao shapefile. Em 3. Choose the field in the table to base the join on: devemos selecionar o nome da coluna da planilha que contm a mesma informao da tabela de atributos (indicada no item 1). Abrir a tabela de atributos e verificar que as informaes foram adicionadas. A associao das informaes foi feita temporariamente. Para manter a associao devemos criar um novo shapefile (clicar com o direito no nome da layer > Data > Export data > indicar o nome do novo shape).

OPERAES COM SHAPEFILES O ArcToolbox permite realizar diversas operaes com todos os formatos de arquivos (raster, vetorial, tabelas...). Algumas operaes frequentemente usadas no laboratrio sero mostradas abaixo. CLIP Permite recortar um shapefile, usando como mscara um outro shapefile. ArcToolbox > Analysis Tools > Extract > Clip Em Input Features selecionar o shape que ser cortado. Em Clip Features selecionar o shape usado como mscara Em Output feature class indicar o nome do arquivo criado. UNION Permite unir as informaes de dois ou mais shapefiles diferentes. ArcToolbox > Analysis Tools > Overlay > Union Em Input features selecionar todos os shapefiles que sero unidos. Em Output feature selecionar o shapefile de sada. Em Join Attributes deixar na opo ALL (indica quais os campo das tabelas de atributos sero mantidos no shapefile de sada. Observar que a tabela de atributos do shapefile de sada possui todas as colunas dos shapefiles de entrada (selecionamos ALL). Com isso podemos resgatar as informaes dos shapefiles originais. INTERSECT Realiza a interseco de dois ou mais shapefiles. ArcToolbox > Analysis Tools > Overlay > Intersect

10

Em Input features selecionar todos os shapefiles da interseco. Em Output feature selecionar o shapefile de sada. Em Join Attributes deixar na opo ALL (indica quais os campo das tabelas de atributos sero mantidos no shapefile de sada. Em Output Type podemos selecionar qual o formato do shape de sada (Input semelhante aos shapes do input, linhas ou pontos). Quando selecionamos a opo Input: - se a interseco for feita entre dois shapes de polgonos, resultar em um novo shape de polgonos. - se a interseco for feita com um shape de polgonos e um shape de linhas, resultar em um shape de linhas, no qual as linhas tero as informaes dos polgonos que a intersectaram. - se a interseco for feita entre um shape de polgonos e um de pontos ou um shape de linhas e um de pontos, o resultado ser um shape com vrios pontos, contendo informaes das linhas ou polgonos que o intersectaram. Quando selecionamos a opo Line: Se a interseco for entre dois shapes de polgonos, o resultado ser um shape de linhas com o contorno dos polgonos. Quando selecionamos a opo Point: Se a interseco for entre dois shapes de polgonos ou entre shapes de linhas, o resultado ser um shapefile de pontos, com todos os vrtices dos polgonos dos shapes de entrada. Observar que a tabela de atributos do shapefile de sada possui todas as colunas dos shapefiles de entrada (selecionamos ALL). Com isso podemos resgatar as informaes dos shapefiles originais. BUFFER Permite gerar polgonos com uma distncia definida a partir de um polgono, linha ou ponto. ArcToolbox > Analysis Tools > Proximity > Buffer Em Input features selecionar o shapefile que contm as feies a partir das quais se deseja criar polgonos com um distncia definida. Em Output Feature Class indicar o nome do shapefile que ser criado. Em Distance [Value or field] deve ser especificada a distncia do buffer. Se selecionamos linear unit, devemos digitar o valor da distncia a ser traada e a unidade. Se selecionarmos Field vamos indicar o nome da coluna da tabela de atributos do shapefile que possui o valor que definira a distancia do buffer. Em Side Type definimos se o buffer ser traado apenas para o lado esquerdo, direito ou ambos os lados de uma linha. Em End type definimos se o final do buffer ter forma circular ou retangular Em Dissolve type definimos se os buffers sero unidos caso haja sobreposio (ALL), se permanecero separados caso haja sobreposio (NONE) ou se sero unidos em funo de algum campo especfico da tabela de atributos (FIELD).

11

MULTIPLE BUFFER Permite criar buffers com vrias distncias a partir de um polgono, linha ou ponto. ArcToolbox > Analysis Tools > Proximity > Multiple Ring Buffer Os parmetros so semelhantes para a criao de um buffer, s necessrio entrar mais de um valor de distncia para criao de buffers. NEAR Permite calcular a menor distncia de um ponto a um outro ponto ou linha ArcToolbox > Analysis Tools > Proximity > Near Em Input Features devemos colocar o shape que contm nossos pontos de interesse Em Near Feature devemos colocar o shape que contm os pontos ou as linhas que queremos calcular a distncia para nossos pontos. Em Search Radiu podemos delimitar um raio de busca para encontrar o objeto mais prximo, se no quisermos que seja feita uma busca na paisagem inteira. Se Location for selecionado, sero includas as coordenadas geogrficas do objeto mais prximo. Se Angle for selecionado, ser includo o ngulo correspondente a localizao do objeto mais prximo ao nosso ponto de interesse. POINT DISTANCE Gera uma planilha de distncias entre pontos selecionados ArcToolbox > Analysis Tools > Proximity > Point distance Em Input Features selecionamos um shape com pontos de interesse Em Near Feature selecionamos um shape com pontos de interesse (pode ser o mesmo do input feature, ou outro shape de pontos) Em Output Table selecionamos o nome da sada da planilha de distncias entre os pontos. Em Search radius podemos delimitar um raio de busca para o clculo das distncias. DISSOLVE Simplifica a tabela de atributos de um shapefile. Todos os itens pertencentes a mesma classe sero agrupados em uma linha. Por exemplo, todos os poligonos de mata de um shapefile sero agrupados. Depois dessa operao no conseguimos mais individualizar cada polgono. Pode ser interessante quando desejamos saber apenas a rea de cada classe da paisagem. ArcToolbox > Data Management Tools > Generalization > Dissolve Em Input Feature selecionamos o shape que queremos simplificar. Em Output Feature indicamos o shape que ser criado. Em Dissolve Field indicamos o campo da tabela de atributos que ser usado para unir os objetos. Em Statistics Fields podemos selecionar alguns campos que tero seus valores recalculados aps a unio dos objetos. Por exemplo, soma as reas de todos os polgonos de mata, resultando no valor de rea de mata da paisagem. USANDO A COMMAND LINE WINDOW Quando temos muitas paisagens para processar com o ArcToolbox e desejamos realizar a mesma operao em todas elas, podemos utilizar o a janela Command Line

12

A janela command line permite digitar comandos para realizar vrias operaes com vrios arquivos. Se desejamos realizar a operao dissolve em vrias paisagens, podemos digitar os comando para essa operao. Para isso devemos clicar no boto Show/Hide command line window localizada ao lado do smbolo do ArcToolbox. Um janela se abrir. Em seguida, no selecionamos a operao que desejamos fazer no ArcToolbox, como descrito nos exemplos anteriores para as operaes individuais. Depois de selecinarados todos os parmetros da operao, devemos mandar rodar. Observar que surgiro comandos na janela Command Line. Devemos copiar o texto que aparece em azul para um bloco de notas. O texto contm o nome do comando (ex: dissolve), o nome do arquivo de entrada, o nome do arquivo de sada e os parmetros da operao realizada. No bloco de notas podemos copiar esses comandos, substituindo apenas os nomes dos arquivos de entrada e sada. (trabalhar com arquivos em um nico diretrio facilita no momento de realizar essas operaes). Quando tivermos todas as paisagens escritas no bloco de notas, podemos copiar o texto e colar na Command Line Window. O ArcMap far todas as operaes de uma vez. Aps o trmino, conferir na janela command line se todas as operaes rodaram com sucesso. Se alguma operao apresentou problema, o texto da mesma aparecer em vermelho na command line window. PROPOSTA DE EXERCCIO INTEGRANDO AS OPERAES APRENDIDAS 1- Utilizar o mapeamento das imagens da USP da dcada de 80 e atual. -Cortar os mapeamentos para definir o tamanho das duas paisagens. -Analisar a composio da paisagem nas duas datas (rea das classes, nmero de fragmentos, e relao permetro rea da vegetao arbrea). -Analisar as mudanas da paisagem para identificar reas que foram desmatadas, reas regeneradas, reas construdas ou demolidas. - Quantificar o surgimento de vias na paisagem. 2- Utilizar o mapeamento de Tapirai ou Ribeiro -Identificar as APPs de corpos dgua e realizar o diagnstico sobre o cumprimento da legislao -Identificar e quantificar as atividades que mais desrespeitam a legislao

13