Você está na página 1de 8

Matriz Discursiva UTA A FASE I 21/03 at 08/04 [O aluno poder estar utilizando o Software VisuALG]

- RU: Nota: 70 PROTOCOLO:

Disciplina(s):
Lgica de Programao e Algoritmos

Data de incio: 04/04/2016 17:33


Prazo mximo entrega: 04/04/2016 19:03
Data de entrega: 04/04/2016 18:04

Questo 1/5
Faaumalgoritmoquecrieumafunodeconversodeumatemperaturaemgrauscelsiusparaumatemperaturaem
Farenheit.

Afrmulaparaconverso:

Nota: 20.0

algoritmo"conversaoCFf"
//SeodeDeclaraes
var
far,celsius:real

funcaoconv(c:real):real
varres:real
inicio

res<9/5*c+32
retorneres
fimfuncao

inicio
//SeodeComandos

escreval("InformaatemperaturainicialemGrausCelsius:")
leia(celsius)

far<conv(celsius)

escreval("TemperaturaemFarehneit:",far)

fimalgoritmo

Referncia:ContedodaAula8.

Resposta:
algoritmo"conversaoCFf"

var
far,celsius:real
funcao(conv:c:real):real
varres:real

res<9/5*c+32
retorneres

fimfuncao

inicio
//
escreval("InformaosGrausCelsius")
leia(celsius)

far<conv:(celsius)

escreval("TemperaturaemF")

Questo 2/5
Faaumalgoritmoqueescrevaosquadradosdetodososnmerosparesentre1e20(inclusive).

Nota: 10.0

algoritmo"quadrados"
//SeodeDeclaraes
var
i:inteiro

inicio
//SeodeComandos

escreval("Quadradosdosnumerosparesentre1e20")
paraide2ate20passo2faca
escreva(i*i)
fimpara

fimalgoritmo

ContedodaAula7.
Resposta:
algoritmo"inclusive"

real:pares
escreval("Todososnumerosparesentre1e20")
se(1de20for9pares)
senao

escreval("Todososquadradossox>9")

fimalgoritmo

Questo 3/5
Faaumalgoritmoquerecebaumvetorcomvalorespositivosenegativos.Apsaentradadosdadosoalgoritmodever
decomporesteemoutrosdoisvetores.Umvetorsomentedenmerospositivoseoutrovetorsdenmerosnegativos.
Aotrmino,mostrarosdoisnovosvetores.

Nota: 10.0

algoritmo"vetores"
var

i,j,k,n:inteiro
v:vetor[1..50]dereal
vp:vetor[1..50]dereal
vn:vetor[1..50]dereal

aux:real

inicio
//seodecomandos

escreval("Digiteonmerodeelementosdovetor:")
leia(n)
paraide1atenfaca
escreval("Digiteumnumeroqualquer:")
leia(v[i])
fimpara

limpatela

k<0
j<0
paraide1atenfaca
se(v[i]>0)entao
k<k+1
vp[k]<v[i]
senao
j<j+1
vn[j]<v[i]
fimse

fimpara

escreval("Positivos:")
paraide1atejfaca
escreval(vp[i])
fimpara

escreval("Negativos:")
paraide1atekfaca
escreval(vn[i])
fimpara


fimalgoritmo

Referncia:ContedodasAulas9e10.

Resposta:
algoritmo"vetores"

var
i,n,posicao:inteiro
valor:real
v:vetor[1..50]dereal

aux:real

inicio
//SEODECOMANDOS

escreval("Digiteondeelementos")
leia(n)
paraide1atenfaca
escreval("Digite")
leia(v[1])
fimpara

leia(valor)
leia(posicao)

paraidenate2passo1faca
se(i>posicao)entao
v{i>posicao)entao
fimse

se1=posicaoentao
v[i+1]<v{i}
fimse

se1=posicaoentao
v[i]<valor
fimse

fimpara

inicio
fimalgoritmo
se(i>=posicao)entao

Questo 4/5
FaaumalgoritmoqueexibaumrelatriodeTotaise%porfaixaetriaesexonoseguinteformato:

"***Totaisporfaixaetriaesexo***
Nmerodemeninas:
Nmerodemulheres:
Nmerodemeninos:
Nmerodehomens:
Totalgeral:

%demeninas:
%demulheres:
%demeninos:
%dehomens:

Nota: 10.0

algoritmo"estat"
var
x,idade,qt,fem_maior,fem_menor,masc_maior,masc_menor:inteiro
sexo:caracter

inicio
//SeodeComandos
escreval("Digiteaquantidadedeentradas:")
leia(qt)
enquantox<qtfaca

escreva("Digiteumaidade:")
leia(idade)
escreva("Digiteosexo(f/m):")
leia(sexo)

se(idade<18)e(sexo="f")entao
fem_menor<fem_menor+1
fimse

se(idade<18)e(sexo="m")entao
masc_menor<masc_menor+1
fimse

se(idade>=18)e(sexo="f")entao
fem_maior<fem_maior+1
fimse

se(idade>=18)e(sexo="m")entao
masc_maior<masc_maior+1
fimse


x<x+1
fimenquanto

escreval("***Totaisporfaixaetriaesexo***")
escreval("Nmerodemeninas:",fem_menor)
escreval("Nmerodemulheres:",fem_maior)
escreval("Nmerodemeninos:",masc_menor)
escreval("Nmerodehomens:",masc_maior)
escreval("Totalgeral:",qt)

escreval("%demeninas:",fem_menor*100/qt,"%")
escreval("%demulheres:",fem_maior*100/qt,"%")
escreval("%demeninos:",masc_menor*100/qt,"%")
escreval("%dehomens:",masc_maior*100/qt,"%")


fimalgoritmo

ContedodasAulas9e10.

Resposta:
algoritmo"total%"
var
valor:n1,n2,n3,n4:geral

***Totaisporfaixaetria***
separa
escreval("Nmerodemeninas:")
leia(n1)
escreval("Nmerodemulheres:")
leia(n2)
escreval("Nmerodemeninos:")
leia(n3)
escreval("Nmerodehomens:")
leia(n4)
escreva("Totalgeral:")
leia(geral)

fimse

Questo 5/5
Faaumalgoritmoqueleiaumvalorquecorrespondaaotempodeproduoemhoraseumvalorquerepresenteocusto
emreaisdaproduo.Mostreamensagemconformeatabelaabaixo:

Tempo Valor Mensagem


<0.5 <50,00 Ideal
>=1.0 >50,00 Invivel
>=0.5e<1.0 <50,00 Vivel

Nota: 20.0

algoritmo"producaoviavel"
//SeodeDeclaraes
var
tempo:real
valor:real
inicio
//SeodeComandos
escreva("Digiteotempodeproduoemhoras")
leia(tempo)
escreva("Digiteocustoemreais")
leia(valor)

se(tempo<0.5)e(valor<50.00)entao
escreval("Ideal")
fimse
se((tempo>=0.5)e(tempo<1.0))e(valor<50.00)entao
escreval("Viavel")
fimse
se(tempo>=1.0)e(valor>50.00)entao
escreval("Inviavel")
fimse

fimalgoritmo

ContedodaAula6.

Resposta:
algoritmo"producaoviavel"
var
tempo:real
valor:real
inicio
//
escreva"Digiteotempodeprodemhrs"
leia(tempo)
escreva"Dig.ocusto"
leia(valor)

setempo<5,0)e(valor<50.000)entao
escreval("Ideal")
fimse
se(tempo>=1.0)e(valor>50.000)entao
escreval"Inviavel"
fimse