Você está na página 1de 8

Matriz Discursiva UTA A FASE I – 21/03 até 08/04 [O aluno poderá estar utilizando o Software VisuALG]

- RU:

Nota: 70

PROTOCOLO:

Disciplina(s):

Lógica de Programação e Algoritmos

Data de início:

04/04/2016 17:33

Prazo máximo entrega:

04/04/2016 19:03

Data de entrega:

04/04/2016 18:04

Questão 1/5 Façaumalgoritmoquecrieumafunçãodeconversãodeumatemperaturaemgrauscelsiusparaumatemperaturaem Farenheit.

Afórmulaparaconversãoé:

Nota: 20.0
Nota: 20.0
Farenheit. Afórmulaparaconversãoé: Nota: 20.0  algoritmo"conversaoCFf"

algoritmo"conversaoCFf"

//SeçãodeDeclarações

var

far,celsius:real

funcaoconv(c:real):real

varres:real

inicio

res<­9/5*c+32;

retorneres

fimfuncao

inicio

//SeçãodeComandos

escreval("InformaatemperaturainicialemGrausCelsius:")

leia(celsius)

far<­conv(celsius)

escreval("TemperaturaemFarehneit:",far)

fimalgoritmo

Referência:ConteúdodaAula8.

Resposta:

algoritmo"conversaoCFf"

var

far,celsius:real

funcao(conv:c:real):real

varres:real

res<­9/5*c+32;

retorneres

fimfuncao

inicio

//

escreval("InformaosGrausCelsius")

leia(celsius)

far<­conv:(celsius)

escreval("TemperaturaemF")

Questão 2/5

Façaumalgoritmoqueescrevaosquadradosdetodososnúmerosparesentre1e20(inclusive).

Nota: 10.0
Nota: 10.0

algoritmo"quadrados"

//SeçãodeDeclarações

var

i:inteiro

inicio

//SeçãodeComandos

escreval("Quadradosdosnumerosparesentre1e20")

paraide2ate20passo2faca

escreva(i*i)

fimpara

fimalgoritmo

ConteúdodaAula7.

Resposta: algoritmo"inclusive" real:pares escreval("Todososnumerosparesentre1e20") se(1de20for9pares)

Resposta:

algoritmo"inclusive"

real:pares

escreval("Todososnumerosparesentre1e20")

se(1de20for9pares)

senao

escreval("Todososquadradossãox>9")

fimalgoritmo

Questão 3/5 Façaumalgoritmoquerecebaumvetorcomvalorespositivosenegativos.Apósaentradadosdadosoalgoritmodeverá decomporesteemoutrosdoisvetores.Umvetorsomentedenúmerospositivoseoutrovetorsódenúmerosnegativos. Aotérmino,mostrarosdoisnovosvetores.

Nota: 10.0
Nota: 10.0

algoritmo"vetores"

var

i,j,k,n:inteiro v:vetor[1 50]dereal vp:vetor[1 50]dereal vn:vetor[1 50]dereal

aux:real

inicio

//seçãodecomandos

escreval("Digiteonúmerodeelementosdovetor:") leia(n)

paraide1atenfaca

escreval("Digiteumnumeroqualquer:")

leia(v[i])

fimpara

limpatela

k<­0

j<­0

paraide1atenfaca

se(v[i]>0)entao

k<­k+1 vp[k]<­v[i] senao j<­j+1 vn[j]<­v[i] fimse fimpara escreval("Positivos:")
k<­k+1
vp[k]<­v[i]
senao
j<­j+1
vn[j]<­v[i]
fimse
fimpara
escreval("Positivos:")
paraide1atejfaca
escreval(vp[i])
fimpara
escreval("Negativos:")
paraide1atekfaca
escreval(vn[i])
fimpara
fimalgoritmo
Referência:ConteúdodasAulas9e10.

Resposta:

algoritmo"vetores"

var i,n,posicao:inteiro valor:real v:vetor[1 50]dereal

aux:real

inicio

//SEÇÃODECOMANDOS

escreval("Digiteonºdeelementos") leia(n)

paraide1atenfaca

escreval("Digite")

leia(v[1])

fimpara

leia(valor)

leia(posicao)

paraidenate2passo­1faca

se(i>posicao)entao

v{i>posicao)entao

fimse

se1=posicaoentao

v[i+1]<­v{i}

fimse

se1=posicaoentao

v[i]<­valor

fimse

fimpara

inicio

fimalgoritmo

se(i>=posicao)entao

Questão 4/5 FaçaumalgoritmoqueexibaumrelatóriodeTotaise%porfaixa­etáriaesexonoseguinteformato:

"***Totaisporfaixa­etáriaesexo***

Númerodemeninas:

Númerodemulheres:

Númerodemeninos:

Númerodehomens:

Totalgeral:

%demeninas:

%demulheres:

%demeninos:

%dehomens:

Nota: 10.0
Nota: 10.0

algoritmo"estat"

var

x,idade,qt,fem_maior,fem_menor,masc_maior,masc_menor:inteiro

sexo:caracter

inicio

//SeçãodeComandos

escreval("Digiteaquantidadedeentradas:")

leia(qt)

enquantox<qtfaca

escreva("Digiteumaidade:")

leia(idade)

escreva("Digiteosexo(f/m):")

leia(sexo)

se(idade<18)e(sexo="f")entao

fem_menor<­fem_menor+1

fimse

se(idade<18)e(sexo="m")entao

masc_menor<­masc_menor+1

fimse

se(idade>=18)e(sexo="f")entao

fem_maior<­fem_maior+1

fimse

se(idade>=18)e(sexo="m")entao

masc_maior<­masc_maior+1

fimse

x<­x+1

fimenquanto

escreval("***Totaisporfaixa­etáriaesexo***")

escreval("Númerodemeninas:",fem_menor)

escreval("Númerodemulheres:",fem_maior)

escreval("Númerodemeninos:",masc_menor)

escreval("Númerodehomens:",masc_maior)

escreval("Totalgeral:",qt)

escreval("%demeninas:",fem_menor*100/qt,"%")

escreval("%demulheres:",fem_maior*100/qt,"%")

escreval("%demeninos:",masc_menor*100/qt,"%")

escreval("%dehomens:",masc_maior*100/qt,"%")

fimalgoritmo

ConteúdodasAulas9e10.

Resposta:

algoritmo"total%" var

valor:n1,n2,n3,n4:geral

***Totaisporfaixaetária*** separa escreval("Númerodemeninas:")

leia(n1)

escreval("Númerodemulheres:")

leia(n2)

escreval("Númerodemeninos:")

leia(n3)

escreval("Númerodehomens:")

leia(n4)

escreva("Totalgeral:")

leia(geral)

fimse

Questão 5/5 Façaumalgoritmoqueleiaumvalorquecorrespondaaotempodeproduçãoemhoraseumvalorquerepresenteocusto emreaisdaprodução.Mostreamensagemconformeatabelaabaixo:

Tempo

Valor

Mensagem

<0.5

<50,00

Ideal

>=1.0

>50,00

Inviável

>=0.5e<1.0

<50,00

Viável

Nota: 20.0
Nota: 20.0

algoritmo"producao­viavel"

//SeçãodeDeclarações

var

tempo:real

valor:real

inicio

//SeçãodeComandos

escreva("Digiteotempodeproduçãoemhoras")

leia(tempo)

escreva("Digiteocustoemreais")

leia(valor)

se(tempo<0.5)e(valor<50.00)entao

escreval("Ideal")

fimse

se((tempo>=0.5)e(tempo<1.0))e(valor<50.00)entao

escreval("Viavel") fimse

se(tempo>=1.0)e(valor>50.00)entao

escreval("Inviavel")

fimse

fimalgoritmo

ConteúdodaAula6.

Resposta:

algoritmo"producaoviavel"

var

tempo:real

valor:real

inicio

//

escreva"Digiteotempodeprodemhrs"

leia(tempo)

escreva"Dig.ocusto"

leia(valor)

setempo<5,0)e(valor<50.000)entao

escreval("Ideal") fimse

se(tempo>=1.0)e(valor>50.000)entao

escreval"Inviavel"

fimse