Você está na página 1de 12

Tutorial para configurao de equipamentos do tipo switch Cisco L3

O objetivo deste tutorial fornecer meios para um administrador de redes, que j possui
conhecimentos consolidados de redes TCP/IP, configurar um switch Cisco L3 para executar
operaes bsicas de camadas 2 e 3.
Este material possui vrias simplificaes que visam a melhor compreenso e facilidade de
implementao por parte do administrador de redes, para maior aprofundamento no assunto,
recomendo os livros da cisco press (www.ciscopress.com).
Este tutorial est dividido em trs partes: configuraes bsicas, configuraes avanadas e
exemplo de configurao.
Na primeira parte, abordaremos algumas caractersticas do equipamento, bem como algumas
configuraes comuns a qualquer switch da rede.
Na segunda parte vamos apresentar as configuraes de uma forma genrica, a fim de serem
implementadas em qualquer ponto da rede.
Na terceira parte, teremos um exemplo de configurao que buscar apresentar um exemplo bem
completo das configuraes apresentadas.

Parte I Configuraes Bsicas

IOS
O IOS (Internetwork Operating System) o sistema operacional do switch. Cada equipamento pode
ter vrios IOS disponveis, a diferena est nas funcionalidades habilitadas. O arquivo do IOS fica
armazenado na memria flash e carregado durante a inicializao do equipamento.

Login no Switch

Quando o switch for ligado pela primeira vez ser apresentado as opes de auto-instalao, no
aceite esta opo.
Como no tem senha configurada, o switch j entrar no modo usurio sem pedir senha.

Would you like to terminate autoinstall? [yes]: no

--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no

Would you like to terminate autoinstall? [yes]:


Switch>

Modos de utilizao

O Switch Cisco tem vrios modos de utilizao.


O primeiro deles o modo de usurio, que representado pelo sinal de maior >.
Switch>
O segundo o modo privilegiado, que representado pelo sinal tralha #. para passarmos do modo
de usurio para o modo privilegiado, precisamos utilizar o comando enable.
Switch>enable
Switch#
Como no tem senha configurada, o switch entrar no modo privilegiado sem pedir senha.
O terceiro modo o de configurao global, representado pela palavra config no prompt de
comando. A partir deste modo que so feitas todas as configuraes no switch.
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
Existem tambm os modos de configurao de interface que sero abordados mais a frente.

Apagar configurao

Entrar no modo privilegiado

Switch#delete flash:vlan.dat
Delete filename [vlan.dat]?
Delete flash:vlan.dat? [confirm]
Switch#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
Switch#reload
Proceed with reload? [confirm]

Salvar as configuraes do switch

Para salvar as configuraes, partimos do modo de configurao global e podemos utilizar uma das
opes abaixo.

Switch#wr
Building configuration...
Configured from console by console[OK]
ou
Switch#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

As duas opes surtem o mesmo efeito, porm a mais fcil wr

Trocar o nome do switch

A partir do modo de configurao global, utilizar o comando hostname nome, imediatamente o


nome ser trocado.
Switch(config)#hostname Brasil
Brasil(config)#

Configurar senha de usurio

Existem, por padro, duas formas de se conectar no switch, uma atravs da porta de console e outra
atravs de telnet. Com o switch sendo ligado pela primeira vez, no existem senhas configuradas e o
login e a alternncia entre os modos feita sem a solicitao de senhas.
Primeiro vamos configurar a senha da porta de console. O primeiro comando line console 0, serve
para entrarmos no modo de configurao da console. Agora vamos definir a senha propriamente
dita com o comando password senha, onde a palavra senha a senha propriamente dita. Por ltimo
precisamos do comando login para que a senha seja solicitada quando entrarmos no switch.
Switch(config)#line console 0
Switch(config-line)#password cisco senha
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#
Uma vez configurada a senha na console, vamos configurar a senha de telnet. A senha de telnet tem
uma particularidade em relao a senha de console, pois possvel realizar mais de uma seo de
telnet ao mesmo tempo, por isso existem 16 interfaces para telnet. A configurao realizada como
se segue da mesma forma que a console.
Switch(config)#line vty 0 15
Switch(config-line)#password senha
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#

Tipos de memria do switch

Nos equipamentos Cisco, temos quatro tipos de memria: ROM, NVRAM, RAM e FLASH.
Memria ROM: ROM quer dizer Read Only Memory ou memria apenas de leitura, nesta parte da
mamria esto salvas as configuraes necessrias para que o equipamento inicie o seu
funcionamento. Esta memria no pode ser alterada pelo usurio e nem perde os dados nela
gravados quando desligamos o switch.
Memria NVRAM: NVRAM quer dizer Non Volatil Random Access Memory ou memria de
acesso aleatrio no voltil, nesta parte da memria fica salvo o arquivo com as configuraes do
switch que sero carregadas sempre que o mesmo iniciar o seu funcionamento, este arquivo de
configurao tambm chamado de startup-config. Esta memria no perde os dados quando o
equipamento desligado.
Memria RAM: RAM quer dizer Random Access Memory ou memria de acesso aleatrio, nesta
parte ficam armazenadas as informaes referentes ao funcionamento do switch, tais como tabelas
de roteamento, tabelas com endereo MAC e o arquivo de configurao que est sendo utilizado, o
running-config. Todas as alteraes de configurao so realizadas no arquivo running-config, por
isso que o procedimento de salvar as configuraes consiste em gravar este arquivo da memria
RAM para a memria NVRAM. Toda vez que o equipamento desligado, as informaes contidas
na RAM so apagadas.

Visualizar a verso do IOS e modelo do switch


Atravs do comando show version, podemos verificar as informaes referentes ao hardware do
equipamento e da verso do IOS.
Switch#show version
Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(35)SE5, RELEASE
SOFTWARE (fc1)
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 19-Jul-07 18:15 by nachen
Image text-base: 0x00003000, data-base: 0x01100000

ROM: Bootstrap program is C3560 boot loader


BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(25r)SEC, RELEASE
SOFTWARE (fc4)

Switch uptime is 57 minutes


System returned to ROM by power-on
System image file is "flash:c3560-ipbase-mz.122-35.SE5/c3560-ipbase-mz.122-35.SE5.bin"

cisco WS-C3560-24TS (PowerPC405) processor (revision E0) with 122880K/8184K bytes of


memory.
Processor board ID FDO1146Z8LV
Last reset from power-on
1 Virtual Ethernet interface
24 FastEthernet interfaces
2 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.
--More--
512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 00:1E:7A:44:97:80
Motherboard assembly number : 73-9897-06
Power supply part number : 341-0097-02
Motherboard serial number : FDO11460MRE
Power supply serial number : AZS114203T3
Model revision number : E0
Motherboard revision number : B0
Model number : WS-C3560-24TS-S
System serial number : FDO1146Z8LV
Top Assembly Part Number : 800-26160-02
Top Assembly Revision Number : E0
Version ID : V02
CLEI Code Number : COMMG00ARB
Hardware Board Revision Number : 0x01

Switch Ports Model SW Version SW Image


------ ----- ----- ---------- ----------
* 1 26 WS-C3560-24TS 12.2(35)SE5 C3560-IPBASE-M

--More--
Configuration register is 0xF

Switch#

Duas informaes importantes esto destacadas, a verso do IOS e o modelo do switch.

Visualizar as configuraes do switch


Agora que j aprendemos um pouco sobre as memrias e arquivo de configurao, vamos verificar
as configuraes correntes no switch.
Para verificar o contedo do arquivo de configurao que est sendo utilizado, vamos fazer uso do
comando show running-config a partir do modo privilegiado.

Switch#sh running-config
Building configuration...

Current configuration : 1270 bytes


!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
password senha
login
line vty 0 4
password senha
login
line vty 5 15
password senha
login
!
end

Switch#

Vamos atentar para alguns detalhes sublinhados no arquivo de configurao.


a) Logo no incio podemos ver a configurao referente ao nome do equipamento;
b) Podemos verificar que este switch possui 24 portas fastethernet e duas portas gigabitethernet;
c) Neste ponto ainda no iremos introduzir o conceito de Vlan, mas, por hora, cabe ressaltar a
existncia da Vlan 1 que default em todo switch e no pode ser apagada, somente desabilitada;
d) Temos tambm a configurao ip http server, que habilita um servidor web para configurar o
switch, este servidor pode ser desabilitado atravs do comando no ip http server. uma boa pr[tica
de segurana desabilitar este servidor;
e) Repare que as senhas de console e de telnet aparecem em texto claro e precisam ser
criptografadas.

Criptografar as senhas de console e telnet

Para criptografas as senhas, vamos utilizar o servio de criptografia do switch, atravs do comando
service password-encryption.

Switch(config)#service password-encryption
Switch(config)#end
Switch#show runnning-config
###
Sada omitida
###
line con 0
password 7 03175E050E0E
login
line vty 0 4
password 7 03175E050E0E
login
line vty 5 15
password 7 15010E020C2B
login

Agora a senha no aparece mais em texto claro.

Configurao da senha de modo privilegiado (enable)

A senha de enable pode ser do tipo password, que possui uma criptografia fraca, ou do tipo secret
que possui uma criptografia melhor. Vamos demonstrar somente o modo secret.

Switch(config)#enable secret senha


Switch(config)#end
Switch#wr
Building configuration...
[OK]
Switch#show runnning-config
###
Sada omitida
###
!
enable secret 5 $1$OEJ7$CubpRMlCGH.7M9NONRSWh.
!
###
Sada omitida
###

Parte II Configuraes avanadas


At este ponto foi possvel fazer as configuraes bsicas que devem ser realizadas em todos os
switches. A partir deste ponto vamos abordar as configuraes mais especficas do equipamento.

Configuraes de camada 2

O que o CDP?
CDP o Cisco Discovery Protocol ou protocolo de descobrimento Cisco, este protocolo indica a
conectividade de camada 2 existentes entre switches Cisco diretamente conectados.
Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID


CENTRO Fas 1/0/21 151 R 2621 Fas 0/0
BARRA Fas 1/0/19 141 RSI WS-C3560-2 Fas 0/1
LAGOA Fas 1/0/1 127 RSI WS-C3750-2 Fas 2/0/3
NITEROI Fas 1/0/17 168 RSI WS-C3560-2 Fas 0/1
IPANEMA Fas 1/0/24 130 RSI WS-C3560-8 Fas 0/8

Atravs do CDP, podemos verificar o nome dos equipamentos diretamente conectados, a interface
local onde o equipamento remoto est conectada, o tempo de conexo, as capacidades, a plataforma
do equipamento conectado e a porta no equipamento conectado.
Este protocolo muito importante, pois podemos verificar se existe conectividade de camada 2
entre os equipamentos.
Cabe ressaltar que o CDP s funciona com equipamentos Cisco e diretamente conectados.
Para desabilitar o CDP, basta utilizar o comando no cdp enable.

Criar uma Vlan


Vlan quer dizer virtual local area network ou rede local virtual. Uma Vlan, como o prprio nome j
diz uma rede local virtual, ou seja, a vlan no se prende a um nico switch ou espao fsico, uma
vlan pode existir em todos os switches da rede, basta apenas que os mesmos sejam configurados
adequadamente. No nosso caso, vamos configurar uma vlan para cada grupo especfico de usurios,
que podem estar no mesmo espao fsico, ou separados fsicamente.
Para criar uma Vlan existe mais de um mtodo, mas neste texto ser apresentado apenas um.
Switch(config)#vlan 100
Switch(config-vlan)#name BACKBONE
Com estes comandos criamaos a Vlan de nmero 100 com o nome BACKBONE. Para verificar a
configurao vamo utilizar o comando show vlan.
Switch#sh vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gi0/1, Gi0/2
100 BACKBONE active
###
Sada omitida
###

Reparem que a Vlan foi criada corretamente, porm no existente nenhuma porta associada a ela.

Configurar uma interface do tipo Vlan


A interface do tipo Vlan recebe configurao de IP/Mscara (ip address), descrio (description) e
ativao (no shutdown).
Switch(config)#interface vlan 100
Switch(config-if)#description Vlan Rede Backbone
Switch(config-if)#ip address 10.1.0.254 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#end
Switch#show runnig-config
###
Sada omitida
###
interface Vlan100
description Vlan Rede Backbone
ip address 10.1.0.254 255.255.255.0
###
Sada omitida
###

Tipos de portas associadas a Vlans


Existem duas formas de associar portas a uma Vlan, o modo acesso e modo Trunk.
No modo acesso qualquer equipamento pode ser conectado a porta e todos os equipamentos
cascateados naquela porta pertenceram a mesma Vlan.
No modo trunk a porta do switch dever necessariamente estar conectada a outro equipamento com
configurao de trunk de Vlan. No trunk de Vlan, o enlace dividido lgicamente formando vrios
enlaces distintos onde os dados permanecero separados.

Associando portas a uma Vlan no modo de acesso


O modo de acesso dever ser utilizado quando todos os equipamentos conectados a porta
pertencerem a mesma Vlan. Para associar uma porta a uma Vlan no modo de acesso, precisamos
entrar no modo de configurao de interface e associar a inteface a Vlan.
Um bom procedimento quando lidamos com Vlans e temos portas sobrando no Switch associar
duas portas a mesma Vlan, mesmo que tenhamos apenas um equipamento conectado a Vlan.
Aps criarmos a Vlan 100, vamos adicionar as portas FastEthernet 0/1 e 0/2 a Vlan 100.
Switch(config)#interface FastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 100
Switch(config-if)#description Interface Vlan 100
Switch(config-if)#no shutdown
Switch(config)#interface FastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 100
Switch(config-if)#description Interface Vlan 100
Switch(config-if)#no shutdown
Para verificar as configuraes nas interfaces, vamos utilizar o comando show ruuning-config.
Switch#show running-config
###
Sada omitida
###
interface FastEthernet0/1
description Interface Vlan 100
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/2
description Interface Vlan 100
switchport access vlan 100
switchport mode access
###
Sada omitida
###

Outra forma de verificar que as portas foram corretamente associadas a Vlan atravs do comando
show vlan.
Switch#show vlan

VLAN Name Status Ports


---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gi0/1, Gi0/2
100 BACKBONE active Fa0/1, Fa0/2
###
Sada omitida
###

Associando portas a uma Vlan no modo Trunk


Aps a criao das Vlans, configurar uma porta no modo trunk bem paracido com o modo de
acesso, porm a porta no associada a nenhuma Vlan especfica, permitindo que todas as Vlans
configuradas no switch possam trafegar atravs da porta. Uma observao importante que as vlans
devem estar configuradas normalmente nos dois switches com portas no modo acesso e a porta no
modo trunk ser apenas para ligao entre os switches. Vamos configurar as portas FastEthernet
0/23 e 0/24 com o modo trunk.
Switch(config-if)#interface FastEthernet 0/23
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#description Interface Trunk
Switch(config-if)#no shutdown
Switch(config-if)#interface FastEthernet 0/24
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#description Interface Trunk
Switch(config-if)#no shutdown

Uma observao importante que no comando show vlan as portas 0/23 e 0/24 no vo aparecer
associadas a nenhuma Vlan.
Switch#show running-config
###
Sada omitida
###
interface FastEthernet0/23
description Interface Trunk
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/24
description Interface Trunk
switchport trunk encapsulation dot1q
switchport mode trunk
###
Sada omitida
###

Configuraes de camada 3

Habilitado o roteamento
As configuraes de camada 3 ficam caracterizadas pela utilizao de roteamento IP no switch. Para
habilitarmos o roteamento utilizamos o comando ip routing.
Switch(config)#ip routing

Tipos de rotas
Existem vrios tipos de rotas referentes aos vrios tipos de protocolos de roteamento disponveis
nos switches L3. Atravs do comando show ip route podemos ver as rotas e os seus respectivos
tipos.
Switch#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


###
Sada omitida
###

Cabe ressaltar que os tipos de rotas que podem ser configuradas dependem do IOS que est em uso.
Rotas diretamente conectadas dizem respeito as Vlans ativas que esto configuradas no switch e so
configuradas automaticamente. As rotas estticas so as de maior prioridade, seguido das rotas
estticas e depois das rotas aprendidas dinamicamente.

Configurando rotas estticas


As rotas no switch representam os caminhos percorridos pelos pacotes na rede. Cada switch da rede
deve conhecer todas as redes, ou ento possuir um default gateway e este por sua vez deve conhecer
as redes.
Para incluir uma rota esttica, utilizamos o comando ip route <ip rede destino> <mscara da rede
destino> <gateway>
Switch(config)#ip route 10.2.2.0 255.255.255.0 10.1.1.254
Para configurar um default gateway utilizamos o comando ip default-gateway <ip gateway>.
Switch(config)# ip default-gateway 10.1.1.254