Você está na página 1de 5

Exerccio de Algoritmo

1-#include <stdio.h> #include <stdlib.h> int fat( int n){ if (n==1||n==0) return 1; else return n*fat(n-1); } int main(int argc, char *argv[]) { int n; printf("Digite um numero "); scanf("%d",&n); printf("O Fatorial e %d" " \n",fat(n)); system("PAUSE"); } xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

1Fatorial Declarao de Variveis Fat , N, I : Inteiro; Incio Escreva('Digite um N '); Leia(N); Fat:= N; Para I:=N-1 at 1 Faa Fat :=Fat * I; Escreva(Fat); Fim Xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

2- Variveis a, b, c, D, x1, x2 : real; Incio Escreva ('Digite o a da equao do 2grau ='); Leia (a); Se a<>0 ento Incio Escreva ('Digite o b da equao do 2grau ='); Leia (b); Escreva ('Digite o c da equao do 2grau='); Leia (c); D:=(sqr(b)-4*a*c); Se D<0 ento Escreva ('No existem razes quadradas de nmeros negativos'); Seno x1:=(-b+sqrt(D))/2*a; x2:=(-b-sqrt(D))/2*a; Escreva ('As razes so:', x1, x2); Fim; Se a=0 ento Escreva ('O a no pode ser 0, pois a equao ser do 1grau'); Fim.

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 3-Variveis n,i,soma;inteiro Inicio Soma=0; Para i=1 at 100 Faa Escreva(Digite um numero menor que 100) Leia(n) Se (n/3==0); Soma=soma+n Escreva(Os nmeros divisveis por 3 so: soma) Fim

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 4- Variveis
I, S : Inteiro; Inicio S:=0; Para i:=1 at 100 faa Inicio S:= S + i; Escreva (s); Fim;

Fim. Declarao de variveis I, S : Inteiro; Inicio S:=0; I:=0; Enquanto I<100 Faa Inicio I:= I + 1; S:= S + i; Escreva (s); Fim; Fim. 5-Declarao de variveis l, x, y, t : inteiro; Incio Escreva ('Digite um nmero:'); Leia (l); t:=0; x:=0; Repita x:=x+1; y:=x*x ; At y>l; Escreva (x); Fim. xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 6-Declarao de variveis d,f,I,x:inteiro Inicio d = 0; f = 0; Enquanto i<10 Faa { Escreva(Digite um numero); leia(numero); Se (numero>=10) && (numero<=50)) d = d+1; Se no f = f+1; } Escreva(Foram digitados d valores dentro do intervalo [10,50]); Escreva(Foram digitados f valores fora do intervalo [10,50]);
}
Fim xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx 7- Variveis n : inteiro; i : inteiro; primo : lgico; fim-variveis incio primo := verdadeiro;

imprima("Digite um nmero: "); n := leia() para i de 2 at (n-1) passo 1 faa se (n % i) = 0 ento primo := falso; fim-se fim-para se primo = verdadeiro ento imprima(" primo"); seno imprima("No primo"); fim-se fim xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

8-variveis

i,n : inteiro fibonacci : vetor [1..100] de inteiro inicio // Seo de Comandos fibonacci[1]<- 1 fibonacci[2]<- 1 para i de 3 ate 50 faca fibonacci[i]<- fibonacci[i-2]+ fibonacci[i-1] fimpara para i de 1 ate 50 faca escreval(fibonacci[i]," ") fimpara fimalgoritmo
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

10- Tabuada de n Declarao de variveis X, Res, N : Inteiro; Incio Escreva ('Digite Um N'); Leia(N); Se N<>-1 ento Incio; Para x:=1 At 10 Faa

Incio Res:=N+x; Escreva ('A Tabuada da soma ',Res); Fim; Para x:=1 At 10 Faa Incio Res:=N*x; Escreva ('A Tabuada de ,n,',Res); Fim Fim. Xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx