Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas

SISTEMA DE ENSINO PRESENCIAL CONECTADO

CURSO SUPERIOR DE TECNOLOGIA EM ANÁLISE E DESENVOLVIMENTO DE SISTEMAS

Aline Ludmila Costa Alysson Willian Costa e Silva Delio Martins Junior Fabíola Natally Martins Dias

PRODUÇÃO TEXTUAL INTERDISCIPLINAR - GRUPO

Sete Lagoas 2011

UNOPAR VIRTUAL

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas Aline Ludmila Costa Alysson Willian Costa e Silva Delio Martins Junior Fabíola Natally Martins Dias PRODUÇÃO TEXTUAL INTERDISCIPLINAR – GRUPO Trabalho apresentado ao Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas da Universidade Norte do Paraná – UNOPAR. Veronice de Freitas SUMÁRIO Sete Lagoas 2011 UNOPAR VIRTUAL . para a disciplina Linguagens e Técnicas de Programação I. Prof.

Referências Sete Lagoas 2011 UNOPAR VIRTUAL . Considerações finais 4.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas SUMÁRIO: 1. Introdução 2. Desenvolvimento 3.

O quinto exercício pode ser desenvolvido de forma integral ou através da representação de um código com a documentação de seu funcionamento (o programa deverá ser comentado para que seja possível analisar a forma como foi realizada a conversão).Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 1. Parte II Traduzir para a linguagem lógica algum conceito de Fundamentos da Administração da Informação e construir a respectiva tabela-verdade. Sete Lagoas 2011 UNOPAR VIRTUAL . INTRODUÇÃO Parte I Desenvolver os quatro primeiros exercícios utilizando o VisuAlg.

Vol.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 2. CM: real inicio //Obtenção dos dados escreva ("Distância total percorrida (Km): ") leia (Dist) escreva ("Volume de combustível gasto (L): ") Sete Lagoas 2011 UNOPAR VIRTUAL . DESENVOLVIMENTO Parte I 1) Escreva o pseudocódigo equivalente ao fluxograma abaixo: algoritmo "Consumo_Médio" // Função: Calcular o consumo médio de gasolina por quilômetro percorrido var // Declarando as variáveis Dist.

SAIDA: Ao final exiba o nome do funcionário. se não.00. sal_final: real inicio //Obtenção dos dados escreval ("Digite o nome do funcionário: ") leia (nome) escreval ("Digite o salário do funcionário: ") leia (sal) // Aplicando a função SE Sete Lagoas 2011 UNOPAR VIRTUAL .Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas leia (Vol) //Cálculo do consumo médio CM <. calcule desconto de 11% do INSS.00 calcule 11% de desconto de INSS. Se o salário for acima de R$1000.Ao final. DADOS DE ENTRADA: NOME. calcule 9%.o salário bruto e o salário com desconto de INSS. CM . exiba o nome do funcionário. o salário bruto e o salário com desconto de INSS. " Km/L") fimalgoritmo 2) Crie um algoritmo que receba pelo teclado o nome de um Funcionário e seu salário bruto.Dist/Vol //Exibição dos resultados escreval ("Consumo médio=". dependendo do salário do funcionário var //Declarando as variáveis nome: caracter sal. SALÁRIO BRUTO PROCESSAMENTO: Se o salário for acima de R$1000. se não. calcule 9%. algoritmo "Desconto_INSS" // Função :Calcular desconto do INSS.

calcula o valor de desconto a ser concedido para um determinado cliente. de acordo como valor da compra.00 Entre R$ 1.sal-(sal*11/100) senao sal_final<. que recebia ". valor do desconto algoritmo "Calculo_Desconto_Compra" // Função :Calcula o desconto da compra de acordo com valores da tabela var cliente: literal valor_compra.000.00 a R$ 5. ". sal_final.sal-(sal*9/100) fimse // Exibição do resultado escreva ( nome. ".") filmalgoritmo 3) Crie um algoritmo em que. " passa a receber ".000. " reais. dada a tabela a seguir. sal. Valor da compra Ate R$ 1.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas se sal>=1000 entao sal_final<.000.00 % de desconto 5 10 15 DADOS DE ENTRADA: Nome do cliente. Valor total da compra PROCESSAMENTO: comparar o valor da compra para obter o desconto de acordo com a tabela DADOS DE SAIDA: Nome do cliente. O algoritmo deverá receber pelo teclado o nome do cliente e o valor total da compra.000. desconto: real inicio //----------Entrada------------escreval("***Nome do Cliente:") leia(cliente) escreval("***Valor da Compra:") leia(valor_compra) //---------Processamento--------se valor_compra < 1000.00 Acima de R$ 5.00 entao Sete Lagoas 2011 UNOPAR VIRTUAL . " por questão do desconto de INSS.

valor_compra * 0. Obs.15 fimse //----------Saida---------------escreval("Cliente:". cliente) escreval ("Desconto:".valor_compra * 0. desconto) fimalgoritmo 4) O algoritmo abaixo possibilita calcular a média das notas de 5 alunos.soma + nota // Contando as notas abaixo da media se nota < 6 entao cont_n <. media: real inicio //Inicializando soma soma<. soma.00 entao desconto<.: faça as alterações necessárias para que o algoritmo possibilite a média da turma e também imprima quantos alunos estão com a nota abaixo da média.0 //Aplicando o comando de repetição para I de 1 ate 5 faca escreva ("Digite a nota: " ) leia (nota) //Acumulando a nota lida soma <.valor_compra * 0.00 entao desconto <.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas desconto<. algoritmo "media_notas" // Função : calcular a media das notas da turma e contar quantas notas estão abaixo da media var //Declarando as variáveis i: inteiro cont_n: inteiro nota.10 fimse se valor_compra > 5000.cont_n +1 fimse Sete Lagoas 2011 UNOPAR VIRTUAL .05 fimse se valor_compra >=1000.

REPRESENTAÇÃO DA INFORMAÇÃO: A representação da informação no computador esta de acordo com o modo de funcionamento dos computadores. Sete Lagoas 2011 UNOPAR VIRTUAL . então o sistema de numeração que naturalmente se adéqua para a representação da informação é o binário em virtude de ser constituído por apenas dois dígitos. a que chamamos bits. media ) // Escrevendo a quantidade de notas abaixo da media escreval (" Quantidade de notas abaixo da media: ". e para aqueles que estão mais “presos” ao sistema de numeração décima (0 a 9). Esta atividade consiste na elaboração ou na descrição de um algoritmo que possibilite a conversão do sistema decimal para binário (poderá fazer uso de qualquer linguagem de programação para exemplificar o código). Como sabe. um programa é executado a partir da memória principal do computador. o 0 e o 1. No texto a seguir é representado a conversão de um número decimal para binário (esse exemplo foi colocado somente para ilustrar a forma de conversão). ligado e desligado.soma / 5 //Escrevendo a media calculada escreva ("A media da turma é: ". Sendo esta um dispositivo digital de dois estados.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas fimpara //Calculando a média media <. cont_n ) fimalgoritmo 5) Na representação da conversão do sistema decimal para binário é obtido pelos restos da divisão como ilustrado no exemplo abaixo. Antes de prosseguirmos. informamos que a única diferença entre estes dois sistemas é o número de dígitos que os compõem.

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas algoritmo "de decimal para binário" // Função: Converter número decimal para binário var x : caracter y.y enquanto y > 0 faca se (y mod 2) = 0 entao x <.d : inteiro inicio // entrar com o numero em decimal escreva("Entre com um número decimal :") leia(y) d <.y div 2 fimenquanto escreval("A representação binária é ".x) fimalgoritmo Sete Lagoas 2011 UNOPAR VIRTUAL ."1" + x fimse y <."0" + x senao x <.

Sete Lagoas 2011 UNOPAR VIRTUAL . r: Conhecimento pode ser compreendido como o conjunto de ferramentas conceituais e categorias usadas pelos seres humanos para criar. colecionar. q.r) e faça a tabela-verdade para essa proposição composta.r): Se dados são conjuntos de elementos que expressa um fato isolado gerado por uma atividade que pode ser controlada e informação é o resultado do tratamento dos dados existentes acerca de alguém o alguma coisa. colecionar. armazenar e compartilhar uma informação. escreva em linguagem lógica a proposição composta T (p. q: Informação é o resultado do tratamento dos dados existentes acerca de alguém o alguma coisa. A partir da proposições simples p. armazenar e compartilhar uma informação.q. então o conhecimento não pode ser compreendido como o conjunto de ferramentas conceituais e categorias usadas pelos seres humanos para criar. r a seguir.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas Parte II 1) Traduzir para a linguagem lógica algum conceito de Fundamentos da Administração da Informação e construir a respectiva tabela-verdade.q. p: Dados são conjuntos de elementos que expressa um fato isolado gerado por uma atividade que pode ser controlada. T(p.

Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas T=(p ^ ~q) ->~ r p V V V V F F F F q V V F F V V F F r V F V F V F V F ~q F F V V F F V V ~r F V F V F V F V p ^ ~q F F V V F F F F (p ^ ~q)->~r F V F V V V V V Sete Lagoas 2011 UNOPAR VIRTUAL .

tais como execução passo a passo. embora mais simples e usando uma linguagem de programação sem tantos recursos. visualização do conteúdo das variáveis. etc. executar e depurar o pseudocódigo para resolver problemas propostos nas aulas e em exercícios. CONSIDERAÇÕES O VisuAlg é um aplicativo que fornece aos estudantes que se iniciam nas disciplinas de programação ferramentas para digitar. Ambientes como o VisuAlg promovem a experimentação e permitem desde cedo o entendimento do funcionamento de um programa de computador. O uso deste software nos estágios iniciais do ensino de programação tem-se mostrado bastante produtivo por permitir que desde o início os estudantes tenham contato com um ambiente de desenvolvimento próximo ao que encontrarão em sua vida profissional.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 3. fornecendo também aos professores vários recursos didáticos para que expliquem como os programas funcionam. Sete Lagoas 2011 UNOPAR VIRTUAL .

Ed. MICHAEL T. GARCIA. ANITA. 1. ROBERTO. GUTO. 1. 2002 Sete Lagoas 2011 UNOPAR VIRTUAL .. Rio de Janeiro: Elsevier. Ed. análise e exemplos da internet.Curso Superior de Tecnologia em Análise e Desenvolvimento de Sistemas 4. Projeto de algoritmos: fundamento. 2004 LOPES. REFERÊNCIAS GOODRICH. TAMASSIA. Introdução a programação: 500 algoritmos resolvidos. Porto Alegre: Bookman.

Sign up to vote on this title
UsefulNot useful