Você está na página 1de 34

Procedimento para criar componentes no Altium designer

Procedimento caso no tenha um biblioteca j criada

1 Passo:

Criar uma biblioteca integrada.

- Abrir o altium designer. - Clicar em File -> New -> Project -> Integrated Library. - Como mostrado na Figura 1.

Figura 1

- Deve aparecer uma tela igual ao da Figura 2.

Figura 2 - Clicar em File -> Save Project As. - Como mostrado na Figura 3.

Figura 3

- Deve aparecer uma tela igual ao da Figura 4.

Figura 4

- De um nome para a biblioteca ex: (TRANSISTOR_SMD.LibPkg) ressaltando que por padro o nome dever ser todo em maisculo e especificado se a biblioteca e de componentes SMD OU CONVENCIONAL. EX: Biblioteca SMD -> TRANSISTOR_SMD. Biblioteca Convencional -> TRANSISTOR_CONVENCIONAL. click em salvar.

2 Passo:

Criar o smbolo do componente.

- Clicar em File -> New -> Library > Schematic_Library - Como mostrado na figura 5.

Figura 5

- Deve aparecer uma tela igual ao da Figura 6

Figura 6 - Clicar em File -> Save as. - Como mostrado na Figura 7.

Figura 7

- Deve aparecer uma tela igual ao da Figura 8.

Figura 8 - De um nome para a Sub - biblioteca ex: (Transistor_smd.SchLib) ressaltando que por padro o nome dever ser minusculo e especificado se a biblioteca e de componentes SMD OU CONVENCIONAL. EX: Sub - Biblioteca SMD -> Transistor_smd. Sub - Biblioteca Convencional -> Transistor_convencional. click em salvar. Para criao de qualquer tipo de componente aconselhvel cri-lo a partir de um componente j existente, mesmo que o componente seja totalmente diferente do que esta sendo criado, pois fazendo isto, aproveitaremos uma serie de propriedades e campos j criados para o componente j existente. - Para isso encontre uma biblioteca pronta e de um duplo click na mesma. - Deve aparecer uma tela igual ao da Figura 9.

Figura 9 - Clicar em extract Sources. - Na prxima tela que aparecer clicar em OK. - Deve aparecer uma tela igual ao da Figura 10.

Figura 10

- Dentro da biblioteca integrada que voc acabou de abrir de um duplo click na Sub biblioteca que tem a extenso (.SchLib). - Como Indicado pelo circulo na Figura 11.

Figura 11

- No rodap do software tem algumas opes. - Como indicado pelo circulo na figura 12.

Figura 12 - Clicar na aba SCH Library. - Deve aparecer uma tela igual ao da Figura 13.

Figura 13

- Escolher qual componente se parece mais com o que voc deseja criar. - A escolha feita clicando uma vez no respectivo componente que esta na lista indicada na Figura 14.

Figura 14 - Quando j tiver escolhido o componente. - Clicar com o boto direito em cima do mesmo e selecionar a opo copy. - Como mostrado na Figura 15.

Figura 15 - Clicar na aba Project no canto inferior esquerdo do software. - Como mostrado na Figura 16.

Figura 16

- Deve aparecer uma tela igual ao da Figura 17.

Figura 17 - De um duplo click na Sub-Biblioteca que voc esta criando. - Deve aparecer uma tela igual ao da Figura 18.

Figura 18

- Clicar novamente na aba SCH Library no canto inferior esquerdo do software. - Como mostrado na Figura 19.

Figura 19 - Clicar com o boto direito na parte branca da lista onde fica os componentes e selecionar paste. - Como mostrado na Figura 20.

Figura 20 - Deve aparecer uma tela igual ao da Figura 21.

Figura 21 - Clicar com o boto direito em cima do component_1 e selecionar delete. - Clicar em Yes na mensagem que aparecer. - Na aba editor apagar todos os arquivos que se encontram presentes. - Para apagar selecione o arquivo click em remover. - Clicar em Tools -> Rename Component. - Como mostrado na Figura 22.

Figura 22 - Deve aparecer uma tela igual ao da Figura 23.

Figura 23 - No campo da tela acima digitar o nome do componente conforme anexo I.

- Clicar em Tools -> Component Properties. - Como mostrado na Figura 23.

Figura 23 Deve aparecer uma tela igual ao da Figura 24.

Figura 24

- Para os campos Default Designator, Default comment, Description, apagar estes campos e preencher de acordo com os dados em anexo I. - Para o campo parmetro selecionar a opo desejada e clicar em editar e editar os valores de acordo com os do anexo I.

3 Passo:

Criar o FootPrint do componente.

- Clicar em File -> New -> Library -> PCBLibrary. - Como mostrado na Figura 23.

Figura 25 - Neste momento pode carregar um FootPrint j pronto, importar de outra biblioteca ou criar um novo. - Para isso encontre uma biblioteca pronta e de um duplo click na mesma. - Deve aparecer uma tela igual ao da Figura 26.

Figura 26 - Clicar em extract Sources. - Na prxima tela que aparecer clicar em OK. - Deve aparecer uma tela igual ao da Figura 27.

Figura 27

- Dentro da biblioteca integrada que voc acabou de abrir de um duplo click na Sub biblioteca que tem a extenso (.PcbLib). - Como mostrado na Figura 28.

Figura 28 - Deve aparecer uma tela igual ao da Figura 29. - Clicar na aba PCB Library como indicado na Figura 29.

Figura 29 - Deve aparecer uma tela igual ao da Figura 30.

Figura 30 - Marcar o componente desejado click com o boto direito sobre o mesmo e selecione a opo copy. - Clicar em Project no canto inferior esquerdo do software. - Como mostrado na figura 30.

Figura 30 - Dentro da biblioteca integrada que voc esta criando de um duplo click na Sub biblioteca que tem a extenso (.PcbLib). - Como mostrado na Figura 31.

Figura 31 - Clicar em PCBLibrary no canto inferior esquerdo do software.

- Como mostrado na Figura 32.

Figura 32 - Clicar com o boto direito do mouse na parte branca da lista de componentes e selecionar paste 1 Components. - Como mostrado na Figura 33.

Figura 33

- Clicar com o boto direito do mouse em cima do PCBComponente_0 e deleta l. - clicar em Yes na mensagem que aparecer. - Como mostrado na Figura 34.

Figura 34 - Deve aparecer uma tela igual ao da Figura 35.

Figura 35

- Clicar em Tools -> Components properties. - Deve aparecer uma tela igual ao da Figura 36.

Figura 36 - Apagar os campos que aparecer e preencher de acordo com o anexo I. - Clicar em OK aps terminar de preencher. - Clicar com o boto direito na biblioteca integrada que voc abriu para copiar o componente e selecionar close Project. - Click em NO na mensagem que aparecer.

4 Passo:

Criar o modelo 3D do componente.

- Clicar em Place -> 3D Body. - Deve aparecer uma tela igual ao da Figura 37.

Figura 37 - Em 3D Model Type selecionar a opo Generic STEP Model. - Agora clicar no boto Embed STEP Model. - Procura o modelo 3D e carregar o mesmo. - Agora atravs das coordenadas X, Y, Z e Standoff height voc ajusta o modelo 3D corretamente em cima do FootPrint. - Feito isto voc clica em OK e posiciona o desenho 3D em cima do FootPrint. - Depois salve as alteraes clicando com o boto direito do mouse em cima da SubBiblioteca com a extenso (.PCBLib). - Sempre que modificar alguma coisa no FootPrint tem que salvar para que as modificaes sejam alteradas.

5 Passo:

Compilar a Biblioteca Integrada.

- Primeiro salve o projeto e as duas Sub-Bibliotecas voc pode fazer isto clicando com o boto direito em cima de casa um e selecionando salvar. - Agora click com o boto direito em cima da Biblioteca Integrada e selecione Compile Integrated Library. - - Como mostrado na Figura 38.

Figura 38

- Aguarde compilar se no estiver nada errado deve aparecer uma tela igual ao da Figura 39.

Figura 39

- Pronto o componente esta finalizado e pronto pra uso.

Autor: Leandro Souza Titulo: Criar componentes Data: 17/01/2013 Reviso: R00 N: 1 Descrio: Procedimento para criar componentes no altium designer

Anexo

Para Transistor
Simbolo
Rename Component Default Designator Default Comment Campo: Description Campo: Type Symbol Reference Data da Ultima Reviso Encapsulamento Verso do dataSheet FootPrint Fabricante PartNumber Tipo Valor MODELO CODIGO Colocar o nome do componente ex: MMBT3904

Q? MMBT3904 NPN General Purpose Amplifier Standard MMBT3904 15/01/2013 SOT 23 OUTUBRO DE 2011 SOT 23 PANASONIC ERA-6YEB102V CIRCUITO INTEGRADO MMBT3904 SMD 1

FootPrint

Name Description

Colocar o nome do componente ex: MMBT3904

NPN General Purpose Amplifier

Para Resistor

Simbolo

Rename Component Default Designator Default Comment Campo: Description Campo: Type Symbol Reference Data da ultima Reviso Encapsulamento Verso do dataSheet FootPrint Fabricante PartNumber Tipo Valor MODELO CODIGO Tolerancia

Colocar o nome do componente ex: Resistor 1K 5%

R? Resistor 1K Chip Resistor 0805 Standard Resistor 1K - 5% 15/01/2013 0805 OUTUBRO DE 2011 0805 Panasonic ERA-6YEB102V Chip 1K SMD 1 5%

FootPrint

Name Description

Colocar o nome do componente ex: RESISTOR - 0805

Chip Resistor 0805

Para Capacitor

Simbolo

Rename Component Default Designator Default Comment Campo: Description Campo: Type Symbol Reference Data da ultima Reviso Encapsulamento Verso do dataSheet FootPrint Fabricante PartNumber Tipo Valor MODELO CODIGO Tolerancia

Colocar o nome do componente ex: CAPACITOR 100nF 50V

C? CAPACITOR 100 nF Chip Capacitor 0805 Standard CAPACITOR 100 nF 50V 15/01/2013 0805 OUTUBRO DE 2011 0805 Panasonic ERA-6YEB102V Chip 100nF SMD 1 5%

FootPrint

Name Description

Colocar o nome do componente ex: CAPACITOR - 0805

Chip Capacitor 0805