P. 1
Dicas Excel

Dicas Excel

|Views: 7.938|Likes:
Publicado porronaldodpaiva

More info:

Published by: ronaldodpaiva on Oct 01, 2010
Direitos Autorais:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

07/17/2013

pdf

text

original

DICAS EXCEL

:

Como utilizar o relógio do computador em uma formula do Excel? De: Ricardo. Escolha uma célula em branco, digite a fórmula '=agora()' e tecle Enter. Automaticamente irão aparecer a hora e a data do computador. O legal dessa fórmula é que os valores não permanecem fixos e são atualizados assim que você realiza alguma ação dentro da planilha Se não for possível ter um texto em apenas uma linha, como se faz para mostrar em mais linhas? De: Kazuhisa Kanno. Primeiro selecione as linhas que você deseja preencher com o seu texto. Depois, no alto da tela, clique no menu Formatar > Células. Clique na aba Alinhamento e assinale a opção Mesclar Células. É só clicar em OK e pronto! Outro jeito é ir em Formatar > Células > Alinhamento e Wrap Text. Como usar a fórmula PROCV? De: Marcos. A formula PROCV serve para fazer busca de dados em tabelas. O padrão é =PROCV(número de busca;tabela;qual coluna retornar). Vamos explicar: por exemplo, você tem uma lista de funcionários da empresa e quer saber dados dele apenas inserindo o código funcional. Você faz =PROCV(Número do funcionário; marca o intervalo da tabela, e marca a coluna que contém o dado que você quer). Para que o dado retornado seja o da linha use PROCH. Se o seu Excel é em inglês, use VLookup para colunas e HLookup para linhas. Veja imagem abaixo com a fórmula em ação:

Como alterar texto para maiúsculas no Excel? De: Graça Santos. Vamos supor que a o texto que você deseja deixar em maiúsculas esteja na célula C10. Escolha uma célula vazia da planilha e digite este código: =MAIÚSCULA(C10) e pressione Enter. O conteúdo da célula C10 ficará, agora, em maiúscula. Se quiser fazer o contrário, transformar em minúsculas, basta escrever o mesmo código e substituir MAÍSCULA por MINÚSCULA. E se você quiser, ainda, que só as primeiras letras de cada palavra estejam em letra maiúscula, digite PRI.MAIÚSCULA. Como programar uma célula para aparecer com preenchimento colorido automático quando uma determinada condição ocorrer? De: Luiz Souza. Você terá que utilizar o recurso da Formatação Condicional. Imagine que na sua planilha você tem uma coluna na qual todas as células estão

Selecione a coluna com esses valores e logo na seqüência clique no menu Formatar. Se você usar cores em sua planilha. para reposição ou redução do estoque. os dados da filial A devem ter layout idêntico ao dos dados da filial B. Se mudar a política de estoques para esse produto. defina: se o valor da célula é menor que o estoque mínimo (200).ou seja. o arquivo ou planilha de janeiro deve ter a mesma estrutura do arquivo ou planilha de fevereiro. é possível usar numa planilha informações armazenadas em arquivos externos. não defina nenhum formato. clique no botão Adicionar e determine as condições para o estoque alto. esse recurso foi incorporado ao programa com o nome de Formatação Condicional. Sua empresa convenciona que o normal é ter entre 200 e 500 peças do produto. escolha a cor vermelha. Confira o resultado. escolha "maior do que" e no campo 3 escolha novamente "0". Por exemplo. Preencha essas células com os respectivos valores. será mais fácil perceber quando e como agir. por exemplo. você precisava fazer algumas ginásticas para formatar uma célula conforme seu conteúdo. clique no botão Formatar e estabeleça uma marca para a célula. tabelas que consolidam dados de outras tabelas. Exemplos clássicos são resultados mensais consolidados numa planilha anual. do mesmo modo.preenchidas com valores e você deseja que os valores inferiores a 0 apareçam com a fonte em vermelho e os superiores em azul. escolha a azul e novamente clique em OK. Ou seja. Clique no botão Adicionar e vamos para o estoque normal. repita a operação no campo 1. formate a fonte em azul e negrito. As inclusões posteriores também estarão condicionadas a esta formatação. No campo 2. Clique em OK. nomeie duas células. Na caixa de diálogo. Na Condição 1. agora ao invés de escolher a cor vermelha. basta substituir o conteúdo dessas duas células. A partir da versão 97. Se quiser sofisticar a solução. Na planilha. Clique de novo em Formatação e. 500 e 200. ou vários documentos de filiais resumidos num documento único. entre inclui os dois extremos). selecione a área dos dados e acione Formatar > Formatação Condicional. para toda a empresa. na aba Fonte. Admita que você tem uma planilha para controlar o estoque de um produto. . "0" (campo 3). Se o valor da célula está entre 200 e 500 (nesse caso. destacar em vermelho os números abaixo de um determinado patamar e em azul os que pertencerem a uma faixa bem definida. Se o número de peças for maior que 500. Para isso. Pronto. e assim por diante. Clique no botão Formatar e. como Condição 1. Na sua planilha os valores menores do que 0 estarão em vermelho e os maiores em azul. escolha "o valor da célula é" (campo 1). "menor que" (campo 2). Defina. o que estiver abaixo ou acima dessa faixa requer providências.a do estoque baixo. Escolha a opção Formatação Condicional. Você pode trabalhar com as cores da fonte e do fundo da célula e ainda com a borda. Na Condição 2. Portanto. Mais uma vez. uma como Estoque_Max e a outra como Estoque_Min. Até agora você cobriu apenas uma faixa . Números negativos em vermelho no Excel Faça com que os números negativos apareçam em vermelho em planilhas do Excel 97/2000/XP Antes do Excel 97. a fonte como vermelho e negrito. As formatações da planilha se adaptarão automaticamente à nova política Consolide várias planilhas do Excel Aprenda a consolidar várias planilhas numa única com o Excel 97/2000/XP No Excel. Isso permite a criação de planilhas-resumo . A maneira mais fácil de criar uma planilha consolidada é conceber uma estrutura única para todas as planilhas ou documentos. selecione a célula e dê o comando Inserir/Nome/Definir e digite o nome.

A forma mais simples é criar sete planilhas numa mesma pasta de trabalho: seis planilhas mensais. que os dados de junho estão numa pasta de trabalho à parte. em Gênero. tela para digitação. Agora. relatórios variados. Junho. Para voltar a visualizar a totalidade dos registros. mais uma para o total. A qualquer momento. ao escolher a opção Rock. Crie uma tabela. desfaça o caminho: escolha Tudo. todos os campos. Dos discos de rock. Para facilitar.xls]Plan2´!G7 O Excel funciona como um BD. na linha de títulos. use o comando Dados > Filtrar > AutoFiltro. Admita. Para pesquisar. No primeiro campo. terminado o primeiro semestre. na célula C5 da planilha consolidada: =SOMA(Janeiro:Junho!C5) Mesmo que as seis fontes de dados não pertençam todas a um mesmo arquivo. e Tudo.. em todas as planilhas. . você vai ver na tela apenas os registros com essa classificação. para obter a receita do semestre. com uma planilha para cada mês. montar um filtro em cima de um conjunto já filtrado. escolha a opção "é maior ou igual a" e ao lado escreva 10. o Excel quebra um bom galho.Vejamos um exemplo prático. a tabela de CDs tem um campo Gênero. Só é preciso conhecer bem o layout do documento fora do padrão. Para obter a receita do semestre. basta usar a seguinte fórmula. use os recursos de banco de dados do Excel. Se você precisa manter uma lista de contatos pessoais.xls. por exemplo. o perfil das receitas e despesas da empresa. Os comandos Editar > Localizar e Editar > Substituir são outros recursos para trabalhar com os registros. Bem. Você pode. Você acompanha. use a fórmula: =SOMA(Janeiro:Maio!C5)+´h:\docs\[Junho. Abra a caixa de verificação do campo Faixas e escolha Personalizar. ainda. Se. Para um cadastro simples. Uma forma simples de obter isso é construir a lógica de uma das planilhas e depois copiá-la para as demais. Digamos que a receita mensal esteja. com os campos de dados indicados na primeira linha. os dados que vão ser aproveitados na planilha Ano devem estar nas mesmas posições em todas as planilhas. deseja consolidar essas informações num documento único. Ao fazer isso. Nesse caso. você pode acionar o comando Dados > Classificar e reorganizar os registros com base em até três campos. por exemplo. ou mesmo o cadastro de sua coleção de CDs ou DVDs. na qual a receita mensal se encontra na planilha Plan2. ainda assim é possível fazer a consolidação. descubra quais têm dez ou mais faixas. se você quiser montar um banco de dados com várias tabelas relacionadas.. ganham uma caixa de verificação que lhe permite filtrar o banco de dados para ver apenas os registros de um determinado tipo. use um programa de banco de dados. Agora. célula G7. na célula C5. em Faixas. nesse caso.

Se VERDADEIRO ou omitida. Use PROCV. Se valor_procurado for menor do que o menor valor na primeira coluna de matriz_tabela. Procurar_intervalo Um valor lógico que especifica se você deseja que PROCV localize uma correspondência exata ou aproximada. Os valores na primeira coluna de matriz_tabela são aqueles procurados por valor_procurado. O V em PROCV significa vertical.nú… Valor_procurado O valor a ser localizado na primeira coluna da matriz (matriz: usada para criar fórmulas únicas que produzem vários resultados ou que operam em um grupo de argumentos organizados em linhas e colunas. núm_índice_coluna É o número da coluna em matriz_tabela a partir do qual o valor correspondente deve ser retornado. o valor de erro #N/D será retornado. Você pode colocar os valores em ordem ascendente escolhendo o comando Classificar no menu Dados e selecionando Crescente. Se uma correspondência exata não for encontrada. PROCV fornecerá o valor de erro #N/D. Para obter mais informações. o valor maior mais próximo que é menor que o valor_procurado será retornado. Se uma correspondência exata não for encontrada. PROCV poderá não fornecer o valor correto. Se núm_índice_coluna for: Menor do que 1. os valores na primeira coluna de matriz_tabela não precisam ser classificados. PROCV fornecerá o valor de erro #REF!. quando os valores da comparação estiverem localizados em uma coluna à esquerda dos dados que você deseja encontrar. uma constante de matriz é um grupo de constantes usado como um argumento. caso contrário. consulte Ordens de classificação padrão. um núm_índice_coluna de 2 retornará o valor na segunda coluna em matriz_tabela. Textos em maiúsculas e minúsculas são equivalentes. Sintaxe PROCV(valor_procurado. e assim por diante. . Um núm_índice_coluna de 1 retornará o valor na primeira coluna em matriz_tabela. números ou valores lógicos. uma correspondência aproximada será retornada.) da tabela. PROCV somente localizará uma correspondência exata. Matriz_tabela Duas ou mais colunas de dados. Maior que o número de colunas em matriz_tabela.matriz_tabela. Um intervalo de matrizes compartilha uma fórmula comum. Os valores na primeira coluna de matriz_tabela devem ser colocados em ordem de classificação crescente. Valor_procurado pode ser um valor ou uma referência. PROCV retornará o valor de erro #VALOR!. em vez de PROCH. Se FALSO. Nesse caso. o primeiro valor encontrado será usado.COMO USAR O PROCV??? Localiza um valor na primeira coluna de uma matriz de tabela e retorna um valor na mesma linha de outra coluna na matriz da tabela. Esses valores podem ser texto. Se houver dois ou mais valores na primeira coluna de matriz_tabela que corresponderem ao valor_procurado. Use uma referência a um intervalo ou nome de intervalo.

Para organizar o trabalho. Dê OK. ao mesmo tempo. digite: em cima. Então. clique no controle Caixa de Combinação e desenhe o objeto. A função CONT. Quantidade e Total. nas células A20. Na barra Caixa de Ferramentas de Controle.? Sempre que você aumentar a lista. Assim. construa o formulário de orçamento. Deixe em branco a linha seguinte e escreva a especificação de cada item. 8. crie essa lista numa planilha separada. Clique com o botão direito na caixa de combinação e. Na caixa Propriedades. Batizaremos essa coluna com o nome Produtos. pode adicionar o logotipo da empresa. Vamos incluir nela a lista de produtos. se você quiser. Portanto. Vamos usá-la junto com o recurso de nomear a coluna A de Plan2. no exemplo. A solução. Assim: Plan2!A2:A19. Desenho da caixa Volte para a planilha Plan1. e embaixo: =DESLOC(Plan2! $A$2. Agora. Produtos. as caixas de combinação do Excel são fáceis de usar e não exigem conhecimento avançado. agora. 1. Repita esse processo para todas as linhas. Nessa barra. o usuário poderá escolhê-la quando quiser cancelar a inclusão de uma linha no orçamento. Além disso. Produtos. Observe: na lista foi incluída uma célula em branco. Para isso. escolha a opção Propriedades. copiar e colar Cada linha da coluna Produto deve conter uma caixa de combinação com o mesmo conteúdo. que será a lista de produtos disponíveis. 3. em vez de repetir o que foi feito no bloco anterior. no menu. Essas caixas — que contêm uma lista de opções — facilitam a elaboração do documento quando há itens que se repetem em determinados campos. Dê o comando Exibir > Barras de Ferramentas e deixe visível a barra Caixa de Ferramentas de Controle. 4. . na linha 1. terá um formulário em branco.Menos digitação no Excel Explore o recurso das caixas de combinação do Excel para criar listas de opções e reduzir o trabalho de digitação As caixas de combinação em planilhas do Excel constituem um recurso muito prático que poucos usuários utilizam. adicionar fórmulas à coluna Valor e formatar os números. Assim. DESLOC usa esse número para definir o intervalo. acione Inserir > Nome > Definir. O Excel tem uma função chamada DESLOC que pode ajudar a resolver o problema. Nela. 5. A primeira tarefa é definir o conteúdo dessas caixas. Na coluna A da planilha Plan2. Mas. E como ficarão as coisas se a lista incorporar novos itens. vamos incluir as caixas de combinação nas células da coluna Produto. o melhor é salvá-lo como modelo (XLT). selecione a célula imediatamente abaixo e dê o comando colar. Região automática A solução é redefinir automaticamente o intervalo da lista de produtos. Cada caixa de combinação contém a lista de produtos. clique no botão com o esquadro azul. Conteúdo da caixa A caixa de combinação está vazia. Desse modo. Lista de produtos Vamos usar como exemplo uma planilha para orçamento de venda com as seguintes colunas: Produto.VALORES(Plan2!$A:$A)). Isso define uma região chamada Produtos. vamos por um atalho. Ajuste a caixa para que coincida com as dimensões da primeira célula da coluna Produto. em vez de digitar. A21 etc. em cada caixa. Ele alterna entre o modo de desenvolvimento e o modo de ação da planilha. vamos dizer ao Excel que Produtos não equivale a toda a coluna A. Agora. Um novo problema A planilha já está pronta. escreva Produtos. Copie a caixa de combinação. Mas vamos pensar um pouco. que ocupa o intervalo de células A2:A19. endereço etc. Que trabalhão. 7. em vez de um endereço (A2:A19). Agora. Um formulário para a apresentação de orçamentos é o tipo de documento para ser utilizado muitas vezes. A2. Então. 6. em tese O que faz a função DESLOC? Ela define uma região da planilha de forma elástica. Aumente a altura das linhas (18 é um bom número para a altura).0. pronto para ser preenchido. Salvar como modelo Falta. será obrigado a atualizar o endereço dela em cada uma das caixas. Além disso. toda vez que você abrir o modelo. Na caixa Definir Nome. vai ser possível aumentar a lista sem precisar mexer nas caixas de combinação.VALORES conta as células preenchidas na coluna A. coloque o título.CONT. em vez de armazená-lo como um arquivo comum (XLS). Veja no passo-a-passo a seguir como utilizá-las em suas planilhas. Digite a região da lista de produtos. localize a linha ListFillRange. mas somente ao intervalo que vai de A2 (a célula em branco) até onde a coluna estiver preenchida. As caixas de combinação vão ser usadas no campo Produto. O objetivo é deixá-la como a primeira linha da lista. 2. escolhese uma opção.0. Preço Unitário.

" na célula selecionada e. sem ser atualizada toda vez que o arquivo for aberto (ex: para indicar a data da abertura do arquivo ): • Basta clicar em "Ctrl" e ". o Em Todos os programas. Se você quiser inserir a data do dia. VISTA ou Windows7 para o Microsoft Office 2003 e o 2007 : o Botão Iniciar. 2 No ambiente XP.9. mas neste caso é preciso ativar os macros a cada abertura do arquivo. Criação da assinatura • • 1 No Microsoft Office 2000: o Fazer uma busca do arquivo SELFCERT. Na janela do assistente No campo "Nome do seu certificado". A utilização do código VBA requer um nível de segurança baixo ou médio. clique duas vezes em SelfCert. Mas para isso é preciso montar um esquema bastante criativo ou programar em linguagem VBA. digitar um nome simples que você queira dar à . É possível. incluir uma coluna de preços na lista de produtos (Plan2). Mais expansões Você pode automatizar ainda mais a planilha de orçamento. o Ferramentas Microsoft Office. se você quiser inserir a hora no formato HH:MM: • Basta clicar em "Ctrl" e ":" na célula.Assinatura digital. pronto. o E em Certificado digital para os projetos VBA. criando a sua própria assinatura digital para autenticar a codificação dos macros gravados. o preço aparecerá na coluna correspondente. por exemplo. Assim. Idem. que ela permaneça fixa. quando se escolher um item. Excel . no formato DD / MM / AAAA e. o Clique em Microsoft Office. É possível remediar esses inconvenientes. em uma célula.exe para exibir o assistente.

ativar os macros. os macros se ativarão. 3 Na barra dos menus do Visual Basic Editor: Ferramentas > Assinatura Eletrônica > clicar em Escolher > e no nome da sua assinatura e. No ambiente Microsoft Excel 2007 • • • • • Se a guia "Desenvolvedor" não estiver ativada. Salvar e fechar o arquivo. em OK. automaticamente. Na abertura do primeiro arquivo. Agora você pode assinar nossos códigos No ambiente Microsoft Excel 2000 e 2003 • 1 Abrir o arquivo Excel com um código macro. como o seu pseudônimo. clicar no botão Microsoft Office E em Opções Excel. Clicar em Padrão e marcar Exibir a guia Desenvolvedor na fita. usando a assinatura digital. Marcar a opção "Confiar sempre nos macros deste editor". Visual Basic ou (Alt+F11) . Ativar os macros. 4 Salvar e fechar o arquivo : na abertura. clicar em OK. por exemplo. Abrir o arquivo com o código macro para assinar Na guia "Desenvolvedor". Ferramentas > Macros > Segurança > Guia "Nível de segurança" > assinalar o nível médio). Quando a mensagem de confirmação do certificado aparecer. uma caixa de diálogo proporá a ativação dos macros: • • • • Antes de ativar os macros. Maior segurança Você pode aumentar a segurança para o nível elevado (Ferramentas > Macros > Segurança > marcar Elevado).sua assinatura. (Na abertura. Salvar e fechar o arquivo. • • • 2 Ferramentas/Macro/Visual Basic Editor ou Alt+F11.

Tutorial Função PROCH (HLOOKUP) Procedimento do PROCH (Excel 2003 e Excel 2007) Referências • Você deve selecionar as referências em sua planilha. Excel 2007: A definição do nome é feita através do menu Fórmulas. Voltar à sua planilha Guia Desenvolvedor. Depois de selecionar. Local onde os dados encontrados aparecerão • Neste exemplo: o J1=Termo a ser procurado o J3=Descrição encontrada (coluna2 da nossa planilha) . a sua referência é $A$1:$F$4. Segurança dos macros Marcar: Desativar todos os macros exceto os macros assinados digitalmente e OK Salvar Fechar o arquivo e o aplicativo.Nome . Neste exemplo.• • • • • • Na barra dos menus do Visual Basic : Ferramentas > Assinatura Eletrônica > clicar em Escolher > e no nome da sua assinatura e.Definir (Para este exemplo. clicar em Inserir . em OK. dei o nome de PRODUITOS).

PRODUTOS. e extraímos o valor colocado na segunda linha.3.2. se nada foi encontrado.row_index_num. FALSO.PRODUTOS. procuramos na primeira linha da tabela PRODUTOS." Desconhecido "."Desconhecido".2. partindo do conteúdo da célula H1. indica que estamos procurando uma correspondência exata.FALSO)). a coluna começando com esse conteúdo.PRODUTOS.FALSO) Simplificando.FALSO)). a coluna começando com esse conteúdo. PROCH ($J$1. partindo do conteúdo da célula H1.PRODUTOS.PRODUTOS. J5 o o o o o • J7 o o .3.FALSO) Para ser mais claro.4."Desconhecido") =PROCH($J$1.P ROCH($J$1.tabela_matriz.no_index_lig. procuramos na primeira linha da tabela PRODUTOS. se nada foi encontrado.2. indica que estamos procurando uma correspondência exata.3.PRODUTOS. FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1."Desconhecido") =PROCH ($J$1. Para evitar a mensagem #N/A. procuramos na primeira linha da tabela PRODUTOS.valor_aproximado) (=HLOOKUP(lookup_value.PRODUTOS. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. FALSO. Para evitar a mensagem #N/A. =SE(FORNA(PROCH($J$1. =SE(FORNA(PROCH($J$1. FALSO. partindo do conteúdo da célula H1. a coluna começando com esse conteúdo.table_array. e extraímos o valor colocado na terceira linha.range_lookup) (tutorial PROCH) • J3 o o o o =PROCH ($J$1.2. indica que estamos procurando uma correspondência exata.FALSO).PRODUTOS. e extraímos o valor colocado na quarta linha. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.FALSO)) (Veja a função SE ou IF aqui) * • o • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1.FALSO) Simplificando.3.o o J5=Quantidade encontrada (coluna 3 da nossa planilha) J7=Preço encontrado (coluna 4 da nossa planilha) Fórmulas A sintaxe de base da função PROCH é: = PROCH (valor_pesquisa.FALSO).PRODUTOS.

colocamos o parâmetro em FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e. Se este parâmetro for omitido. seu valor padrão é VERDADEIRO.4.PRODUTOS.FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEIERRO(PROCH($J$1. =SE(FORNA(PROCH($J$1.o o o Para evitar a mensagem #N/A. se nada foi encontrado.PRODUTOS.FALSO). neste caso. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.PRODUTOS.P ROCH($J$1. Tutorial Função PROCV (VLOOKUP) Procedimento do PROCV(Excel 2003 & Excel 2007) .FALSO). a lista de valores deve estar organizada.4."Desconhecido".4. em VERDADEIRO se o valor for igual ou inferior mais próximo."Desconhecido") Nota: Na fórmula.

Neste exemplo.FALSO)) H6 o o o o .CAMPOS.CAMPOS.FALSO) Simplificando.FALSO)).FALSO) Para ser mais claro. a coluna começando com esse conteúdo.3.PR OCV($H$1.3. Depois de selecionar.Referências • Você deve selecionar as referências em sua planilha.range_lookup) • H4 o o o o o • =PROCV($H$1.FALSO). se nada foi encontrado. procuramos na primeira linha da tabela CAMPOS. Excel 2007: A definição do nome é feita através do menu Fórmulas.3.row_index_num. indica que estamos procurando uma correspondência exata. FALSO. dei o nome de CAMPOS). =SE(FORNA(PROCV($H$1."Desconhecido". utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. FALSO.CAMPOS.CAMPOS.2. indica que estamos procurando uma correspondência exata. a coluna começando com esse conteúdo.2."Desconhecido". se nada foi encontrado."Desconhecido") =PROCV($H$1.2. a sua referência é $A$2:$D$10. =SE(FORNA(PROCV($H$1.table_array.Nome Definir (Para este exemplo. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1. e extraímos o valor colocado na terceira linha. clicar em Inserir . procuramos na primeira linha da tabela CAMPOS. Local onde os dados encontrados aparecerão • Neste exemplo: o H1= Termo a ser procurado o H4= Descrição encontrada (coluna2 da nossa planilha) o H6= Quantidade encontrada (coluna 3 da nossa planilha) o H8= Preço encontrado (coluna 4 da nossa planilha) Fórmulas A sintaxe de base da função PROCV é: =PROCV(valor_pesquisa. Para evitar a mensagem #N/A.PR OCV($H$1.valor_aproximado) (=VLOOKUP(lookup_value.tabela_matriz.no_index_lig.2.CAMPOS. e extraímos o valor colocado na segunda linha.CAMPOS. Para evitar a mensagem #N/A.CAMPOS.FALSO)). partindo do conteúdo da célula H1. partindo do conteúdo da célula H1.

seu valor padrão é VERDADEIRO."Desconhecido") =PROCV($H$1. partindo do conteúdo da célula H1. Se este parâmetro for omitido."Desconhecido".CAMPOS.CAMPOS. utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado. .FALSO)) Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1. =SE(FORNA(PROCV($H$1.FALSO).CAMPOS. colocamos o parâmetro em FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e.CAMPOS. em VERDADEIRO se o valor for igual ou inferior mais próximo.4. neste caso. se nada foi encontrado."Desconhecido") H8 o o o o o Nota: Na fórmula.o • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1.FALSO) Simplificando.PR OCV($H$1. a coluna começando com esse conteúdo. Para evitar a mensagem #N/A. procuramos na primeira linha da tabela CAMPOS.3. e extraímos o valor colocado na quarta linha. a lista de valores deve estar organizada. FALSO.CAMPOS.4.4.FALSO)).4.FALSO). indica que estamos procurando uma correspondência exata.

Para localizar a(s) célula(s) que apresentam vínculos na pasta de trabalho ativa. Por exemplo: se você digitar em uma célula =A1*ICMS o Excel recuperará o valor da variável e o utilizará na fórmula. Verifique se há vínculos através do menu Editar. 1. a pasta de trabalho ativa não possui nenhum vínculo externo. Clique no botão OK. Procurar nomes de áreas e observar suas referências Se mesmo assim a coisa ficar complicada. Nesta caixa de diálogo. sem que você saiba onde eles estão. 4. Na caixa REFERE-SE A. no comando Vínculos. Abra o menu INSERIR e escolha NOME . Confirme a atualização deles e depois vamos procura-los. Caso o comando esteja desabilitado. Observe os nomes dos arquivos. Agora você poderá utilizar o nome da variável em fórmulas em qualquer planilha da pasta de trabalho para a qual foi definido o Nome.DEFINIR. digite o nome desejado para variável (por exemplo ICMS).17). verificar se existem planilhas ocultas e/ou protegidas. Se houver gráficos. utilize no Menu Editar o comando Localizar. Se não houver vínculos em nenhuma das planilhas. com a ajuda do Menu Editar Localizar. não se preocupe. utilizando-a em qualquer fórmula.Crie uma variável par ser utilizada em fórmulas Se você tiver uma planilha ou pasta de trabalho que use várias vezes uma mesma constante. porque às vezes os vínculos não são . 2. Na caixa DEFINIR NOME na caixa NOMES DA PASTA DE TRABALHO. Localizando vínculos em um pasta de trabalho Se você abrir uma pasta de trabalho que indicar vínculos. Vá até o Menu Editar Vínculos. o MS-Excel relaciona quais são todas as pastas de trabalho que estão enviando dados para a pasta de trabalho ativa. 5. Verificar a existência de botões de chamada de macros. Verificar a existência de gráficos. pode atribuir nome e valor a ela. digite o valor da variável (por exemplo 0. Verificar a existência de objetos. Execute tal procedimento em todas as planilhas da pasta de trabalho. clicar em cada uma das séries do gráfico e observar suas referências. 6. 3. e procure as células que tem estes nomes.

representando a função contrária. Completando o clique.tão óbvios assim ou você não deseja fazer esta investigação toda. Qual o efeito prático disto? Podemos economizar espaço nas barras de ferramentas. Ao clicar no botão com a tecla Shift apertada. uma vez que não precisamos dos dois botões com funcionalidade equivalente na barra de ferramentas. há outra maneira: faça o download do suplemento findlink.PROCURAR(" ". Vamos a um exemplo: Alguns botões das barras de ferramentas do MS-Excel (aproximadamente 40) apresentam dupla função.B7) . como por exemplo: Função Normal Imprimir Desfazer (Undo) Classificar ascendente Alinhar Esquerda Retirar Casas Decimais Salvar Função com a tecla Shift Visualizar Impressão Repetir (Redo) Classificar Descendente Alinhar Direita Aplicar Casas Decimais Abrir Se você tentar.xla (clicando no nome). o ícone se altera. Utilizando a tecla Shift para agilizar trabalhos A tecla Shift tem algumas funcionalidades muito interessantes no MS-Excel.1) retorna Jaime . o botão estará fazendo uma função contrária. clicando sobre um ícone com a tecla SHIFT acionada. a função é executada.A expressão =ESQUERDA(B7. Como Buscar um Nome em uma Lista Retornando Apenas o Primeiro Nome Seja o nome Jaime Monteiro Borges Júnior colocado na célula B7. execute-o para instalá-lo como suplemento do Excel e pode utilizar o suplemento para verificar onde estão os links. vai verificar que.

Alternativa Criar um suplemento xla. Se quiser ter uma visão da prévia do resultado. clique em VISUALIZAR IMPRESSÃO na caixa de diálogo de impressão. sem ter que cortar e colá-las em uma planilha separada. mantenha a tecla CTRL pressionada e vá até a próxima seção que você deseja imprimir e a selecione. Colocado no mesmo diretório.Como? A função PROCURAR busca o primeiro intervalo (espaço em branco) e retorna a sua posição (é o sexto caractere) e a função ESQUERDA retorna os 6-1=5 primeiros caracteres. Não solte a tecla CTRL! É possível marcar quantas seções não contíguas você desejar. Todas as pastas aí colocadas abrem automaticamente quando iniciamos o Excel. Na planilha. Terminada a seleção das áreas. imprima seções não contíguas. dependendo do idioma do Excel). como um item de menu. Planilhas abrindo automaticamente ao iniciar o Excel Você pode criar uma pasta de trabalho que é aberta cada vez que o Excel é carregado. desde que mantenha a tecla CTRL sempre pressionada. ele é carregado na memória juntamente com o Excel e fica disponível no menu FERRAMENTAS. exatamente o primeiro nome do nome completo que está na célula B7. colocando-a no diretório XLINICIO (ou XLSTART.Esta alternativa pode descomplicar bastante a sua abertura . O Excel imprimirá cada seção em uma página separada. Em vez disso. vá em Arquivo-Imprimir e aperte o botão Seleção. Imprimir seleções não contíguas Você não precisa imprimir resmas e resmas de folhas apenas para ter cópias de algumas áreas de uma planilha Excel. Em seguida. basta apertar OK. Caso contrário. selecione o primeiro conjunto de células que você deseja imprimir.

Como apenas o primeiro valor do intervalo da soma é fixado. a fórmula representará. selecionar a célula. copie e selecione a célula da extrema esquerda da linha que você deseja criar. A seguir clique EDITARCOLAR ESPECIAL. como mostra a tabela abaixo: . como na coluna B da tabela abaixo.. Você pode usar o comando COLAR ESPECIAL para isto: selecione a coluna. a B5).. Aluguel Telefone Gás Luz é colada da seguinte forma Aluguel Telefone Gás Luz Criar uma fórmula para mostrar um total acumulado progressivo Por vezes você constrói uma tabela onde precisa de uma coluna com o total acumulado a partir do valor da primeira célula calculado progressivamente.Convertendo linhas em colunas ou vice-versa Você já quis transformar uma coluna de texto ou números em uma linha para poder usar as linhas como linhas de rótulos de colunas em uma tabela? às vezes. em cada célula. o valor acumulado de A1 até a célula correspondente. por exemplo: A 100 200 300 400 500 B 100 300 600 1000 1500 1 2 3 4 5 Basta escrever na célula B1 a fórmula: =SOMA($A$1:A1) Em seguida. mover manualmente é lento e trabalhoso.TRANSPOR. clicar sobre a alça de arraste e arrastar a fórmula coluna abaixo até a célula final (no exemplo.

Acis Menezes e Marcelo Soares. Exemplo: Como limitar a área de exibição de uma planilha? Esta dica veio dos colegas José Luiz.Linha . ao qual pertenço. por exemplo. pode usar dois métodos: a) Via formatação (José Luiz) Se você quiser que a sua planilha não exiba as linha abaixo da linha 115. selecionando. usar as duas primeiras partes da função. Se você desejar limitar a área de exibição de uma planilha.A2. usar somente a primeira parte da função. teclar CTRL+Shift+SetaParaBaixo (para se deslocar. na célula A1 e a final na célula A2.A2. a inicial. basta clicar sobra a linha 116. do grupo de discussão EXCEL Br. da Yahoo.Ocultar. .1 2 3 4 5 A B 100 =SOMA($A$1:A1) 200 =SOMA($A$1:A2) 300 =SOMA($A$1:A3) 400 =SOMA($A$1:A4) 500 =SOMA($A$1:A5) Função para retornar o tempo transcorrido entre duas datas Caso seja necessário calcular o tempo transcorrido entre duas datas."Y") & " anos " & DATADIF(A1. Caso se deseje anos e meses. até a linha 65536) e daí ir ao menu Formatar ."YM") & " meses " & DATADIF(A1.A2. usar a seguinte função: =DATADIF(A1. "MD") & " dias" Caso se deseje apenas o número de anos.

Select End Sub A segunda é do Marcelo: Sub_ocultar() ' oculta linhas Range("115:65536").Reexibir.Select Selection. b) Via Macro Esta forma é interessante para se colocar nos eventos de abertura e fechamento da planilha. por exemplo.Hidden = True End Sub Para reexibir.Activate ActiveSheet. clicar CTRL+Shift+SetaParaDireita e Formatar-Coluna-Ocultar.Hidden = True ' oculta colunas Range("G:IV). A primeira é do Acis: Sub Congela_area() Worksheet("Plan 1").Linha (ou Coluna) . crie uma função com a mesma sintaxe. use o mesmo procedimento (lembrar que as colunas vão até a coluna IV): selecionar a coluna H. basta selecionar a última linha (ou coluna) em exibição e Formatar .EntireColumn.ScrollArea = "A1:G115" Range("A1"). substituindo TRUE por FALSE. Para reexibir.EntireRow.Select Selection.Para fazer o mesmo com a s colunas. Neste caso temos duas formas. .

You're Reading a Free Preview

Descarregar
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->