Você está na página 1de 15

Gabarito das atividades

Sesso de Aprendizagem 06: Resoluo de problemas


Atividade 6.1 Rede1_Sessao6_ADR8

Vamos configurar a rede da esquerda primeiro. Vamos configurar a sesso eBGP entre os
roteadores ROTA e border1, conforme mostrado na listagem a seguir.
ROTA# conf t
ROTA(config)# router
ROTA(config-router)#
ROTA(config-router)#
ROTA(config-router)#
ROTA(config-router)#
ROTA# conf t
ROTA(config)# router
ROTA(config-router)#
ROTA(config-router)#
ROTA#

bgp 64500
network 200.130.24.0/22
neighbor 172.31.10.2 remote-as 64501
neighbor 172.31.10.2 desc sessao eBGP com border1
^Z
ospf
redistribute bgp
^Z

Observe que o ROTA anuncia apenas o bloco 200.130.24.0/22 que engloba as 4 redes dos
usurios. Para que o enlace BGP entre os dois ASs funcione, vamos configurar em seguida o
border1.
border1# conf t
border1(config)# router
border1(config-router)#
border1(config-router)#
border1(config-router)#
border1(config-router)#
border1(config router)#
border1(config-router)#
border1# conf t
border1(config)# router
border1(config-router)#
border1(config-router)#
border1#

bgp 64501
network 10.0.0.0/24
network 10.0.1.0/24
network 192.168.10.0/24
neighbor 172.31.10.1 remote-as 64500
neighbor 172.31.10.1 desc sessao eBGP com ROTA
^Z
ospf
redistribute bgp
^Z

Observe que redistribumos as rotas BGP para o protocolo OSPF, o que simplifica bastante a
configurao. Como se tratam de dois ASs privados, isto no causa problemas nas tabelas
de roteamento. O border1 anuncia somente as redes dos seus usurios para o vizinho.
Para conferir se todas as rotas foram aprendidas por ambos os roteadores, vamos listar a
tabela de rotas do ROTA e do border1, conforme mostrado a seguir.
ROTA# sh ip route
Codes: K-kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3

B>* 10.0.0.0/24 [20/0] via 172.31.10.2, eth2, 00:01:07


B>* 10.0.1.0/24 [20/0] via 172.31.10.2, eth2, 00:01:07
B>* 10.0.31.0/28 [20/1] via 172.31.10.2, eth2, 00:01:07
B>* 10.0.31.16/28 [20/1] via 172.31.10.2, eth2, 00:01:07
B>* 10.0.31.33/32 [20/1] via 172.31.10.2, eth2, 00:01:07
C>* 127.0.0.0/8 is directly connected, lo
O
172.31.10.0/24 [110/10] is directly connected, eth2, 00:05:09
C>* 172.31.10.0/24 is directly connected, eth2
O
192.168.0.0/24 [110/10] is directly connected, eth0, 00:05:14
C>* 192.168.0.0/24 is directly connected, eth0
O
192.168.1.0/24 [110/10] is directly connected, eth3, 00:05:14
C>* 192.168.1.0/24 is directly connected, eth3
O
192.168.2.0/24 [110/10] is directly connected, eth1, 00:05:14
C>* 192.168.2.0/24 is directly connected, eth1
B>* 192.168.10.0/24 [20/0] via 172.31.10.2, eth2, 00:01:07
O>* 200.130.24.0/24 [110/20] via 192.168.0.1, eth0, 00:04:31
O>* 200.130.25.0/24 [110/20] via 192.168.0.2, eth0, 00:04:31
O>* 200.130.26.0/24 [110/20] via 192.168.1.2, eth3, 00:04:26
O>* 200.130.27.0/24 [110/20] via 192.168.2.2, eth1, 00:04:21
ROTA#
border1# sh ip route
Codes: K-kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
0>* 10.0.0.0/24 [110/20] via 10.0.31.19, eth0, 00:04:52
*
via 10.0.31.3, eth1, 00:04:52
* 10.0.1.0/24 [110/20] via 10.0.31.20, eth0, 00:04:55
*
via 10.0.31.4, eth1, 00:04:55
O
10.0.31.0/28 [110/10] is directly connected, eth1, 00:05:38
C>* 10.0.31.0/28 is directly connected, eth1
O
10.0.31.16/28 [110/10] is directly connected, eth0, 00:05:43
C>* 10.0.31.16/29 is directly connected, oth0
C>* 10.0.31.33/32 is directly connected, lo
C>* 127.0.0.0/8 is directly connected, lo
C>* 172.31.10.0/24 is directly connected, eth2
B>* 192.168.0.0/24 [20/1] via 172.31.10.1, eth2, 00:01:26
B>* 192.168.1.0/24 [20/1] via 172.31.10.1, eth2, 00:01:26
B>* 192.168.2.0/24 [20/1] via 172.31.10.1, eth2, 00:01:26
B>* 200.130.24.0/22 [20/0] via 172.31.10.1, eth2, 00:01:26
border1#
Para confirmar os anncios de rotas BGP entre os dois roteadores, vamos usar os comandos
listados a seguir.
ROTA# sh ip bgp neighbors 172.31.10.2 advertised-routes
BGP table version is 0, local router ID is 192.168.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i-internal
r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
Metric LocPrf Weight Path
*> 172.31.10.0/24
172.31.10.1
1
32768 ?
*> 192.168.0.0
172.31.10.1
1
32768 ?
*> 192.168.1.0
172.31.10.1
1
32768 ?
*> 192.168.2.0
172.31.10.1
1
32768 ?
*> 200.130.24.0/22
172.31.10.1
0
32768 i
Total number of prefixes 5
ROTA# sh ip bgp neighbors 172.31.10.2 routes
BGP table version is 0, local router ID is 192.168.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i-internal
r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
Metric LocPrf Weight Path
*> 10.0.0.0/24
172.31.10.2
0
0 64501 i
*> 10.0.1.0/24
172.31.10.2
0
0 64501 i
*> 10.0.31.0/28
172.31.10.2
1
0 64501 ?

*> 10.0.31.16/28
172.31.10.2
*> 10.0.31.33/32
172.31.10.2
* 172.31.10.0/24
172.31.10.2
*> 192.168.10.0
172.31.10.2
Total number of prefixes 7
ROTA#

1
1
1
0

0
0
0
0

64501
64501
64501
64501

?
?
?
i

border1# sh ip bgp neighbors 172.31.10.1 advertised-routes


BGP table version is 0, local router ID is 10.0.31.33
Status codes: s suppressed, d damped, h history, * valid, > best, i-internal
r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
Metric LocPrf Weight Path
*> 10.0.0.0/24
172.31.10.2
0
32768 i
*> 10.0.1.0/24
172.31.10.2
0
32768 i
*> 10.0.31.0/28
172.31.10.2
1
32768 ?
*> 10.0.31.16/28
172.31.10.2
1
32768 ?
*> 10.0.31.33/32
172.31.10.2
1
32768 ?
*> 172.31.10.0/24
172.31.10.2
1
32768 ?
*> 192.168.10.0
172.31.10.2
0
32768 i
Total number of prefixes 7
border1# sh ip bgp neighbors 172.31.10.1 routes
BGP table version is 0, local router ID is 10.0.31.33
Status codes: s suppressed, d damped, h history, * valid, > best, i-internal
r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
Metric LocPrf Weight Path
* 172.31.10.0/24
172.31.10.1
1
0 64500 ?
*> 192.168.0.0
172.31.10.1
1
0 64500 ?
*> 192.168.1.0
172.31.10.1
1
0 64500 ?
*> 192.168.2.0
172.31.10.1
1
0 64500 ?
*> 200.130.24.0/22
172.31.10.1
0
0 64500 i
Total number of prefixes 5
border1#
O primeiro comando mostra as rotas anunciadas pelo roteador para o seu vizinho e o
segundo comando os anncios de rotas recebidas do vizinho. Veja que so compatveis: o
que um anuncia o outro recebe e vice-versa.
Os demais roteadores devem ter aprendido todas as rotas tambm, por exemplo, os
roteadores ROT1 e core1, conforme listado a seguir.
ROT1# sh ip route
Codes: K-Kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
O>* 10.0.0.0/24 [110/20] via 192.168.0.3, eth1, 01:36:49
O>* 10.0.1.0/24 [110/20] via 192.168.0.3, eth1, 01:36:49
O>* 10.0.31.0/28 [110/20] via 192.168.0.3, eth1, 01:36:49
O>* 10.0.31.16/28 [110/20] via 192.168.0.3, eth1, 01:36:49
O>* 10.0.31.33/32 [110/20] via 192.168.0.3, eth1, 01:36:49
C>* 127.0.0.0/8 is directly connected, lo
O>* 172.31.10.0/24 [110/20] via 192.168.0.3, eth1, 01:40:13
O
192.168.0.0/24 [110/10] is directly connected, eth1, 01:40:55
C>* 192.168.0.0/24 is directly connected, eth1
O>* 192.168.1.0/24 [110/20] via 192.168.0.3, eth1, 01:40:13
O>* 192.168.2.0/24 [110/20] via 192.168.0.3, eth1, 01:40:13
O>* 192.168.10.0/24 [110/20] via 192.168.0.3, eth1, 01:36:49
O
200.130.24.0/24 [110/10] is directly connected, eth0, 01:41:00
C>* 200.130.24.0/24 is directly connected, eth0
O>* 200.130.25.0/24 [110/20] via 192.168.0.2, eth1, 01:40:14
O>* 200.130.26.0/24 [110/30] via 192.168.0.3, eth1, 01:40:08
O>* 200.130.27.0/24 [110/30] via 192.168.0.3, eth1, 01:40:02
ROT1#
core1# sh ip route

Codes: K-Kernel route, C-connected, S-static, R-RIP, 0-OSPF,


I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
O
10.0.0.0/24 [110/10] is directly connected, eth2, 01:43:19
C>* 10.0.0.0/24 is directly connected, eth2
O>* 10.0.1.0/24 [110/20] via 10.0.31.4, eth0, 01:42:34
*
via 10.0.31.20, eth1, 01:42:34
O
10.0.31.0/28 [110/10] is directly connected, eth0, 01:42:37
C>* 10.0.31.0/28 is directly connected, eth0
O
10.0.31.16/28 [110/10] is directly connected, eth1, 01:42:34
C>* 10.0.31.16/28 is directly connected, eth1
C>* 10.0.31.35/32 is directly connected, lo
C>* 127.0.0.0/8 is directly connected, lo
O>* 192.168.0.0/24 [110/20] via 10.0.31.1, eth0, 01:38:37
*
via 10.0.31.17, eth1, 01:38:37
O>* 192.168.1.0/24 [110/20] via 10.0.31.1, eth0, 01:38:37
*
via 10.0.31.17, eth1, 01:38:37
O>* 192.168.2.0/24 [110/20] via 10.0.31.1, eth0, 01:38:37
*
via 10.0.31.17, eth1, 01:38:37
O>* 200.130.24.0/22 [110/20] via 10.0.31.1, eth0, 01:38:37
*
via 10.0.31.17, eth1, 01:38:37
core1#
Observe que todas as rotas so do protocolo OSPF, que recebeu as rotas BGP por
redistribuio.
Neste ponto devemos ter conectividade entre os ASs, como podemos verificar atravs do
comando ping do PC1 para alguns endereos do AS vizinho, conforme mostrado a seguir.
root@PC1:/tmp/pycore.58994/PC1.conf# ping 10.0.1.2
PING 10.0.1.2 (10.0.1.2) 56(84) bytes of data.
64 bytes from 10.0.1.2: icmp_req=1 ttl=60 time=0.424 ms
64 bytes from 10.0.1.2: icmp_req=2 ttl=60 time=0.894 ms
^C
--- 10.0.1.2 ping statistics --2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.424/0.659/0.894/0.235 ms
root@PC1:/tmp/pycore.58994/PC1.conf# ping 192.168.10.2
PING 192.168.10.2 (192.168.10.2) 56(84) bytes of data.
From 172.31.10.2 icmp_seq=1 Destination Net Unreachable
From 172.31.10.2 icmp_seq=2 Destination Net Unreachable
^C
--- 192.168.10.2 ping statistics
2 packets transmitted, O received, +2 errors, 100% packet loss, time 999ms
root@PC1:/tmp/pycore.58994/PC1.conf#
O ping para o endereo 192.168.10.2 falhou. Por qu?
Analisando melhor a tabela de rotas do core1, vemos que a rede 192.168.10.0/24 no
aparece na tabela. Isto um indcio de que o roteador border2 no est anunciando esta
rede. Realmente, verificando a configurao do border2, vemos que ele s anuncia as redes
10.0.31.0/28 e 10.0.3.16/28. Veja a listagem a seguir.
border2# sh run
Building configuration...
Current configuration:
!
interface eth0
ip address 10.0.31.18/28
ipv6 nd suppress-ra
!
interface eth1
ip address 10.0.31.2/28
ipv6 nd suppress-ra
!
interface eth2
ip address 192.168.10.1/24

ipv6 nd suppress-ra
!
interface lo
ip address 10.0.31.34/32
!
router bgp 64501
bgp router-id 10.0.31.34
redistribute connected
!
router ospf
ospf router-id 10.0.31.34
network 10.0.31.0/28 area 0.0.0.0
network 10.0.31.16/28 area 0.0.0.0
!
ip forwarding
ipv6 forwarding
!
line vty
!
end
border2#
Para corrigir isso, digite os seguintes comandos na console do border2.
border2# conf t
border2(config)# router ospf
border2(config-router)# network 192.168.10.0/24 area 0
border2(config-router)# ^Z
border2#
Com isso o border2 passa a anunciar a rede 192.168.10.0/24. O ping do PC1 agora funciona.
root@PC1:/tmp/pycore.58994/PC1.conf# ping 192.168.10.2
PING 192.168.10.2 (192.168.10.2) 56(84) bytes of data.
64 bytes from 192.168.10.2: icmp_req=1 ttl=60 time=13.5 ms
64 bytes from 192.168.10.2: icmp_req=2 ttl=60 time=0.619 ms
^C
--- 192.168.10.2 ping statistics --2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/av9/max/mdev = 0.619/7.080/13.542/6.462 ms
root@PC1:/tmp/pycore.58994/PC1.conf#
Podemos verificar que agora todos os roteadores esto com as tabelas de rotas completas.

Atividade 6.2 Rede2_Sessao6_ADR8

As seguintes correes devem ser feitas na configurao proposta aos alunos:


1. O Gateway padro do PC-01 deve ser: 10.10.10.1
2. O Gateway padro do PC-03 deve ser: 10.10.30.1
3. O Gateway padro do PC-02 deve ser: 10.10.20.1
4. O Gateway padro do PC-04 deve ser: 10.10.40.1
Essas correes podem ser feitas editando a configurao dos PCs atravs das opes
Configure/Services.../DefaultRoute (clicar no cone da ferramenta).
Apesar dessas correes, a tabela de rotas dos roteadores continua errada. O problema na
rede WAN 10.10.5.0/24 que serve de ponte entre as redes locais. O enlace entre os
roteadores Rot01 e Rot03 est correto, mas o enlace entre o Rot01 e o Rot02 NO pode usar
a mesma subrede. A soluo usar qualquer outra subrede ainda no usada, por exemplo, a
subrede 10.10.15.0/24, como mostrado na figura.
Observe que neste simulador a configurao do Rot01, feita em modo de Edio, aceita,
porm, em simuladores de roteadores Cisco e nos roteadores reais, dar uma mensagem de
erro acusando o overlap de endereos IP entre as interfaces eth1 e eth2.
Para corrigir isso, devem ser feitas as seguintes correes:
1. O endereo IP da interface eth2/Rot01 deve ser: 10.10.15.3/24
2. O endereo IP da interface eth2/Rot02 deve ser: 10.10.15.4/24
Essas correes devem ser feitas na tela de Configure e tambm na tela de Services.../zebra
(clicar no cone da ferramenta). Salvar o arquivo corrigido com outro nome.
Isso ainda no resolve o problema do Rot02, porque o protocolo RIP est configurado errado.
Se der o comando sh run, poder verificar que o comando network 10.10.5.0/24
est errado. O correto : network 0.0.0.0/0, como nos demais roteadores.
A correo pode ser feita de duas maneiras:

1. Parar o simulador e editar a configurao do Rot02, corrigindo o comando network


10.10.5.0/24 para network 0.0.0.0/0. Salvar o arquivo corrigido com outro
nome.
2. Abrir a console do Rot02 e digitar os comandos (no modo privilegiado):

#conf t
#router rip
#no network 10.10.5.0/24 (nega o comando errado)
#network 0.0.0.0/0 (comando correto)
#Ctrl-Z
A segunda maneira s vale enquanto estiver no modo de Execuo, pois no corrige o
arquivo de configurao Rede2_Sessao6_ADR8.imn.
Aps todas essas correes a tabela de rotas de todos os roteadores deve ficar semelhante
do Rot01, como listado a seguir.
Rot01# sh ip route
Codes: K-kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
C>* 10.10.5.0/24 is directly connected, eth1
C>* 10.10.10.0/24 is directly connected, eth0
C>* 10.10.15.0/24 is directly connected, eth2
R>* 10.10.20.0/24 [120/2] via 10.10.15.4, eth2, 00:00:14
R>* 10.10.30.0/24 [120/2] via 10.10.5.2, eth1, 00:02:32
R>* 10.10.40.0/24 [120/2] via 10.10.15.4, eth2, 00:00:14
C>* 127.0.0.0/8 is directly connected, lo
Rot01#
Agora os PCs podem se comunicar normalmente.

Atividade 6.3 Rede3_Sessao6_ADR8

As seguintes correes devem ser feitas na configurao proposta aos alunos:


1. O endereo IP do pc10 deve ser: 201.38.10.17/28
2. O endereo IP do pc20 deve ser: 201.38.10.55/28
3. O Gateway padro do pc20 deve ser: 201.38.10.50
4. O endereo IP do pc30 deve ser: 201.38.10.60/28
5. O endereo IP do pc40 deve ser: 201.38.10.90/28

6. O Gateway padro do pc40 deve ser: 201.38.10.81


7. O endereo IP da interface eth1/router0 deve ser: 201.38.10.33/28
8. O endereo IP da interface eth2/router1 deve ser: 201.38.10.65/28
9. O endereo IP da interface eth1/router2 deve ser: 201.38.10.70/28
10. O endereo IP da interface eth0/router2 deve ser: 201.38.10.81/28
Isso ainda no resolve o problema das tabelas de rotas, porque o protocolo RIP est
configurado errado. Em qualquer roteador, se der o comando sh run, poder verificar que
o comando network
201.38.10.0/28 est errado. O correto : network

201.38.10.0/24.
A correo pode ser feita de duas maneiras:
1. Parar o simulador e editar a configurao dos roteadores, corrigindo o comando
network 201.38.10.0/28 para network 201.38.10.0/24. Salvar o arquivo
corrigido com outro nome.
2. Abrir a console de cada roteador e digitar os comandos (no modo privilegiado):
#config t
#router rip
#no network 201.38.10.0/28 (nega o comando errado)
#network 201.38.10.0/24 (comando correto)
#Ctrl-Z
A segunda maneira s vale enquanto estiver no modo de Execuo, pois no corrige o
arquivo de configurao Rede3_Sessao6_ADR8.imn.
Aps todas essas correes a tabela de rotas de todos os roteadores deve ficar semelhante
do router0, como listado a seguir.
router0# sh ip route
Codes: K-kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
C>* 127.0.0.0/8 is directly connected, lo
C>* 201.38.10.16/28 is directly connected, eth0
C>* 201.38.10.32/28 is directly connected, eth1
R>* 201.38.10.48/28 [120/2] via 201.38.10.40, eth1, 00:00:56
R>* 201.38.10.64/28 [120/2] via 201.38.10.40, eth1, 00:01:08
R>* 201.38.10.80/28 [120/3] via 201.38.10.40, eth1, 00:00:52
router0#
Agora os PCs podem se comunicar normalmente.

Atividade 6.4 Rede4_Sessao6_ADR8

O endereamento IP da rede do provedor est errado. Supondo que se deseja economizar


endereos IP do backbone do provedor, deve-se atribuir o menor nmero de endereos IP
possvel rota que o cliente vai usar.
Como vamos precisar de apenas dois endereos IP nas sub-redes usadas para cada enlace
de roteador, deve-se usar a mscara 255.255.255.252 (/30) para as sub-redes que sero
usadas. Sero necessrias, portanto, as seguintes 6 sub-redes:
1.
2.
3.
4.
5.
6.

131.100.10.4/30 no enlace router0/router1 (endereos disponveis: 5 e 6);


131.100.10.8/30 no enlace router1/router2 (endereos disponveis: 9 e 10);
131.100.10.12/30 no enlace router1/router3 (endereos disponveis: 13 e 14);
131.100.10.16/30 no enlace router2/router4 (endereos disponveis: 17 e 18);
131.100.10.20/30 no enlace router3/router4 (endereos disponveis: 21 e 22);
131.100.10.24/30 no enlace router4/router5 (endereos disponveis: 25 e 26).

As interfaces dos roteadores devem ser corrigidas de acordo com o esquema acima.
Alm disso, preciso corrigir a configurao do protocolo RIP que est errada.
A configurao correta :
1. No router0: network 172.16.10.0/24 e network 131.100.10.0/24;
2. Nos roteadores router1, router2, router3 e router4: network 131.100.10.0/24;
3. No router5: network 192.168.10.0/24 e network 131.100.10.0/24.
Finalmente, preciso corrigir os endereos dos Gateway padro de ambos os pcs:
1. O Gateway padro do pc10 deve ser: 172.16.10.254;
2. O Gateway padro do pc20 deve ser: 192.168.10.254.
As tabelas de rotas dos roteadores devem estar atualizadas, conforme est mostrado na
listagem a seguir para os roteadores router0 e router5.
router0# sh ip route
Codes: K-kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
C>* 127.0.0.0/8 is directly connected, lo
C>* 131.100.10.4/30 is directly connected, eth1
R>* 131.100.10.8/30 [120/2] via 131.100.10.6, eth1, 00:00:41
R>* 131.100.10.12/30 [120/2] via 131.100.10.6, eth1, 00:00:41
R>* 131.100.10.16/30 [120/3] via 131.100.10.6, eth1, 00:00:39
R>* 131.100.10.20/30 [120/3] via 131.100.10.6, eth1, 00:00:36
R>* 131.100.10.24/30 [120/4] via 131.100.10.6, eth1, 00:00:36
C>* 172.16.10.0/24 is directly connected, eth0
R>* 192.168.10.0/24 [120/5] via 131.100.10.6, eth1, 00:00:20
router0#

router5# sh ip route
Codes: K-kernel route, C-connected, S-static, R-RIP, 0-OSPF,
I-ISIS, B-BGP, >-selected route, *-FIB route, o-OSPFv3
C>* 127.0.0.0/8 is directly connected, lo
R>* 131.100.10.4/30 [120/4] via 131.100.10.25, eth1, 00:00:50
R>* 131.100.10.8/30 [120/3] via 131.100.10.25, eth1, 00:00:25
R>* 131.100.10.12/30 [120/3] via 131.100.10.25, eth1, 00:00:23
R>* 131.100.10.16/30 [120/2] via 131.100.10.25, eth1, 00:00:50
R>* 131.100.10.20/30 [120/2] via 131.100.10.25, eth1, 00:00:50
C>* 131.100.10.24/30 is directly connected, eth1
R>* 172.16.10.0/24 [120/5] via 131.100.10.25, eth1, 00:00:36
C>* 192.168.10.0/24 is directly connected, eth0
router5#
Finalmente, podemos testar a continuidade entre os pc10 e pc20.
root@pc10:/tmp/pycore.58994/pc10.conf# ping -c 2 192.168.10.1
PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
64 bytes from 192.168.10.1: icmp_req=1 ttl=59 time=19.9 ms
64 bytes from 192.168.10.1: icmp_req=2 ttl=59 time=0.314 ms
--- 192.168.10.1 ping statistics --2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/av9/max/mdev = 0.314/10.133/19.953/9.820 ms
root@pc10:/tmp/pycore.58994/pc10.conf#
Resposta da questo especial:
O router1 pensa que est na rede 131.100.10.8/29. Assim, a sua interface eth0 com endereo
IP 131.100.10.10/29 vlida, bem como a interface eth1/router0 com o endereo IP
131.100.10.9/29. As interfaces eth1 e eth2 do router1 esto com endereos que fazem
overlap com o endereo da interface eth0 e, portanto, no so vlidas.
Quando executado o comando ping 131.100.10.15 (endereo IP da interface
eth0/router3), a interface no alcanada por causa do problema com o endereo da interface
eth2/router1 descrito acima. At a tudo bem (so far, so good ).
Acontece que a rede 131.100.10.8/29 tem como endereo de broadcast o endereo IP
131.100.10.15 (a prxima sub-rede seria a 131.100.10.16/29). Ento a nica interface vlida
a interface eth1/router0 com o endereo IP 131.100.10.9/29.

Atividade 6.5 Rede5_Sessao6_ADR8

A rede acima composta de 4 redes locais: 172.16.10.0/24, 172.16.20.0/24, 172.16.30.0/24 e


172.16.40.0/24, onde os equipamentos das redes locais so representados pelos pc1, pc2, pc3
e pc4, respectivamente.
Os problemas apresentados so devido configurao de rotas errada. Veja as rotas que esto
configuradas nos roteadores e os comentrios correspondentes.
As rotas do roteador R0 esto mostradas na tabela ao lado.
Ele anuncia a rede 40 pelo RIP, mas no anuncia as demais
redes que ele conhece. A rota esttica para a rede 20 est
apontando para a interface eth1 de R2, que no o melhor
caminho. Idem para a rede 30. Na verdade, houve um
engano, pois as rotas esto trocadas.

As rotas do roteador R1 esto mostradas na tabela ao lado.


Ele anuncia a rede 20 pelo RIP, mas no anuncia as demais
redes que ele conhece. A rota esttica para a rede 30 est
apontando para a interface eth2 de R0, que no o melhor
caminho. Idem para a rede 40. Na verdade, houve um
engano, pois as rotas esto trocadas.

As rotas do roteador R2 esto mostradas na tabela ao lado.


A rota esttica para a rede 20 est apontando para a
interface eth1 de R0, o que est correto. A rota para a rede
40 no faz sentido, uma vez que ela est diretamente
conectada.
Os problemas apresentados podem ser corrigidos de vrias maneiras. Uma delas apagar
todas as rotas RIP e estticas e configurar rotas estticas corretamente, conforme mostrado a
seguir.

Agora todos os PCs se comunicam sem problemas e pelo melhor caminho.

Atividade 6.6 Rede6_Sessao6_ADR8

Vamos primeiro calcular as sub-redes dos enlaces entre roteadores. A mscara que permite a
maior economia possvel de endereos IP num enlace entre dois roteadores a /30
(255.255.255.252). Abaixo uma tabela dos enlaces entre roteadores e respectivas sub-redes
(uma das possveis solues).
Enlace

Sub-rede

1 endereo

2 endereo

R0
R1

192.168.10.0/30

eth1/R0: 192.168.10.1

eth0/R1: 192.168.10.2

R0
R2

192.168.10.4/30

eth2/R0: 192.168.10.5

eth0/R2: 192.168.10.6

R1
R2

192.168.10.8/30

eth1/R1: 192.168.10.9

eth1/R2:
192.168.10.10

R2
R3

192.168.10.12/3
0

eth2/R2:
192.168.10.13

eth0/R3:
192.168.10.14

R3
R4

192.168.10.16/3
0

eth1/R3:
192.168.10.17

eth1/R4:
192.168.10.18

R3
R5

192.168.10.20/3
0

eth2/R3:
192.168.10.21

eth0/R5:
192.168.10.22

R5
R6

192.168.10.24/3
0

eth1/R5:
192.168.10.25

eth1/R6:
192.168.10.26

R6
R7

192.168.10.28/3
0

eth0/R6:
192.168.10.29

eth1/R7:
192.168.10.30

R7
R8

192.168.10.32/3
0

eth0/R7:
192.168.10.33

eth1/R8:
192.168.10.34

Duas maneiras possveis de fazer essa configurao:


1. No Modo de Edio, opo Configure, na tela que se abre digitar os endereos. A
vantagem deste mtodo que uma vez salvo o arquivo de configurao, podemos rodar
o experimento vrias vezes sem ter que reconfigurar as interfaces dos roteadores.
2. No Modo de Execuo, digitar na console de cada roteador os comandos de
configurao mostrados a seguir (exemplo do roteador R0):
R0# conf t
R0(config)# int eth1
R0(config-if)# ip address 192.168.10.1/30
R0(config-if)# no shut
R0(config-if)# int eth2
R0(config-if)# ip address 192.168.10.5/30
R0(config-if)# no shut
R0(config-if)# ^Z
R0#
A desvantagem deste mtodo que a configurao s tem validade enquanto rodar o
experimento. Se pararmos o experimento, todas as configuraes sero perdidas.
Se voc usou o primeiro mtodo (recomendado), salve a configurao com outro nome.
Em seguida vamos configurar os protocolos de roteamento.
1. Configurao do roteador R0.
R0# conf t
R0(config)# router
R0(config-router)#
R0(config-router)#
R0(config-router)#
R0#

ospf
network 192.168.10.0/30 area 1
network 192.168.10.4/30 area 1
^Z

2. Configurao do roteador R1.


R1# conf t
R1(config)# router
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1#

ospf
network 192.168.10.0/30 area 1
network 192.168.10.8/30 area 1
^Z

3. Configurao do roteador R2.


R2# conf t
R2(config)# router
R2(config-router)#
R2(config-router)#
R2(config-router)#
R2(config-router)#
R2(config-router)#
R2#

ospf
router-id 192.168.10.6
network 192.168.10.4/30 area 1
network 192.168.10.8/30 area 1
network 192.168.10.12/30 area 0
^Z

4. Configurao do roteador R3.


R3# conf t
R3(config)# router ospf
R3(config-router)# router-id 192.168.10.21

R3(config-router)#
R3(config-router)#
R3(config-router)#
R3(config-router)#
R3# conf t
R3(config)# router
R3(config-router)#
R3(config-router)#
R3#

redistribute rip
network 192.168.10.12/30 area 0
network 192.168.10.20/30 area 0
^Z
rip
network 192.168.10.16/30
^Z

5. Configurao do roteador R4.


R4# conf t
R4(config)# router
R4(config-router)#
R4(config-router)#
R4(config-router)#
R4#

rip
network 200.130.26.0/24
network 192.168.10.16/30
^Z

6. Configurao do roteador R5.


R5# conf t
R5(config)# router
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5# conf t
R5(config)# router
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5(config-router)#
R5#

ospf
router-id 192.168.10.25
redistribute bgp
network 192.168.10.20/30 area 0
^Z
bgp 6500
bgp router-id 192.168.10.25
network 200.130.26.0/24
network 200.130.25.0/24
network 200.130.24.0/24
neighbor 192.168.10.26 remote-as 1900
neighbor 192.168.10.26 description sessao eBGP com R6
^Z

7. Configurao do roteador R6.


R6# conf t
R6(config)# router
R6(config-router)#
R6(config-router)#
R6(config-router)#
R6(config-router)#
R6# conf t
R6(config)# router
R6(config-router)#
R6(config-router)#
R6(config-router)#
R6(config-router)#
R6(config-router)#
R6#

ospf
router-id 192.168.10.29
network 192.168.10.28/30 area 0
redistribute bgp
^Z
bgp 1900
bgp router-id 192.168.10.29
network 200.130.27.0/24
neighbor 192.168.10.25 remote-as 6500
neighbor 192.168.10.25 description sessao eBGP com R5
^Z

8. Configurao do roteador R7.


R7# conf t
R7(config)# router
R7(config-router)#
R7(config-router)#
R7(config-router)#
R7(config-router)#
R7#

ospf
router-id 192.168.10.33
network 192.168.10.28/30 area 0
network 192.168.10.32/30 area 1
^Z

9. Configurao do roteador R8.


R8# conf t

R8(config)# router ospf


R8(config-router)# network 192.168.10.32/30 area 1
R8(config-router)# ^Z
R8#
10. Podemos testar agora a conectividade entre os PCs, conforme mostrado a seguir.
root@pc1:/tmp/pycore.58994/pc1.conf# ping -c 2 200.130.25.2
PING 200.130.25.2 (200.130.25.2) 56(84) bytes of data.
64 bytes from 200.130.25.2: icmp_req=1 ttl=62 time=8.31 ms
64 bytes from 200.130.25.2: icmp_req=2 ttl=62 time=0.338 ms
--- 200.130.25.2 ping statistics --2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.338/4.328/8.319/3.991 ms
root@pc1:/tmp/pycore.58994/pc1.conf# ping -c 2 200.130.26.2
PING 200.130.26.2 (200.130.26.2) 56(84) bytes of data.
64 bytes from 200.130.26.2: icmp_req=1 ttl=60 time=16.5 ms
64 bytes from 200.130.26.2: icmp_req=2 ttl=60 time=0.360 ms
--- 200.130.26.2 ping statistics --2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 0.360/8.469/16.579/8.110 ms
root@pc1:/tmp/pycore.58994/pc1.conf# ping -c 2 200.130.27.2
PING 200.130.27.2 (200.130.27.2) 56(84) bytes of data.
64 bytes from 200.130.27.2: icmp_req=1 ttl=57 time=12.9 ms
64 bytes from 200.130.27.2: icmp_req=2 ttl=57 time=0.358 ms
--- 200.130.27.2 ping statistics --2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.358/6.646/12.935/6.289 ms
root@pc1:/tmp/pycore.58994/pc1.conf#