Você está na página 1de 9

Errata do Livro de Algoritmos e Lgica de Programao I 2014/2015

Pg. 19: Segunda linha do primeiro pargrafo desconsiderar a sequncia


aps ...processo de aprendizagem, e antes de Ascencio e Campos (2010)...:
+00000003.

Pg. 33: No pargrafo sobre Iniciando a formulao do algoritmo,...,


desconsiderar a expresso Quadro 64: Pseudocdigo Algoritmo registro
aluno. Considerar nova linha:
Algoritmo problema1
Em seguida, temos a declarao das variveis, que dada por:

Pg. 41: No existe a palavra Const na 4 linha. Onde diz phoraextra = 10


deveria ser phoraextra: inteiro.
Aps a palavra Incio, acrescentar uma linha com: phoraextra <- 100.

Pg. 44: O vdeo <http://www.brasilacademico.com.ed/testemesa.htm>, no


est disponvel.

Pg. 49: Faltam as setas de atribuio ( <- ) em 'fmensal' e 'fanual' e na ltima


linha diz 'faunal' ao invs de 'fanual'.
Em declarao de variveis, ao invs de inteiro est interio.

Pg. 51: A linha 7 est totalmente errada. Deveria ser:


perimetro <- 2 * Pi * r
area <- PI *(raio **2)
Em declarao de variveis, faltou vrgula (,) entre as variveis permetro e
raio.
Faltou fechar aspas no ltimo Escreva aps (O permetro : , ...).

Pg. 52: Em declarao de variveis, aps a palavra quadrado deveria ser dois
pontos (:) e no ponto e vrgula (;) como est. No algoritmo, na 9 linha onde
diz 'Quadrado <- sqrt(num)' deveria ser 'Quadrado <- sqr(num)'. Na 11 linha, o
correto : Escreva (A raiz quadrada : , raiz).

Pg. 61: No Quadro 29 est errado o cabealho: OPERADOR OU. O correto


OPERADOR NO.

Pg. 62: O algoritmo do Quadro 30 est com erros, segue abaixo o correto:
Algoritmo par
Var
n, resto: inteiro
metade : real
Incio
Escreva (Digite um nmero: )
Leia (n)
resto <- n mod2
Se (resto = 0) ento
Metade <- n/2
Escreva (A metade do nmero , metade)
Fim_se
Fim.
Pg. 63: No quarto pargrafo, a palavra essa est errada e o correto seria
Precisamos dessa....

Pg. 68: Na linha 13 do algoritmo deveria ser 'max <- a' ao invs de 'max <- b'.

Pg. 69: Na 17 linha, o primeiro a maisculo: A para a varivel max.

Pg. 71: No primeiro pargrafo, na 2 linha, a palavra escolha em negrito e


letra maiscula: Escolha. A sintaxe da estrutura deve ser substituda por:
Escolha <varivel>
caso <valor 1> escreva <instruo 1>
caso <valor 2> escreva <instruo 2>

caso <valor 3> escreva <instruo 3>


Fim_escolha
No segundo pargrafo, na 4 linha, a palavra Caso deve ser substituda por
Escolha; na 6 e 9 linhas, as palavras (fim_caso) devem ser substitudas por
(fim_escolha).

Pg. 72: No algoritmo, a palavra Caso deve ser substituda por Escolha; todas
as palavras Seja devem ser substitudas por Caso; a palavra Fim_caso deve
ser substituda por Fim_escolha.

Pg. 75: Na 15 linha a palavra correta aninhada e no aninha.

Pg. 81: Onde diz 'imc peso/sqn(altura)' o correto 'imc <- peso/sqr(altura)'

Pg. 84: retirar o 6. Antes da expresso x1=....

Pg. 84-85: O algoritmo tem muitos erros que o torna praticamente


incompreensvel. Segue abaixo o algoritmo corrigido:
Algoritmo raiz
Var
a, b, c, delta, x1, x2: real
Incio
Escreva ("Digite o valor de a: ")
Leia (a)
Escreva ("Digite o valor de b: ")
Leia (b)
Escreva ("Digite o valor de c: ")
Leia (c)
Se (a = 0) ento
Escreva ("No uma equao do segundo grau")
Seno
delta <- sqr (b) - 4 * a * c
Se (delta < 0) ento
Escreva ("No existe raiz real")
Seno
Se (delta = 0) ento
Escreva ("Existe raiz real")
x1 <- (-b) / (2 * a)
Escreva ("A raiz : ", x1)

Seno
Se (delta > 0) ento
Escreva ("Existem duas razes reais")
x1 <- (-b + sqrt(delta)) / (2 * a)
Escreva ("A raiz x1 : ", x1)
x2 <- (-b - sqrt(delta)) / (2 * a)
Escreva ("A raiz x2 : ", x2)
Fim_se
Fim_se
Fim_se
Fim_se
Fim

Pg. 90: No 5 pargrafo, na 8 linha, onde est escrito faixa1 o correto


faixa 1.

Pg. 92: No pargrafo Agora que voc..., na 4 linha, a palavra databuada


est escrita errada, o correto da tabuada.

Pg. 94: No Quadro 45, na 8 linha, leia-se:


mult <- num * i

Pg. 96: Onde est escrito Escreva (num, x, i, =, mult*i) o correto


Escreva (num, x, i, =, num*i).

Pg. 98: Na 7 linha do algoritmo faltou acrescentar o recebe: cont <- 0.

Pg. 100: Nas linhas 7 e 10 do algoritmo faltou acrescentar o recebe:


cont <- 0
cont <- cont +1.

Pg. 103: Nas linhas 5 e 10 do algoritmo faltou acrescentar o recebe:

cont <- 0
cont <- cont +1.

Pg. 108: Nas linhas 8 e 10 do algoritmo faltou acrescentar o recebe:


fat <- 1
fat <- fat * cont.

Pg. 111: No algoritmo, na linha 9, onde est escrito aprovadas, leia-se


aprovados; na linha 10, onde est escrito reprovada, leia-se reprovados. O
Fimpara e o Fim-se leia-se Fim_para e Fim_se.

Pg. 112: No algoritmo, na primeira linha, leia-se fim_enquanto; no algoritmo


do Quadro 52, na ltima linha, leia-se aprovados.

Pg. 113: No algoritmo, na primeira linha, leia-se reprovados; o Fimpara e o


Fim-se leia-se Fim_para e Fim_se.

Pg. 115: O vdeo <http://youtube.com/watch?v=av5T0y6rwdk>, no est


disponvel.

Pg. 116: No exerccio de fixao N 1, o objetivo do algoritmo est errado, o


correto : ler um nmero de vezes que se deseja imprimir a palavra
ALGORITMOS.

Pg. 117: Na atividade 2, no algoritmo, est faltando o recebe na 5 e 6 linhas:


npares <- 0
nimpares <- 0

Pg. 118: Na atividade 2, no algoritmo, est faltando o recebe na 2 e 4 linhas:


npares <- npar + 1

nimpares <- nimpar + 1


Na atividade 3, no algoritmo, est faltando o recebe na 5 e 9 linhas:
qtdade <- 0
qtdade <- qtdade + 1

Pg. 120: No algoritmo, no Fim-enquanto, o correto Fim_enquanto.

Pg. 121: Todos os quatro Fim-se devem-se escrever: Fim_Se.

Pg. 133: No algoritmo, na 5 linha, leia-se:


media[cont] <- (n1[cont] + n2[cont] + n3[cont] + n4[cont])/4

Pg. 141: No algoritmo, na 10 linha, leia-se:


acha <- verdadeiro

Pg. 142: Na Figura 34, onde se l x [4,1] e x [3,2] leia-se x [1,4] e x [2,3],
pois primeiro deve se ler a linha para depois a coluna.

Pg. 144: O algoritmo est com erros que o torna praticamente


incompreensvel. Segue abaixo o algoritmo correto:

Algoritmo media
Var
media: vetor[1..20] de real
notas: vetor[1..20, 1...4] de real
somat, soma, mediat: real
i, j : inteiro
Incio
somat <- 0
soma <- 0
Para i de 1 at 20 passo 1 faa
Para j de 1 at 4 passo 1 faa

Escreva (Informe a nota, j, do aluno i)


Leia (notas[i,j])
soma <- soma + notas[i,j]
Fim_para
media[i] <- soma/4
somat <- somat + soma
soma <- 0
Fim_para
mediat <- somat/20
Para i de 1 at 20 passo 1 faa
Escreva (A mdia do aluno, i, :, media[i])
Fim_para
Escreva (A mdia da turma :, mediat)
Fim

Pg. 145: Na 7 linha, a palavra Para deve ser em negrito.

Pg. 151: O algoritmo do Quadro 67 est com erros que o torna praticamente
incompreensvel. Segue abaixo o algoritmo correto:
Algoritmo registroproduto
Tipo
Cad_produto = registro
codigo: inteiro
nome: caractere[30]
preco: real
saldo: inteiro
Fim_registro
Var
produto: vetor [1..10] de Cad_produto
i, codigo: inteiro
acha: logico
resp: caractere[3]
Incio
Para i de 1 at 20 faa
Escreva ("Informe cdigo do produto: ")
Leia (produto[i].codigo)
Escreva ("Informe a descrio do produto: ")
Leia (produto[i].nome)
Escreva ("Informe o preo do produto: ")
Leia (produto[i].preco)
Escreva ("Informe o saldo em estoque do produto: ")
Leia (produto[i].saldo)
Fim_para
resp <- "sim"
Enquanto (resp = "sim") faa

Escreva ("Informe o cdigo a ser pesquisado: ")


Leia (codigo)
i <- 1
acha <- falso
Enquanto (i <= 20) e (acha = falso) faa
Se (produto[i].codigo = codigo) ento
acha <- verdadeiro
Seno
i <- i + 1
Fim_se
Fim_enquanto
Se (acha = verdadeiro) ento
acha <- falso
Escreva ("O preo : ", produto[i].preco)
Escreva ("O saldo em estoque : ", produto[i].saldo)
Seno
Escreva ("No h produto com o cdigo informado")
Fim_se
Escreva ("Deseja continuar a pesquisa?")
Leia (resp)
Fim_enquanto
Fim.

Pg. 158: No algoritmo, na 18 linha, faltou o recebe:


C <- A[i, j] B [i, j]

Pg. 159: Onde est escrito: Objetivo do algoritmo: ler informaes sobre 20
contatos e realizar consulta-zelo nome, leia-se: Objetivo do algoritmo: ler
informaes sobre 20 contatos e realizar consulta pelo nome.

Pg. 170: No algoritmo, na 12 linha, faltou o recebe:


opco <- 0

Pg. 171: No 6 pargrafo, na 3 linha, onde est escrito: ..., temos a rotina 2.1
Observe que a rotina..., leia-se: ..., temos a rotina 2.1. Observe que a
rotina....

Pg. 172: O pargrafo abaixo est repetido e est faltando um ponto final aps
a rotina 2.1 (em vermelho):

Em relao sub-rotina 2 temos que as variveis A e B so globais para a


rotina 2.1. A varivel M declarada na rotina 2 uma varivel global para a
rotina 2.1, que possui uma varivel X que local e no apresenta nenhuma
relao com a varivel X definida na rotina 1.

Pg. 175: Na 8 linha do algoritmo est faltando o recebe:


fat <- fat * i

Pg. 177: No algoritmo, na 7 linha, onde est escrito Fabiana(n, resultado),


leia-se: fatorial(n, resultado).

Pg. 178: No algoritmo, na 4 linha, est faltando a varivel fat; na 8 linha est
faltando o recebe:
fat <- fat * i

Pg. 179: No algoritmo, na 5 linha, est faltando o recebe:


Resultado <- Fatorial(n)

Pg. 180: No algoritmo, na 7 linha, o correto seria:


retorne x * fatorial (x - 1)

Pg. 186: O vdeo no Saiba Mais no est disponvel.

Pg. 188: No algoritmo, na 8 linha, est faltando o recebe:


total <- total + i