Você está na página 1de 4

27/10/2016

[DICA] 32 ­ MIKROTIK ­ BONDING ­ Agregar múltiplos Enlaces

Novidades Fóruns Galeria FAQ FaleConosco Busca Registre­se NovosPosts FAQ Calendario Comunidade
Novidades
Fóruns
Galeria
FAQ
FaleConosco
Busca
Registre­se
NovosPosts FAQ Calendario Comunidade
OpçõesdosFóruns
LinksRápidos
FAQ Calendario Comunidade OpçõesdosFóruns LinksRápidos Blogs interhome

Blogs interhome [DICA]32­MIKROTIK­BONDING­AgregarmúltiplosEnlaces

interhome

interhome + CriarBlog [DICA] 32 ­ MIKROTIK ­ BONDING ­ Agregar

[DICA] 32 ­ MIKROTIK ­ BONDING ­ Agregar múltiplos Enlaces

por

em05­12­2013às12:22(5898Visualizações)

Introdução

Através do BONDING no MIKROTIK, podemos agregar múltiplas interfaces de rede para alcançar mais produtividade com um maior nível de disponibilidade.

Principais tipos de bonding:

1. Balance­RR (Round Robin) – Forma genérica para dual LAN enviando pacotes de forma sequencial pelas placas, provendo bom balanço entre “load balancing” e tolerância à falhas.

2. Active Backup (failover) – Usa apenas uma das placas de rede durante todo o tempo e passa a usar a segunda em caso de falha da primeira (apenas tolerância a falhas).

3. Balance XOR – Ao longo do tempo mapeia algumas estações destino para placas específica fazendo a divisão de carga e da banda entre os acessos.

4. Broadcast – Envia o mesmo conjunto de pacotes pelas duas placas, serve para prover tolerância a falhas.

5. IEE 802.3ad Dynamic Link Agregation – Usa um algoritmo complexo para agregar a largura de banda usando a especificação 802.3ad. Exige suporte explícito do SWITCH para 802.3ad.

6. Balance­tlb Adaptive Transmit Load Balance – Equilibra a carga dinamicamente pela velocidade e volume de tráfego dos pacotes de SAÍDA (leituras). Não requer suporte especial do SWITCH. Atua trocando dinamicamente o endereço MAC no caso da placa destino não ser capaz de atender a solicitação provendo agregação e tolerância a falhas.

7. Balance­alb Adaptive Load Balance – similar ao Balance­tlb, mas também consegue redistribuir pacotes de ENTRADA (gravações) provendo agregação e tolerância a falhas.

Vamos discutir uma ligação dupla aqui, mas tenha em mente que mais links pode ser ligado para alcançar maior velocidade / disponibilidade.

A visualização do que estamos tentando realizar:

Requisitos

4

Ubiquiti Rádios A / B / G / N, dependendo da sua aplicação

2

roteadores Mikrotik com 2 portas Ethernet availible

4

Antenas e cabos apropriados (se estiver usando um dispositivo UBNT

que não tê­los incorporado) Verdadeira Layer 2 a conectividade entre os dois dispositivos Mikrotik em todos os links que serão utilizados no vínculo Isto pode ser conseguido por AP­WDS/STA­WDS nos dispositivos UBNT ou usando EOIP dentro software Mikrotik. Vamos discutir a abordagem WDS.

software Mikrotik. Vamos discutir a abordagem WDS. interhome IrparaPerfil MarcarcomoLido DatadeIngresso: Oct2008

DatadeIngresso:

Oct2008

Idade:

42

Posts:

1.057

PostsdeBlog:

15

PostsRecentesnosBlogs

09­07­201411:52

13­12­201316:40

06­12­201315:09

05­12­201312:22

03­12­201313:06 13:06

[DICA]9­UBIQUITI­TutorialComandosSSH ComentáriosRecentes HOTSPOT)+ipdoequipamento+Up_Time+

porint21

porjosir josir

poremsfalcao emsfalcao

<

 

D

S

T

Q

Q

S

S

25

26

27

28

29

30

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

1

2

3

4

5

27/10/2016

Configuração Dispositivos UBNT

[DICA] 32 ­ MIKROTIK ­ BONDING ­ Agregar múltiplos Enlaces

A1

 

1. Sob a guia sem fio, defina: Mode "Access Point WDS"

2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.11,

a

máscara de sub­rede para 255.255.255.0 e Gateway para 192.168.0.10

3. Dê ao dispositivo um nome descritivo e alterar a senha

A2

 

1. Sob a guia sem fio, defina: Mode "Access Point WDS"

2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.12,

a

máscara de sub­rede para 255.255.255.0 e Gateway para 192.168.0.10

3. Dê um nome ao dispositivo descritivo e alterar a senha

B1

 

1. Sob a guia sem fio, defina: Mode "Station WDS"

2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.21,

a

máscara de sub­rede para 255.255.255.0 e Gateway para 192.168.0.20

3. Dê ao dispositivo um nome descritivo e alterar a senha

B2

1. Sob a guia sem fio, defina: Mode "Station WDS"

2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.22,

a máscara de sub­rede para 255.255.255.0 e Gateway para 192.168.0.20

3. Dê ao dispositivo um nome descritivo e alterar a senha

Mikrotik engrenagem

Ligar para o seu router Mikrotik pode ser feito com Putty ou Winbox e está bem documentado na sua Wiki e manual . Este documento explica a configuração da linha de comando, que pode ser facilmente realizado com o Mikrotik GUI (WinBox). E para evitar confusão A1 vai para ether1 e A2 vai para ether2 eo mesmo para a outra torre, exceto substituir o A com um B. Router A

1. Faça o login no seu router Mikrotik

2. Criar uma interface de vinculação: Aqui você dizer o roteador que interfaces devem ser incluídos no vínculo. Nós vamos usar o modo round­robin, faça ether1 e ether2 os escravos e dar a interface de um nome de "bonding1". Os diferentes modos são explicados em Mikrotik Wiki / Bonding .

/interface bonding add slaves=ether1,ether2 name=bonding1 mode=balance­rr

3. Atribua um IP à interface de ligação. Nunca atribuir ip do que as próprias interfaces de escravos.

/ip address add address 192.168.0.10/24

interface=bonding1

4. Adicionar monitoramento de link para que o seu router sabe quando uma ligação está a ter um problema. Vamos usar ARP para monitoramento de link e dizer ao router para assistir a ARP em 192.168.0.20. Um explaniation dos diferentes tipos de monitoramento de link podem ser encontradas em Mikrotik Wiki / Bonding .

/interface bonding set bonding1 link­monitoring=arp

arp­ip­targets=192.168.0.20

Router B

27/10/2016

[DICA] 32 ­ MIKROTIK ­ BONDING ­ Agregar múltiplos Enlaces

1. Faça o login no seu router Mikrotik

2. Criar uma interface de vinculação: Aqui você dizer o roteador que interfaces devem ser incluídos no vínculo. Nós vamos usar o modo round­robin, faça ether1 e ether2 os escravos e dar a interface de um nome de "bonding1". Os diferentes modos são explicados em Mikrotik Wiki / Bonding .

/interface bonding add slaves=ether1,ether2 name=bonding1 mode=balance­rr

3. Atribua um IP à interface de ligação. Nunca atribuir ip do que as próprias interfaces de escravos.

NomedoUsuário

Senha

Conectar

/ip address add address 192.168.0.20/24

interface=bonding1

4. Adicionar monitoramento de link para que o seu router sabe quando uma ligação está a ter um problema. Vamos usar ARP para monitoramento de link e dizer ao router para assistir a ARP em 192.168.0.10. Um explaniation dos diferentes tipos de monitoramento de link podem ser encontradas em Mikrotik Wiki / Bonding .

/interface bonding set bonding1 link­monitoring=arp

arp­ip­targets=192.168.0.10

Prova

PesquisenoUnderLinux

PesquisenoUnderLinux

Precisamos testar e certificar­se o vínculo está funcionando. Siga estes passos para garantir que tudo está funcionando corretamente.

1. Faça o login no Router A

2. Execute um ping para o roteador B

/ping 192.168.0.20

3. Execute a ferramenta de teste de velocidade para Router B /tool bandwidth­test 192.168.0.20 direction=receive

status: running duration: 9s rx­current: 213.4Mbps rx­10­second­average: 69.4Mbps rx­total­average: 69.4Mbps lost­packets: 0 random­data: no direction: receive rx­size: 1500

Enquanto o speedtest está funcionando desligar um de seus éter do conectado ao seu engrenagem UBNT, você deve obter alguns pings perdidos depois ver algo semelhante ao seguinte. status: running duration: 8s rx­current: 93.3Mbps rx­10­second­average: 38.1Mbps rx­total­average: 38.1Mbps lost­packets: 0 random­data: no direction: receive rx­size: 1500

Conclusão

Um par de coisas que eu gostaria de salientar aqui. A largura de banda total realizável aqui é 2X a velocidade da ligação mais lenta.

Exemplo:

Vamos dizer que um elo faz 90 Mbit e o outro faz 80 Mbit seu rendimento total deve ser de cerca de 160 Mbit (80 x 2). A configuração de ligação descrito aqui é um link half­duplex. Bonding funcionará através de ligações multi­hop, enquanto há camada de 2 a conectividade entre os pontos finais que fazem a ligação.

27/10/2016

[DICA] 32 ­ MIKROTIK ­ BONDING ­ Agregar múltiplos Enlaces

­ Rebel2234 15:47, 23 de junho de 2010 (UTC)

REFERENCIAS:

(Geeek) . Acessado em 02/12/2013 as 19:59:00 http://wiki.ubnt.com/Mikrotik_bonding . Autor Rebel2234 15:47, 23 de junho de 2010 (UTC) . Acessado em 02/12/2013 as 19:59:00

Curtam nossa página. Obrigado.

inter­homesolucoes

NomedoUsuário

Senha

Conectar

Avalie nosso Post e nos ajude a continuar escrevendo. Obrigado.

Categorias:Artigos,Dicas,Tutoriais

Obrigado. Categorias: Artigos , Dicas , Tutoriais EnviarPostdeBlogporEmail PesquisenoUnderLinux « [

PesquisenoUnderLinux

PesquisenoUnderLinux
» Servidorespara BondingnoMikrotik Soluçõesderede

Comentários

Muito bom, e detalhado, parabéns pela iniciativaunder­linux.org under­linux.org Comentários netuai ­08­12­201311:40 Essa seria uma forma de dividir

netuai­08­12­201311:40

Essa seria uma forma de dividir travego ou seria mais uma forma de de evitar que a rede pare de vez?parabéns pela iniciativa netuai ­08­12­201311:40 wans1105 ­08­12­201322:01 + Enviar Comentário

wans1105­08­12­201322:01