Você está na página 1de 6

Problema 1

Problema 2

Problema 3
algoritmo "Km/h versus m/s"

// Funo :

// Autor : Abilio

// Data : 21/02/2017

// Seo de Declaraes

var

V:real

Res:real

inicio

V<-1228.0

Res<- V / 3.6

escreva("A Converso de 1.288,0 Km/h em m/s :" ,Res)

fimalgoritmo

Problema 4
algoritmo "Desconto"
// Funo : Desconto
// Autor : Abilio
// Data : 21/02/2017
// Seo de Declaraes
var
valor: real
inicio

escreval("Informe o valor da compra R$:")


leia(valor)
se(valor >= 250) entao
valor<- valor*0.2
escreva("O valor do desconto foi de R$",valor," reais")

senao
valor<- valor*0.15
escreva("O valor do desconto foi de R$",valor," reais")
fimse

fimalgoritmo

Problema 5

Problema 6
a)

algoritmo "NumerosParesExistentes"

// Funo : QuantidadeDosNumerosPares

// Autor : Abilio

// Data : 21/02/2017

// Seo de Declaraes

var

i, N, quant: inteiro
inicio

// Seo de Comandos

escreval("Informe o valor de N:")

leia(N)

quant<-0

para i de 0 ate N passo 2 faca

i<-1

quant<-quant+i

fimpara

escreval("A soma dos Nmeros Pares " ,quant)

fimalgoritmo

b)

algoritmo "SomaDosNumerosPares"

// Funo : SomaDosNumerosPares

// Autor : Abilio

// Data : 21/02/2017

// Seo de Declaraes

var

i, N, soma: inteiro

inicio

// Seo de Comandos

escreval("Informe um nmero:")

leia(N)

soma<-0

para i de 0 ate N passo 2 faca

soma<- soma + i

fimpara

escreval("A soma dos Nmeros Pares " ,soma)

fimalgoritmo

Problema 7
a)

algoritmo "SequenciadeFibonacci"

// Funo : Calcular os N primeiros termos da sequencia de Fibonacci

// Autor : Abilio

// Data : 21/02/2017

//Logica: A partir do terceiro nmero vai ser sempre a soma do seus anteriores.

var

anterior:inteiro

depois:inteiro

N:inteiro

inicio

//1,1,2,3,5,8,13,21,...

anterior<-0

depois<-1

escreval("Informe o valor de N:")

leia(N)

escreval("Sequencia de Fibonacci de 1 ",N)

escreva(depois)

enquanto depois<= N faca

depois<- anterior + depois

anterior<- depois - anterior

escreva(", ", depois)

fimenquanto

fimalgoritmo

b)
algoritmo "SequenciadeFibonacci"

// Funo : Calcular os N primeiros termos da sequencia de Fibonacci

// Autor : Abilio

// Data : 21/02/2017

//Logica: A partir do terceiro nmero vai ser sempre a soma do seus anteriores.

var

anterior:inteiro

depois:inteiro

N:inteiro

cont:inteiro

inicio

//1,1,2,3,5,8,13,21,...

anterior<-0

depois<-1

cont<- 1

escreval("Informe o valor do Termo:")

leia(N)

enquanto cont <> N faca

depois<- anterior + depois

anterior<- depois - anterior

cont<- cont + 1

fimenquanto

escreva("O Valor do Termo :",depois)

fimalgoritmo

Problema 8
algoritmo "ValordeS"

// Funo :Qual o valor contido na vriavel

// Autor : Abilio
// Data : 21/02/2017

var

A:inteiro

S:inteiro

inicio

A<-1

S<-0

enquanto A < 500 faca

S<- S + A

A<-A + 2

fimenquanto

escreva(S)

fimalgoritmo