Você está na página 1de 3

Algoritmo e estrutura de dados 05

Os nicos limites do homem so: o tamanho das suas ideias e o grau da sua dedicao.
(F. Veiga)

Roteiro
1. Operadores
2. Estruturas de controle: seleo
3. Exerccios

OPERADORES

Os operadores so meios pelo qual incrementamos, decrementamos, comparamos


e avaliamos dados dentro do computador. Temos trs tipos de operadores:
Operadores Aritmticos
Operadores Relacionais
Operadores Lgicos

OPERADORES ARITMTICOS

Os operadores aritmticos so os utilizados para obter resultados numricos. Alm


da adio, subtrao, multiplicao e diviso, podem utilizar tambm o operador para
exponenciao.

Os smbolos para os operadores aritmticos so:


+, -, *, /, ^ (potencia) ou exp(base, expoente), % (resto da diviso)

HIERARQUIA DAS OPERAES ARITMTICAS

1 ( ) Parnteses
2 Exponenciao
3 Multiplicao, diviso (o que aparecer primeiro)
4 + ou (o que aparecer primeiro)

OPERADORES RELACIONAIS

Os operadores relacionais so utilizados para comparar String de caracteres e

nmeros. Os operadores so: >, <, >=, <=, < >, =


OPERADORES LGICOS

Os operadores lgicos atuam sobre expresses e tambm resultam em valores


lgicos VERDADEIRO ou FALSO.

Pgina 1 de 3
Algoritmo e estrutura de dados 05

ESTRUTURA CONDICIONAL

Na vida real tomamos decises a todo o momento baseadas em uma situao


existente. Em um algoritmo, chamamos esta situao de condio. Associada a uma
condio, existir uma alternativa possvel de aes.

Se <condio> entao
<aes (uma ou mais) a serem realizadas se a condio for verdadeira>
Fimse

ou

Se <condio> entao
<aes (uma ou mais) a serem realizadas se a condio for verdadeira>
Senao
<aes (uma ou mais) a serem realizadas se a condio for verdadeira>
Fimse

Exemplo: Faa um Algoritmo para calcular a rea de um circulo, fornecido o valor do


raio, que deve ser positivo.

Algoritmo "Calcula Area do Circulo"


VAR
Area, Raio: Real
inicio
Escreval ("Entre com raio do crculo")
Leia (Raio)
Se Raio > 0 entao
Area <- PI*(Raio^2)
Escreva ("A rea do crculo de raio", Raio, " ", Area)
fimse
Se Raio <= 0 entao
Escreva ("Raio no pode ser nulo ou negativo!")
fimse
fimalgoritmo

EXERCCIOS BSICOS

1. Faa um algoritmo e um fluxograma que leia um nmero


digitado pelo usurio e verifique se o nmero igual, maior ou
menor que 5 (cinco).
2. Faa um algoritmo e um fluxograma que calcule a rea e o
permetro de um quadrado, some as reas e verifique se o
resultado maior que 100.
3. Uma loja de presentes resolveu dar um bnus de 30% do valor
do salrio a seus funcionrios com tempo de trabalho na loja

Pgina 2 de 3
Algoritmo e estrutura de dados 05

igual ou superior a quatro anos e de 15% restante, tendo como


entrada de dados o salrio do funcionrio E TEMPO DE
TRABALHO (EM ANOS). Faa um algoritmo e um
fluxograma que calcule e mostre o valor do bnus.
EXERCCIOS MDIOS

4. Usando a estrutura de deciso encadeada, calcule a mdia aritmtica semestral entre


quatro notas bimestrais e exiba se o aluno foi aprovado, reprovado ou permaneceu de
exame. Para a condio de aprovado, a nota tem que ser maior ou igual 7, e se a nota
ficar entre 5 e 7 o aluno permanece de exame, abaixo disso, o aluno est reprovado.
5. Faa um algoritmo e um fluxograma que recebe do usurio o placar de um jogo de
futebol (os gols de cada time) e informa se o resultado foi um empate, a vitria do
primeiro time ou do segundo time.

EXERCCIOS AVANADOS

6. Faa um algoritmo e um fluxograma que verifique se um valor digitado pelo usurio


unidade, dezena ou centena, tanto os negativos e os positivos.
7. Faa um algoritmo e um fluxograma que simule uma calculadora simples de nmeros
inteiros.

Pgina 3 de 3