Você está na página 1de 1

Algoritmo: E:\Vetores\Vetor3.

alg
Data: 17/07/2017

1 Algoritmo "semnome"
2 // Disciplina : [Linguagem e Lógica de Programação]
3 // Professor : Jose Augusto Teixeira de Lima Junior
4 // Descrição : Aqui você descreve o que o programa faz! (função)
5 // Autor(a) : Nome do(a) aluno(a)
6 // Data atual : 13/07/2017
7 Var
8 // Seção de Declarações das variáveis
9 V: vetor[1..10] de inteiro
10 cont: inteiro
11 spar,mimpar: inteiro
12 Inicio
13 // Seção de Comandos, procedimento, funções, operadores, etc...
14
15 // preenchimento do vetor:
16
17 spar <- 0
18 mimpar <- 1
19
20 para cont de 1 ate 10 faca
21 V[cont] <- randi(4)
22 Escreval(V[cont])
23 fimpara
24
25 para cont de 1 ate 10 faca
26 se V[cont] mod 2 = 0 entao
27 spar <- spar + V[cont]
28 senao
29 mimpar <- mimpar * V[cont]
30 fimse
31 fimpara
32
33 Escreval("Soma dos elementos pares -> ",spar)
34 Escreval("Multiplicacao dos elementos impares -> ",mimpar)
35
36
37
38
39
40 Fimalgoritmo