Você está na página 1de 2

var tv:caracter //tipo de vinho //Varivel que recebe a entrada de to dos os tipos de vinho.

conv:inteiro //contador de vinho //Contador (ou acumulador) soma todos os vinhos que entraram ct:inteiro //contador de tinto //Contador (ou acumulador) soma todo s os VINHOS TINTOS que entraram cb: inteiro //Contador (ou acumulador) soma todos os VINHOS BRANCOS que entraram cr: inteiro //Contador (ou acumulador) soma todos os VINHOS ROS que en traram pt,pb,pr:real //porcentagem de tinto, branco e ros //Varivel que guardar as porc entagem de cada vinho inicio //Incia a codificao // Seo de Comandos //rea reservada para os comandos escreval ("Digite (t) para vinho tinto") //Interagem com o usurio e solicita que ele escolha a letra t para vinho tinto escreval ("Digite (b) para vinho branco") //Interagem com o usurio e solicita q ue ele escolha a letra b para vinho branco escreval ("Digite (r) para vinho ros") //Interagem com o usurio e solicita que ele escolha a letra r para vinho ros escreval ("Digite (f) para sair") //Interagem com o usurio e sol icita que ele escolha a letra f para sair do cdigo e mostrar respostas //inicializao de diversos contadores //Espao reservado para inicializar os conta dores. Lembre-se que necessrio atribuir algum valor. conv <- 0 //Atribuio do valor 0 (zero) par a o contador(ou acumulador) conv. ct <- 0 //Atribuio do valor 0 (zero) p ara o contador(ou acumulador) ct. cb <- 0 //Atribuio do valor 0 (zero) pa ra o contador(ou acumulador) cb. cr <- 0 //Atribuio do valor 0 (zero) pa ra o contador(ou acumulador) cr. repita //Lao de repetio leia (tv) //Ler o que o usurio digitou inde pendente de ser t, b, r ou f ele ir ler. e ser trabalhado pelo comando escolha escolha tv //Verifica o que entrou na varivel t v e verificar os casos. Voc Emerson, fez isso no cdigo anterior. caso "t" //Se o usurio digitar t vai acumul ar +1 na varivel ct. ct <- ct + 1 //Contador (ou acumulador) caso "b" //Se o usurio digitar b vai acumular +1 na varivel cb. cb <- cb + 1 //Contador (ou acumulador) caso "r" //Se o usurio digitar r vai acumular + 1 na varivel cr. cr <- cr + 1 //Contador (ou acumulador) fimescolha //Termina a verificao dos casos. conv <- conv + 1 //Contador (ou acumulador) ate tv = "f" //Se o usurio digitar f ele finaliz a a operao e imprime o resultado. conv <- conv - 1 //descontar o finalizador "f" //Este comando ele vai d escontar 1 do acumulador geral. porque quando o usurio digitou f para sair ele contou como se fosse um tipo de vinho. e se voc deixar sem descontar 1 o resultado final da porcentagem vai dar errado.

se (conv > 0)entao //Esta ve rificao lgica serve para verificar se o usurio digitou algum tipo de vinho ou foi logo fechando antes de digitar um tipo de vinho. Se ele no digitou nenhum tipo ir mostrar a mensagem:"Nenhum tipo de vinho fornecido!" pt <- (ct * 100)/conv //Faz os clculos da porcentagem baseado na entrada de vinhos tintos. pb <- (cb * 100)/conv //Faz os cl culos da porcentagem baseado na entrada de vinhos brancos. pr <- (cr * 100)/conv //Faz os cl culos da porcentagem baseado na entrada de vinhos ross. escreval ("Porcentagem de tintos = ",pt:3:2,"%") //Mostra porcent. dos vin hos tintos. :3:2 para limitar os nmeros que sero exibidos. escreval ("Porcentagem de brancos = ",pb:3:2,"%") //Mostra porcent. dos vi nhos brancos. :3:2 para limitar os nmeros que sero exibidos. escreval ("Porcentagem de ross = ",pr:3:2,"%") //Mostra porcent. dos vinhos ross. :3:2 para limitar os nmeros que sero exibidos. senao //se (conv > 0)entao.. Se NO for maior que 0 (zero) vai mostrar a mensagem abaixo. escreva ("Nenhum tipo de vinho fornecido!") //Mostra mensagem e finaliza a execuo fimse //Fecha a condicional 'se' fimalgoritmo //Finaliza o algori tmo.