Você está na página 1de 10

1) Elabore um algoritmo que calcule a rea de um crculo qualquer de raio fornecido.

Inicio Real: raio, area, pi; pi <-- 3.14; Leia(raio); area <-- pi * pot(raio, 2); Escreva(area); Fim. 2) Prepare um algoritmo que seja capaz de inverter um nmero, de trs dgitos, fornecido, ou seja, apresentar primeiro a unidade e, depois, a dezena e a centena. Inicio Inteiro: unidade, dezena, centena, numero; Leia(numero); centena <-- (numero div 100); dezena <-- (numero div 10); unidade <-- ((centena * 100) + (dezena * 10)) - numero; Escreva(unidade, dezena, centena); Fim. 3) Ao completar o tanque de combustvel de um automvel, faa um algoritmo que calcule o consumo efetuado, assim como a autonomia que o carro ainda teria antes do abastecimento. Considere que o veculo sempre seja abastaecido at encher o tanque e que so fornecidas apenas a capacidade do tanque, a quantidade de litros abastecidos e a quilometragem percorrida desde o ltimo abastecimento. Inicio // CT = Capacidade Tanque // QLA = Quantidade de Litros Abastecidos // QP = Quilomentragem Percorrida // C = Consumo // AF = Automonia Futura Inteiro: CT, QLA, QP, C, AF; Leia(CT, QLA, QP); C <-- (QP / QLA); AF <-- (CT - QLA) * C; Escreva(C, AF); Fim.

Sobre Estruturas de Seleo: 4) Escreva o signo do zodaco correspondente ao dia e ms informado. Inicio Inteiro: dia, mes; Leia(dia, mes); se (mes = 1) ento se (dia <= 20) ento Escreva(Capricrnio); seno Escreva(Aqurio); fimse; fimse; se (mes = 2) ento se (dia <= 19) ento Escreva(Aqurio); seno Escreva(Peixes); fimse; fimse; se (mes = 3) ento se (dia <= 20) ento Escreva(Peixes); seno Escreva(ries); fimse; fimse; se (mes = 4) ento se (dia <= 20) ento Escreva(ries); seno Escreva(Touro); fimse; fimse; se (mes = 5) ento se (dia <= 21) ento Escreva(Touro); seno Escreva(Gmeos); fimse; fimse; se (mes = 6) ento se (dia <= 21) ento Escreva(Gmeos); seno Escreva(Cncer);

fimse; fimse; se (mes = 7) ento se (dia <= 22) ento Escreva(Cncer); seno Escreva(Leo); fimse; fimse; se (mes = 8) ento se (dia <= 21) ento Escreva(Leo); seno Escreva(Virgem); fimse; fimse; se (mes = 9) ento se (dia <= 22) ento Escreva(Virgem); seno Escreva(Libra); fimse; fimse; se (mes = 10) ento se (dia <= 23) ento Escreva(Libra); seno Escreva(Escorpio); fimse; fimse; se (mes = 11) ento se (dia <= 20) ento Escreva(Escorpio); seno Escreva(Sagitrio); fimse; fimse; se (mes = 12) ento se (dia <= 21) ento Escreva(Sagitrio); seno Escreva(Capricrnio); fimse; fimse; Fim.

5) A partir da idade informada de uma pessoa, elabore um algoritmo que informe a sua classe eleitoral, sabendo que menores de 16 no votam (no votante), que o voto obrigatrio para adultos entre 18 e 65 (eleitor obrigatrio) e que o voto opcional para eleitores entre 16 e 18, ou maiores de 65 (eleitor facultativo). Inicio Inteiro: idade; Leia(idade); se (idade < 16) ento Escreva(No Votante); seno se ((idade >= 18) e (idade <= 65)) ento Escreva(Eleitor Obrigatrio); seno Escreva(Eleitor Facultativo); fimse; fimse; Fim. 6) Escreva um algoritmo que, a partir do ms fornecido (de 1 a 12), apresente o nome dele por extenso ou uma mensagem de ms invlido. Inicio Inteiro: mes; Leia(mes); escolha (mes) caso 1: Escreva("Janeiro"); caso 2: Escreva("Fevereiro"); caso 3: Escreva("Maro"); caso 4: Escreva("Abril"); caso 5: Escreva("Maio"); caso 6: Escreva("Junho"); caso 7: Escreva("Julho"); caso 8: Escreva("Agosto"); caso 9: Escreva("Setembro"); caso 10: Escreva("Outubro"); caso 11: Escreva("Novembro"); caso 12: Escreva("Dezembro"); caso contrrio: Escreva("Invlido"); fimescolha; Fim.

Sobre Estruturas de Repetio: 7) A converso de graus Fahrenheit para centgrados obtida pela frmula C = 5/9 (F 32). Escreva um algoritmo que calcule e escreva uma tabela de graus centgrados em funo de Fahrenheit que variem de 50 a 150 de 1 em 1 grau. Inicio Real: C; Inteiro: F; F <-- 50; repita C <-- 5 / 9 (F - 32); F <-- F + 1; Escreva(C); at (F <= 150); Fim. 8) Prepare um algoritmo que calcule o valor de H, sendo que ele determinado pela srie: H = 1/1 + 3/2 + 5/3 + 7/4 + ... + 99/50. Inicio Inteiro: A, B; Real: H; A <-- 1; B <-- 1; H <-- 0; repita H <-- H + A / B; A <-- A + 1; B <-- B + 2; at (A <= 50); Escreva(H); Fim.

9) Elabore um algoritmo que determine o valor de S, em que: S = 1/1 - 2/4 + 3/9 - 4/16 + 5/25 6/36 ... 100/100. Inicio Inteiro: A, B; Real: S; A <-- 1; B <-- 1; S <-- 0; repita A <-- A + 1; B <-- A * A; se ((A MOD 2) = 0) ento S <-- S - (A / B); seno S <-- S + (A / B); fimse; at (A <= 100); Escreva(S); Fim. 10) Joo tem 1,50 metro e cresce 2 centmeros por ano, enquanto Lucas tem 1,10 metro e cresce 3 centmetros por ano. Construa um algoritmo que calcule e imprima quantos anos sero necessrios para que Lucas seja maior que Joo. Inicio Inteiro: joao, lucas, ano; ano <-- 0; joao <-- 150; lucas <-- 110; enquanto (joao >= lucas) joao <-- joao + 2; lucas <-- lucas + 3; ano <-- ano + 1; fimenquanto; Escreva(ano); Fim.

11) Em um prdio h trs elevadores denominados A, B e C. Para otimizar o sistema de controle dos elevadores foi realizado um levantamento no qual cada usurio, num total de 100 usurios, respondia: - O elevador que utilizava com mais frequencia; - O perodo em que utilizava o elevador, entre: - M = Manh - T = Tarde - N = Noite Construa um algoritmo que calcule e imprima: - Qual o elevador mais frequentado e em que perodo se concentra o maior fluxo; - Qual o perodo mais usado de todos e a que elevador pertence; - Qual a diferena porcentual entre o mais usado dos horrios e o menos usado. Inicio Caractere: elevador, periodo, maisusado, menosusado; Inteiro: usuario, A, B, C, MA, TA, NA, MB, TB, NB, MC, TC, NC; // Elevador A, B, C. M = Manha, T = Tarde, N = Noite. // MA = Manha A, TA = Tarde A, NA = Noite A, etc ... Usuario <-- 1; enquanto (usuario <= 100) Leia(elevador, periodo); escolha elevador caso A: inicio escolha periodo caso M: MA <-- MA + 1; caso T: TA <-- TA + 1; caso N: NA <-- NA + 1; fimescolha; A <-- A + 1; fim caso B: inicio escolha periodo caso M: MB <-- MB + 1; caso T: TB <-- TB + 1; caso N: NB <-- NB + 1; fimescolha; B <-- B + 1; fim caso C: inicio escolha periodo caso M: MC <-- MC + 1; caso T: TC <-- TC + 1; caso N: NC <-- NC + 1; fimescolha; C <-- C + 1; fim

fimescolha; usuario <-- usuario + 1; fimenquanto; M <-- MA + MB + MC; T <-- TA + TB + TC; N <-- NA + NB + NC; // Qual o elevador mais frequentado e em que perodo se concentra o maior fluxo: se ((A > B) e (A > C)) ento Escreva(Elevador mais frequentado o , A); seno se ((B > A) e (B > C)) ento Escreva(Elevador mais frequentado o , B); seno Escreva(Elevador mais frequentado o , C); fimse; fimse; // Qual o perodo mais usado de todos e a que elevador pertence: se ((M > T) e (M > N)) ento inicio maisusado <-- M; se ((MA > MB) e (MA > MC)) ento Escreva(Periodo mais usado a M, Elevador A); seno se ((MB > MA) e (MB > MC)) ento Escreva(Periodo mais usado a M, Elevador B); seno Escreva(Periodo mais usado a M, Elevador C); fimse; fimse; se (T < N) ento menosusado <-- T; seno menosusado <-- N; fimse; fim seno se ((T > M) e (T > N)) ento inicio maisusado <-- T; se ((TA > TB) e (TA > TC)) ento Escreva(Periodo mais usado a T, Elevador A); seno se ((TB > TA) e (TB > TC)) ento Escreva(Periodo mais usado a T, Elevador B); seno Escreva(Periodo mais usado a T, Elevador C);

fimse; fimse; se (M < N) ento menosusado <-- M; seno menosusado <-- N; fimse; fim seno inicio maisusado <-- N; se ((NA > NB) e (NA > NC)) ento Escreva(Periodo mais usado a N, Elevador A); seno se ((NB > NA) e (NB > NC)) ento Escreva(Periodo mais usado a N, Elevador B); seno Escreva(Periodo mais usado a N, Elevador C); fimse; fimse; se (M < T) ento menosusado <-- M; seno menosusado <-- T; fimse; fim fimse; fimse; // Qual a diferena porcentual entre o mais usado dos horrios e o menos usado: Escreva(Diferena percentual entre mais usado e menos usado , ((menosusado/maisusado)*100)); Fim.