Você está na página 1de 9

Manual RSLogix 500

ndice
Captulo 1
Conhecendo o RSLogix 500.........................................................................1
Bem-vindo ao RSLogix 500...........................................................................................................2
Explorando RSLogix 500...............................................................................................................3
Requisitos do Sistema...................................................................................................................4
Requisitos de Hardware................................................................................................................4
Requisitos de Software..................................................................................................................4
Quick Start Steps.......................................................................................................................5
Step 1 _ Configure o sistema de comunicao..................................................................5
Step 2 _ Criar um novo projeto ou abrir um projeto existente...........................................6
Step 3 _ Criar um programa e tabela de arquivo de dados...................................................7
Step 4 _ Definir chassis e mdulos...............................................................................................8
Step 5 _ Fazer lgica do programa...............................................................................................9
Step 6 _ Adicionar a documentao para lgica de instrues..................................................10
Step 7 _ Verifique a lgica do programa.....................................................................................11
Step 8 _ Configure o canal de comunicao, download, and go online................11
Step 9 _ Monitor de arquivos de dados.......................................................................................12
Step 10 _ Pesquisa e substitui as instrues..............................................................................13
Step 11 _ Imprimindo um relatrio..............................................................................................13

Captulo 2
Instalando o RSLogix 500...........................................................................................................15
Introduo....................................................................................................................................16
Instalao......................................................................................................................16
Instalando o software Linx Lite....................................................................................................17
Instalando o software RSLogix 500......................................................................................17
Starting do software RSLogix 500..................................................................18
Solucionando problemas de instalao.......................................................................................18

Captulo 3
Mais sobre a configurao das Comunicaes...........................................................................19
Sistema de comunicao vs. Controlador de comunicao.......................................................20
Existe uma diferena.....................................................................................................20
Who Active....................................................................................................................21

Captulo 4
Mais sobre a instalao do chassi e do mdulo..........................................................................23
Apresentao..............................................................................................................24
Power carga da fonte.........................................................................................25
Analgica e especialidade configurao do mdulo...................................................................25
Configurao automtica dos I/O................................................................................................25

Captulo 5
Mais sobre a lgica do Ladder....................................................................................................27
Introduo..................................................................................................................28
Fazendo o seu trabalho.........................................................................................28
Recuperao Crash...............................................................................................................29
Rpida entrada de instrues......................................................................................................30
Endereando.................................................................................................................31
Ramificao..................................................................................................................31
Adicionar um ramo......................................................................................................................31
Mover um branch.................................................................................................................31
Expandir um branch.................................................................................................................31
Nested branches.........................................................................................................................32
Parallelos branches..............................................................................................................32
Copiar ramo branch..........................................................................................................32
Copiar estrutura inteira do ramo...........................................................................................32
Deletar um branch...................................................................................................................32
Restries Branching....................................................................................................32
Operao Undo.........................................................................................................33
Edio on-line............................................................................................................33
Marcadores de zona Lower-case................................................................................................34
Marcadore de zona Upper-case.........................................................................................35
Exemplo de edio on-line..........................................................................................................35
Restrio de edio on-line..............................................................................................37
Edio ASCII.............................................................................................................37
Configurando Interrupes........................................................................................37
STI (Tempo de Interrupo Selecionavl)...................................................................................37
DII (Entrada Discreta de Interrupo)..........................................................................................38

CAPTULO 1 Comeando com o RSLogix 500


Bem Vinvo ao RSLogix 500...........................................................................................................2
Explorando RSLogix 500...............................................................................................................3
Quick Start Steps.......................................................................................................................5
Step 1 _ Configure o sistema de comunicao..................................................................5
Step 2 _ Criar um novo projeto ou abrir um projeto existente...........................................6
Step 3 _ Criar um programa e tabela de arquivo de dados...................................................7
Step 4 _ Definir chassis e mdulos...............................................................................................8
Step 5 _ Fazer lgica do programa...............................................................................................9
Step 6 _ Adicionar a documentao para lgica de instrues..................................................10
Step 7 _ Verifique a lgica do programa.....................................................................................11
Step 8 _ Configure o canal de comunicao, download, and go online................11
Step 9 _ Monitor de arquivos de dados.......................................................................................12
Step 10 _ Pesquisa e substitui as instrues..............................................................................13
Step 11 _ Imprimindo um relatrio..............................................................................................13

Bem Vindo ao RSLogix 500


O RSLogix 500 um software de 32 bits janela de programao em lgica ladder,
pacote para processadores SLC 500 e Micrologix. Atuando no Microsoft Windows 95 e
Windows NT, RSLogix 500 compatvel com programas criados com qualquer programao
Rockwell, Dos-based e pacote de software.
A funcionalidade do software RSLogix 500 inclu:

Um editor de escada de forma livre que lhe permite concentrar-se na lgica da


aplicao em vez de sintaxe apropriada como voc escreve seu programa.

Um verificador de projeto poderoso que voc usa para construir uma lista de erros que
voc pode navegar par fazer as correes de sua convenincia.

Drag-and-drop de edio para mover rapidamente os elementos de dados da tabela a


partir de um arquivo de dados outro, os degraus de uma sub-rotina ou projeto para
outro, ou instrues de degrau a degrau de um projeto.

Procurar e substituir para alterar rapidamente as ocorrncias de um determinado


endereo ou smbolo.

Um personalizado monitor de dados para exibir elementos de dados separados entre si


e observar interaes.

Uma interface de ponto-e-clique chamado de rvore de projeto que permite acesso a


todos as pastas e arquivos contidos no seu projeto.

Tendncia e funcionalidade de histograma de acompanhamento e exibio do


processo de dados.

O SLC possui bibliotecas para armazenar e recuperar pores da lgica ladder para
uso em qualquer produto de programao software Rockwell software SLC.

Explorando o RSLogix 500


Para navegar atravs das vrias janelas e barras de ferramentas no RSLogix 500 mais
facilmente, voc deve entender o que eles contm e que a funcionalidade de cada
proporciona.
Quando voc abre um projeto no RSLogix 500 voc pode visualizar:

Project tree (rvore de projeto) Contm todas as pastas e arquivos contidos em seu
projeto. Voc tambm pode clicar em um cone na rvore e clique no boto direito do
mouse para um menu que se aplica apenas para o cone selecionado. Por exemplo, se
voc clicar no boto direito do mouse sobre um arquivo de programa, voc ver opes
para renomear o arquivo de programa, abra o arquivo de programa, esconder o arquivo
de programa, ou revelar as propriedades do arquivo de programa.

Ladder view Nesta parte da janela do aplicativo possvel visualizar vrios arquivos
de programas ao mesmo tempo. Isto , onde voc edita sua lgica.

Results window - Mostra os resultados de uma pesquisa ou uma verificao de todas


as pesquisas em andamento. Voc pode ocultar esta janela de exibio ou separ-la
da aplicao, para que a janela possa ser colocada em qualquer lugar na tela.

Standard icon bar (barra de cones padro) - A barra de cones padro contm
muitas funes que ser usada repetidamente quando voc desenvolver e testar seu
programa de lgica. Se voc quiser saber o que qualquer um dos cones representam,
o RSLogix 500 pode dizer. Basta mover o cursor para o cone. Uma janela ToolTip
flutuante vai aparecer e dizer-lhe para que o cone utilizado.

Instruction tollbar (barra de ferramentas) Exibe abas com guia de instrues.


Quando voc clica em uma guia de instrues a barra de ferramentas muda para
mostrar o tipo de instruo. Clique em uma instruo no sentido de inseri-lo em seu
programa ladder.

Quick Start steps


Os passos seguintes explicam como se levantar e correr rapidamente com RSLogix
500 assim como instal-lo.

Step 1 - Configure o sistema de comunicao


Faa isso antes de comear um novo projeto. As configuraes que voc estabelece
em esta etapa continuar com o projeto e sero aplicadas quando voc tentar fazer o download
de qualquer lgica de programa.
A partir do menu Comms, clique em System Comms. Em seguida clique em System
Comunications guia na janela Opes do sistema, para dar-lhe o foco.

A partir de este separador selecionar driver, node, and timeout (tempo de espera). Um
mtodo de atalho disponvel se voc j usou o software RSLogix 500 para configurar a
comunicao de um n de rede. Clique na ltima configurao drop-down listbox para ver uma
lista de drivers configurados anteriormente em ns. Em seguida, selecione um da lista.
Voc tambm pode acessar o recurso disponvel em Who Active RSLinx. Este utilitrio
exibe todas as estaes / os ns em redes de comunicao. Isso pode ajuda se voc no tiver
certeza do nmero do n de um dispositivo especfico na rede.
Para informaes mais detalhadas sobre os passos que voc segue para configurar o
seu sistema comunicaes referem-se ao captulo 3 deste livro.

Step 2 Criando Um Novo Projeto ou Abrindo Um Projeto Existente.


Novos Projetos
RSLogix 500 baseado em projetos. Os projetos so o conjunto completo de arquivos
associados com sua lgica de programao. Voc cria um projeto a partir do menu File,
clicando em Novo. RSLogix 500 pede-lhe o tipo de processador que voc ir se comunicar e
cria um controle de rvore do projeto. Esta rvore do projeto o ponto de acesso para
programa, tabela de dados e arquivos de banco de dados.

Projetos Existentes
No menu File, clique em Abrir. Use a caixa de dilogo que aparece ao lado, para abrir
um projeto de escada lgica e/ou sua base de dados associados. Dependendo do tipo de ao
(abrir ou importar) RSLogix 500 apresenta uma extenso de arquivo padro. Voc pode No
entanto, selecione um tipo de arquivo diferente para abrir ou importar. Certifique-se que voc
tem a tipo correto de arquivo listados na caixa de listagem Arquivos do tipo drop-down no
Abrir / Importar SLC janela do Programa 500.
Abertura de Arquivos Multiplos
Para abrir vrios arquivos dentro do mesmo projeto, voc pode dividir a janela de
visualizao.

Use o mouse para apontar para a barra de diviso. O ponteiro se transforma em uma
barra dupla com duas setas. Arraste a barra para cima ou para baixo para sua nova posio, o
que lhe permite ver dois vista da janela.
Voc no pode exibir arquivos de programa de projetos diferentes com apenas um
nico RSLogix 500 aplicao rodando em seu computador. Voc deve abrir mais de uma

aplicao para trabalhar em vrios projetos ao mesmo tempo. Assim que tiver o projeto aberto,
no entanto, voc pode arrastar e soltar as instrues e dados entre elas.

Step 3 Criar no Programa tabela de dados e arquivos


A rvore do projeto a sua porta de entrada para criar novos arquivos ou acessar
arquivos existentes. Para criar um novo arquivo, clique com o boto direito do mouse no
programa ou arquivo de dados e selecione o cone New a partir do menu. Voc ser solicitado
a fornecer informaes sobre o arquivo.

Programa e arquivos contm informaes sobre o controlador, o programa da ladder


principal, e qualquer programas sub-rotina. Com os controladores SLC voc pode ter at 256
programas arquivos. Com o controlador MicroLogix voc pode ter at 16 arquivos de programa.
Tabela de dados e arquivos contm informaes de estado associado externo I/O e
todas as outras instrues que voc usa em sua principal sub-rotina e arquivos do programa
ladder. E, alm disso, esses arquivos armazenam informaes sobre o funcionamento do
controlador. Voc pode tambm usar os arquivos para armazenar as receitas e as tabelas de
look-up, se necessrio.

Step 4 Definir Chassis e Mdulos


Depois de ter aberto um projeto, voc tem que definir o seu chassis, identificar os
cartes I / O que voc est usando, indicando a sua posio no rack slot do processador, e
selecione uma fonte de alimentao para cada rack em sua configurao. Uma aplicao real
pode ter at trs racks e eu muitos mdulos I/O.
Voc executa esses procedimentos na janela Configuration I/O. Acesso a esta
janela clicando duas vezes o I/O cone de configurao na rvore do projeto. Em seguida
Clique em um mdulo na lista do lado direito da janela e arrast-lo para dentro da ranhura
onde voc quer que ele reside.

A partir da janela de configurao I/O, clique o boto Power Supply para examinar
a carga em um rack com base na configurao do mdulo que voc selecionou.
Para obter mais informaes sobre outras tarefas que voc pode realizar a partir da
janela de configurao I/O, consulte o captulo 4 deste livro.

Step 5 Fazer a Lgica do Programa


Quando voc abre um arquivo de programa clicando duas vezes no seu cone na
rvore do projeto, o arquivo ladder abre na metade direita a janela do RSLogix 500. Geralmente
programa file # 2, o arquivo principal do programa, ser aberta quando voc abre um projeto.
Se voc no tiver comeado a entrar em qualquer lgica ladder, apenas o fim degrau ser
exibido.
Clique sobre o degrau final e selecione o cone do novo degrau na barra de
ferramentas do usurio. Para adicionar uma instruo, clique no cone degrau a sobre uma das
barras de ferramentas.

Voc pode colocar vrias instrues em um degrau em seqncia, clicando os cones


um aps o outro. RSLogix 500 instrues e lugares da esquerda para a direita.
RSLogix 500 suporta um editor baseado em arquivos. Isso significa que voc pode:

Criar e/ou editar linhas mltiplas em um momento;

Digitar endereos antes de realmente criar arquivos de dados da tabela para o seu I/O;

Inserir smbolos antes de ter os endereos IP designados para eles no banco de dados;

Inserir instrues sem ter que fornecer endereos at pouco antes de ocorrer a
validao do arquivo.

Para adicionar endereos, basta clicar em uma instruo e, em seguida, digite o endereo
no campo vazio que aparece acima da instruo. Com RSLogix 500 voc tambm pode
arrastar os endereos de um arquivo de tabela de dados para as instrues na sua lgica.
Lembre-se de usar o boto direito do mouse para acessar a funcionalidade sempre que
possvel. O boto direito do mouse oferece opes de menus contexto que a lista de edio. E
lembre-se que voc pode clicar em F1 (ou no boto Ajuda quando disponvel) em qualquer
instruo, ou em qualquer janela de acesso de ajuda.
Usurios podem pressionar a tecla [Shift + 10] no teclado ou clicar com o boto direito do
mouse no menu:
Voc pode selecinar vrios degraus, mantendo pressionada a tecla [Ctrl] e clicando no
boto esquerdo do mouse sobre cada degrau que voc deseja selecionar. Voc tambm pode
selecionar um intervalo de degraus, mantendo pressionada a tecla [Shift] e clicando no incio do
degrau e final degrau.
Quando voc seleciona os degraus dessa forma, lembre que o RSLogix 500 mantem a
ordem em que voc fez sua escolha, e cola os degraus em ordem para o prancheta. Quando
voc colar os degraus, a ordem em que voc copiou so mantidos. Por exemplo, se voc clicar
em degrau 11 e ento [Shift] clique no degrau 8 e copiar uma srie de degraus, os degraus so
copiados do degrau 11 para o degrau 8. Colando estes degraus colocando no novo local nesta
mesma ordem.
Para informaes mais detalhadas sobre estes passos, e para entrar na lgica ladder
incluindo informaes sobre a ramificao, endereamento e executar programa de edies
online, veja o captulo 5 deste livro.

Step 6 Adicionar a Documentao para a Sua Lgica de Instrues


Voc pode usar vrios mtodos para adicionar smbolos e descries de endereos na
banco de dados.

Abra o arquivo do programa para adicionar a documentao diretamente para o


destinatrio instruo. Utilize o boto direito do mouse para isso ..

Modificar a documentao e atribuir um endereo no arquivo de dados. Clique duas


vezes no arquivo de dados na rvore do projeto e, em seguida clicar em um endereo
na rede que aparecer no arquivo de dados de dilogo. Na parte inferior da janela
existem campos onde voc pode digitar a documentao para o endereo.

Modificar o banco de dados usando o editor de banco de dados. Clique duas vezes em
um cone na pasta de banco de dados localizado na rvore do projeto.

Inserir um smbolo diretamente e depois atribuir um endereo para o smbolo usando o


smbolo de banco de dados editor / descrio.
Para obter mais informaes sobre a importao de bando de dados e opes de
exportao disponveis, consulte o Captulo 6 deste livro.

Step 7 Verificar a Lgica do Programa e Adicionar Documentao


Quando voc est pronto para construir seu projeto, voc pode validar um
nico programa ou arquivo ou voc pode validar o projeto inteiro. Use a barra de menu
ou o boto direito do mouse para iniciar este processo

Depois de iniciar a verificao, a janela de sada Verify Results exibe os


resultados e lhe d informaes sobre os erros ou omisses que possam ter
ocorrido na escrita do seu programa de lgica.

Os resultados de qualquer verificao so exibidos na parte inferior da janela


sob a rvore do projeto. Para ocultar esta janela de resultados aps v-lo,
clique no menu Exibir e, em seguida, clique em Resultados.