Você está na página 1de 4

Yahoo! Respostas - Excel - Combinar Fórmulas, alguém sabe?

Página 1 de 4
 Yahoo!
 Meu Yahoo!
 Yahoo! Mail

Yahoo! Search
Buscar: Buscar na Web

Yahoo! Games

EntrarNovo usuário? Cadastre-se

 Início -
 Blog -
 Regras -
 Ajuda

 Pergunte
 Responda
 Descubra

Buscar perguntas: Buscar Opções

Meu perfil

1. Página inicial >


2. Computadores e Internet >
3. Software >
4. Perguntas respondidas

Larissa

Membro desde:
08 de Novembro de 2007
Total de pontos:
103 (Nível 1)

 Adicionar amigo(a)
 Bloquear

Perguntas respondidas
Mostre-me outra »

Excel - Combinar Fórmulas, alguém sabe?


Olá

Preciso de uma fórmula no excel que talvez tenha que combinar Procv e a função SE.
Eu quero que o excel vá buscar um valor em uma planilha e caso não encontre naquela planilha que procure em mais
umas 3.

Estou usando essa fórmula: =Procv(B2;Azul;7;0)


Só que essa busca não pode ser feita somente na planilha "Azul", pois os valores podem estar também nas planilhas

http://br.answers.yahoo.com/question/index?qid=20071213120310AA2fEsj 13/3/2008
Yahoo! Respostas - Excel - Combinar Fórmulas, alguém sabe? Página 2 de 4
"Laranja"ou na "Vermelho" ou na "Amarelo".

Então não estou sabendo combinar essas fórmulas. A lógica teria que ser mais ou menos assim: "Procure esse valor
na planilha azul se não estiver lá procure na planilha laranja, se não encontrar o valor lá procure na Vermelho....

Alguém sabe combinar e montar essa fórmula?

Obrigada.

 3 meses atrás

Denuncie

by jes_kp

Membro desde:
02 de Agosto de 2006
Total de pontos:
1749 (Nível 3)

 Adicionar amigo(a)
 Bloquear

Melhor resposta - Escolhida pelo autor da pergunta


Muito boa pergunta.
Ó, prá fazer numa fórmula só, vai ficar muito complexo (pense na manutenção).
Eu arrumei uma solução "fracionada". Se você desejar, junte tudo - por sua conta e risco

Criei as três tabelas chamadas Azul, Laranja e Amarelo (mas por simplicifação apenas com duas colunas). Criei 3
pesquisas, uma em cada tabela e depois "consolidei" as pesquisas.
As fórmulas ficaram assim:
procura na tabela azul na C2: =PROCV(B2;Azul;2;0)
procura na tabela laranja na D2: =PROCV(B2;Laranja;2;0)
procura na tabela amarelo na E2: =PROCV(B2;Amarelo;2;0)

A consolidação (onde você desejar): =SE(É.NÃO.DISP(C2); SE(É.NÃO.DISP(D2);E2;D2);C2)

Nos meus testes, foi bala. Volta o correspondente da tabela onde tem, ou #N/D, se não tem em nenhuma.

Numa única linha ficaria:


=SE(É.NÃO.DISP(PROCV(B2;Azul;2;0)); SE(É.NÃO.DISP( PROCV(B2;Laranja;2;0)); PROCV(B2;Amarelo;2;0)
; PROCV(B2;Laranja;2;0)); PROCV(B2;Azul;2;0))

O que acontece se tiver em mais de uma tabela?

 2 meses atrás

 Denuncie

Avaliação do autor da pergunta:

Comentário do autor da pergunta:


Já estava perdendo a esperança de uma resposta que me ajudasse. Muito Obrigada mesmo.

É isto que você está buscando?

http://br.answers.yahoo.com/question/index?qid=20071213120310AA2fEsj 13/3/2008
Yahoo! Respostas - Excel - Combinar Fórmulas, alguém sabe? Página 3 de 4
 Avaliação: Resposta boa
 Avaliação: resposta ruim

 1 estrelas - marque esta como Interessante!

Quem marcou como interessante?


1. jes_kp
 E-mail
 Comentário (0)
 Salvar
 Marcar como favorita
 Salvar no Favoritos
 Adicionar ao Meu Yahoo!
 RSS

Atualmente não há comentários para esta pergunta.

* Você precisa estar logado no Respostas para adicionar comentários. Entre ou Crie uma nova conta.

Outras Respostas (1)

 by o.merlin
Membro desde:
20 de Novembro de 2007
Total de pontos:
6564 (Nível 5)
 Adicionar amigo(a)
 Bloquear
Se você precisar de ajuda passo a passo...
0800 888 4081...Microsoft...
A ligação é grátis, e o atendimento é 100%...
 3 meses atrás
 0 Avaliação: Resposta boa
 2 Avaliação: resposta ruim
 Denuncie

Perguntas abertas em Software


 por favor me ajudem!!!! preciso de um programa que eu possa editar audio e video e dep gravar em cd vcs
sabem?
 Como acessar um pc que já tem o logmein instalado, mas que não foi eu quem instalou portanto não sei a
senha?
 existe adobe reader que faz leitura em voz alta em português??!!??
 Como faço para torcar o wind vista para xp?

Perguntas resolvidas em Software


 Como eu faço pra aprender a fazer programas ou softwares?
 Como faço pra inserir um som em todos os slides?
 Comprei um Notebook com librix. Mas tenho cd original do Vista em casa. Posso intalar o vista em cima do
libr?
 Como colocar iniciais maiusculas no excel ? Primero que responder certo ganha 10 pts!?

http://br.answers.yahoo.com/question/index?qid=20071213120310AA2fEsj 13/3/2008
Yahoo! Respostas - Excel - Combinar Fórmulas, alguém sabe? Página 4 de 4

Ainda tem uma dúvida? Pergunte.


Get answers from
millions of real people.

Adicionar pergunta

Categorias
 Todas as categorias
 Computadores e Internet
 Hardware
 Internet
 Programação e Design
 Redes de Computadores
 Segurança
 Software
 Outros - Computadores

Y! Respostas em outros países:


 Alemanha
 Argentina
 Austrália
 Brasil
 Canadá
 China
 Cingapura
 Coréia do Sul
 Espanha
 Estados Unidos
 Filipinas
 França
 Hong Kong
 Indonésia
 Itália
 Japão
 Malásia
 México
 Nova Zelândia
 Quebec
 Reino Unido
 Tailândia
 Taiwan
 Vietnã
 em Espanhol
 Índia

O Yahoo! não avalia ou garante a precisão de qualquer conteúdo no Yahoo! Respostas. Clique aqui para ler o Termo
de Responsabilidade.

Copyright © 2008 Yahoo!. Todos os direitos reservados.

 Direitos Autorais -
 Política de Privacidade -
 Termos do serviço -
 Regras da Comunidade

http://br.answers.yahoo.com/question/index?qid=20071213120310AA2fEsj 13/3/2008