Você está na página 1de 45

08/04/15

CRIP - Embratel

Comandos Bsicos de
Resoluo de Problemas na
Rede
Ping
Traceroute
Show ip route
Show running-config interface serial #

08/04/15

CRIP - Embratel

Ping
Comando usado para testar conectividade
Ferramenta padro de testes
Baseado em ICMP

08/04/15

CRIP - Embratel

Ping
Cdigos de Retorno
!
.
U
M

Sucesso
Tempo esgotado (time-out)
Unreachable - Inalcanvel
No pode fragmentar

Tipo de pacote desconhecido

&

Tempo de vida expirado

Source quench (destination too busy)

08/04/15

CRIP - Embratel

Ping - Exemplo
#ping 200.214.224.82
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.214.224.82, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/80/108 ms
#
#ping vrf ABRROAMING:1249 200.255.221.190
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.255.221.190, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
#
08/04/15

CRIP - Embratel

Ping - Exemplo
#ping 200.214.224.82 ?
data
specify data pattern
df-bit enable do not fragment bit in IP header
repeat specify repeat count
size
specify datagram size
source specify source address or name
timeout specify timeout interval
validate validate reply data
<cr>
#ping 200.214.224.82 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 200.214.224.82, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 60/125/184 ms
#
08/04/15

CRIP - Embratel

Ping - Exemplo
#ping
Protocol [ip]:
Target IP address: 200.214.224.82
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.214.224.82, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/92/96 ms
#

08/04/15

CRIP - Embratel

Ping - Exemplo
#ping vrf ABRROAMING:1249
Protocol [ip]:
Target IP address: 200.255.221.190
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.255.221.190, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/71/88 ms
#

08/04/15

CRIP - Embratel

Traceroute
Usado para descobrir as rotas que os
pacotes fazem.
Exemplo:
#traceroute 200.214.224.82
Type escape sequence to abort.
Tracing the route to ipea-gov-S1-0-0-acc01.rjo.embratel.net.br
(200.214.224.82)
1 ipea-gov-S1-0-0-acc01.rjo.embratel.net.br (200.214.224.82) 196 msec *
164 msec
#
08/04/15

CRIP - Embratel

Ping e Traceroute
Desempenho
Ao usar os comandos de Ping e
Traceroute, ns obtemos o Round-Trip
Time ou seja, o tempo de envio e
recebimento do pacote;
Pode ser til para ter uma idia de delay;
No so precisos para ser usados como
avaliao de desempenho.
08/04/15

CRIP - Embratel

10

Show ip route
#sh ip route 200.214.224.82
Routing entry for 200.214.224.80/30
Known via "connected", distance 0, metric 0 (connected, via interface)
Redistributing via bgp 4230
Advertised by bgp 4230 route-map CONNECTED
Routing Descriptor Blocks:
* directly connected, via Serial1/0/0
Route metric is 0, traffic share count is 1
#
#sh ip route | i Serial1/0/0
S
200.255.249.128 is directly connected, Serial1/0/0
C
200.214.224.80 is directly connected, Serial1/0/0
#

08/04/15

CRIP - Embratel

11

Show running-config
interface serial #
#show running-config interface serial 1/0/0
Building configuration...
Current configuration : 388 bytes
!
interface Serial1/0/0
description IPEA.GOV | 1024K | RJO/IP/01931 | (RJO/IP/01931)
bandwidth 1024
ip address 200.214.224.81 255.255.255.252
ip verify unicast source reachable-via rx allow-default allow-self-ping
encapsulation ppp
no peer neighbor-route
clock source internal
ts16
serial restart-delay 0
no fair-queue
no cdp enable
no clns route-cache
end
#
08/04/15

CRIP - Embratel

12

HDLC
Normalmente usado quando o CPE
tambm CISCO
Default para links seriais
Permite balanceamento (mx. 12M)

08/04/15

CRIP - Embratel

13

HDLC
Teste
Verificar se o circuito esta em loop
Fazer teste de ping no endereo ip da
WAN-PE

08/04/15

CRIP - Embratel

14

HDLC -Teste
#show interfaces serial 3/0/1
Serial3/0/1 is up, line protocol is up (looped)
Hardware is cyBus Serial
Description: OGLOBO | 2048K | RJO/IP/02813 | (RJO/IP/02813)
Internet address is 200.179.69.89/30
MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
reliability 255/255, txload 66/255, rxload 13/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec) ...
#
#acc09.rjo#ping 200.179.69.89 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 200.179.69.89, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 4/7/28 ms
#

08/04/15

CRIP - Embratel

15

PPP
PPP pode ser usado em circuitos entre
equipamentos de diferentes fabricantes
Permite conexes multilink
Permite balanceamento (mx. 12M ou
16M para multilink)
08/04/15

CRIP - Embratel

16

PPP - Teste
Trocar o encapsulamento de PPP para
HDLC
Verificar se o circuito esta em loop
Fazer teste de ping no endereo ip da
WAN-PE
Aps o teste voltar o encapsulamento
para PPP

08/04/15

CRIP - Embratel

17

PPP - Teste
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#interface serial 3/0/1
(config-if)#encapsulation hdlc
(config-if)#^Z
#
#show interfaces serial 3/0/1
Serial3/0/1 is up, line protocol is up (looped)
Hardware is cyBus Serial
Description: OGLOBO | 2048K | RJO/IP/02813 | (RJO/IP/02813)
Internet address is 200.179.69.89/30
MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
reliability 255/255, txload 66/255, rxload 13/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec) ...
#
08/04/15

CRIP - Embratel

18

PPP - Teste (cont.)


#acc09.rjo#ping 200.179.69.89 re 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 200.179.69.89, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 4/7/28 ms
#
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#interface serial 3/0/1
(config-if)#encapsulation ppp
(config-if)#^Z
#

08/04/15

CRIP - Embratel

19

ATM
No ATM no possvel realizar teste de loop*
Apenas teste de conectividade - PING
Caso o circuito possua conexo BGP, verificar
se houve log de quedas desta conexo
*nos circuitos ponto-a-ponto possvel teste de loop

08/04/15

CRIP - Embratel

20

ARPA
No ARPA no possvel realizar teste de loop
Apenas teste de conectividade - PING
Caso o circuito possua conexo BGP, verificar
se houve log de quedas desta conexo

08/04/15

CRIP - Embratel

21

Frame Relay
No FR no possvel realizar teste de loop.*
CIR:
Taxa na qual o provedor se comprometeu a
entregar ao cliente.
DE (Discard Elegible):
O bit DE sinaliza se o frame deve ou no ser
descartado.
*nos circuitos ponto-a-ponto possvel teste de loop
08/04/15

CRIP - Embratel

22

Frame Relay
Comandos
show frame-relay pvc interface serial#
show frame-relay map
show policy-map interface serial# *

* caso o circuito possua DTS configurado


08/04/15

CRIP - Embratel

23

MPLS
Frame Relay
Circuitos ponto-a-ponto com encapsulamento
Frame Relay
Como fazer teste de loop
QOS e Fragmentao de pacotes
Compresso de cabealho
08/04/15

CRIP - Embratel

24

MPLS - Teste de Loop


Para teste de loop em circuitos MPLS
FR deve ser removido o parmetro
keepalive na interface principal, veja:
Exemplo: Interface Serial 1/0/3:3.1
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#interface serial 1/0/3:3
(config-if)#no keepalive
(config-if)#^Z
#
08/04/15

CRIP - Embratel

25

MPLS - Teste de Loop


No aparecer a palavra looped no show
interface serial, veja:
#show interface serial1/0/3:3.1
Serial1/0/3:3.1 is up, line protocol is up
Hardware is Multichannel T1/E1 without TDM
Description: GMDEALER | 128K | IIG/IP/00020 | (IIG/IP/00020)
Internet address is 201.30.245.249/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 3/255, rxload 3/255
Encapsulation FRAME-RELAY IETF
Last clearing of "show interface" counters never
#

08/04/15

CRIP - Embratel

26

MPLS
Teste de Loop
E assim efetuar o teste de ping no ip WANPE.
#ping vrf GMDEALER:150170 201.30.245.249 repeat 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 201.30.245.249, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 32/32/32 ms
#

08/04/15

CRIP - Embratel

27

MPLS
Teste de Loop
No esquecer de voltar o parmetro
keepalive aps o teste de loop, veja:
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#interface serial 1/0/3:3
(config-if)#keepalive 10
(config-if)#^Z
#

08/04/15

CRIP - Embratel

28

MPLS - QoS
Problemas de Qualidade da Voz - M
qualidade da Voz
As causas possveis so:

08/04/15

Descarte por policiamento no Backbone


Descarte na Sada pelo CPE

CRIP - Embratel

29

MPLS - QoS
Chamada de voz muda em um sentido
-

Isto provavelmente ocorre devido a problemas com


a compresso de cabealho, cRTP

Deve-se, antes de tudo, verificar se a compresso


est configurada no PE e no CPE corretamente

08/04/15

CRIP - Embratel

30

MPLS - QoS
Problemas de Eco e/ou Volume
-

Deve ser verificado no CPE

O CPE possui parmetros de configurao para


suprir eco e ganho de volume

08/04/15

CRIP - Embratel

31

MPLS
QoS
Comandos para Troubleshooting:
show policy-map interface
show ip rtp header-compression serial
show frame-relay fragment interface serial
show policy-map WORD (policy-map name)

08/04/15

CRIP - Embratel

32

MPLS - QoS

PING ESTENDIDO para teste das classes configuradas


Pode-se forar o trfego pelas classes REALTIME e BUSINESS
utilizando o ping estendido.
No caso do REALTIME, coloca-se 184 no campo "Type of service".
Para BUSINESS, coloca-se 104.

08/04/15

CRIP - Embratel

33

MPLS - QoS
acc02.cta#ping vrf SADIALEG:1133
Protocol [ip]:
Target IP address: 192.168.1.24
Repeat count [5]: 50
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 104
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 192.168.1.24, timeout is 2
seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max =
24/91/156 ms

08/04/15

CRIP - Embratel

34

MPLS - QoS
acc02.cta#ping vrf SADIALEG:1133
Protocol [ip]:
Target IP address: 192.168.1.24
Repeat count [5]: 50
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 184
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 192.168.1.24, timeout is 2
seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

08/04/15

CRIP - Embratel

35

MPLS - QoS
O valor a ser usado no ping o valor decimal do
DSCP multiplicado por 4. Isso ocorre devido ao fato
dos 6 bits DSCP estarem deslocados 2 bits a esquerda
(22=4). Ver tabelas a seguir:
DS5 DS4 DS3 DS2 DS1 DS0

(DS5-DS0) Differentiated Services Code Point


(DSCP) 6 bits
(U) Unused 2 bits

08/04/15

CRIP - Embratel

36

MPLS - QoS
DSCP Class (nome)
BE (best effort, default)
AF11 (assured forwarding, see RFC 2597)
AF12
AF13
AF21
AF22
AF23
AF31
AF32
AF33
AF41
AF42
AF43
CS1 (class selector)
CS2
CS3
CS4
CS5
CS6
CS7
EF (expedited forwarding, see RFC 2598)

08/04/15

Valor
Valor Valor a ser usado no ping
Binrio Decimal
estendido
000000
0
0
001010
10
40
001100
12
48
001110
14
56
010010
18
72
010100
20
80
010110
22
88
011010
26
104
011100
28
112
011110
30
120
100010
34
136
100100
36
144
100110
38
152
001000
8
32
010000
16
64
011000
24
96
100000
32
128
101000
40
160
110000
48
192
111000
56
224
101110
46
184

CRIP - Embratel

37

MPLS - QoS
Header-compression proprietrio da Cisco, o
Vanguard ao invs de comprimir o cabealho RTP ele
implementa uma funcionalidade chamada VAD (Voice
Activity Detection), que atua na supresso dos pacotes
de silncio e otimiza a banda.
Exemplos:

CISCO:
G.729a
G.723

VANGUARD: s/VAD
G.723
22K

08/04/15

s/compresso
30K
22K

c/compresso
15K
11K
c/VAD
11K

CRIP - Embratel

38

MPLS - QoS
FRAGMENTAO:
A
tabela
de
fragmentao calculada em funo
apenas da banda do circuito e independe
do roteador
Vanguard no fragmenta valores menores
que 128 bytes, s fragmenta em mltiplos
de 64K, que numericamente igual a
banda do circuito
08/04/15

CRIP - Embratel

39

MPLS QoS
Tabela de Fragmentao:
CISCO:
Link Speed (kbps)
56
64
128
256
512

Fragmentation Size (bytes)


70
80
160
320
640

VANGUARD:
Link Speed (kbps)
64
128
256
512

Fragmentation Size (bytes)


128
128
256
512

08/04/15

CRIP - Embratel

40

Nuvem MPLS
Comandos para Troubleshooting :
show ip vrf interfaces | i <WORD>
WORD VPN Routing/Forwarding instance name
show ip vrf detail <WORD>
show ip route vrf <WORD>
show ip bgp vpnv4 vrf <WORD>

08/04/15

CRIP - Embratel

41

Multilink PPP
Interfaces PPP at 512Kbps
interface Multilink1
bandwidth 512
ip vrf forwarding BPN
ip address 10.0.0.5 255.255.255.252
service-policy input QOS_POLICY_IN
service-policy output QOS_POLICY_OUT
load-interval 30
no cdp enable
ppp multilink
! A fragmentao deve ser configurada com delay de
!serializao de 10ms, que o valor recomendado para o
!funcionamento da voz.
ppp multilink fragment delay 10
ppp multilink interleave
ppp multilink group 1
no clns route-cache
08/04/15

CRIP - Embratel

42

Multilink PPP
Depois de criada a interface Multilink, as seriais devem ser
includas no Bundle:
interface Serial3/0/6:0
no ip address
encapsulation ppp
tx-queue-limit 26
no cdp enable
ppp chap hostname TESTE
! Este comando define o par origem-destino pertencente
!interface Multilink. Deve ser obrigatoriamente
!configurado no caso de haverem mltiplas interfaces
!Multilink para o mesmo par origem-destino
ppp multilink
ppp multilink group 1
no clns route-cache
08/04/15

CRIP - Embratel

43

Multilink PPP
Interfaces PPP acima de 512Kbps e abaixo de 2Mbps:
interface Multilink1
! Repare que no usado o comando bandwidth, isto pq este
! comando fixaria a banda da interface virtual no
! permitindo que os ajustes percentuais tenham efeito
ip vrf forwarding TESTE
ip address 10.22.1.62 255.255.255.252
ip pim sparse-mode
service-policy input WAN_IN
service-policy output WAN_OUT
load-interval 30
ppp multilink
ppp multilink fragment disable
ppp multilink links minimum <nde links> mandatory
! Usando o mandatory se o n de links for inferior ao !limite
setado a interface declarada down
ppp multilink group 1
no clns route-cache
08/04/15

CRIP - Embratel

44

Multilink PPP
Adicionando as Seriais ao Bundle:
interface Serial1/0/0:0
no ip address
encapsulation ppp
no fair queue
ppp chap hostname G2
ppp multilink
ppp multilink group 1
no clns route-cache
!
interface Serial1/0/1:0
no ip address
encapsulation ppp
no fair-queue
ppp chap hostname G2
ppp multilink
ppp multilink group 1
no clns route-cache
08/04/15

CRIP - Embratel

45