Você está na página 1de 4

PR-PROCESSAMENTO DE

IMAGENS DO SENSOR ASTER


Programa ENVI
@

Guia de referncia
DISERE/2005
Mnica Mazzini Perrotta
DISERE
perrotta@sp.cprm.gov.br

Pr-processamento de imagens do sensor ASTER no programa ENVI
PR-PROCESSAMENTO DE IMAGENS DO SENSOR ASTER NO
SOFTWARE ENVI
Guia de referncia
Introduo: Uma cena ASTER (1B) original vem em dois arquivos:
AST_L1B_003_MMDDAAAAHHMMSS_ mmddaaaahhmmss.hdf e
AST_L1B_003_MMDDAAAAHHMMSS_ mmddaaaahhmmss.hdf.met
O primeiro de extenso .hdf traz os dados propriamente ditos
O segundo, de extenso .met (ASCII) o cabealho com as informaes da
imagem.
AST_L1B_003: significa que se trata de uma imagem no formato 1B (com pr-
processamento: correo geomtrica, georreferenciamento e valores de radincia
reamostrados entre 0 e 255), no sensor V003.
MMDDAAAAHHMMSS: corresponde data e horrio (GMT) de aquisio da cena.
mmddaaaahhmmss: corresponde data e horrio (GMT) de processamento da
cena.
A correspondncia entre as bandas espectrais do sensor ASTER e dos sensores
LANDSAT TM e ETM+pode ser observada na figura 1.

Figura 1
Preliminares:
No ENVI: File > Preferences > Default directories > Selecionar como diretrios de
dados e de sada (data directory e output directory) o diretrio de trabalho. Salvar a
nova configurao.
1. Abrir a imagem:
File > Open external file > EOS > ASTER > Input file AST_L1B_003_
MMDDAAAAHHMMSS_ mmddaaaahhmmss.hdf > ok
Observaes:
a. o ENVI abre tambm diretamente a imagem em File > Open image file,
selecionando-se o arquivo de extenso .hdf
b. observe que na caixa de dilogo Available bands list sero abertos 4 conjuntos de
bandas:
_______________________________________________________________________________
DISERE
Diviso de Sensoriamento Remoto
1


Pr-processamento de imagens do sensor ASTER no programa ENVI
1: corresponde s 3 bandas do VNIR (visvel e infravermelho prximo, 1 - comprimento
de onda no verde, 2 comprimento de onda no vermelho, 3 comprimento de onda no
infravermelho prximo). Resoluo de 15 m.
2: corresponde banda 3B (back visada traseira para par estereoscpico).
Resoluo de 15 m.
3: corresponde s 6 bandas do SWIR (infravermelho de ondas curtas). Resoluo de
30 m.
4: corresponde s 5 bandas do TIR (infravermelho termal). Resoluo de 90 m.
2. Fechar as bandas 3B e TIR (que no sero utilizadas neste trabalho):
Na caixa de dilogo Available bands list > clicar no ttulo da banda 3B com o
boto da direita do mouse > close selected file.
Repetir para o conjunto TIR.
3. Visualizao das imagens em escala de cinza e em canais de cor RGB
Available bands list > gray scale (escolher vrias bandas).
Available bands list > RGB (escolher vrios tripletes de bandas)
Observaes:
a. Para que a imagem no fique inclinada na horizontal, as cenas ASTER vm com uma
rotao de aproximadamente -8 com relao ao norte.
b. Note-se que no possvel fazer-se uma composio colorida misturando-se bandas dos
conjuntos VNIR e SWIR, j que tem resolues espaciais diferentes e portanto deve-se
proceder a compatibilizao da resoluo, aumentando-se (artificialmente) a do SWIR ou
diminuindo-se a do VNIR.
4. Criar a imagem no formato ENVI, com todas as bandas da cena:
Observaes:
a. Depois deste procedimento o giro da cena vai ser eliminado. A cena pode tambm ser
rotacionada da seguinte forma: Menu Basic Tools > Rotate/Flip data > o ENVI identifica
automaticamente o ngulo de rotao, baseando-se no cabealho da imagem.
b. Se o computador tiver um bom espao em disco e boa memria RAM (maior que 512
Mb) e principalmente se o trabalho for em escala igual ou maior que 1:100.000, no hesite,
escolha a imagem de sada com resoluo de 15 m, assim toda a resoluo das bandas do
VNIR aproveitada, caso contrrio, reamostre todas as bandas para 30 m.
c. Procure definir uma extenso de sua preferncia (img, dat, etc) para as imagens geradas
no ENVI (como default elas no tem extenso).
Basic tools > layer stacking > Import files > Input file 2 conjuntos: (VNIR
- 3 bandas e SWIR - 6 bandas) (figura 2) > Reorder Files (para colocar as
bandas na ordem correta de numerao) > na janela Reorder files, com o boto
da esquerda do mouse pressionado arraste a banda para a posio desejada
(figura 3) > na projeo de sada, aceitar UTM e o datum WGS84 (o mesmo das
imagens Geocover 2000) > no mtodo de reamostragem utilize vizinho mais
prximo ou bilinear (o primeiro preserva mais os dados originais mas o
segundo gera uma imagem visualmente mais agradvel) > no tamanho do pixel
de sada entre com o valor desejado > Output file (escolher um nome).img
(figura 2).
_______________________________________________________________________________
DISERE
Diviso de Sensoriamento Remoto
2


Pr-processamento de imagens do sensor ASTER no programa ENVI
Figura 2
Figura 3
5. Consideraes finais:
Os procedimentos descritos em 1, 2, 3 e 4 devem ser executados para todas as
cenas ASTER que compem a rea de trabalho.
A partir das imagens produzidas para cada cena, que contm 9 bandas nas regies
do VNIR e SWIR do espectro eletromagntico, pode-se fazer o processamento
digital normalmente, como se faz com as imagens LANDSAT. Consulte o manual
Processamento digital bsico de imagens de sensores remotos pticos para uso
em mapeamento geolgico para referncia de procedimentos bsicos no
tratamento de imagens.
6. Referncia
Research Systems International. 2003. ENVI - The environment for Visualizing
Images. Users Guide, 1084 p. Disponvel na forma digital.

_______________________________________________________________________________
DISERE
Diviso de Sensoriamento Remoto
3