Você está na página 1de 5

Exerccio Excel Imagine uma loja que tenha dezenas de funcionrios espalhados em vrias regies e queira fazer um clculo

do total de vendas desses funcionrios, um total de vendas por regio e para complicar, descobrir quanto cada um desses funcionrios vai receber de comisso baseado nesse total de vendas. Normalmente, geram-se tabelas diversas para cada um desses objetivos, o que vem a ser mais trabalhoso do que fazer tudo de uma tacada s. Utilizando o Excel, podemos criar uma nica tabela na qual conste: o nome dos vendedores, os produtos vendidos e as regies que eles trabalham e as vendas de cada um deles. Como no exemplo abaixo:

Montada a tabela, mas ainda preciso de uma informao, preciso do total de cada produto vendido pelo vendedor. Para isso, devo efetuar um clculo simples de multiplicao. Devo multiplicar a quantidade pelo preo do produto (= E4*F4) na coluna Total. Bom, agora j podemos comear a complicar a coisa. Como eu tinha dito acima, eu quero obter dessa tabela diversos relatrios: quero saber o total de vendas por vendedor, por regio e por produto. Alm disso, quero saber quanto de comisso o vendedor vai receber (seguindo um critrio, que toma por base o total de vendas do mesmo). Complicadinho, n? Mas s na aparncia. A segunda parte da nossa tabela digitar o que se espera obter da mesma, por isso, irei montar trs tabelinhas a parte com os itens do relatrio: Para calcular o total de vendas por vendedor, preciso realizar uma soma condicional, isso , eu s quero que o programa calcule o total da vendedora X. Para isso, uma frmula no seria eficiente, preciso de uma Funo.

S relembrando, funes so recursos semelhantes s formulas, mas com uma capacidade maior de resolver o nosso problema, primeiro que as mesmas no se restringem apenas ao clculo, embora no se furtem a isso, se necessrio, mas tambm nos oferecem resolues mais trabalhadas. Como no nosso exemplo. Neste caso, preciso de uma funo chamada SOMASE ( o prprio nome j diz a que veio essa funo realiza uma Soma, Se algo for cumprido) uma soma condicional. Veja se ela realmente se aplica ao nosso caso: Como j havia dito preciso calcular o total das vendas do vendedor X. Ento, preciso que o programa busque na coluna dos vendedores todas as referncias ao vendedor X e faa uma relao com a coluna Total do Preos dos produtos vendidos. A funo SOMASE possui uma estrutura bsica que se mantm inaltervel. =SOMASE(Xni:Xnf;nome;Yni:Ynf) Traduzindo: Xni:Xnf = endereo inicial (Xni) at o endereo final (Xnf) da coluna onde se encontra o tem a ser comparado no caso do nosso exemplo o endereo inicial da coluna de vendedores at o endereo final (A4:A20) nome = Nome do tem a ser comparado no caso, o nome do vendedor, pode-se usar neste caso a clula onde se encontra o nome do vendedor. Yni:Ynf= Endereo inicial (Yni) at o endereo final (Ynf) da coluna onde se encontram os valores a serem somados no caso do nosso exemplo o endereo inicial da coluna total at o endereo final (G4:G20) Ficando o resultado final assim: =SOMASE(A4:A20;Vendedor;G4:G20)

Devemos aplicar a funo para cada um dos vendedores, s trocando o nome, o primeiro Maria, o segundo Alfredo etc. Uma maneira melhor substituir vendedor pelas clulas que contm os nomes dos vendedores, H10, H11, H12, H13, H14, H15 No adianta puxar pela ala de preenchimento, pois os endereos devem permanecer sempre os mesmos. Um macete prender as linhas e assim podemos arrastar e somente ir substituindo os nomes dos vendedores.

Ex: =SOMASE(A$4:A$20; H10 ;G$4:G$20) {Agora s usar a ala de preenchimento}

Devemos repetir o mesmo procedimento para gerar relatrios dos totais de Produtos e Regies, s lembrando de trocar a coluna dos vendedores para a de total de Produto e a de Regio.

Agora vamos descobrir quanto cada vendedor ir receber. Para isso vou estipular uma condio: Se o vendedor vendeu mais de R$ 5.000,00 receber 1% de comisso mais o salrio que R$ 500,00, se vendeu abaixo disso, a comisso ser de 1,5% mais o salrio. Quando trabalhamos com condio, usamos a Funo SE, que estipula que algo s acontecer se a condio for cumprida. A funo SE possui uma estrutura bastante simples de se entender, e ela a chave para que nunca mais esquemos como us-la. Estrutura da Funo SE:

=SE(Teste_lgico;Valor_se_Verdadeiro;Valor_se_Falso) Sendo Teste Lgico a nossa condio, o valor se verdadeiro o que acontecer caso a condio seja

atendida e o valor se falso o que acontecer se a condio no for atendida. Dessa maneira temos que transpor o que desejamos obter para dentro dessa estrutura. O primeiro passo seria, ento, descobrir qual o Teste Lgico. Na Frase : Se o vendedor vendeu mais de R$ 5.000,00 receber 1% de comisso mais o salrio que R$ 500,00, se vendeu abaixo disso, a comisso ser de 1,5% mais o salrio qual o Teste Lgico? O que desejamos testar? Preste ateno no inicio da frase: total de vendas do Vendedor ser maior que R$ 5.000,00 ento esse seria o teste lgico. Se esse total for maior que R$ 5.000,00, o vendedor receber 1% de comisso (desse total), acrescido de R$ 500,00 Esse ento seria o valor se verdadeiro e por fim, caso o total devendas seja inferior a R$ 5.000,00 ento a comisso seria de 1,5% (desse total), mais R$500,00. Ficando assim a nossa Funo: =SE(total_de_vendas>5000;(total_de_vendas*1%)+500;(total_de_vendas*1,5%)+500)

Acontece que total de vendas possui um endereo e devemos substituir o texto pelo endereo do mesmo, olhe na tabela e veja em que lugar se encontra o total de vendas por vendedor.

No nosso exemplo, o total est situado na coluna I, linha 10. Ento nossa Funo ficaria exatamente assim: =SE(I10>5000;(I10*1%)+500;(I10*1,5%)+500) Bastaria puxar e teramos a informao do salrio dos vendedores: Resolvendo assim todas os desafios da planilha, agora s salvar.

Confira na planilha abaixo se tudo deu certo.