Você está na página 1de 10

Microsoft Excel

Parte II Frmulas e Funes Especiais


FRMULAS Ao introduzirmos uma frmula numa clula, o Excel ir calcular a resposta correcta automaticamente, mantendo-a sempre actualizada e recalculando os resultados sempre que algum valor for modificado. Ao digitar uma frmula numa clula, obrigatoriamente ela dever comear com um sinal de igual (=). Prioridade em Frmulas Na matemtica alguns operadores tm prioridade sobre outros na ordem de realizao dos clculos. Estas prioridades valem tambm quando so realizadas operaes no Excel. So eles: Smbolos () ^ */ +Exemplos:

Operadores Parnteses Exponenciao Multiplicao e Diviso Soma e Diminuio O resultado 5,5 O resultado 4

=3+5/2 =(3+5)/2

Exerccio 1: Constri a seguinte folha de clculo:

Microsoft Excel Frmulas

Dicas: Para a clula F6 escreva a frmula (no final, prima a tecla ENTER): = C6+D6+E6 Para as clulas de F7 a F11: arraste a ala de preenchimento da clula F6. O Excel ir copiar a frmula anterior e ajustar automaticamente a identificao das clulas. Para a clula F12 digita a frmula: =F6+F7+F8+F9+F10+F11. FUNES ESPECIAIS Uma funo uma frmula pr-definida. Tal como as frmulas criadas pelo utilizador, as funes devem comear por um sinal de igual (=) para que o Excel saiba interpreta-las como frmulas e no como texto. aconselhvel digitar o nome da funo e o nome da clula em letra maiscula. = SOMA(): Soma todos os valores do grupo ou clulas indicadas. Ex: =SOMA(A1:C1) ou =SOMA(A1;B1;C1) Ateno: no deve haver espao entre o nome da funo e o 1 parntese = MDIA(): Calcula o valor mdio do grupo ou clulas indicadas. Ex: =MDIA(A1:C1) ou MDIA(A1;B1;C1) = RAIZ(): Calcula a raiz quadrada da clula indicada. Ex: RAIZ(A1)

Exerccio 2: Faa a seguinte folha de clculo de controlo de mdias escolares:

Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

Dicas: 1 SEM (clculo da mdia a partir do valor real) Para a clula G7 digita a funo: =SOMA(D7:F7) Para as clula G8 a G11: arraste a ala de preenchimento da clula G7 at a clula G11. Para a clula G12 digita a funo: =SOMA(D7:F7) 2 SEM (clculo da mdia na escala de 20) Para a clula G15 digita a funo: =(D15*0,4)+(E15*0,6) isto significa que atribumos um peso de 40% para os trabalhos e 60% para as frequncias e somamos os dois valores. Para a clula G20 digita a funo: =MDIA(G15:G19) Media Geral Para calcular a mdia dos dois semestres: =MDIA(G12;G20) Ateno: nesta funo utilizamos o ponto e vrgula para definir o clculo somente das duas clulas definidas e no do intervalo entre elas.

FUNES AUTOMATIZADAS

Funo Autosoma
Algumas funes mais utilizadas j esto programadas no Excel. Um exemplo disto o boto Autosoma: Exerccio 3: Abra a folha de Controlo de Gastos j construda; Clique na borda da clula Total e arraste-a para a coluna B (para transferi-la, como na imagem); 3. Marque com o rato as clulas de C6 a E11; 4. Clique no boto Autosoma. Os resultados dos gastos totais de cada ms sero colocados nas clulas C12, D12 e E12, respectivamente.
1. 2.

Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

Funo Mximo
Esta funo expe o maior valor de um grupo de clulas. Exerccio 4: Na folha anterior, utilize a funo Mximo para apresentar o Maior Gasto do trimestre na coluna G. Para isto, marque as clulas C6, D6 e E6, clique na seta do boto Autosoma e escolhe a funo Mximo; 2. Repete os procedimentos anteriores para calcular os mximos dos outros departamentos.
1.

Funo Percentagem e Subtraco


Este clculo feito da mesma forma como numa mquina de calcular. A diferena que preciso indicar quais clulas esto envolvidas. Exerccio 5: construa a folha de clculo abaixo. O objectivo organizar os valores totais de venda e calcular o valor com desconto.

Na clula C2 escreva a frmula: =B2*5% Na clula D2 escreva a frmula: =B2-C2 Clique na ala de preenchimento da clula C2 e arraste-a para as clulas C3 e C4; 4. Clique na ala de preenchimento da clula D2 e arraste-a para as clulas D3 e D4;
1. 2. 3.

Frmulas com Referncia Relativa e Absoluta


At agora utilizamos o endereo das clulas e no os seus valores para a construo das nossas frmulas. Isto permite que, sempre que os valores que influenciam a frmula forem alterados, os resultados so automaticamente recalculados. Neste ltimo exerccio, quando arrastamos a ala de preenchimento para as clulas D3 e D4, a frmula foi automaticamente adaptada para os novos endereos C3 e C4. A frmula

Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

utiliza, portanto, referncias relativas. Esta adaptao simplifica muito o trabalho do utilizador. Porm, nem sempre possvel utilizar a cpia das frmulas e a sua consequente adaptao. Na figura abaixo, acrescentamos o clculo do IVA ao preo final dos produtos. Na clula E2 escrevemos a frmula: =D2*E5+D2. Isto implica em calcular o valor do produto mais IVA: 1482*17%+1482. O valor do IVA foi indicado na clula E5. Porm, ao arrastar a ala de preenchimento para as clulas a seguir, o programa ir adaptar a referncia E5 para E6, E7 etc., o que no nos interessa pois isto ir modificar o valor. Ento indicamos ao programa que pode haver adaptao na frmula excepto na clula E5. Assim, com o smbolo $ indicamos a clula E5 como uma referncia absoluta. Imaginando que temos uma lista de 1000 clientes, este processo simplifica muito o trabalho. Nota que o Excel associa, atravs das cores, os endereos da frmula s suas respectivas clulas.

Exerccio 6: na folha de clculo do exerccio anterior, acrescente o clculo do IVA ao valor final a pagar pelo cliente.

Funo SE (frmulas condicionais) = SE (teste_lgico ; valor_se_verdadeiro; valor_se_falso)


Esta funo utilizada para testar mais de uma condio e, conforme o resultado, apresentar um ou outro valor. Em outras palavras, a funo retorna um valor como resultado se a condio testada for VERDADEIRA e outro valor caso a condio seja FALSA. Os valores da funo devem ser colocados entre parnteses, como acima. Exerccio 7 Clculo de Comisses: A loja Sony pagar a comisso de 8% ao vendedor SE as vendas ultrapassarem a meta de 20,000 e 5% SE as vendas forem abaixo deste valor. Assim, considerandose que o valor total das vendas do funcionrio est na clula B4, ento a condio SE ficar como abaixo:

= SE(B4>20000;B4*8%; B4*5%)
Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

teste_lgico: valor_se_verdadeiro:

expresso que verifica se o valor da vendas superior a 20000 euros. se o teste for verdadeiro, ou seja, se as vendas forem superiores a 20000, ento valor da comisso de 8% do valor das vendas (B4*8%). se o valor das vendas for inferior a 20000 a comisso de 5% (B4*5%)

valor_se_falso:

Obs: no necessrio introduzir ponto ou vrgula como separador de milhar. Para introduzir casas decimais e/ou smbolo monetrio v ao menu Formatar / Clulas e no separador Nmero escolha a categoria Contabilidade:

com o smbolo cardinal quando a quantidade de nmeros inserida maior do que o tamanho da clula capaz de mostrar. Clique ento na letra da coluna correspondente e aumente a largura desta.

Erro? O tamanho da clula no suficiente! O Excel preenche o campo

Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

Funo SE com condio Mltipla


Pretende-se fazer um clculo diferenciado para os vendedores estagirios. Assim, se o valor das vendas for superior a 15000, ento h uma comisso de 4%; se for igual a 15000, a comisso ser de 3%, seno (se for inferior a 15000) ser de 2%. Exerccio 8 (utilizar a folha j construda). Uma outra forma de escrever a funo atravs do formulrio. Ele ajuda-nos a introduzir os smbolos e parnteses nos lugares certos. Para isto basta ir ao menu Inserir / Funes, escolher a funo SE e, de seguida, introduzir os dados nos campos. Experimente!

=SE(B7>15000;B7*4%;SE(B7=15000;B7*0,03;B7*0,02))

Funo SE e OU (com linguagem natural)


Exerccio 9: Para compreender esta funo lgica vamos construir um mapa de Stocks.

A funo lgica OU verifica se pelo menos uma das condies indicadas verdadeira. Em outras palavras, SE o Stock Actual for inferior ao Mnimo OU SE o nmero de pedidos registados for maior do que o Stock Actual, ento sinalizamos o mapa com o texto Stock Negativo. Nota que o texto deve sempre ser escrito entre aspas.
Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

=SE(OU(C3<B3;D3>C3);"Stock Negativo";"Stock OK")

Formatao Condicional
Podemos aplicar uma formatao diferente (de texto ou outra) a uma clula ou conjunto de clulas, com base numa determinada condio e assim realar os dados que satisfazem a condio especificada. Exerccio 10. Aplicar cor vermelha ao texto quando o stock estiver inferior ao mnimo. 1- Seleccione as clulas s quais deseja aplicar a formatao; 2- No menu Formatar, escolha a opo Formatao Condicional; 3- No quadro que se abre, defina a condio como sendo quando o valor da clula for igual a Stock Negativo; 4- Clique no boto Formato para definir as caractersticas da formatao. Neste caso a condio a ser verificada um texto, mas poderia ser uma frmula ou um valor;

5- Arraste a ala de preenchimento para as demais linhas. A coluna E dever ficar como na imagem abaixo.

6- Outra forma de destacar esta informao seria definir um intervalo para o nmero de produtos do stock na coluna C. Posicione o cursor na clula C3 da tabela (relativo a Stock Actual). 7- Abra novamente a janela Formatao Condicional no menu Formatar.

Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

8- Neste caso vamos estabelecer duas condies. Primeiro, se o nmero do Stock Actual for menor que o Stk Mnimo, ento marcamos o para minimizar o tamanho da texto em amarelo. Clique no cone caixa de dilogo e, de seguida, clique na clula B3. Com isto indica que se o valor de C3 for menor que o valor de B3, ento o formato deve ser mudado.

9- Clique em Formato para definir a formatao;

10Para definir a segunda condio, clique no boto Adicionar. Isto dever expandir a janela. Defina ento que se o nmero de produtos do Stock Actual for maior ou igual ao Stk Mnimo, ento realamos o texto em azul. Prima Ok; 11Para expandir a formatao da clula C3 para as outras clulas da mesma coluna, posicione o cursor na clula C3, clique no cone de e, de seguida, marque com o rato as clulas cpia de formatao de C4 a C7. Ao soltar o boto do rato a formatao da clula C3 colada nas demais clulas.

Funo SE e E
A funo lgica E verifica se as duas condies impostas pela expresso so verdadeiras. Em outras palavras, SE o aluno tiver mdia final igual ou superior a 14 valores E no tiver nenhuma disciplina em atraso, ento poder se candidatar ao novo mestrado da faculdade. Por outro lado, se ele falhar em apenas uma das duas condies, ento no pode se candidatar. Exerccio 11 - Relao de alunos candidatos ao mestrado. 1- Construa a folha abaixo utilizando os conhecimentos j adquiridos; 2- Na clula D3 escreva a frmula abaixo; 3- Clique e arraste a ala de preenchimento da clula D3 para as outras clulas da mesma coluna e assim copiar a frmula.
Material elaborado por: prof. Ana Maria Abro

Microsoft Excel Frmulas

=SE(E(B3>=14;C3="No");" candidato";"No candidato")

Funo SOMA.SE
A funo lgica SOMASE soma os valores de acordo com o critrio indicado na expresso. SOMA.SE(intervalo_critrio; critrios; intervalo_soma)

intervalo_critrio Intervalo onde ser verificado o critrio. critrios Critrios que condicionam a soma. intervalo_soma Intervalo onde se encontram os valores a serem somados. Exerccio 12: organize os dados da folha de clculo sugerida na figura a seguir para o controlo de facturas pagas. A frmula abaixo pode ser interpretada da seguinte forma: Se no intervalo de clulas de C2 a C7 for encontrado o critrio PG, some os valores das clulas correspondentes no intervalo entre B2 e B7. =SOMA.SE(C2:C7;"PG";B2:B7) 1- Construa a folha de clculo abaixo; 2- Na clula C2 escreva a frmula acima; 4- Clique e arraste a ala de preenchimento da clula C2 para as outras clulas da mesma coluna.

Material elaborado por: prof. Ana Maria Abro

10