Você está na página 1de 8

CAMADA DE REDE TRADUO DE ENDEREOS IPv4

ALUNO(S)/MATRCULA: Rafael Pires Fialho


Roberta da Silva Teixeira
DEPARTAMENTO:

Engenharia de Produo

DISCIPLINA:

Fundamentos de Redes
Robson de Oliveira Albuquerque, Dr.

PROFESSOR:

INTRODUO

A camada de rede responsvel pelo encaminhamento dos dados atravs


da interligao de redes, endereamento de pacotes de dados, e converso de
endereos lgicos (IP) em endereos fsicos ou MAC. Dentro da mesma, a camada 3
(layer 3) do modelo OSI, onde trabalham os roteadores, promovendo servios
relacionados ao processo de encaminhamento. Nessa camada problemas de
congestionamento e escolha de melhores rotas so realizados. Ela tambm
responsvel pela interconexo de diferentes camadas de enlaces de dados.
Dentro da camada de rede h um protocolo que permite a converso de
endereos de rede, endereos IPv4 de computadores de uma rede so convertidos
em endereos IPv4 de computadores em outra rede. Esse o Nat - Network Address
Translation.
O protocolo IPv4 utiliza endereos de 32 bits, segundo regras elaboradas
por forma a facilitar ao mximo o encaminhamento. Inicialmente o espao de
endereamento era largamente superior a qualquer tipo de necessidade em qualquer
instituio isoladamente. medida que as vrias redes IPv4 foram interligadas, vindo
a formar o que hoje conhecido por "internet", comeou a avolumar-se um grave
problema porque todos os endereos tinham de ser nicos. O espao de
endereamento comeou a no ser suficiente para as crescentes necessidades. Para
alm dos espaos de endereamento limitado (32 bits), as regras de endereamento
que dividem as redes em classes revelaram-se tambm muito restritivas, levando ao
"desperdcio" de muitos endereos, pois o aproveitamento de cada rede apenas se
verifica para um nmero exato de ns, que raramente corresponde s situaes
concretas. Para soluo desse problema uma das tcnicas desenvolvidas foi a
traduo de endereos que ser abordada nesta pesquisa.
2

COMO FUNCIONA O NAT

O IPV4 fornece um nmero limitado de endereos (existem 04 octetos,


totalizando 32 bits de endereamento). Com o RFC 1918 foram criadas regras que
permitiram a utilizao de endereos no roteveis nas redes locais, evitando que
toda e qualquer mquina que quisesse se conectar a uma rede tivesse que ser
reconhecida por um nico e exclusivo endereo em toda a Internet, gerando redes
isoladas. Porm essas redes possuem a necessidade de se comunicarem tanto com
a rede pblica quanto com outras redes privadas. a que entra a traduo de
endereos. O NAT opera normalmente em um roteador ou em um firewall, que so
dispositivos que recebem conexes de diferentes redes em seus terminais, Na figura
1, o endereo privado 10.0.0.3 traduzido pelo roteador NAT (RTA) para o endereo
pblico 179.9.8.80, quando o pacote enviado para a internet. Na volta o processo
inverso realizado no mesmo ponto.

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 1 Exemplo de NAT.

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 2 Exemplo de NAT (2).


Na figura 2, o processo NAT na volta realiza a traduo de um endereo
IPv4 de destino pblico para um endereo IPv4 de destino privado.
Pela necessidade de usar os endereos IPv4 pblicos para a internet, NAT
limita o nmero de hosts acessando a internet simultaneamente, dependendo do
nmero de hosts permitido pela sua mscara dos endereos IPv4 pblicos.
O Firewall tambm pode fazer a traduo de endereos assim como o
roteador executou. O sistema de servidores proxy bastante utilizado para executar
tambm o NAT.
2.1 NAT Esttico
3

Esse tipo de NAT associa um endereo privado a um endereo pblico em


uma relao um para um. Particularmente til no caso de servios internos serem
acessveis externamente. Tambm pode ser utilizada essa relao dentro de uma
rede privada que contm sub-redes e necessita efetuar a comunicao entre elas, por
exemplo, um rgo possui uma rede interna para dados e outra rede interna para
videoconferncia e decide utilizar um ip da rede interna de dados dentro da rede
interna de videoconferncia. Uma traduo pode ser realizada conforme passos
abaixo:
interface FastEthernet0/1.513
description ###VLAN 513 - VIDEOCONFERENCIA###
encapsulation dot1Q 513
ip address 10.9.132.100 255.255.128.0
ip access-group bsa-codec in
ip access-group spo-codec out
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip http server
ip nat inside source list nat_videoconf interface FastEthernet0/1.513
overload
ip nat inside source static 10.137.0.11 10.9.132.10
ip nat inside source static 10.150.0.10 10.9.132.16
ip nat inside source static 10.134.50.50 10.9.132.21
ip nat inside source static 10.140.50.50 10.9.132.22
ip nat inside source static 10.1.5.17 10.9.132.23
ip nat inside source static 10.1.50.50 10.9.132.24
ip nat inside source static 10.137.50.50 10.9.132.25
ip nat inside source static 10.144.50.50 10.9.132.27
ip nat inside source static 10.132.50.50 10.9.132.28
ip nat inside source static 10.139.50.50 10.9.132.31
ip nat inside source static 10.139.50.51 10.9.132.32
ip nat inside source static 10.135.50.50 10.9.132.254
ip access-list standard nat_videoconf
permit 10.137.0.26

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 3 NAT esttico.


2.2 NAT Dinmico
Associa um grupo de endereos privados a um grupo de endereos
pblicos em relao muitos para muitos.
Como funciona:

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 5 NAT dinmico (como funciona).

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 5 NAT dinmico (1).


5

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 6 NAT dinmico (2).


2.3 NAT Overloading
Uma forma de associao de mltiplos endereos IP internos a um nico
endereo externo usando diferentes portas TCP/UDP. Tambm conhecido como Port
Address Translation (PAT), NAT de endereo nico ou NAT multiplexado em portas.
Esse sistema permite o uso de um nico endereo IPv4 pblico e define-o
para at 65535 hosts internos. Modifica a porta de origem TCP/UDP para rastrear
endereos de hosts internos. Rastreia e traduz SA (Source Address Endereo de
origem), DA (Destination Address Endereo de destino) e SP (Source Port Porta
TCP ou UDP de origem), que definem de maneira nica cada conexo, para cada
fluxo de trfego.

fonte: Arquitetura e Protocolos de Rede TCP-IP ELIAS/LOBATO

Figura 7 PAT.
2.4 NAT Overlapping
Quando os endereos IP usados na sua rede interna tambm so usados
na rede externa, o roteador deve manter uma tabela destes endereos para que
consiga intercept-los e troc-los por endereos IP pblicos nicos em ambas as
direes. Destaca-se que o roteador NAT deve traduzir os endereos privados para
endereos pblicos, assim como traduzir os endereos pblicos para privados, que
sejam nicos dentro da rede. Isso pode ser feito atravs de NAT esttico ou utilizando
DNS com NAT esttico. Esse NAT utilizado quando necessrio interconectar duas
redes privadas com endereos que se superpem.
Exemplo: Suponha que um mesmo rgo pblico utilize num prdio a rede
privada 172.16.0.0/16 e em outro prdio a mesma faixa de endereos para outra rede
fsica (os dois prdios esto interligados).
Se for necessrio interligar as duas redes fsicas dos dois prdios, duas
alternativas so possveis:
1) Redefinir os endereos privados de uma das redes para evitar a
sobreposio;
2) Usar o esquema NAT Overlapping, que no exige a mudana de
endereos de nenhuma das duas redes fsicas.
2.5 Vantagens de utilizar o NAT
- Conectividade bidirecional transparente entre redes com diferentes endereamentos;
- Eliminam se gastos associados a mudana de endereos de servidores/rede;
- Economia de endereos roteveis do IPV4;
- Facilita o desenho/implementao de Redes;
- Aumenta a proteo das redes locais.
2.6 Desvantagens de utilizar o NAT
- Impossibilidade de se rastrear o caminho do pacote;
- Aumento do processamento no dispositivo tradutor
3

CONCLUSO

A utilizao da traduo de endereos - NAT - permite que se utilize o


espao de endereamento fornecido pelo IPV4 de uma forma mais inteligente e
racional, em conjunto com as especificaes propostas na RFC1918.
Alm da questo pura do endereamento, ele permite que se aumente a
segurana das redes locais contra possveis investidas de usurios externos com o
objetivo de comprometer a estrutura de dados que mantida localmente. muito
mais difcil ter sua rede invadida quando seu endereamento oculto.

perceptvel a possibilidade de crescente utilizado do NAT pelos


administradores de rede em todo o mundo.
REFERENCIAS BIBLIOGRFICAS
COMMER, Douglas E. Internetworking with TCP/IP - volume I. Prentice Hall 1995
ISBN 0-13-216987-8 (V.1)
ELIAS, Gldson. Arquitetura e protocol de rede TCP-IP / Gldson Elias, Luiz Carlos
Lobato. 2. Ed. Rio de Janeiro: RNP/ESR, 2013.
KUROSE, 2011 James F. Kurose and Keith W. Ross; "Redes de Computadores e a
Internet: Uma abordagem top-down"; 5 Edio. Pearson Addison-Wesley, 2011;
(Portugus).
________________https://technet.microsoft.com/pt-br/library/cc753373(v=ws.10).aspx
____________________________http://www.gta.ufrj.br/grad/01_2/nat/#Tipos de NAT