Você está na página 1de 5

Microsoft Excel - Dicas e truques passo a passo

Exemplo de folha de pagamento

Uma das principais dúvidas dos usuários que estão partindo do ponto intermediário ao avançado no Excel está
justamente na maneira correta de se aplicar uma função. As funções são de fundamental importância em
planilhas mais complexas e, como exemplo, iremos desenvolver uma simples planilha de folha de pagamento.

O primeiro passo é determinar o que é uma função. Você saberia definir? De forma simples e objetiva,
podemos definir uma função como uma fórmula e, esta fórmula para gerar um resultado final terá argumentos
e valores. Apesar de termos citados argumentos, uma função poderá ser escrita sem os mesmos, porém a
grande maioria das funções os possuem.

Veja a seguir as sintaxes das funções com ou sem argumentos:

• FUNÇÕES SEM ARGUMENTO:

=função()

Um exemplo simples deste tipo de função é a HOJE. Abra uma planilha no Excel e na célula A1 digite a seguinte
função: =HOJE(). Veja o resultado a seguir:

Observe que, com a ajuda da função HOJE, você facilmente insere em seu documento a data atual e a mesma
será atualizada automaticamente sempre que a planilha for aberta.

• FUNÇÕES COM ARGUMENTO:

=função (argumento1, argumento2, argumento3 .....)

Neste caso, teremos que seguir algumas regras:

1. Nas funções que são exigidos argumentos, os mesmos deverão sempre estar dentro de parênteses;
2. É permitido apenas uma função por célula;
3. O nome da função não poderá ultrapassar 256 caracteres;
4. Os argumentos das funções deverão estar separados pelo símbolo de virgula ou ponto e vírgula;
5. Os argumentos de uma função também poderão ser constantes;
6. Os argumentos de uma função poderão ser fórmulas;
7. Uma função poderá ter como argumento uma outra função.

Vamos então montar a nossa folha de pagamento através do Excel, para isso, siga os passos a seguir:

1. Na célula A1, entre com o seguinte conteúdo texto: Projeto Aprenda em Casa - Folha de pagamento;
2. Na célula A2, entre com o seguinte conteúdo texto: VALOR ATUAL DO SALÁRIO MÍNIMO R$;
3. Em seguida, nas células A4, A5 ... digite respectivamente:

• Nome do Funcionário;
• Código;
• Função;
• Fx salarial;
• Salário Bruto;
• Desc. INSS;
• Número Dep.;
• Sal. Família;
• Desc. IRRF;
• Descontos;
• Salário Liquido.

4. Na célula A13 digite o conteúdo texto: TOTAL DOS SALÁRIOS PAGOS;


5. Na célula A14 digite o conteúdo texto: MÉDIA DOS SALÁRIOS PAGOS;
6. O nome dos funcionários deverão ser digitados nas células A6 ... A10;

No Projeto Aprenda em casa, um código representa uma determinada função e automaticamente uma faixa
salarial, determinada pelo número de salários mínimos, sendo assim, observe a tabela a seguir:

Código Função Fx salarial

1 Atendente 5
2 Analista de suporte 12

3 Desenvolvedor 10

A tabela acima, iremos digitar em uma parte separada da planilha. Digite a mesma a partir da célula M1,
conforme mostra a figura a seguir:

Iremos exibir na tela a função do empregado de forma automática, através de uma função conhecida por
PROCV, tendo como base a pesquisa pelo campo código, que será preenchido na célula B6, entre outras. Esta
função terá argumentos que serão:

• Código selecionado;
• Tabela de código/função/salário; coluna função

Para implementar ainda este procedimento é interessante verificar se o código digitado existe na respectiva
tabela, evitando assim erros de digitação por parte do operador. Posicione o cursor na célula C¨e entre com a
seguinte fórmula:
=SE(OU(B6<=0;B6>=4);"CODIGO ERRADO";PROCV(B6;M$2:O$4;2))

Primeiro, testamos se o código digitado na célula B6 é maior que zero e menor que quatro, assim sendo, será
exibida uma mensagem de erro na célula em questão (C6), que representa o cargo. Depois utilizamos uma
busca, procurando encontrar no intervalo de células que armazena a tabela de função/faixa salarial dos
funcionários, e quando encontrada, retornamos para a célula com o valor do campo respectivo à função. Esta
mesma fórmula deverá ser digitada para as demais colunas que representam o código do funcionário nas
células C7, C8, C9, C10, trocando-se a referência B6 pela respectiva, ou seja, B7, B8, B9, B10. Ao final deste
procedimento, procure digitar códigos válidos ou não na coluna CODIGO e observe o resultado.

A faixa salarial usará o mesmo processo, porém ao invés de retornar o conteúdo da segunda coluna, que
representa a função, irá retornar o conteúdo da terceira coluna que representa a faixa salarial e, ao invés de
retornar uma frase de erro, irá retornar como o salário sendo igual a zero, porque este campo irá servir para
calcular o salário bruto, ou seja, a faixa salarial multiplicada pelo valor do salário mínimo atual. Veja o código
completo

=SE(OU(B6<=0;B6>=4);0;PROCV(B6;M$2:O$4;3))

Esta fórmula deverá ser digitada nas células D6, D7, D8, D9, D10, substituindo o B6 pelo B7, B8 e assim
sucessivamente.

Nas colunas que representam o salário bruto, você deverá colocar a fórmula que representa a respectiva célula
da faixa salarial com a célula que representa o valor do salário mínimo (B2), sendo assim, teremos nas células
a seguir a seguinte fórmula:

Célula Fórmula
E6 =(b2*d6)
E7 =(b2*d7)
E8 =(b2*d8)

E9 =(b2*d9)
E10 =(b2*d10)

Como todos sabemos, o valor do desconto de INSS é realizado através de uma tabela. Não iremos aqui retratar
a realidade, iremos gerar uma tabela contendo o índice de desconto sobre o número de salários recebidos, e tal
tabela deverá ser digitada a partir da célula Q1, conforme mostra a figura a seguir:
A fórmula é parecida com a que observamos acima, e deverá ser digitada nas células F6 à F10, apenas
substituindo a célula da faixa salarial para seu respectivo número. Outro fator interessante nesta função é que
o salário bruto já terá o seu cálculo para o desconto INSS automaticamente realizado. Sendo assim, para as
seguintes células, digite as fórmulas que a acompanham:

F6 =PROCV(D6;Q$2:R$5;2)*E6

F7 =PROCV(D7;Q$2:R$5;2)*E7
F8 =PROCV(D8;Q$2:R$5;2)*E8
F9 =PROCV(D9;Q$2:R$5;2)*E9

F10 =PROCV(D10;Q$2:R$5;2)*E10

Em seguida, você deverá fornecer na coluna respectiva de dependentes o número de dependentes que o
funcionário possui.

Na coluna salário família, teremos como exemplo, um valor determinado, ou seja, R$ 3,20 por dependente,
neste sentido, basta substituir cada uma das células do salário família pela respectiva fórmula:

H6 =(g6*3,20)

H7 =(g7*3,20)
H8 =(g8*3,20)
H9 =(g9*3,20)

H10 =(g10*3,20)

O Imposto de renda terá uma tabela parecida com a do INSS, que será calculado através de uma determinada
faixa salarial. Para isso, iremos criar outra tabela contendo tais índices, conforme podemos observar figura a
seguir:

Em seguida, basta repetir a fórmula utilizada no cálculo do INSS, porém com as referências de células para o
IRRF, conforme mostra a tabela a seguir:

I6 =PROCV(D6;T$2:U$7;2)*E6
I7 =PROCV(D7;T$2:U$7;2)*E7
I8 =PROCV(D8;T$2:U$7;2)*E8
I9 =PROCV(D9;T$2:U$7;2)*E9

I10 =PROCV(D10;T$2:U$7;2)*E10

Na coluna total de descontos, o procedimento é muito simples, basta somar o valor das células que
proporcionam o desconto em seu salário bruto, conforme podemos observar na tabela a seguir as fórmulas que
deverão ser aplicadas:

J6 =F6+I6
J7 =F7+I7
J8 =F8+I8

J9 =F9+I9

J10 =F10+I10

No campo salário liquido, iremos somar o salário bruto com o salário família e deste total, subtrair o total de
descontos, para isso, entre com as seguintes fórmulas nas respectivas células:

K6 =((E6+H6)-J6)
K7 =((E7+H7)-J7)

K8 =((E8+H8)-J8)
K9 =((E9+H9)-J9)
K10 =((E10+H10)-J10)

Na célula que representa o total dos salários pagos (B2), iremos representar a soma das células que
correspondem aos salários pagos, conforme fórmula a seguir:

=SOMA(K6:K10)

Na célula que representa a média dos salários pagos, iremos utilizar a função média, que efetua a soma do
conjunto de células especificado e divide esta soma pelo número de itens somados, conforme podemos
observar na fórmula a seguir:

=MEDIA(K6:K10)