Você está na página 1de 10

Simplificando a funo TEXTO, CONCATENAR e & do Excel

Este contedo faz parte da srie:


Excel Frmulas Bsicas
Ver 10 posts dessa srie

Quando tocamos no assunto de planilhas em excel, muitas pessoas possuem uma ideia
formada que trata-se de algo muito complexo. Em virtude disso que buscamos explicar e
simplificar algumas funes: TEXTO, CONCATENAR E &.

Atravs de modelos de planilhas, vamos auxiliar voc a montar planilhas empresariais com
essas funes, utilizando-as como ferramentas de gesto para o seu negcio. Vamos l!

1 FUNO TEXTO
Atravs da utilizao da funo TEXTO na sua planilha em excel, voc pode fazer a
converso de qualquer valor numrico em um texto, bem como atribuir uma formatao.

Sintaxe:

valor: trata-se de qualquer valor numrico ou refere-se a qualquer valor numrico


existente em uma clula na sua planilha em excel.
formato_texto: trata-se do valor numrico representado atravs de texto que est entre
aspas.

Exemplo:

A planilha de excel abaixo busca elucidar a mdia de valor de vendas semanais de cada
vendedor. Utilizamos a FUNO TEXTO para representar o valor numrico ao formato de
R$ 0,00.

=TEXTO(G2;R$0,00)

Vejamos:

|1
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Passo 1: Atribuir valor.

|2
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Na clula B11, atribuimos primeiro o valor numrico que se refere ao valor representado na
clula G2: =TEXTO(G2;.

Passo 2: Atribuir o formato do texto:

|3
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Aps, inserimos o formato de texto que representar o valor em Reais: =TEXTO(G2;R$


0,00). Pressionamos ENTER e pronto. A clula B11 exibir R$ 840,00.

2 FUNO CONCATENAR:
Atravs da funo CONCATENAR na sua planilha em excel, voc pode agrupar inmeras
sequncias de caracteres em uma nica sequncia de texto.

Sintaxe:

texto1: refere-se ao primeiro item a ser concatenado e obviamente obrigatrio.


texto2: opicionalmente voc poder adicionar textos, os quais devem ser separados por
ponto e vrgula.

|4
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Exemplo: Na clula A17 buscamos descrever em forma de uma frase a mdia semanal de
vendas do funcionrio Carlos.

=CONCATENAR(A2; ALCANOU ;B11; NA MDIA SEMANAL )

Passo 1: Selecionar a Clula A2 que representa o nome do funcionrio Carlos como


TEXTO1: =CONCATENAR(A2;

|5
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Passo 2: Adicionamos a palavra ALCANOU como TEXTO2, entre aspas e com espaos
entre as aspas: =CONCATENAR(A2; ALCANOU ;

|6
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Passo 3: Adicionamos a clula B11 como TEXTO3, a qual representa o valor da mdia de
valores das vendas semanais do funcionrio Carlos. =CONCATENAR(A2; ALCANOU
;B11

|7
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Passo 4:Como TEXTO4 colocamos as palavras NA MDIA SEMANAL, de maneira a


completar a frase, entre aspas e com espao entre as aspas: =CONCATERNAR(A2;
ALCANOU ;B11; NA MDIA SEMANAL ). Pressionamos ENTER e pronto. A clula
A17 exibir a frase CARLOS ALCANOU R$ 840,00 NA MDIA SEMANAL.

3 &:
Atravs do operador & voc alcanar o mesmo resultado que a funo CONCATENAR. Ele
recomendado para frmulas mais curtas.

No presente exemplo, usando & alcanamos o mesmo resultado da funo CONCATENAR


utilizada para o funcionrio Carlos.

=A3& ALCANOU &B12& NA MDIA SEMANAL

|8
Simplificando a funo TEXTO, CONCATENAR e & do Excel

A diferena que agora no ser necessrio digitar =CONCATENAR.

To somente insira = e aps a clula A3 que refere-se ao nome do funcionrio CARLOS e em


sequncia digite &.

Aps entre aspas e com espao entre as aspas digite ALCANOU.

Em seguida digite & e selecione a clula B12 que refere-se ao valor da mdia de valor das
vendas semanas do funcionrio Mrio. Digite &.

Por fim, novamente entre aspas e com espao entre as aspas digite NA MDIA SEMANAL e
clique no ENTER. A clula A18 exibir a frase MRIO ALCANOU R$ 725,00,00 NA
MDIA SEMANAL.

|9
Simplificando a funo TEXTO, CONCATENAR e & do Excel

Atravs das explicaes acima, esperamos ter ajudado voc a entender um pouco mais sobre
as funes TEXTO, CONCATENAR e & para uma maior utilizao nas suas planilhas em
excel a fim de facilitar o seu trabalho atravs de ferramentas de gesto para planilhas
empresariais.

| 10