Você está na página 1de 8

Instituto Superior de Contabilidade e Administrao do Porto

INFORMTICA DE GESTO II
2004/2005

Exerccio Guiado MsProject


Baseado no Microsoft Project98 Passo a Passo

A empresa XYZ SA ir fazer uma reunio anual de accionistas como acontece todos os anos desde a sua criao. De forma a preparar todas as tarefas inerentes a este projecto com a devida antecedncia sugeriu-lhe a elaborao deste trabalho. Paralelamente nomeou uma equipa de projecto que reunir periodicamente de forma a proporcionar-lhe toda a informao referente a esta reunio de accionistas.

1. Criar um novo projecto


A equipa de projecto transmitiu-lhe a data de incio do projecto e alguma informao bsica, tal como o ttulo do projecto e respectivo chefe.
Crie um novo ficheiro de projecto com data de incio em 14 de Outubro de 2004. (No menu Project seleccione Project Information) Defina Reunio accionistas como ttulo do projecto; Reunio anual 2004 como assunto; e o seu nome como autor e chefe do projecto. (No menu File seleccione Properties) Guarde o ficheiro de projecto com o nome Reunio, numa pasta sua escolha. (No menu File seleccione Save As)

2. Introduzir e editar tarefas na lista de tarefas


Durante a reunio com a equipa de projecto, ir introduzir no MsProject a informao transmitida. Ir tambm editar a lista de tarefas medida que os membros da equipa chegam com mais informaes.
Seleccione a vista Gantt Chart e: Introduza as seguintes tarefas e respectivas duraes na lista de tarefas da Reunio de accionistas, comeando pela tarefa 1:
Agendar data da conferncia Imprimir carta Marcar agenda do orador Elaborar carta Planear bufete com fornecedor Imprimir menu bufete Reunio ocorre 1 dias 2 dias 2 dias 1 dias 3 dias 1 dias 0 dias

Grupo de docentes de IG2 - 2004

Exerccio guiado de MsPROJECT

Insira uma nova tarefa Marcar centro de conferncias com a durao de 2 dias antes da tarefa 2 Imprimir carta. (Seleccione a tarefa Imprimir carta e clique na tecla Insert ou no, menu Insert, seleccione New task) Mova a tarefa 3 Imprimir carta para a depois da tarefa 5 Elaborar carta. (Seleccione a tarefa Imprimir carta, clicando no identificador da tarefa o 3 e de seguida Pegue e largue no stio pretendido entre as tarefas 5 e 6) Remova a tarefa 7 Imprimir menu bufete. (Seleccione a tarefa Imprimir menu bufete, e clique na tecla del ou, no menu Edit seleccione Delete Task) , na Guarde o ficheiro sem estrutura base (No menu File seleccione Save As ou clique em barra de ferramentas e na janela que surge seleccione save reuniowithout a baseline) e depois feche o ficheiro. (No menu File seleccione Close)

3. Destacar as tarefas do projecto


A primeira reunio do projecto foi um sucesso, e a lista de tarefas foi discutida e elaborada. Agora ir utilizar os destaques para dividir o projecto em grupos de tarefas relacionadas, designados por fases. Cada fase ir ser atribuda a um grupo da equipa de projecto para avaliao futura.
Abra o ficheiro Reunio. (No menu File, seleccione Open) Considere as tarefas e respectivas duraes resultantes da reunio do projecto. Faa as alteraes convenientes ao seu projecto de forma a obter como resultado o seguinte quadro:
Plano preliminar Agendar data conferncia Marcar centro conferncias Marcar agenda orador Plano preliminar concludo Carta notificao Encomendar stock cartas Elaborar carta Rever carta Aprovar carta Imprimir carta Enviar carta Detalhes reunio Planear comida bufete Arranjar salas reunio comit Arranjar equipamento necessrio Criar agenda Imprimir agenda Reunio ocorre 1d 2d 1d 3d 0d 1d 1h 1d 1d 1d 2d 0d 1d 3d 1d 2d 3d 1d 0d

Insira uma nova tarefa 1 Reunio de accionistas, e depois, efectue a indentao da tarefa 2 , na barra de tarefas) tarefa 20. (Seleccione as tarefas 2 a 20 e clique em Destaque a lista de tarefas em trs grupos como em baixo indicado: Indente da tarefa 3 tarefa 6, Indente da tarefa 8 tarefa 13, Indente da tarefa 15 tarefa 19. , na barra de tarefas) (Para cada um dos casos, seleccione as tarefas e clique em Esconda as subtarefas da tarefa sumria 7 Carta notificao e a tarefa sumria 14 Detalhes
reunio. (Seleccione a tarefa sumria e clique em

) )

Mostre toda a estrutura de destaques. (Seleccione a tarefa sumria e clique em Guarde o ficheiro sem estrutura base (baseline).

Docentes de IG2 2004-2005

Exerccio guiado de MsPROJECT

4. Unir tarefas
Antes das fases serem atribudas s vrias equipas do projecto, ir unir as tarefas por uma dependncia fim-incio. Ir tambm alterar algumas dependncias preliminares baseando-se na especificidade de cada tarefas do projecto.
Una todas as tarefas com uma dependncia fim-incio. (Seleccione todas as tarefas e clique em ) Desuna a tarefa sumria 7 Carta notificao e a tarefa sumria 14 Detalhes reunio. ) (Seleccione as duas tarefas e clique em Una a tarefa sumria 2 Plano preliminar tarefa sumria 14 Detalhes reunio. (Seleccione as ) duas tarefas e clique em Una a tarefa 11 Aprovar carta tarefa sumria 14 Detalhes reunio. (Seleccione as duas tarefas e clique em )

5. Estabelecer dependncias de tarefas


Cada equipa de projecto j reviu a sua fase. Alguns grupos sugeriram algumas alteraes s dependncias das tarefas. Ter de efectuar as alteraes ao cronograma com base na informao que recebeu.
Altere a dependncia entre a tarefa 8 Encomendar stock cartas, e a tarefa 9 Elaborar carta para incio-incio. (Fazendo duplo clique na ligao entre as tarefas, acede janela Task dependency) Altere a dependncia entre a tarefa 16 Arranjar salas reunio comit, e a tarefa 17 Arranjar equipamento necessrio para fim-fim. (Fazendo duplo clique na ligao entre as tarefas, acede janela Task dependency) Defina um tempo de avano de 0,5 dias para a dependncia entre a tarefa 4 Marcar centro conferncias e a tarefa 5 Marcar agenda orador. (Nota: Um avano de x representado por x) Defina um tempo de atraso de 2 dias entre a tarefa 14 Detalhes reunio e a tarefa 20 Reunio ocorre. (Nota: Um atraso de x representado por +x) Guarde o ficheiro sem baseline.

6. Utilizar o assistente GanttChartWizard


Agora que a lista de tarefas e respectivas dependncias parecem estabilizadas, ir visualizar o caminho crtico do projecto recorrendo para isso ao assistente GanttChartWizard.
Inicie assistente GanttChartWizard. (No menu Format seleccione GanttChartWizard) Apresente o caminho crtico no Diagrama de Gantt. (Seleccione Critical Path) Apresente os nomes dos recursos e as datas direita das barras de Gantt. (Seleccione Resources and dates) Mostre as linhas de ligao para as tarefas com dependncias. (Seleccione Yes, please) Formate o Diagrama de Gantt e, depois, saia do assistente GanttChartWizard. (Seleccione Format It e depois Exit Wizard) Guarde o ficheiro sem baseline.

Docentes de IG2 2004-2005

Exerccio guiado de MsPROJECT

7. Criar uma lista de recursos


A equipa de projecto deu-lhe uma lista de recursos para a execuo do projecto. Introduza os recursos propostos e respectivos detalhes.
Utilize a caixa de dilogo Assign Resources ( ) para adicionar o recurso Estagirio. Na caixa de dilogo Resource Information (duplo clique em Estagirio), introduza a informao adicional para o recurso Estagirio: Iniciais est; Grupo escritrio; cdigo 105-9 Na vista Resource Sheet, introduza a seguinte informao sobre os recursos do projecto:
Nome do Recurso Iniciais Grupo Unid. Max Cdigo

Vice-presidente Gerente Assist. administrativo

Vp dger Ass adm

Direco Direco Escritrio

100% 100% 200%

101-4 101-6 105-6

8. Atribuir recursos s tarefas


Considere tambm a informao preliminar referente s tarefas e respectivos recursos fornecida pela equipa de projecto.
Introduza as atribuies dos recursos s seguintes tarefas (na vista Gantt Chart, utilize a caixa de dilogo Assingn Resources):
Tarefa Recurso

Agendar data conferncia Marcar centro conferncias Marcar agenda orador Encomendar stock cartas Elaborar carta Rever carta Aprovar carta Planear comida bufete Arranjar salas reunio comit Arranjar equipamento necessrio

Vice-presidente, Gerente Estagirio Gerente Estagirio Assist. Administrativo Gerente Vice-presidente Assist. Administrativo Estagirio Assist. Administrativo

9. Definir os custos dos recursos


O departamento de Contabilidade forneceu-lhe a informao necessria referente aos custos de cada recurso envolvido no projecto. Introduza essa informao para cada recurso.
Introduza a seguinte informao dos custos na vista Resource Sheet:
Nome do Recurso Taxa Normal Taxa HoraExtra

Estagirio Vice-presidente Gerente Assist. administrativo

5.00 por hora 37500 por ano 22500 por ano 10.00 por hora

7.50 por hora

15.00 por hora

Em 1 de Novembro de 2004, o recurso Estagirio ser aumentado em 10% sobre as horas de trabalho normais e as extraordinrias. Defina essa data como incio do aumento. (Faa duplo clique em Estagirio para aceder janela Resource Information. Seleccione o separador Costs e, na tabela A, altere os custos pretendidos) O recurso Assist. Administrativo ter uma maior remunerao nas tarefas em que efectuar trabalhos de superviso. Crie uma nova tabela de custos com custo normal de 12.50 por hora e com custo extra de 18.25 por hora. (Faa duplo clique em Assist. Administrativo para aceder janela Resource Information. Seleccione o separador Costs e, na tabela B, introduza os valores pretendidos)
Docentes de IG2 2004-2005 4

Exerccio guiado de MsPROJECT

Aplique a nova tabela de custos do recurso Assist. Administrativo tarefa Arranjar equipamento necessrio. (Na vista Resource usage, faa duplo clique na tarefa pretendida para obter a janela Assignment Information. No separador General, em Cost rate table, seleccione B)

10. Criar, editar e atribuir calendrios


O projecto Reunio anual de accionistas no requer um horrio tradicional de 8 horas por dia para cada recurso. Em vez disso, as tarefas do projecto sero desenvolvidas apenas durante as manhs, excepto segunda-feira. Assim, ir criar um novo calendrio-base que contemple estes pressupostos e que salvaguarde os dias feriado que acontecem no decorrer do projecto.
Seleccione a vista Gantt Chart. No menu Tools seleccione Change working times. A partir de uma cpia do calendrio-base Standard, crie um novo calendrio-base para o projecto com o nome Reunio de Accionistas. Altere as horas de trabalho como se indica: Segunda-feira: 13:00 s 17:00 De tera-feira a sexta-feira: 8:00 s 12:00 Adicione ao calendrio Reunio de Accionistas os seguintes dias de paragem do projecto: 22 de Outubro - Aniversrio da empresa, paragem s 11:00 at ao fim do dia para almoo e convvio 1 de Novembro - Dia de Todos os Santos Atribua o calendrio Reunio de Accionistas a todos os recursos do projecto. (Na vista Resource sheet) Seleccione este calendrio como calendrio base do projecto. (No menu Project seleccione Project Information e escolha o calendrio Reunio de accionistas) Marque o dia 25 de Outubro de 2004, como dia de paragem para o recurso Gerente no respectivo calendrio. (Na vista Resource Sheet faa duplo clique em Gerente e no separador Working Time faa as alteraes)

11. Manusear os tipos de definies de tarefas


Na mais recente reunio com a equipa de projecto o cronograma foi revisto de forma a verificar se alguma atribuio de recursos necessitava de ser ajustada. Baseado na informao que reuniu nesse evento, efectue as respectivas alteraes ao cronograma.
Seleccione More Views e depois Task Entry: Altere o tipo de definio da tarefa 10, Rever carta, para o tipo de trabalho fixo e, depois, adicione o recurso Vice-presidente tarefa. Na tarefa 17, Arranjar equipamento necessrio, atribua uma unidade adicional do recurso Assist. Administrativo a essa tarefa. Na tarefa 9, elaborar carta, desactive o mtodo de programao baseada no esforo e, depois, atribua o recurso Gerente a essa tarefa.

12. Visualizar as cargas dos recursos


O cronograma do projecto da reunio de accionistas est em fase de concluso. Na ultima reunio com a equipa de projecto foram concludas as atribuies finais dos recursos e os tempos de trabalho. Agora est em condies de resolver qualquer sobrecarga de recurso baseado nos parmetros definidos na reunio. Uma vez o projecto ajustado e antes da primeira tarefa ser iniciada, ir definir a estrutura base
Faa duplo clique na linha que separa as duas janelas da vista Task Entry, para fechar a janela superior e ficar apenas com a vista Gantt Chart.
Docentes de IG2 2004-2005 5

Exerccio guiado de MsPROJECT

Substitua o recurso Gerente pelo recurso Estagirio na tarefa 3 Agendar data conferncia. , na barra de ferramentas, e proceda substituio (Seleccione a tarefa, clique no cone do recurso) Retire a dependncia entre as tarefas 3 Agendar data conferncia e 4 Marcar centro , na barra de ferramentas) conferncias. (Seleccione as duas tarefas e clique no cone Atribua o recurso Assist. Administrativo tarefa 12 Imprimir carta (Seleccione a tarefa,

Resource Sheet, altere as unidades disponveis deste recurso de 200% para 100%. Visualize a vista Resource Usage.

clique no cone

, na barra de ferramentas, e proceda atribuio do recurso) e, na vista

Observe a carga do recurso Estagirio. Apresente a barra Resource Management. (no menu View seleccione Toolbars e Resource Management) Localize as sobrecargas do recurso Assist. Administrativo. (Clique em ferramentas) , na barra de

13. Utilizar nivelamento automtico


Depois de rever as cargas dos recursos, ir utilizar o nivelamento automtico para verificar quais as sobrecargas que podem ser resolvidas dentro de certas definies de nivelamento.
Verifique a data de concluso do projecto. (No menu Project seleccione Project Information) Active a opo de visualizao Resource Allocation. Abra a caixa de dilogo Resource Levelling. (No menu Tools seleccione Resource Levelling) Aplique o nivelamento ao projecto com as opes: Automatic; Day By Day; Level from 14/10/04 to 29/10/04. Visualize as alteraes resultantes do nivelamento para o recurso Estagirio entre 14/10/04 e 21/10/04. (A vista Resource Allocation apresenta o diagrama antes do nivelamento, a verde e depois do nivelamento, a azul)

14. Resolver manualmente as sobrecargas dos recursos


Tendo em conta que no conseguiu resolver todas as sobrecargas com o nivelamento automtico, ir utilizar as tcnicas de gesto para resolver as sobrecargas pendentes dentro de parmetros aceitveis definidos pela equipa de projecto.
Abra a caixa de dilogo Resource Levelling. Aplique o nivelamento ao projecto com a opo: Manual e Level entire Project. Localize a sobrecarga para o recurso Assist. Administrativo. Resolva a sobrecarga incrementando o nmero mximo de unidades disponveis, para Assist. Administrativo, no projecto para 200%. (Na vista Resource Sheet) Active a vista Resource Usage para se assegurar de que no existem mais sobrecargas de recursos. Verifique se o nivelamento estendeu a data de concluso do projecto.

15. Definir uma estrutura base (baseline)


O cronograma do projecto da reunio de accionistas foi ajustado e agora reflecte o melhor esforo da equipa de projecto na criao do plano. Para finalizar, ir definir uma estrutura base do projecto para futuras comparaes com o seu progresso.
Grave o ficheiro com a baseline.
Docentes de IG2 2004-2005 6

Exerccio guiado de MsPROJECT

16. Acompanhar o progresso individual das tarefas


O projecto da reunio de accionistas j comeou, e necessrio iniciar o acompanhamento das tarefas do projecto. Os recursos providenciaram-lhe um conjunto de informao do progresso do projecto que ir introduzir no cronograma. Vrias tarefas no progrediram de acordo com o planeado. Ir introduzir a informao actual sobre essas tarefas no cronograma e, depois actualizar as tarefas restantes de acordo com a data corrente.
Seleccione a vista Gantt Chart. Apresente a barra de ferramentas Tracking. (No menu View seleccione Toolbars e de seguida Tracking) Actualize a tarefa 3 Agendar data de conferncia, para reflectir a data de concluso efectiva de 21/10/04. (No menu Tools seleccione Tracking e depois Update Tasks ou, na barra de ) ferramentas, clique em Actualize a tarefa 4 Marcar centro conferncias que comeou no dia 17/10/04 e demorou 2 dias a concluir. (No menu Tools seleccione Tracking e depois Update Tasks ou, na barra ) de ferramentas, clique em A tarefa 5 Marcar agenda orador, demorou 2 dias a concluir. Seleccione a vista Resource Usage. No menu Format, seleccione Details e Actual Work. O gerente dedicou um total de 3 horas a trabalhar num rascunho da carta de notificao no dia 29/10/04. Altere o tempo actual de trabalho para a tarefa 9 Elaborar carta, para reflectir o tempo efectivamente despendido. As tarefas restantes progrediram como previsto no plano at ao dia 4/11/04. (Seleccione as tarefas e no menu Tools, seleccione Tracking e depois Update Project) A impressora avariou no dia 08/11/04. Divida a tarefa 12 Imprimir carta reprogramando o trabalho restante, que se deve iniciar na data em que o tcnico vir reparar a impressora e divida a tarefa) (12/11/04). (Na barra de ferramentas clique em Atribua a percentagem de 50% para a execuo da Tarefa 15 Planear comida buffet. (Seleccione a tarefa e na barra de ferramentas, clique em ) Compare o progresso do projecto com a estrutura base ao nvel da data de concluso, duraes e custos. (No menu Project seleccione Project Information e clique em Statistics ou clique no icone Grave o ficheiro. , na barra de ferramentas)

17. Filtrar as tarefas e os recursos


Quando actualizou o progresso do projecto, pediram-lhe alguma informao preliminar antes da reunio da equipa de projecto da semana seguinte. Existe a possibilidade de o recurso Estagirio poder sair do projecto. Ir filtrar o recurso Estagirio para poder saber a sua importncia no projecto. Ir tambm utilizar um filtro para aplicar sobre as tarefas crticas.
Apresente a tabela Entry na vista Task Sheet. Utilize o filtro automtico (clique em Estagirio. ) para procurar as tarefas que incluem o recurso

) Desligue o Autofilter. (clique novamente em Utilize o filtro Critical para procurar as tarefas que se encontram no caminho crtico. Crie um filtro personalizado, de nome Dep-9-11-04, para localizar todas as tarefas que se iniciam em ou depois de 09/11/04. (No menu Project seleccione Filtered for e depois More Filters. Construa o seu novo filtro)

Docentes de IG2 2004-2005

Exerccio guiado de MsPROJECT

18. Ordenar as tarefas e os recursos


O Departamento de Contabilidade pediu-lhe que fornecesse alguma informao sobre o projecto. Assim, ir efectuar uma ordenao por custo e pela percentagem de concluso que possibilite Contabilidade conhecer as tarefas que tm maiores custos. Na vista Task Sheet, apresente a tabela Cost. (No se esquea de retirar o filtro aplicado anteriormente, seleccionando All Tasks) Ordene as tarefas por ordem decrescente de custo e, depois, ordene por percentagem de concluso por ordem decrescente. (No menu Project seleccione Sort e depois Sort by. Escolha as opes de ordenao) Apresente a vista Resource Sheet e a tabela entry. Ordene os recursos pelo campo Code por ordem decrescente.

19. Criar tabelas e vistas personalizadas


A Direco requisitou-lhe alguma informao sobre varincias de datas e custos do projecto. Assim, ir criar uma tabela personalizada com base na tabela Variance, a qual lhe adicionar a informao sobre as varincias de custo. Apresente a vista Gantt Chart Crie uma tabela personalizada de nome Varincia Total com base numa cpia da tabela Variance. (No menu View seleccione Table e depois More tables) Remova os campos Start e Finish. Adicione os campos Baseline Cost e Cost Variance. Utilize Custo Base e Var.Custo como ttulos das colunas. Aplique a tabela personalizada. Crie uma vista singular de nome Overbudget. Utilize a vista Task Sheet, a tabela Varincia Total e o filtro Cost Overbudget. Aplique a vista.

20. Criar um relatrio personalizado


A equipa de projecto gostaria de ter uma informao semanal sobre o trabalho dos recursos para apresentar em cada reunio de projecto. Assim, ir personalizar um relatrio predefinido para incluir a informao necessria. Apresente o relatrio Who Does what. A partir de uma cpia do relatrio Who Does What, crie um relatrio personalizado de nome Quem trabalha onde. No separador Definition, utilize a tabela work. No separador Details, apresente as atribuies de cronograma e de trabalho. Anteveja o novo relatrio.

Docentes de IG2 2004-2005